Add patch for libxcrypt
This commit is contained in:
parent
664896a6c6
commit
c54059a679
13
009-add-libxcrypt-support.patch
Normal file
13
009-add-libxcrypt-support.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/pypy/module/crypt/interp_crypt.py b/pypy/module/crypt/interp_crypt.py
|
||||
index d227b6a..da969e6 100644
|
||||
--- a/pypy/module/crypt/interp_crypt.py
|
||||
+++ b/pypy/module/crypt/interp_crypt.py
|
||||
@@ -6,7 +6,7 @@ import sys
|
||||
if sys.platform.startswith('darwin'):
|
||||
eci = ExternalCompilationInfo()
|
||||
else:
|
||||
- eci = ExternalCompilationInfo(libraries=['crypt'])
|
||||
+ eci = ExternalCompilationInfo(libraries=['crypt'], includes=['crypt.h'])
|
||||
c_crypt = rffi.llexternal('crypt', [rffi.CCHARP, rffi.CCHARP], rffi.CCHARP,
|
||||
compilation_info=eci, releasegil=False)
|
||||
|
10
pypy3.spec
10
pypy3.spec
@ -1,7 +1,7 @@
|
||||
Name: pypy3
|
||||
Version: 5.10.1
|
||||
%global pyversion 3.5
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Python 3 implementation with a Just-In-Time compiler
|
||||
|
||||
# LGPL and another free license we'd need to ask spot about are present in some
|
||||
@ -155,6 +155,11 @@ Patch6: 006-always-log-stdout.patch
|
||||
# community that won't make sense outside of it). [Sorry to be a killjoy]
|
||||
Patch7: 007-remove-startup-message.patch
|
||||
|
||||
# Glibc's libcrypt was replaced with libxcrypt in f28, crypt.h header has
|
||||
# to be added to privent compilation error.
|
||||
# https://fedoraproject.org/wiki/Changes/Replace_glibc_libcrypt_with_libxcrypt
|
||||
Patch9: 009-add-libxcrypt-support.patch
|
||||
|
||||
# It seems ppc64 has no faulthandler
|
||||
Patch11: 011-no-faulthandler.patch
|
||||
|
||||
@ -816,6 +821,9 @@ CheckPyPy %{name}-stackless
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Mar 29 2018 Michal Cyprian <mcyprian@redhat.com> - 5.10.1-4
|
||||
- Add patch for libxcrypt
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.10.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user