Merge with pypy + package review (#1215732) history

This commit is contained in:
Miro Hrončok 2015-05-10 16:16:10 +02:00
commit 908d523efb
7 changed files with 1100 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/pypy3-2.4.0-src.tar.bz2

View File

@ -0,0 +1,12 @@
diff -rup pypy-pypy-f66246c46ca3/rpython/translator/platform/__init__.py pypy-pypy-f66246c46ca3/rpython/translator/platform/__init__.py
--- pypy-pypy-f66246c46ca3/rpython/translator/platform/__init__.py 2013-05-27 10:35:37.680237338 +0200
+++ pypy-pypy-f66246c46ca3/rpython/translator/platform/__init__.py 2013-05-27 10:41:04.113098738 +0200
@@ -138,6 +138,8 @@ class Platform(object):
self._handle_error(returncode, stdout, stderr, outname)
def _handle_error(self, returncode, stdout, stderr, outname):
+ for line in stdout.splitlines():
+ log.message(line)
if returncode != 0:
errorfile = outname.new(ext='errors')
errorfile.write(stderr, 'wb')

View File

@ -0,0 +1,12 @@
diff -rup pypy-pypy-f66246c46ca3/lib_pypy/_pypy_interact.py pypy-pypy-f66246c46ca3/lib_pypy/_pypy_interact.py
--- pypy-pypy-f66246c46ca3/lib_pypy/_pypy_interact.py 2013-05-27 10:35:37.612236951 +0200
+++ pypy-pypy-f66246c46ca3/lib_pypy/_pypy_interact.py 2013-05-27 10:37:25.602852747 +0200
@@ -4,7 +4,7 @@ import sys
irc_header = "And now for something completely different"
-def interactive_console(mainmodule=None, quiet=False):
+def interactive_console(mainmodule=None, quiet=True):
# set sys.{ps1,ps2} just before invoking the interactive interpreter. This
# mimics what CPython does in pythonrun.c
if not hasattr(sys, 'ps1'):

5
macros.pypy3 Normal file
View File

@ -0,0 +1,5 @@
%__pypy3 /usr/bin/pypy3
%pypy3_sitelib %(%{__pypy3} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")
%pypy3_sitearch %(%{__pypy3} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")
%pypy3_version %(%{__pypy3} -c "import sys; sys.stdout.write(sys.version[:3])")
%pypy3dir %{_builddir}/pypy3-%{name}-%{version}-%{release}

View File

@ -0,0 +1,12 @@
diff -rup pypy-pypy-f66246c46ca3/rpython/tool/ansi_print.py pypy-pypy-f66246c46ca3/rpython/tool/ansi_print.py
--- pypy-pypy-f66246c46ca3/rpython/tool/ansi_print.py 2013-05-27 10:35:37.648237156 +0200
+++ pypy-pypy-f66246c46ca3/rpython/tool/ansi_print.py 2013-05-28 10:15:58.200426205 +0200
@@ -25,7 +25,7 @@ class AnsiLog:
self.kw_to_color = self.KW_TO_COLOR.copy()
self.kw_to_color.update(kw_to_color)
self.file = file
- self.fancy = True
+ self.fancy = False
self.isatty = getattr(sys.stderr, 'isatty', lambda: False)
if self.fancy and self.isatty():
self.mandelbrot_driver = Driver()

1057
pypy3.spec Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1 @@
96ba72916114d16904e12562b5d84e51 pypy3-2.4.0-src.tar.bz2