Update to 7.3.0
This commit is contained in:
parent
5aa1d86125
commit
41c6994849
1
.gitignore
vendored
1
.gitignore
vendored
@ -9,3 +9,4 @@
|
|||||||
/pypy3.5-v7.0.0-src.tar.bz2
|
/pypy3.5-v7.0.0-src.tar.bz2
|
||||||
/pypy3.6-v7.1.1-src.tar.bz2
|
/pypy3.6-v7.1.1-src.tar.bz2
|
||||||
/pypy3.6-v7.2.0-src.tar.bz2
|
/pypy3.6-v7.2.0-src.tar.bz2
|
||||||
|
/pypy3.6-v7.3.0-src.tar.bz2
|
||||||
|
@ -16,9 +16,9 @@ index 9f5d151..8b81155 100644
|
|||||||
|
|
||||||
+_WHEEL_DIR = "/usr/share/python-wheels/"
|
+_WHEEL_DIR = "/usr/share/python-wheels/"
|
||||||
|
|
||||||
-_SETUPTOOLS_VERSION = "40.6.2"
|
-_SETUPTOOLS_VERSION = "41.2.0"
|
||||||
|
|
||||||
-_PIP_VERSION = "18.1"
|
-_PIP_VERSION = "19.2.3"
|
||||||
+def _get_most_recent_wheel_version(pkg):
|
+def _get_most_recent_wheel_version(pkg):
|
||||||
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
|
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
|
||||||
+ suffix = "-py2.py3-none-any.whl"
|
+ suffix = "-py2.py3-none-any.whl"
|
||||||
|
@ -1,49 +0,0 @@
|
|||||||
# HG changeset patch
|
|
||||||
# User Armin Rigo <arigo@tunes.org>
|
|
||||||
# Date 1571380165 -7200
|
|
||||||
# Node ID d81c769a235307f6671a8fa916f48d6896cbb823
|
|
||||||
# Parent f27546b858f97bfa286a891e1474579759028784
|
|
||||||
Arguably, clarify the logic. The real motivation is a gcc bug, see issue #3086
|
|
||||||
|
|
||||||
diff --git a/rpython/jit/backend/aarch64/opassembler.py b/rpython/jit/backend/aarch64/opassembler.py
|
|
||||||
--- a/rpython/jit/backend/aarch64/opassembler.py
|
|
||||||
+++ b/rpython/jit/backend/aarch64/opassembler.py
|
|
||||||
@@ -808,9 +808,7 @@
|
|
||||||
# Inline a series of STR operations, starting at 'dstaddr_loc'.
|
|
||||||
#
|
|
||||||
self.mc.gen_load_int(r.ip0.value, 0)
|
|
||||||
- i = 0
|
|
||||||
- adjustment = 0
|
|
||||||
- needs_adjustment = itemsize < 8 and (startbyte % 8)
|
|
||||||
+ i = dst_i = 0
|
|
||||||
total_size = size_box.getint()
|
|
||||||
while i < total_size:
|
|
||||||
sz = itemsize
|
|
||||||
@@ -818,19 +816,19 @@
|
|
||||||
next_group += 8
|
|
||||||
if next_group <= total_size:
|
|
||||||
sz = 8
|
|
||||||
+ if dst_i % 8: # unaligned?
|
|
||||||
+ self.mc.ADD_ri(dstaddr_loc.value, dstaddr_loc.value, dst_i)
|
|
||||||
+ dst_i = 0
|
|
||||||
if sz == 8:
|
|
||||||
- if needs_adjustment:
|
|
||||||
- self.mc.ADD_ri(dstaddr_loc.value, dstaddr_loc.value, i)
|
|
||||||
- adjustment = -i
|
|
||||||
- needs_adjustment = False
|
|
||||||
- self.mc.STR_ri(r.ip0.value, dstaddr_loc.value, i + adjustment)
|
|
||||||
+ self.mc.STR_ri(r.ip0.value, dstaddr_loc.value, dst_i)
|
|
||||||
elif sz == 4:
|
|
||||||
- self.mc.STRW_ri(r.ip0.value, dstaddr_loc.value, i + adjustment)
|
|
||||||
+ self.mc.STRW_ri(r.ip0.value, dstaddr_loc.value, dst_i)
|
|
||||||
elif sz == 2:
|
|
||||||
- self.mc.STRH_ri(r.ip0.value, dstaddr_loc.value, i + adjustment)
|
|
||||||
+ self.mc.STRH_ri(r.ip0.value, dstaddr_loc.value, dst_i)
|
|
||||||
else:
|
|
||||||
- self.mc.STRB_ri(r.ip0.value, dstaddr_loc.value, i + adjustment)
|
|
||||||
+ self.mc.STRB_ri(r.ip0.value, dstaddr_loc.value, dst_i)
|
|
||||||
i += sz
|
|
||||||
+ dst_i += sz
|
|
||||||
|
|
||||||
else:
|
|
||||||
if isinstance(size_box, ConstInt):
|
|
10
pypy3.spec
10
pypy3.spec
@ -1,8 +1,8 @@
|
|||||||
%global basever 7.2
|
%global basever 7.3
|
||||||
Name: pypy3
|
Name: pypy3
|
||||||
Version: %{basever}.0
|
Version: %{basever}.0
|
||||||
%global pyversion 3.6
|
%global pyversion 3.6
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python 3 implementation with a Just-In-Time compiler
|
Summary: Python 3 implementation with a Just-In-Time compiler
|
||||||
|
|
||||||
# LGPL and another free license we'd need to ask spot about are present in some
|
# LGPL and another free license we'd need to ask spot about are present in some
|
||||||
@ -164,9 +164,6 @@ Patch9: 009-add-libxcrypt-support.patch
|
|||||||
# It seems ppc64 has no faulthandler
|
# It seems ppc64 has no faulthandler
|
||||||
Patch11: 011-no-faulthandler.patch
|
Patch11: 011-no-faulthandler.patch
|
||||||
|
|
||||||
# https://bitbucket.org/pypy/pypy/issues/3086
|
|
||||||
Patch12: d81c769a235307f6671a8fa916f48d6896cbb823.patch
|
|
||||||
|
|
||||||
# Instead of bundled wheels, use our RPM packaged wheels from
|
# Instead of bundled wheels, use our RPM packaged wheels from
|
||||||
# /usr/share/python-wheels
|
# /usr/share/python-wheels
|
||||||
# We conditionally apply this, but we use autosetup, so we use Source here
|
# We conditionally apply this, but we use autosetup, so we use Source here
|
||||||
@ -861,6 +858,9 @@ CheckPyPy %{name}-stackless
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Dec 28 2019 Miro Hrončok <mhroncok@redhat.com> - 7.3.0-1
|
||||||
|
- Update to 7.3.0
|
||||||
|
|
||||||
* Wed Oct 23 2019 Miro Hrončok <mhroncok@redhat.com> - 7.2.0-2
|
* Wed Oct 23 2019 Miro Hrončok <mhroncok@redhat.com> - 7.2.0-2
|
||||||
- Enable JIT on aarch64
|
- Enable JIT on aarch64
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pypy3.6-v7.2.0-src.tar.bz2) = bcbb53062a473d504bcc082cf6286f6169c83d1f38d22c4d7c4e46ddc32bca9d91e71194637e6650db5bec02b29fe262b22fe236d627b6bc3e6e0c59c66c07cc
|
SHA512 (pypy3.6-v7.3.0-src.tar.bz2) = 313a4254262dd8d8b995a50bddbc360cfb67add0818e51a3e9ce25bda6a9b639e9fea8efe7da6adda76dff0a86a364544a13faa516e51b9ea6c25ec99223b435
|
||||||
|
Loading…
Reference in New Issue
Block a user