Update to 5.10.0
This commit is contained in:
parent
7fad2637ac
commit
b07d419db5
13
009-add-libxcrypt-support.patch
Normal file
13
009-add-libxcrypt-support.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/pypy/module/crypt/interp_crypt.py b/pypy/module/crypt/interp_crypt.py
|
||||||
|
index d227b6a..da969e6 100644
|
||||||
|
--- a/pypy/module/crypt/interp_crypt.py
|
||||||
|
+++ b/pypy/module/crypt/interp_crypt.py
|
||||||
|
@@ -6,7 +6,7 @@ import sys
|
||||||
|
if sys.platform.startswith('darwin'):
|
||||||
|
eci = ExternalCompilationInfo()
|
||||||
|
else:
|
||||||
|
- eci = ExternalCompilationInfo(libraries=['crypt'])
|
||||||
|
+ eci = ExternalCompilationInfo(libraries=['crypt'], includes=['crypt.h'])
|
||||||
|
c_crypt = rffi.llexternal('crypt', [rffi.CCHARP, rffi.CCHARP], rffi.CCHARP,
|
||||||
|
compilation_info=eci, releasegil=False)
|
||||||
|
|
17
pypy.spec
17
pypy.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pypy
|
Name: pypy
|
||||||
Version: 5.9.0
|
Version: 5.10.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python implementation with a Just-In-Time compiler
|
Summary: Python implementation with a Just-In-Time compiler
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -154,6 +154,11 @@ Patch0: 006-always-log-stdout.patch
|
|||||||
# community that won't make sense outside of it). [Sorry to be a killjoy]
|
# community that won't make sense outside of it). [Sorry to be a killjoy]
|
||||||
Patch1: 007-remove-startup-message.patch
|
Patch1: 007-remove-startup-message.patch
|
||||||
|
|
||||||
|
# Glibc's libcrypt was replaced with libxcrypt in f28, crypt.h header has
|
||||||
|
# to be added to privent compilation error.
|
||||||
|
# https://fedoraproject.org/wiki/Changes/Replace_glibc_libcrypt_with_libxcrypt
|
||||||
|
Patch2: 009-add-libxcrypt-support.patch
|
||||||
|
|
||||||
# Build-time requirements:
|
# Build-time requirements:
|
||||||
|
|
||||||
# pypy's can be rebuilt using itself, rather than with CPython; doing so
|
# pypy's can be rebuilt using itself, rather than with CPython; doing so
|
||||||
@ -585,6 +590,11 @@ install -m 644 %{SOURCE2} %{buildroot}/%{_rpmconfigdir}/macros.d
|
|||||||
# Remove build script from the package
|
# Remove build script from the package
|
||||||
#rm %{buildroot}/%{pypyprefix}/lib_pypy/ctypes_config_cache/rebuild.py
|
#rm %{buildroot}/%{pypyprefix}/lib_pypy/ctypes_config_cache/rebuild.py
|
||||||
|
|
||||||
|
# since 5.10.0, the debug binaries are built and shipped, making the
|
||||||
|
# pypy package ~350 MiB. let's remove them here for now and TODO figure out why
|
||||||
|
rm -f %{buildroot}%{pypyprefix}/bin/pypy.debug
|
||||||
|
rm -f %{buildroot}%{pypyprefix}/bin/libpypy-c.so.debug
|
||||||
|
|
||||||
%check
|
%check
|
||||||
topdir=$(pwd)
|
topdir=$(pwd)
|
||||||
|
|
||||||
@ -755,6 +765,9 @@ CheckPyPy %{name}-c-stackless
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 21 2018 Michal Cyprian <mcyprian@redhat.com> - 5.10.0-1
|
||||||
|
- Update to 5.10.0
|
||||||
|
|
||||||
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5.9.0-6
|
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 5.9.0-6
|
||||||
- Escape macros in %%changelog
|
- Escape macros in %%changelog
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pypy2-v5.9.0-src.tar.bz2) = 3170747e81088043c6a4885bd0bc92e911556420b6c2539a4ed7e62956f1c741651f772def0fb00d8826a1bef9d6f4e79a13682a4456a31d987f7c9bd8608a4d
|
SHA512 (pypy2-v5.10.0-src.tar.bz2) = 11892418d753ddc59e928a5f59b3406b7c22b8689ad6995eeb183182dbb5184117e68bb567c770ffa60a14d6763550d658e260584e65da5025ed481f48501379
|
||||||
|
Loading…
Reference in New Issue
Block a user