Merge remote-tracking branch 'up/main' into main-riscv64
Signed-off-by: Jason Montleon <jmontleo@redhat.com>
This commit is contained in:
commit
a462afc392
@ -1,22 +0,0 @@
|
|||||||
From 789f964fff59c722b0872abcdc56d2b1373a9f3b Mon Sep 17 00:00:00 2001
|
|
||||||
From: mattip <matti.picus@gmail.com>
|
|
||||||
Date: Tue, 19 Mar 2024 08:36:55 +0200
|
|
||||||
Subject: [PATCH] fix 'const' in signature of gdbm_open (issue 4926)
|
|
||||||
|
|
||||||
---
|
|
||||||
lib_pypy/_gdbm_build.py | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/lib_pypy/_gdbm_build.py b/lib_pypy/_gdbm_build.py
|
|
||||||
index 8578874554f..113f5496dc0 100644
|
|
||||||
--- a/lib_pypy/_gdbm_build.py
|
|
||||||
+++ b/lib_pypy/_gdbm_build.py
|
|
||||||
@@ -11,7 +11,7 @@
|
|
||||||
#define GDBM_NOLOCK ...
|
|
||||||
#define GDBM_REPLACE ...
|
|
||||||
|
|
||||||
-void* gdbm_open(char *, int, int, int, void (*)());
|
|
||||||
+void* gdbm_open(const char *, int, int, int, void (*)(const char *));
|
|
||||||
void gdbm_close(void*);
|
|
||||||
|
|
||||||
typedef struct {
|
|
25
pypy.spec
25
pypy.spec
@ -4,9 +4,9 @@
|
|||||||
# %%{_libdir}/pypy%%{pyversion} (see e.g. pypy3.7 or pypy3.8 for inspiration).
|
# %%{_libdir}/pypy%%{pyversion} (see e.g. pypy3.7 or pypy3.8 for inspiration).
|
||||||
%global basever 7.3
|
%global basever 7.3
|
||||||
Name: pypy
|
Name: pypy
|
||||||
Version: %{basever}.15
|
Version: %{basever}.16
|
||||||
%global pyversion 2.7
|
%global pyversion 2.7
|
||||||
Release: %autorelease -e 2.riscv64
|
Release: %autorelease
|
||||||
Summary: Python implementation with a Just-In-Time compiler
|
Summary: Python implementation with a Just-In-Time compiler
|
||||||
|
|
||||||
# PyPy is MIT
|
# PyPy is MIT
|
||||||
@ -177,12 +177,6 @@ Patch1: 007-remove-startup-message.patch
|
|||||||
# https://fedoraproject.org/wiki/Changes/Replace_glibc_libcrypt_with_libxcrypt
|
# https://fedoraproject.org/wiki/Changes/Replace_glibc_libcrypt_with_libxcrypt
|
||||||
Patch2: 009-add-libxcrypt-support.patch
|
Patch2: 009-add-libxcrypt-support.patch
|
||||||
|
|
||||||
# Fix function signatures uncovered by GCC 14 enforcement of
|
|
||||||
# -Wincompatible-pointer-types
|
|
||||||
# Resolved upstream:
|
|
||||||
# https://github.com/pypy/pypy/commit/789f964fff59c722b0872abcdc56d2b1373a9f3b
|
|
||||||
Patch3: 010-fix-pointers.patch
|
|
||||||
|
|
||||||
# Instead of bundled wheels, use our RPM packaged wheels from
|
# Instead of bundled wheels, use our RPM packaged wheels from
|
||||||
# /usr/share/python-wheels
|
# /usr/share/python-wheels
|
||||||
# We conditionally apply this, but we use autosetup, so we use Source here
|
# We conditionally apply this, but we use autosetup, so we use Source here
|
||||||
@ -250,13 +244,15 @@ BuildRequires: bzip2-devel
|
|||||||
BuildRequires: ncurses-devel
|
BuildRequires: ncurses-devel
|
||||||
BuildRequires: expat-devel
|
BuildRequires: expat-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
|
%if 0%{?fedora} >= 41
|
||||||
BuildRequires: openssl-devel-engine
|
BuildRequires: openssl-devel-engine
|
||||||
|
%endif
|
||||||
BuildRequires: gdbm-devel
|
BuildRequires: gdbm-devel
|
||||||
BuildRequires: chrpath
|
BuildRequires: chrpath
|
||||||
|
|
||||||
BuildRequires: python-rpm-macros
|
BuildRequires: python-rpm-macros
|
||||||
|
|
||||||
%ifarch %{valgrind_arches}
|
%ifnarch s390
|
||||||
BuildRequires: valgrind-devel
|
BuildRequires: valgrind-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -387,7 +383,7 @@ Provides: bundled(python2dist(webencodings)) = 0.5.1
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Find the version in lib_pypy/cffi/_pycparser/__init__.py
|
# Find the version in lib_pypy/cffi/_pycparser/__init__.py
|
||||||
Provides: bundled(python2dist(pycparser)) = 2.21
|
Provides: bundled(python2dist(pycparser)) = 2.22
|
||||||
|
|
||||||
# Find the version in lib_pypy/cffi/_pycparser/ply/__init__.py
|
# Find the version in lib_pypy/cffi/_pycparser/ply/__init__.py
|
||||||
Provides: bundled(python2dist(ply)) = 3.9
|
Provides: bundled(python2dist(ply)) = 3.9
|
||||||
@ -486,10 +482,6 @@ rm lib-python/2.7/distutils/command/*.exe
|
|||||||
%global optflags %(echo %{optflags} | sed 's/-march=z9-109 /-march=z10 /')
|
%global optflags %(echo %{optflags} | sed 's/-march=z9-109 /-march=z10 /')
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifarch riscv64
|
|
||||||
export PYPY_MULTIARCH=riscv64-linux-gnu
|
|
||||||
%endif
|
|
||||||
|
|
||||||
BuildPyPy() {
|
BuildPyPy() {
|
||||||
ExeName=$1
|
ExeName=$1
|
||||||
Options=$2
|
Options=$2
|
||||||
@ -577,12 +569,7 @@ BuildPyPy() {
|
|||||||
$INTERP ../../rpython/bin/rpython \
|
$INTERP ../../rpython/bin/rpython \
|
||||||
%{gcrootfinder_options} \
|
%{gcrootfinder_options} \
|
||||||
$Options \
|
$Options \
|
||||||
%ifarch riscv64
|
|
||||||
targetpypystandalone \
|
|
||||||
--withoutmod-_continuation
|
|
||||||
%else
|
|
||||||
targetpypystandalone
|
targetpypystandalone
|
||||||
%endif
|
|
||||||
|
|
||||||
echo "--------------------------------------------------------------"
|
echo "--------------------------------------------------------------"
|
||||||
echo "--------------------------------------------------------------"
|
echo "--------------------------------------------------------------"
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (pypy2.7-v7.3.15-src.tar.bz2) = 40448c7c94878bcb88402de8719a4a6a4ffe3f68d7e70500f04fe77a460b1605c83dace360988d2dae70fa2c9bb31a20c22003f70a3a2fde988f6d60507edefe
|
SHA512 (pypy2.7-v7.3.16-src.tar.bz2) = 131635433e53d4d86730a3daf1ad81799a7dd1117511618cc2607ac7234ce3aa5c833400df09cbd3376a391e125d6d2ec3471f120f81a6d53700f5c3d087793c
|
||||||
|
Loading…
Reference in New Issue
Block a user