1.7
* Mon Nov 21 2011 David Malcolm <dmalcolm@redhat.com> - 1.7-1 - 1.7: refresh patch 0 (configuration) and patch 4 (readability of generated code)
This commit is contained in:
parent
953cba8f40
commit
4ef3f10721
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
/pypy-1.4.1-src.tar.bz2
|
/pypy-1.4.1-src.tar.bz2
|
||||||
/pypy-1.5-src.tar.bz2
|
/pypy-1.5-src.tar.bz2
|
||||||
/release-1.6.tar.bz2
|
/release-1.6.tar.bz2
|
||||||
|
/release-1.7.tar.bz2
|
||||||
|
49
config.patch
Normal file
49
config.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
diff -up pypy-pypy-release-1.7/pypy/translator/platform/linux.py.configure-fedora pypy-pypy-release-1.7/pypy/translator/platform/linux.py
|
||||||
|
--- pypy-pypy-release-1.7/pypy/translator/platform/linux.py.configure-fedora 2011-11-19 02:44:54.000000000 -0500
|
||||||
|
+++ pypy-pypy-release-1.7/pypy/translator/platform/linux.py 2011-11-21 13:07:03.454240019 -0500
|
||||||
|
@@ -1,15 +1,21 @@
|
||||||
|
"""Support for Linux."""
|
||||||
|
|
||||||
|
+import os
|
||||||
|
import sys
|
||||||
|
from pypy.translator.platform.posix import BasePosix
|
||||||
|
|
||||||
|
+CFLAGS = ['-O3', '-pthread', '-fomit-frame-pointer',
|
||||||
|
+ '-Wall', '-Wno-unused']
|
||||||
|
+if os.environ.get('CFLAGS', None):
|
||||||
|
+ CFLAGS.extend(os.environ['CFLAGS'].split())
|
||||||
|
+CFLAGS = tuple(CFLAGS)
|
||||||
|
+
|
||||||
|
class BaseLinux(BasePosix):
|
||||||
|
name = "linux"
|
||||||
|
|
||||||
|
link_flags = ('-pthread',)
|
||||||
|
extra_libs = ('-lrt',)
|
||||||
|
- cflags = ('-O3', '-pthread', '-fomit-frame-pointer',
|
||||||
|
- '-Wall', '-Wno-unused')
|
||||||
|
+ cflags = CFLAGS
|
||||||
|
standalone_only = ()
|
||||||
|
shared_only = ('-fPIC',)
|
||||||
|
so_ext = 'so'
|
||||||
|
@@ -26,13 +32,14 @@ class BaseLinux(BasePosix):
|
||||||
|
return self._pkg_config("libffi", "--libs-only-L",
|
||||||
|
['/usr/lib/libffi'])
|
||||||
|
|
||||||
|
- def library_dirs_for_libffi_a(self):
|
||||||
|
- # places where we need to look for libffi.a
|
||||||
|
- # XXX obscuuure! only look for libffi.a if run with translate.py
|
||||||
|
- if 'translate' in sys.modules:
|
||||||
|
- return self.library_dirs_for_libffi() + ['/usr/lib']
|
||||||
|
- else:
|
||||||
|
- return []
|
||||||
|
+ # Fedora, at least, has the shared version but not the static:
|
||||||
|
+ #def library_dirs_for_libffi_a(self):
|
||||||
|
+ # # places where we need to look for libffi.a
|
||||||
|
+ # # XXX obscuuure! only look for libffi.a if run with translate.py
|
||||||
|
+ # if 'translate' in sys.modules:
|
||||||
|
+ # return self.library_dirs_for_libffi() + ['/usr/lib']
|
||||||
|
+ # else:
|
||||||
|
+ # return []
|
||||||
|
|
||||||
|
|
||||||
|
class Linux(BaseLinux):
|
@ -1,15 +1,15 @@
|
|||||||
diff -up pypy-1.5-src/pypy/interpreter/pycode.py.more-readable-c-code pypy-1.5-src/pypy/interpreter/pycode.py
|
diff -up pypy-pypy-release-1.7/pypy/interpreter/pycode.py.more-readable-c-code pypy-pypy-release-1.7/pypy/interpreter/pycode.py
|
||||||
--- pypy-1.5-src/pypy/interpreter/pycode.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/interpreter/pycode.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/interpreter/pycode.py 2011-05-02 14:28:33.942161002 -0400
|
+++ pypy-pypy-release-1.7/pypy/interpreter/pycode.py 2011-11-21 16:16:15.673463780 -0500
|
||||||
@@ -13,6 +13,7 @@ from pypy.interpreter.gateway import Non
|
@@ -13,6 +13,7 @@ from pypy.interpreter.gateway import Non
|
||||||
from pypy.interpreter.astcompiler.consts import (CO_OPTIMIZED,
|
from pypy.interpreter.astcompiler.consts import (
|
||||||
CO_OPTIMIZED, CO_NEWLOCALS, CO_VARARGS, CO_VARKEYWORDS, CO_NESTED,
|
CO_OPTIMIZED, CO_NEWLOCALS, CO_VARARGS, CO_VARKEYWORDS, CO_NESTED,
|
||||||
CO_GENERATOR, CO_CONTAINSGLOBALS)
|
CO_GENERATOR, CO_CONTAINSGLOBALS)
|
||||||
+from pypy.interpreter.pytraceback import offset2lineno
|
+from pypy.interpreter.pytraceback import offset2lineno
|
||||||
from pypy.rlib.rarithmetic import intmask
|
from pypy.rlib.rarithmetic import intmask
|
||||||
from pypy.rlib.debug import make_sure_not_resized
|
from pypy.rlib.debug import make_sure_not_resized
|
||||||
from pypy.rlib import jit
|
from pypy.rlib import jit
|
||||||
@@ -80,6 +81,7 @@ class PyCode(eval.Code):
|
@@ -81,6 +82,7 @@ class PyCode(eval.Code):
|
||||||
self.hidden_applevel = hidden_applevel
|
self.hidden_applevel = hidden_applevel
|
||||||
self.magic = magic
|
self.magic = magic
|
||||||
self._signature = cpython_code_signature(self)
|
self._signature = cpython_code_signature(self)
|
||||||
@ -17,7 +17,7 @@ diff -up pypy-1.5-src/pypy/interpreter/pycode.py.more-readable-c-code pypy-1.5-s
|
|||||||
self._initialize()
|
self._initialize()
|
||||||
|
|
||||||
def _initialize(self):
|
def _initialize(self):
|
||||||
@@ -396,3 +398,23 @@ class PyCode(eval.Code):
|
@@ -397,3 +399,23 @@ class PyCode(eval.Code):
|
||||||
|
|
||||||
def repr(self, space):
|
def repr(self, space):
|
||||||
return space.wrap(self.get_repr())
|
return space.wrap(self.get_repr())
|
||||||
@ -41,9 +41,9 @@ diff -up pypy-1.5-src/pypy/interpreter/pycode.py.more-readable-c-code pypy-1.5-s
|
|||||||
+ # raise an IOError)
|
+ # raise an IOError)
|
||||||
+ self._ensure_source()
|
+ self._ensure_source()
|
||||||
+ return self._cached_source[linenum - 1]
|
+ return self._cached_source[linenum - 1]
|
||||||
diff -up pypy-1.5-src/pypy/objspace/flow/model.py.more-readable-c-code pypy-1.5-src/pypy/objspace/flow/model.py
|
diff -up pypy-pypy-release-1.7/pypy/objspace/flow/model.py.more-readable-c-code pypy-pypy-release-1.7/pypy/objspace/flow/model.py
|
||||||
--- pypy-1.5-src/pypy/objspace/flow/model.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/objspace/flow/model.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/objspace/flow/model.py 2011-05-02 14:28:33.942161002 -0400
|
+++ pypy-pypy-release-1.7/pypy/objspace/flow/model.py 2011-11-21 16:15:36.599466455 -0500
|
||||||
@@ -31,6 +31,120 @@ from pypy.tool.identity_dict import iden
|
@@ -31,6 +31,120 @@ from pypy.tool.identity_dict import iden
|
||||||
|
|
||||||
__metaclass__ = type
|
__metaclass__ = type
|
||||||
@ -268,10 +268,10 @@ diff -up pypy-1.5-src/pypy/objspace/flow/model.py.more-readable-c-code pypy-1.5-
|
|||||||
result.append(copyop)
|
result.append(copyop)
|
||||||
return result
|
return result
|
||||||
newblock.operations = copyoplist(block.operations)
|
newblock.operations = copyoplist(block.operations)
|
||||||
diff -up pypy-1.5-src/pypy/objspace/flow/objspace.py.more-readable-c-code pypy-1.5-src/pypy/objspace/flow/objspace.py
|
diff -up pypy-pypy-release-1.7/pypy/objspace/flow/objspace.py.more-readable-c-code pypy-pypy-release-1.7/pypy/objspace/flow/objspace.py
|
||||||
--- pypy-1.5-src/pypy/objspace/flow/objspace.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/objspace/flow/objspace.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/objspace/flow/objspace.py 2011-05-02 14:28:33.943161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/objspace/flow/objspace.py 2011-11-21 16:15:36.600466455 -0500
|
||||||
@@ -313,7 +313,9 @@ class FlowObjSpace(ObjSpace):
|
@@ -315,7 +315,9 @@ class FlowObjSpace(ObjSpace):
|
||||||
def do_operation(self, name, *args_w):
|
def do_operation(self, name, *args_w):
|
||||||
spaceop = SpaceOperation(name, args_w, Variable())
|
spaceop = SpaceOperation(name, args_w, Variable())
|
||||||
if hasattr(self, 'executioncontext'): # not here during bootstrapping
|
if hasattr(self, 'executioncontext'): # not here during bootstrapping
|
||||||
@ -282,9 +282,9 @@ diff -up pypy-1.5-src/pypy/objspace/flow/objspace.py.more-readable-c-code pypy-1
|
|||||||
self.executioncontext.recorder.append(spaceop)
|
self.executioncontext.recorder.append(spaceop)
|
||||||
return spaceop.result
|
return spaceop.result
|
||||||
|
|
||||||
diff -up pypy-1.5-src/pypy/objspace/flow/test/test_model.py.more-readable-c-code pypy-1.5-src/pypy/objspace/flow/test/test_model.py
|
diff -up pypy-pypy-release-1.7/pypy/objspace/flow/test/test_model.py.more-readable-c-code pypy-pypy-release-1.7/pypy/objspace/flow/test/test_model.py
|
||||||
--- pypy-1.5-src/pypy/objspace/flow/test/test_model.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/objspace/flow/test/test_model.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/objspace/flow/test/test_model.py 2011-05-02 14:28:33.943161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/objspace/flow/test/test_model.py 2011-11-21 16:15:36.600466455 -0500
|
||||||
@@ -119,3 +119,25 @@ def test_variable():
|
@@ -119,3 +119,25 @@ def test_variable():
|
||||||
assert v2.renamed
|
assert v2.renamed
|
||||||
assert v2.name.startswith("foobar_") and v2.name != v.name
|
assert v2.name.startswith("foobar_") and v2.name != v.name
|
||||||
@ -311,9 +311,9 @@ diff -up pypy-1.5-src/pypy/objspace/flow/test/test_model.py.more-readable-c-code
|
|||||||
+ assert cmp(oplocA, oplocB) < 0
|
+ assert cmp(oplocA, oplocB) < 0
|
||||||
+ assert cmp(oplocB, oplocA) > 0
|
+ assert cmp(oplocB, oplocA) > 0
|
||||||
+
|
+
|
||||||
diff -up pypy-1.5-src/pypy/rpython/rtyper.py.more-readable-c-code pypy-1.5-src/pypy/rpython/rtyper.py
|
diff -up pypy-pypy-release-1.7/pypy/rpython/rtyper.py.more-readable-c-code pypy-pypy-release-1.7/pypy/rpython/rtyper.py
|
||||||
--- pypy-1.5-src/pypy/rpython/rtyper.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/rpython/rtyper.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/rpython/rtyper.py 2011-05-02 14:28:33.943161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/rpython/rtyper.py 2011-11-21 16:15:36.601466455 -0500
|
||||||
@@ -800,7 +800,7 @@ class HighLevelOp(object):
|
@@ -800,7 +800,7 @@ class HighLevelOp(object):
|
||||||
return vars
|
return vars
|
||||||
|
|
||||||
@ -341,9 +341,9 @@ diff -up pypy-1.5-src/pypy/rpython/rtyper.py.more-readable-c-code pypy-1.5-src/p
|
|||||||
if resulttype is None:
|
if resulttype is None:
|
||||||
vresult.concretetype = Void
|
vresult.concretetype = Void
|
||||||
return None
|
return None
|
||||||
diff -up pypy-1.5-src/pypy/translator/backendopt/inline.py.more-readable-c-code pypy-1.5-src/pypy/translator/backendopt/inline.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/backendopt/inline.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/backendopt/inline.py
|
||||||
--- pypy-1.5-src/pypy/translator/backendopt/inline.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/backendopt/inline.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/backendopt/inline.py 2011-05-02 14:32:26.975161005 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/backendopt/inline.py 2011-11-21 16:15:36.601466455 -0500
|
||||||
@@ -4,6 +4,7 @@ from pypy.translator.simplify import get
|
@@ -4,6 +4,7 @@ from pypy.translator.simplify import get
|
||||||
from pypy.translator.unsimplify import copyvar
|
from pypy.translator.unsimplify import copyvar
|
||||||
from pypy.objspace.flow.model import Variable, Constant, Block, Link
|
from pypy.objspace.flow.model import Variable, Constant, Block, Link
|
||||||
@ -371,9 +371,9 @@ diff -up pypy-1.5-src/pypy/translator/backendopt/inline.py.more-readable-c-code
|
|||||||
return result
|
return result
|
||||||
|
|
||||||
def copy_block(self, block):
|
def copy_block(self, block):
|
||||||
diff -up pypy-1.5-src/pypy/translator/c/funcgen.py.more-readable-c-code pypy-1.5-src/pypy/translator/c/funcgen.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/c/funcgen.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/c/funcgen.py
|
||||||
--- pypy-1.5-src/pypy/translator/c/funcgen.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/c/funcgen.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/c/funcgen.py 2011-05-02 14:28:33.944161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/c/funcgen.py 2011-11-21 16:15:36.602466455 -0500
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
import sys
|
import sys
|
||||||
+import inspect
|
+import inspect
|
||||||
@ -420,7 +420,7 @@ diff -up pypy-1.5-src/pypy/translator/c/funcgen.py.more-readable-c-code pypy-1.5
|
|||||||
class FunctionCodeGenerator(object):
|
class FunctionCodeGenerator(object):
|
||||||
"""
|
"""
|
||||||
Collects information about a function which we have to generate
|
Collects information about a function which we have to generate
|
||||||
@@ -210,14 +244,57 @@ class FunctionCodeGenerator(object):
|
@@ -207,14 +241,57 @@ class FunctionCodeGenerator(object):
|
||||||
|
|
||||||
def cfunction_body(self):
|
def cfunction_body(self):
|
||||||
graph = self.graph
|
graph = self.graph
|
||||||
@ -481,7 +481,7 @@ diff -up pypy-1.5-src/pypy/translator/c/funcgen.py.more-readable-c-code pypy-1.5
|
|||||||
for line in self.gen_op(op):
|
for line in self.gen_op(op):
|
||||||
yield line
|
yield line
|
||||||
if len(block.exits) == 0:
|
if len(block.exits) == 0:
|
||||||
@@ -309,7 +386,7 @@ class FunctionCodeGenerator(object):
|
@@ -306,7 +383,7 @@ class FunctionCodeGenerator(object):
|
||||||
assignments.append((a2typename, dest, src))
|
assignments.append((a2typename, dest, src))
|
||||||
for line in gen_assignments(assignments):
|
for line in gen_assignments(assignments):
|
||||||
yield line
|
yield line
|
||||||
@ -490,16 +490,16 @@ diff -up pypy-1.5-src/pypy/translator/c/funcgen.py.more-readable-c-code pypy-1.5
|
|||||||
if link.target in self.innerloops:
|
if link.target in self.innerloops:
|
||||||
loop = self.innerloops[link.target]
|
loop = self.innerloops[link.target]
|
||||||
if link is loop.links[-1]: # link that ends a loop
|
if link is loop.links[-1]: # link that ends a loop
|
||||||
diff -up pypy-1.5-src/pypy/translator/c/test/test_genc.py.more-readable-c-code pypy-1.5-src/pypy/translator/c/test/test_genc.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/c/test/test_genc.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/c/test/test_genc.py
|
||||||
--- pypy-1.5-src/pypy/translator/c/test/test_genc.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/c/test/test_genc.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/c/test/test_genc.py 2011-05-02 14:28:33.945161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/c/test/test_genc.py 2011-11-21 16:15:36.602466455 -0500
|
||||||
@@ -1,4 +1,5 @@
|
@@ -1,4 +1,5 @@
|
||||||
import autopath, sys, os, py
|
import autopath, sys, os, py
|
||||||
+import re
|
+import re
|
||||||
from pypy.rpython.lltypesystem.lltype import *
|
from pypy.rpython.lltypesystem.lltype import *
|
||||||
from pypy.annotation import model as annmodel
|
from pypy.annotation import model as annmodel
|
||||||
from pypy.translator.translator import TranslationContext
|
from pypy.translator.translator import TranslationContext
|
||||||
@@ -515,3 +516,130 @@ def test_inhibit_tail_call():
|
@@ -532,3 +533,130 @@ def test_inhibit_tail_call():
|
||||||
else:
|
else:
|
||||||
assert 0, "the call was not found in the C source"
|
assert 0, "the call was not found in the C source"
|
||||||
assert 'PYPY_INHIBIT_TAIL_CALL();' in lines[i+1]
|
assert 'PYPY_INHIBIT_TAIL_CALL();' in lines[i+1]
|
||||||
@ -630,10 +630,10 @@ diff -up pypy-1.5-src/pypy/translator/c/test/test_genc.py.more-readable-c-code p
|
|||||||
+ assert 'Here is a ' in c_fn_src
|
+ assert 'Here is a ' in c_fn_src
|
||||||
+ assert 'style comment within an RPython docstring' in c_fn_src
|
+ assert 'style comment within an RPython docstring' in c_fn_src
|
||||||
+
|
+
|
||||||
diff -up pypy-1.5-src/pypy/translator/driver.py.more-readable-c-code pypy-1.5-src/pypy/translator/driver.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/driver.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/driver.py
|
||||||
--- pypy-1.5-src/pypy/translator/driver.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/driver.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/driver.py 2011-05-02 14:28:33.945161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/driver.py 2011-11-21 16:15:36.603466455 -0500
|
||||||
@@ -536,6 +536,7 @@ class TranslationDriver(SimpleTaskEngine
|
@@ -535,6 +535,7 @@ class TranslationDriver(SimpleTaskEngine
|
||||||
dstname = self.compute_exe_name() + '.staticdata.info'
|
dstname = self.compute_exe_name() + '.staticdata.info'
|
||||||
shutil.copy(str(fname), str(dstname))
|
shutil.copy(str(fname), str(dstname))
|
||||||
self.log.info('Static data info written to %s' % dstname)
|
self.log.info('Static data info written to %s' % dstname)
|
||||||
@ -641,9 +641,9 @@ diff -up pypy-1.5-src/pypy/translator/driver.py.more-readable-c-code pypy-1.5-sr
|
|||||||
|
|
||||||
#
|
#
|
||||||
task_source_c = taskdef(task_source_c, ['database_c'], "Generating c source")
|
task_source_c = taskdef(task_source_c, ['database_c'], "Generating c source")
|
||||||
diff -up pypy-1.5-src/pypy/translator/gensupp.py.more-readable-c-code pypy-1.5-src/pypy/translator/gensupp.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/gensupp.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/gensupp.py
|
||||||
--- pypy-1.5-src/pypy/translator/gensupp.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/gensupp.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/gensupp.py 2011-05-02 14:33:31.026161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/gensupp.py 2011-11-21 16:15:36.603466455 -0500
|
||||||
@@ -14,8 +14,8 @@ def ordered_blocks(graph):
|
@@ -14,8 +14,8 @@ def ordered_blocks(graph):
|
||||||
allblocks = []
|
allblocks = []
|
||||||
for block in graph.iterblocks():
|
for block in graph.iterblocks():
|
||||||
@ -655,9 +655,9 @@ diff -up pypy-1.5-src/pypy/translator/gensupp.py.more-readable-c-code pypy-1.5-s
|
|||||||
else:
|
else:
|
||||||
ofs = sys.maxint
|
ofs = sys.maxint
|
||||||
# then we order by input variable name or value
|
# then we order by input variable name or value
|
||||||
diff -up pypy-1.5-src/pypy/translator/interactive.py.more-readable-c-code pypy-1.5-src/pypy/translator/interactive.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/interactive.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/interactive.py
|
||||||
--- pypy-1.5-src/pypy/translator/interactive.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/interactive.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/interactive.py 2011-05-02 14:28:33.946161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/interactive.py 2011-11-21 16:15:36.604466454 -0500
|
||||||
@@ -138,7 +138,7 @@ class Translation(object):
|
@@ -138,7 +138,7 @@ class Translation(object):
|
||||||
def source_c(self, argtypes=None, **kwds):
|
def source_c(self, argtypes=None, **kwds):
|
||||||
self.update_options(argtypes, kwds)
|
self.update_options(argtypes, kwds)
|
||||||
@ -667,9 +667,9 @@ diff -up pypy-1.5-src/pypy/translator/interactive.py.more-readable-c-code pypy-1
|
|||||||
|
|
||||||
def source_cl(self, argtypes=None, **kwds):
|
def source_cl(self, argtypes=None, **kwds):
|
||||||
self.update_options(argtypes, kwds)
|
self.update_options(argtypes, kwds)
|
||||||
diff -up pypy-1.5-src/pypy/translator/llsupport/wrapper.py.more-readable-c-code pypy-1.5-src/pypy/translator/llsupport/wrapper.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/llsupport/wrapper.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/llsupport/wrapper.py
|
||||||
--- pypy-1.5-src/pypy/translator/llsupport/wrapper.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/llsupport/wrapper.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/llsupport/wrapper.py 2011-05-02 14:28:33.946161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/llsupport/wrapper.py 2011-11-21 16:15:36.604466454 -0500
|
||||||
@@ -59,6 +59,8 @@ def new_wrapper(func, translator, newnam
|
@@ -59,6 +59,8 @@ def new_wrapper(func, translator, newnam
|
||||||
# "return result"
|
# "return result"
|
||||||
block = Block(wrapper_inputargs)
|
block = Block(wrapper_inputargs)
|
||||||
@ -679,10 +679,10 @@ diff -up pypy-1.5-src/pypy/translator/llsupport/wrapper.py.more-readable-c-code
|
|||||||
translator.update_call_graph(wgraph, graph, object())
|
translator.update_call_graph(wgraph, graph, object())
|
||||||
translator.graphs.append(wgraph)
|
translator.graphs.append(wgraph)
|
||||||
block.operations[:] = newops
|
block.operations[:] = newops
|
||||||
diff -up pypy-1.5-src/pypy/translator/simplify.py.more-readable-c-code pypy-1.5-src/pypy/translator/simplify.py
|
diff -up pypy-pypy-release-1.7/pypy/translator/simplify.py.more-readable-c-code pypy-pypy-release-1.7/pypy/translator/simplify.py
|
||||||
--- pypy-1.5-src/pypy/translator/simplify.py.more-readable-c-code 2011-04-30 10:18:50.000000000 -0400
|
--- pypy-pypy-release-1.7/pypy/translator/simplify.py.more-readable-c-code 2011-11-19 02:44:54.000000000 -0500
|
||||||
+++ pypy-1.5-src/pypy/translator/simplify.py 2011-05-02 14:28:33.952161001 -0400
|
+++ pypy-pypy-release-1.7/pypy/translator/simplify.py 2011-11-21 16:15:36.605466454 -0500
|
||||||
@@ -298,7 +298,7 @@ def join_blocks(graph):
|
@@ -292,7 +292,7 @@ def join_blocks(graph):
|
||||||
return renaming.get(v, v)
|
return renaming.get(v, v)
|
||||||
def rename_op(op):
|
def rename_op(op):
|
||||||
args = [rename(a) for a in op.args]
|
args = [rename(a) for a in op.args]
|
@ -1,39 +0,0 @@
|
|||||||
diff -up pypy-1.5-src/pypy/translator/platform/linux.py.configure-fedora pypy-1.5-src/pypy/translator/platform/linux.py
|
|
||||||
--- pypy-1.5-src/pypy/translator/platform/linux.py.configure-fedora 2011-04-30 10:18:50.000000000 -0400
|
|
||||||
+++ pypy-1.5-src/pypy/translator/platform/linux.py 2011-04-30 18:59:24.041160978 -0400
|
|
||||||
@@ -1,13 +1,18 @@
|
|
||||||
"""Support for Linux."""
|
|
||||||
-
|
|
||||||
+import os
|
|
||||||
from pypy.translator.platform.posix import BasePosix
|
|
||||||
|
|
||||||
+CFLAGS = ['-O3', '-pthread', '-fomit-frame-pointer',
|
|
||||||
+ '-Wall', '-Wno-unused']
|
|
||||||
+if os.environ.get('CFLAGS', None):
|
|
||||||
+ CFLAGS.extend(os.environ['CFLAGS'].split())
|
|
||||||
+CFLAGS = tuple(CFLAGS)
|
|
||||||
+
|
|
||||||
class BaseLinux(BasePosix):
|
|
||||||
name = "linux"
|
|
||||||
|
|
||||||
link_flags = ('-pthread', '-lrt')
|
|
||||||
- cflags = ('-O3', '-pthread', '-fomit-frame-pointer',
|
|
||||||
- '-Wall', '-Wno-unused')
|
|
||||||
+ cflags = CFLAGS
|
|
||||||
standalone_only = ()
|
|
||||||
shared_only = ('-fPIC',)
|
|
||||||
so_ext = 'so'
|
|
||||||
@@ -29,9 +34,10 @@ class Linux(BaseLinux):
|
|
||||||
shared_only = () # it seems that on 32-bit linux, compiling with -fPIC
|
|
||||||
# gives assembler that asmgcc is not happy about.
|
|
||||||
|
|
||||||
- def library_dirs_for_libffi_a(self):
|
|
||||||
- # places where we need to look for libffi.a
|
|
||||||
- return self.library_dirs_for_libffi() + ['/usr/lib']
|
|
||||||
+ # Fedora Linux, at least, has the shared version but not the static
|
|
||||||
+ #def library_dirs_for_libffi_a(self):
|
|
||||||
+ # # places where we need to look for libffi.a
|
|
||||||
+ # return self.library_dirs_for_libffi() + ['/usr/lib']
|
|
||||||
|
|
||||||
|
|
||||||
class Linux64(BaseLinux):
|
|
14
pypy.spec
14
pypy.spec
@ -1,6 +1,6 @@
|
|||||||
Name: pypy
|
Name: pypy
|
||||||
Version: 1.6
|
Version: 1.7
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Python implementation with a Just-In-Time compiler
|
Summary: Python implementation with a Just-In-Time compiler
|
||||||
|
|
||||||
Group: Development/Languages
|
Group: Development/Languages
|
||||||
@ -126,14 +126,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|||||||
%(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
|
%(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
|
||||||
|
|
||||||
# Source and patches:
|
# Source and patches:
|
||||||
Source0: https://bitbucket.org/pypy/pypy/get/release-1.6.tar.bz2
|
Source0: https://bitbucket.org/pypy/pypy/get/release-%{version}.tar.bz2
|
||||||
|
|
||||||
# Supply various useful RPM macros for building python modules against pypy:
|
# Supply various useful RPM macros for building python modules against pypy:
|
||||||
# __pypy, pypy_sitelib, pypy_sitearch
|
# __pypy, pypy_sitelib, pypy_sitearch
|
||||||
Source2: macros.pypy
|
Source2: macros.pypy
|
||||||
|
|
||||||
# Edit a translator file for linux in order to configure our cflags and dynamic libffi
|
# Edit a translator file for linux in order to configure our cflags and dynamic libffi
|
||||||
Patch0: pypy-1.5-config.patch
|
Patch0: config.patch
|
||||||
|
|
||||||
# By default, if built at a tty, the translation process renders a Mandelbrot
|
# By default, if built at a tty, the translation process renders a Mandelbrot
|
||||||
# set to indicate progress.
|
# set to indicate progress.
|
||||||
@ -163,7 +163,7 @@ Patch3: pypy-1.4.1-add-LIBRARY_INSTALLATION_PATH.patch
|
|||||||
# http://codespeak.net/pipermail/pypy-dev/2010q4/006532.html
|
# http://codespeak.net/pipermail/pypy-dev/2010q4/006532.html
|
||||||
# TODO: get this into the upstream bug tracker, and finish inlining
|
# TODO: get this into the upstream bug tracker, and finish inlining
|
||||||
# support (rhbz#666963)
|
# support (rhbz#666963)
|
||||||
Patch4: pypy-1.5-more-readable-c-code.patch
|
Patch4: more-readable-c-code.patch
|
||||||
|
|
||||||
# In my koji builds, /root/bin is in the PATH for some reason
|
# In my koji builds, /root/bin is in the PATH for some reason
|
||||||
# This leads to test_subprocess.py failing, due to "test_leaking_fds_on_error"
|
# This leads to test_subprocess.py failing, due to "test_leaking_fds_on_error"
|
||||||
@ -847,6 +847,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 21 2011 David Malcolm <dmalcolm@redhat.com> - 1.7-1
|
||||||
|
- 1.7: refresh patch 0 (configuration) and patch 4 (readability of generated
|
||||||
|
code)
|
||||||
|
|
||||||
* Tue Oct 4 2011 David Malcolm <dmalcolm@redhat.com> - 1.6-7
|
* Tue Oct 4 2011 David Malcolm <dmalcolm@redhat.com> - 1.6-7
|
||||||
- skip test_multiprocessing
|
- skip test_multiprocessing
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user