Update to 7.3.1
This commit is contained in:
parent
d8b07897c5
commit
0fdc213e80
@ -1,8 +1,8 @@
|
||||
diff --git a/lib-python/2.7/ensurepip/__init__.py b/lib-python/2.7/ensurepip/__init__.py
|
||||
index ae01aa7..f1311be 100644
|
||||
index 78ffd23..225c90a 100644
|
||||
--- a/lib-python/2.7/ensurepip/__init__.py
|
||||
+++ b/lib-python/2.7/ensurepip/__init__.py
|
||||
@@ -1,9 +1,10 @@
|
||||
@@ -1,11 +1,14 @@
|
||||
#!/usr/bin/env python2
|
||||
from __future__ import print_function
|
||||
|
||||
@ -10,25 +10,32 @@ index ae01aa7..f1311be 100644
|
||||
+import glob
|
||||
import os
|
||||
import os.path
|
||||
-import pkgutil
|
||||
import pkgutil
|
||||
import shutil
|
||||
import sys
|
||||
+import runpy
|
||||
import tempfile
|
||||
@@ -11,10 +12,20 @@ import tempfile
|
||||
import warnings
|
||||
|
||||
@@ -13,9 +16,24 @@ import warnings
|
||||
__all__ = ["version", "bootstrap"]
|
||||
|
||||
|
||||
-_SETUPTOOLS_VERSION = "44.0.0"
|
||||
+_WHEEL_DIR = "/usr/share/python-wheels/"
|
||||
|
||||
-_SETUPTOOLS_VERSION = "41.2.0"
|
||||
|
||||
-_PIP_VERSION = "19.2.3"
|
||||
-_PIP_VERSION = "20.0.2"
|
||||
+_wheels = {}
|
||||
+
|
||||
+def _get_most_recent_wheel_version(pkg):
|
||||
+ prefix = os.path.join(_WHEEL_DIR, "{}-".format(pkg))
|
||||
+ suffix = "-py2.py3-none-any.whl"
|
||||
+ pattern = "{}*{}".format(prefix, suffix)
|
||||
+ versions = (p[len(prefix):-len(suffix)] for p in glob.glob(pattern))
|
||||
+ return str(max(versions, key=distutils.version.LooseVersion))
|
||||
+ _wheels[pkg] = {}
|
||||
+ for suffix in "-py2.py3-none-any.whl", "-py3-none-any.whl":
|
||||
+ pattern = "{}*{}".format(prefix, suffix)
|
||||
+ for path in glob.glob(pattern):
|
||||
+ version_str = path[len(prefix):-len(suffix)]
|
||||
+ _wheels[pkg][version_str] = os.path.basename(path)
|
||||
+ return str(max(_wheels[pkg], key=distutils.version.LooseVersion))
|
||||
+
|
||||
+
|
||||
+_SETUPTOOLS_VERSION = _get_most_recent_wheel_version("setuptools")
|
||||
@ -37,16 +44,43 @@ index ae01aa7..f1311be 100644
|
||||
|
||||
_PROJECTS = [
|
||||
("setuptools", _SETUPTOOLS_VERSION),
|
||||
@@ -85,12 +96,9 @@ def bootstrap(root=None, upgrade=False, user=False,
|
||||
@@ -28,13 +46,18 @@ def _run_pip(args, additional_paths=None):
|
||||
if additional_paths is not None:
|
||||
sys.path = additional_paths + sys.path
|
||||
|
||||
- # Install the bundled pip, filtering the PipDeprecationWarning
|
||||
- import pip._internal.cli.main
|
||||
- from pip._internal.utils.deprecation import PipDeprecationWarning
|
||||
- with warnings.catch_warnings():
|
||||
- warnings.filterwarnings('ignore', category=PipDeprecationWarning)
|
||||
- return pip._internal.cli.main.main(args)
|
||||
+ # Invoke pip as if it's the main module, and catch the exit.
|
||||
+ backup_argv = sys.argv[:]
|
||||
+ sys.argv[1:] = args
|
||||
+ try:
|
||||
+ # run_module() alters sys.modules and sys.argv, but restores them at exit
|
||||
+ runpy.run_module("pip", run_name="__main__", alter_sys=True)
|
||||
+ except SystemExit as exc:
|
||||
+ return exc.code
|
||||
+ finally:
|
||||
+ sys.argv[:] = backup_argv
|
||||
|
||||
+ raise SystemError("pip did not exit, this should never happen")
|
||||
|
||||
def version():
|
||||
"""
|
||||
@@ -88,13 +111,10 @@ def bootstrap(root=None, upgrade=False, user=False,
|
||||
# additional paths that need added to sys.path
|
||||
additional_paths = []
|
||||
for project, version in _PROJECTS:
|
||||
wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||
- wheel_name = "{}-{}-py2.py3-none-any.whl".format(project, version)
|
||||
- whl = pkgutil.get_data(
|
||||
- "ensurepip",
|
||||
- "_bundled/{}".format(wheel_name),
|
||||
- )
|
||||
- with open(os.path.join(tmpdir, wheel_name), "wb") as fp:
|
||||
- fp.write(whl)
|
||||
+ wheel_name = _wheels[project][version]
|
||||
+ with open(os.path.join(_WHEEL_DIR, wheel_name), "rb") as sfp:
|
||||
+ with open(os.path.join(tmpdir, wheel_name), "wb") as fp:
|
||||
+ fp.write(sfp.read())
|
||||
|
38
pypy.spec
38
pypy.spec
@ -1,8 +1,8 @@
|
||||
%global basever 7.3
|
||||
Name: pypy
|
||||
Version: %{basever}.0
|
||||
Version: %{basever}.1
|
||||
%global pyversion 2.7
|
||||
Release: 3%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Python implementation with a Just-In-Time compiler
|
||||
|
||||
# LGPL and another free license we'd need to ask spot about are present in some
|
||||
@ -300,34 +300,35 @@ Requires: emacs-filesystem >= %{_emacs_version}
|
||||
Requires: python-setuptools-wheel < 45
|
||||
Requires: python-pip-wheel
|
||||
%else
|
||||
Provides: bundled(python2dist(setuptools)) = 41.2.0
|
||||
Provides: bundled(python2dist(setuptools)) = 44.0.0
|
||||
Provides: bundled(python2dist(packaging)) = 16.8
|
||||
Provides: bundled(python2dist(pyparsing)) = 2.2.1
|
||||
Provides: bundled(python2dist(six)) = 1.10.0
|
||||
|
||||
Provides: bundled(python2dist(pip)) = 19.2.3
|
||||
Provides: bundled(python2dist(pip)) = 20.0.2
|
||||
Provides: bundled(python2dist(appdirs)) = 1.4.3
|
||||
Provides: bundled(python2dist(CacheControl)) = 0.12.5
|
||||
Provides: bundled(python2dist(certifi)) = 2019.6.16
|
||||
Provides: bundled(python2dist(CacheControl)) = 0.12.6
|
||||
Provides: bundled(python2dist(contextlib2)) = 0.6.0
|
||||
Provides: bundled(python2dist(certifi)) = 2019.11.28
|
||||
Provides: bundled(python2dist(chardet)) = 3.0.4
|
||||
Provides: bundled(python2dist(colorama)) = 0.4.1
|
||||
Provides: bundled(python2dist(distlib)) = 0.2.9.post0
|
||||
Provides: bundled(python2dist(colorama)) = 0.4.3
|
||||
Provides: bundled(python2dist(distlib)) = 0.3.0
|
||||
Provides: bundled(python2dist(distro)) = 1.4.0
|
||||
Provides: bundled(python2dist(html5lib)) = 1.0.1
|
||||
Provides: bundled(python2dist(idna)) = 2.8
|
||||
Provides: bundled(python2dist(ipaddress)) = 1.0.22
|
||||
Provides: bundled(python2dist(ipaddress)) = 1.0.23
|
||||
Provides: bundled(python2dist(lockfile)) = 0.12.2
|
||||
Provides: bundled(python2dist(msgpack)) = 0.6.1
|
||||
Provides: bundled(python2dist(packaging)) = 19.0
|
||||
Provides: bundled(python2dist(pep517)) = 0.5.0
|
||||
Provides: bundled(python2dist(msgpack)) = 0.6.2
|
||||
Provides: bundled(python2dist(packaging)) = 20.1
|
||||
Provides: bundled(python2dist(pep517)) = 0.7.0
|
||||
Provides: bundled(python2dist(progress)) = 1.5
|
||||
Provides: bundled(python2dist(pyparsing)) = 2.4.0
|
||||
Provides: bundled(python2dist(pytoml)) = 0.1.20
|
||||
Provides: bundled(python2dist(pyparsing)) = 2.4.6
|
||||
Provides: bundled(python2dist(pytoml)) = 0.1.21
|
||||
Provides: bundled(python2dist(requests)) = 2.22.0
|
||||
Provides: bundled(python2dist(retrying)) = 1.3.3
|
||||
Provides: bundled(python2dist(setuptools)) = 41.0.1
|
||||
Provides: bundled(python2dist(six)) = 1.12.0
|
||||
Provides: bundled(python2dist(urllib3)) = 1.25.3
|
||||
Provides: bundled(python2dist(setuptools)) = 44.0.0
|
||||
Provides: bundled(python2dist(six)) = 1.14.0
|
||||
Provides: bundled(python2dist(urllib3)) = 1.25.7
|
||||
Provides: bundled(python2dist(webencodings)) = 0.5.1
|
||||
%endif
|
||||
|
||||
@ -858,6 +859,9 @@ CheckPyPy %{name}-c-stackless
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 20 2020 Tomas Hrnciar <thrnciar@redhat.com> - 7.3.1-1
|
||||
- Update to 7.3.1
|
||||
|
||||
* Wed Feb 12 2020 Miro Hrončok <mhroncok@redhat.com> - 7.3.0-3
|
||||
- Use bundled wheels, to allow updating setuptools in Fedora
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pypy2.7-v7.3.0-src.tar.bz2) = 05f039f090d837a72012db55f23d94da3f21c7458f18bd1e8ba632489248eb6486ced07b786d05e573abf2b3def2a68d96e7e1109e6d189d8e6c303c60ee3535
|
||||
SHA512 (pypy2.7-v7.3.1-src.tar.bz2) = 1bec44fa0fc4b1186e25f69303f9e332df32184be990d86fba41c40152664a93bd65eabf4dded133371271402cea9b150b60c13bce89d1004b276f0908c0b8f1
|
||||
|
Loading…
Reference in New Issue
Block a user