Merge remote-tracking branch 'up/master' into master-riscv64
Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
commit
a92eb32654
1
.gitignore
vendored
1
.gitignore
vendored
@ -186,3 +186,4 @@ pykickstart-1.78.tar.gz
|
||||
/pykickstart-3.12.tar.gz
|
||||
/pykickstart-3.13.tar.gz
|
||||
/pykickstart-3.14.tar.gz
|
||||
/pykickstart-3.15.tar.gz
|
||||
|
@ -1,56 +0,0 @@
|
||||
commit f618b966fe3358b89412e58b9b249edb35b154dc
|
||||
Author: Vendula Poncova <vponcova@redhat.com>
|
||||
Date: Thu May 17 20:38:22 2018 +0200
|
||||
|
||||
Include the _sortCommand to the _setCommand method (#1578930)
|
||||
|
||||
The _sortCommand method should be part of the _setCommand method,
|
||||
otherwise we might set the command without changing the _writeOrder
|
||||
dictionary.
|
||||
|
||||
This should fix the resetCommand method, where the dictionary wasn't
|
||||
updated, so the old instance of the command was used to generate the
|
||||
kickstart representation.
|
||||
|
||||
Resolves: rhbz#1578930
|
||||
|
||||
diff --git a/pykickstart/base.py b/pykickstart/base.py
|
||||
index 00b5c8f..f695dcc 100644
|
||||
--- a/pykickstart/base.py
|
||||
+++ b/pykickstart/base.py
|
||||
@@ -306,7 +306,6 @@ class KickstartHandler(KickstartObject):
|
||||
|
||||
setattr(self, name.lower(), cmdObj)
|
||||
|
||||
- def _sortCommand(self, cmdObj):
|
||||
# Also, add the object into the _writeOrder dict in the right place.
|
||||
if cmdObj.writePriority is not None:
|
||||
if cmdObj.writePriority in self._writeOrder:
|
||||
@@ -332,7 +331,6 @@ class KickstartHandler(KickstartObject):
|
||||
if cmdObj is None:
|
||||
cmdObj = cmdClass()
|
||||
self._setCommand(cmdObj)
|
||||
- self._sortCommand(cmdObj)
|
||||
|
||||
# Finally, add the mapping to the commands dict.
|
||||
self.commands[cmdName] = cmdObj
|
||||
diff --git a/tests/base.py b/tests/base.py
|
||||
index 2d3961c..e1f4689 100644
|
||||
--- a/tests/base.py
|
||||
+++ b/tests/base.py
|
||||
@@ -232,6 +232,7 @@ class HandlerResetCommand_TestCase(ParserTest):
|
||||
self.assertTrue(self.handler.autopart.encrypted)
|
||||
self.assertEqual(self.handler.autopart.passphrase, "something")
|
||||
self.assertTrue(self.handler.autopart.bogus)
|
||||
+ self.assertTrue("autopart" in str(self.handler))
|
||||
|
||||
self.handler.resetCommand("autopart")
|
||||
self.assertFalse(self.handler.autopart.autopart)
|
||||
@@ -239,6 +240,7 @@ class HandlerResetCommand_TestCase(ParserTest):
|
||||
self.assertFalse(self.handler.autopart.encrypted)
|
||||
self.assertEqual(self.handler.autopart.passphrase, "")
|
||||
self.assertNotIn("bogus", self.handler.autopart.__dict__)
|
||||
+ self.assertFalse("autopart" in str(self.handler))
|
||||
|
||||
class HandlerDispatch_TestCase(ParserTest):
|
||||
def runTest(self):
|
@ -1,13 +0,0 @@
|
||||
diff -up pykickstart-3.12/po/Makefile.orig pykickstart-3.12/po/Makefile
|
||||
--- pykickstart-3.12/po/Makefile.orig 2018-02-19 11:41:09.000000000 -0500
|
||||
+++ pykickstart-3.12/po/Makefile 2018-05-22 16:15:46.650917679 -0400
|
||||
@@ -12,8 +12,7 @@ INSTALL_NLS_DIR = $(DESTDIR)/`$(PYTHON)
|
||||
|
||||
# PO catalog handling
|
||||
MSGMERGE = msgmerge -v
|
||||
-XGETTEXT = ../translation-canary/xgettext_werror.sh --default-domain=$(NLSPACKAGE) \
|
||||
- --add-comments
|
||||
+XGETTEXT = xgettext --default-domain=$(NLSPACKAGE) --add-comments
|
||||
MSGFMT = msgfmt --statistics --verbose
|
||||
|
||||
# What do we need to do
|
@ -10,8 +10,8 @@
|
||||
%bcond_with runtests
|
||||
|
||||
Name: pykickstart
|
||||
Version: 3.14
|
||||
Release: 3.0.riscv64%{?dist}
|
||||
Version: 3.15
|
||||
Release: 2.0.riscv64%{?dist}
|
||||
License: GPLv2 and MIT
|
||||
Group: System Environment/Libraries
|
||||
Summary: Python utilities for manipulating kickstart files.
|
||||
@ -20,9 +20,7 @@ Url: http://fedoraproject.org/wiki/pykickstart
|
||||
# our distribution. Thus the source is only available from
|
||||
# within this srpm.
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Patch0: pykickstart-rhbz1578930.patch
|
||||
Patch1: pykickstart-translation-canary.patch
|
||||
Patch2: pykickstart-3.14-fix-UnicodeDecodeError.patch
|
||||
Patch0: pykickstart-3.14-fix-UnicodeDecodeError.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -81,8 +79,6 @@ the pykickstart package.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%if %{with python2}
|
||||
rm -rf %{py3dir}
|
||||
@ -116,7 +112,6 @@ make PYTHON=%{__python3} test
|
||||
%endif
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%license COPYING
|
||||
%doc README.rst
|
||||
%doc data/kickstart.vim
|
||||
@ -131,7 +126,6 @@ make PYTHON=%{__python3} test
|
||||
|
||||
%if %{with python2}
|
||||
%files -n python2-kickstart
|
||||
%defattr(-,root,root,-)
|
||||
%doc docs/2to3
|
||||
%doc docs/programmers-guide
|
||||
%doc docs/kickstart-docs.txt
|
||||
@ -140,7 +134,6 @@ make PYTHON=%{__python3} test
|
||||
%endif
|
||||
|
||||
%files -n python3-kickstart
|
||||
%defattr(-,root,root,-)
|
||||
%doc docs/2to3
|
||||
%doc docs/programmers-guide
|
||||
%doc docs/kickstart-docs.txt
|
||||
@ -148,9 +141,30 @@ make PYTHON=%{__python3} test
|
||||
%{python3_sitelib}/pykickstart*.egg-info
|
||||
|
||||
%changelog
|
||||
* Sat Jun 16 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 3.14-3.0.riscv64
|
||||
* Fri Aug 03 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 3.15-2.0.riscv64
|
||||
- Fix UnicodeDecodeError while generating packages list
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.15-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Jul 10 2018 Chris Lumens <clumens@redhat.com> - 3.15-1
|
||||
- New release: 3.15 (clumens)
|
||||
- Add nvdimm command to RHEL7 (rvykydal)
|
||||
- Fix tests timeout (vponcova)
|
||||
- Fix pylint errors (vponcova)
|
||||
- The deprecated command upgrade is removed in another handler (vponcova)
|
||||
- The partition option --active is deprecated in another handler (vponcova)
|
||||
- The ignoredisk option --interactive is deprecated in another handler (vponcova)
|
||||
- The bootloader option --upgrade is deprecated in another handler (vponcova)
|
||||
- The command install is deprecated in another handler (vponcova)
|
||||
- The command deviceprobe is deprecated in another handler (vponcova)
|
||||
- Add kickstart warnings (vponcova)
|
||||
- Add the enablemodule command (mkolman)
|
||||
- Remove translation-canary wrapper for xgettext command. (dcantrell)
|
||||
- Use 'New release:' in the 'make bumpver' commit messages. (dcantrell)
|
||||
- Update the 'make pypi' target. (dcantrell)
|
||||
- Include the _sortCommand to the _setCommand method (#1578930) (vponcova)
|
||||
|
||||
* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 3.14-3
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
@ -193,7 +207,7 @@ make PYTHON=%{__python3} test
|
||||
- Get the version number from setup.py instead of the spec file. (clumens)
|
||||
- Remove PKGNAME from the Makefile. (clumens)
|
||||
|
||||
* Thu Apr 18 2018 David Cantrell <dcantrell@redhat.com> - 3.12-5
|
||||
* Thu Apr 19 2018 David Cantrell <dcantrell@redhat.com> - 3.12-5
|
||||
- BuildRequires: python2-ordered-set
|
||||
|
||||
* Mon Apr 16 2018 David Cantrell <dcantrell@redhat.com> - 3.12-4
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (pykickstart-3.14.tar.gz) = a83390350059bfc6ab98274eddd425c2df6fc70d70252c1df1cf6f959ef1602cd4f373aa196017c79f4100d93d89436cc5ed885c668efa4a294caccec27bd9c2
|
||||
SHA512 (pykickstart-3.15.tar.gz) = 94da465e342e8dc10dc295499ec1032aef9d1d02e94245b478c839d91947b14416c3fe535b74dc7c60532cd76434869ea10df1cd1ab2ae49f7eafb5076df93e2
|
||||
|
Loading…
Reference in New Issue
Block a user