Use %{python3_pkgversion} macro

This commit is contained in:
Robert Scheck 2018-12-28 18:25:06 +01:00
parent c473c6cad0
commit 69bd94a154
5 changed files with 108 additions and 11 deletions

View File

@ -0,0 +1,24 @@
From 1b99bba11f3d5f5e61a081c2fa3e9b4dc0f31522 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 27 Aug 2014 15:39:11 +0200
Subject: [PATCH] disable failing test
---
test/test_Collator.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/test/test_Collator.py b/test/test_Collator.py
index e229af8..56c836c 100644
--- a/test/test_Collator.py
+++ b/test/test_Collator.py
@@ -127,6 +127,7 @@ class TestCollator(TestCase):
return collator
def testCollatorLoading(self):
+ return
if ICU_VERSION >= '4.6':
collator = self.LoadCollatorFromRules()
--
1.9.3

View File

@ -0,0 +1,24 @@
From 761c64927512d40858bb1d8b24cc5331b95e9ceb Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 27 Aug 2014 15:27:53 +0200
Subject: [PATCH] fix build with icu 53.1
---
common.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/common.h b/common.h
index 2ea50e4..88c99fb 100644
--- a/common.h
+++ b/common.h
@@ -129,6 +129,7 @@ typedef intintobjargproc ssizessizeobjargproc;
#include <unicode/regex.h>
#include <unicode/normlzr.h>
#include <unicode/search.h>
+#include <unicode/sortkey.h>
#include <unicode/stsearch.h>
#define VERSION_HEX(major, minor, patch) \
--
1.9.3

View File

@ -0,0 +1,16 @@
diff -ur old.PyICU-1.5/layoutengine.cpp PyICU-1.5/layoutengine.cpp
--- old.PyICU-1.5/layoutengine.cpp 2012-11-23 21:39:01.000000000 +0100
+++ PyICU-1.5/layoutengine.cpp 2015-10-29 13:44:15.610882520 +0100
@@ -118,6 +118,12 @@
* LEFontInstance API.
*/
+ virtual const void *getFontTable(LETag tableTag, size_t &length) const
+ {
+ length = -1;
+ return getFontTable(tableTag);
+ }
+
virtual const void *getFontTable(LETag tag) const
{
#if PY_MAJOR_VERSION >= 3

View File

@ -4,14 +4,15 @@
%define realname PyICU
Name: pyicu
Version: 1.5
Release: 24%{?dist}
Release: 25%{?dist}
Summary: Python extension wrapping IBM's ICU C++ libraries
Group: Development/Tools
License: MIT
URL: http://pyicu.osafoundation.org/
Source0: http://pypi.python.org/packages/source/P/%{realname}/%{realname}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
BuildRequires: python2-devel
BuildRequires: python-setuptools
BuildRequires: libicu
@ -41,33 +42,65 @@ Obsoletes: pyicu < %{version}-%{release}
%description -n python2-pyicu %_description
%package -n python%{python3_pkgversion}-pyicu
Summary: Python3 extension wrapping IBM's ICU C++ libraries
%description -n python%{python3_pkgversion}-pyicu
%{summary}.
%prep
%setup -q -n %{realname}-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
rm -rf %{py3dir}
cp -a . %{py3dir}
%build
%{__python} setup.py build
%{__python2} setup.py build
pushd %{py3dir}
%{__python3} setup.py build
popd
# we don't want to provide private python extension libs
%{?filter_setup:
%filter_provides_in %{python_sitearch}/.*\.so$
%filter_provides_in %{python2_sitearch}/.*\.so$ %{python3_sitearch}/.*\.so$
%filter_setup
}
%check
%{__python} setup.py test
%{__python2} setup.py test
pushd %{py3dir}
%{__python3} setup.py test
popd
%install
rm -rf %{buildroot}
%{__python} setup.py install --skip-build --root %{buildroot}
%{__python2} setup.py install --skip-build --root %{buildroot}
pushd %{py3dir}
%{__python3} setup.py install --skip-build --root %{buildroot}
popd
# Remove tests
rm -rf %{buildroot}%{python_sitearch}/tests
rm -rf %{buildroot}%{python2_sitearch}/tests %{buildroot}%{python3_sitearch}/tests
%files -n python2-pyicu
%defattr(-,root,root,-)
%doc LICENSE README CHANGES CREDITS
%{python_sitearch}/*.*
%{python_sitearch}/%{realname}-%{version}-py?.?.egg-info/*.*
%{python2_sitearch}/*
%files -n python%{python3_pkgversion}-pyicu
%doc LICENSE
%{python3_sitearch}/*
%changelog
* Fri Dec 28 2018 Robert Scheck <robert@fedoraproject.org> - 1.5-25
- Use %%{python3_pkgversion} macro
* Sun Aug 20 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.5-24
- Add Provides for the old name without %%_isa

View File

@ -1 +1 @@
70cbb5b43c3e6939b74c3f1b27e47aae PyICU-1.1.tar.gz
099a3e6e3b8c2b9ab3bf6dde911db624 PyICU-1.5.tar.gz