From EPEL6 to start

This commit is contained in:
Benjamin Lefoul 2017-01-31 21:53:09 +01:00
parent e0f635b9c2
commit 60ff054aa6
6 changed files with 13 additions and 179 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/PyICU-1.*.tar.gz /PyICU-1.1.tar.gz

View File

@ -1,24 +0,0 @@
From 1b99bba11f3d5f5e61a081c2fa3e9b4dc0f31522 Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 27 Aug 2014 15:39:11 +0200
Subject: [PATCH] disable failing test
---
test/test_Collator.py | 1 +
1 file changed, 1 insertion(+)
diff --git a/test/test_Collator.py b/test/test_Collator.py
index e229af8..56c836c 100644
--- a/test/test_Collator.py
+++ b/test/test_Collator.py
@@ -127,6 +127,7 @@ class TestCollator(TestCase):
return collator
def testCollatorLoading(self):
+ return
if ICU_VERSION >= '4.6':
collator = self.LoadCollatorFromRules()
--
1.9.3

View File

@ -1,24 +0,0 @@
From 761c64927512d40858bb1d8b24cc5331b95e9ceb Mon Sep 17 00:00:00 2001
From: David Tardon <dtardon@redhat.com>
Date: Wed, 27 Aug 2014 15:27:53 +0200
Subject: [PATCH] fix build with icu 53.1
---
common.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/common.h b/common.h
index 2ea50e4..88c99fb 100644
--- a/common.h
+++ b/common.h
@@ -129,6 +129,7 @@ typedef intintobjargproc ssizessizeobjargproc;
#include <unicode/regex.h>
#include <unicode/normlzr.h>
#include <unicode/search.h>
+#include <unicode/sortkey.h>
#include <unicode/stsearch.h>
#define VERSION_HEX(major, minor, patch) \
--
1.9.3

View File

@ -1,16 +0,0 @@
diff -ur old.PyICU-1.5/layoutengine.cpp PyICU-1.5/layoutengine.cpp
--- old.PyICU-1.5/layoutengine.cpp 2012-11-23 21:39:01.000000000 +0100
+++ PyICU-1.5/layoutengine.cpp 2015-10-29 13:44:15.610882520 +0100
@@ -118,6 +118,12 @@
* LEFontInstance API.
*/
+ virtual const void *getFontTable(LETag tableTag, size_t &length) const
+ {
+ length = -1;
+ return getFontTable(tableTag);
+ }
+
virtual const void *getFontTable(LETag tag) const
{
#if PY_MAJOR_VERSION >= 3

View File

@ -3,13 +3,14 @@
%endif %endif
%define realname PyICU %define realname PyICU
Name: pyicu Name: pyicu
Version: 1.5 Version: 1.1
Release: 19%{?dist} Release: 2%{?dist}
Summary: Python extension wrapping IBM's ICU C++ libraries Summary: Python extension wrapping IBM's ICU C++ libraries
Group: Development/Tools Group: Development/Tools
License: MIT License: MIT
URL: http://pyicu.osafoundation.org/ URL: http://pyicu.osafoundation.org/
Source0: http://pypi.python.org/packages/source/P/%{realname}/%{realname}-%{version}.tar.gz Source0: http://pypi.python.org/packages/source/P/%{realname}/%{realname}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python2-devel BuildRequires: python2-devel
BuildRequires: python-setuptools BuildRequires: python-setuptools
@ -17,10 +18,6 @@ BuildRequires: libicu
BuildRequires: libicu-devel BuildRequires: libicu-devel
BuildRequires: gcc-c++ BuildRequires: gcc-c++
Patch0: 0001-fix-build-with-icu-53.1.patch
Patch1: 0001-disable-failing-test.patch
Patch2: pyicu-1.5-fix-build-with-icu-56.1.patch
%description %description
PyICU is Python extension wrapping IBM's International Components PyICU is Python extension wrapping IBM's International Components
for Unicode C++ library (ICU). ICU is a mature, widely used set of for Unicode C++ library (ICU). ICU is a mature, widely used set of
@ -28,132 +25,33 @@ C/C++ and Java libraries providing Unicode and Globalization support
for software applications. ICU is widely portable and gives applications for software applications. ICU is widely portable and gives applications
the same results on all platforms and between C/C++ and Javasoftware. the same results on all platforms and between C/C++ and Javasoftware.
%package -n python3-pyicu
Summary: Python3 extension wrapping IBM's ICU C++ libraries
%description -n python3-pyicu
%{summary}.
%prep %prep
%setup -q -n %{realname}-%{version} %setup -q -n %{realname}-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
rm -rf %{py3dir}
cp -a . %{py3dir}
%build %build
%{__python} setup.py build
%{__python2} setup.py build
pushd %{py3dir}
%{__python3} setup.py build
popd
# we don't want to provide private python extension libs # we don't want to provide private python extension libs
%{?filter_setup: %{?filter_setup:
%filter_provides_in %{python2_sitearch}/.*\.so$ %{python3_sitearch}/.*\.so$ %filter_provides_in %{python_sitearch}/.*\.so$
%filter_setup %filter_setup
} }
%check %check
%{__python2} setup.py test %{__python} setup.py test
pushd %{py3dir}
%{__python3} setup.py test
popd
%install %install
%{__python2} setup.py install --skip-build --root %{buildroot} rm -rf %{buildroot}
%{__python} setup.py install --skip-build --root %{buildroot}
pushd %{py3dir}
%{__python3} setup.py install --skip-build --root %{buildroot}
popd
# Remove tests # Remove tests
rm -rf %{buildroot}%{python2_sitearch}/tests %{buildroot}%{python3_sitearch}/tests rm -rf %{buildroot}%{python_sitearch}/tests
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc LICENSE README CHANGES CREDITS %doc LICENSE README CHANGES CREDITS
%{python2_sitearch}/* %{python_sitearch}/*.*
%{python_sitearch}/%{realname}-%{version}-py?.?.egg-info/*.*
%files -n python3-pyicu
%doc LICENSE
%{python3_sitearch}/*
%changelog %changelog
* Tue Jan 31 2017 Benjamin Lefoul <lef@fedoraproject.org> - 1.5-19
- Python2 for RHEL7
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 1.5-18
- Rebuild for Python 3.6
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-17
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 1.5-16
- rebuild for ICU 57.1
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-14
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
* Thu Oct 29 2015 Eike Rathke <erack@redhat.com> - 1.5-13
- fix build with ICU 56.1
* Wed Oct 28 2015 David Tardon <dtardon@redhat.com> - 1.5-12
- rebuild for ICU 56.1
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 1.5-10
- Rebuilt for GCC 5 C++11 ABI change
* Mon Jan 26 2015 David Tardon <dtardon@redhat.com> - 1.5-9
- rebuild for ICU 54.1
* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 1.5-8
- rebuild for ICU 53.1
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Wed Jul 16 2014 Bastien Nocera <bnocera@redhat.com> 1.5-6
- Build Python3 version as well (#917449)
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Fri Feb 14 2014 Parag Nemade <paragn AT fedoraproject DOT org> - 1.5-4
- Rebuild for icu 52
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Jul 22 2013 David Tardon <dtardon@redhat.com> - 1.5-2
- rebuild for ICU ABI break
* Fri Feb 08 2013 Jon Ciesla <limburgher@gmail.com> - 1.5-1
- libicu rebuild.
- Update to 1.5, 1.4 doesn't build on new libicu.
* Wed Aug 22 2012 Tom Callaway <spot@fedoraproject.org> - 1.4-1
- update to 1.4
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Tue Oct 11 2011 Peter Robinson <pbrobinson@fedoraproject.org> - 1.2-1
- New upstream 1.2 release
* Sun May 08 2011 Prabin Kumar Datta <prabindatta@fedoraproject.org> - 1.1-2 * Sun May 08 2011 Prabin Kumar Datta <prabindatta@fedoraproject.org> - 1.1-2
- added CHANGES CREDITS under doc section - added CHANGES CREDITS under doc section
- updated URL - updated URL

View File

@ -1 +1 @@
099a3e6e3b8c2b9ab3bf6dde911db624 PyICU-1.5.tar.gz 70cbb5b43c3e6939b74c3f1b27e47aae PyICU-1.1.tar.gz