Update to latest version.

This commit is contained in:
Elliott Sales de Andrade 2017-12-14 02:21:10 -05:00
parent 8174232f9b
commit 5fc86bf643
3 changed files with 6 additions and 50 deletions

View File

@ -1,28 +0,0 @@
diff -up pybind11-2.0.1/tests/test_kwargs_and_defaults.py.699 pybind11-2.0.1/tests/test_kwargs_and_defaults.py
diff -up pybind11-2.0.1/tests/test_numpy_array.py.699 pybind11-2.0.1/tests/test_numpy_array.py
--- pybind11-2.0.1/tests/test_numpy_array.py.699 2017-02-26 13:32:20.014729539 -0800
+++ pybind11-2.0.1/tests/test_numpy_array.py 2017-02-26 13:34:13.621804603 -0800
@@ -6,7 +6,7 @@ with pytest.suppress(ImportError):
@pytest.fixture(scope='function')
def arr():
- return np.array([[1, 2, 3], [4, 5, 6]], '<u2')
+ return np.array([[1, 2, 3], [4, 5, 6]], '=u2')
@pytest.requires_numpy
@@ -82,10 +82,10 @@ def test_dim_check_fail(arr):
([1, 2], [6])])
def test_data(arr, args, ret):
from pybind11_tests.array import data, data_t
+ from sys import byteorder
assert all(data_t(arr, *args) == ret)
- assert all(data(arr, *args)[::2] == ret)
- assert all(data(arr, *args)[1::2] == 0)
-
+ assert all(data(arr, *args)[(0 if byteorder == 'little' else 1)::2] == ret)
+ assert all(data(arr, *args)[(1 if byteorder == 'little' else 0)::2] == 0)
@pytest.requires_numpy
def test_mutate_readonly(arr):
diff -up pybind11-2.0.1/tests/test_numpy_dtypes.py.699 pybind11-2.0.1/tests/test_numpy_dtypes.py

View File

@ -1,12 +0,0 @@
diff -up pybind11-2.0.1/tests/CMakeLists.txt.tests pybind11-2.0.1/tests/CMakeLists.txt
--- pybind11-2.0.1/tests/CMakeLists.txt.tests 2017-01-04 06:17:18.000000000 -0800
+++ pybind11-2.0.1/tests/CMakeLists.txt 2017-02-24 06:30:19.356044843 -0800
@@ -27,7 +27,7 @@ set(PYBIND11_TEST_FILES
test_modules.cpp
test_multiple_inheritance.cpp
test_numpy_array.cpp
- test_numpy_dtypes.cpp
+# test_numpy_dtypes.cpp
test_numpy_vectorize.cpp
test_opaque_types.cpp
test_operator_overloading.cpp

View File

@ -5,18 +5,13 @@
%global debug_package %{nil}
Name: pybind11
Version: 2.0.1
Release: 7%{?dist}
Version: 2.2.1
Release: 1%{?dist}
Summary: Seamless operability between C++11 and Python
License: BSD
URL: https://github.com/pybind/pybind11
Source0: https://github.com/pybind/pybind11/archive/v%{version}.tar.gz
# Disable numpy dtypes test as guided in https://github.com/pybind/pybind11/issues/694
Patch0: pybind11-2.0.1-tests.patch
# Fix tests that are broken on bigendian systems, adapted from https://github.com/pybind/pybind11/pull/699
Patch1: pybind11-2.0.1-byteorder.patch
# These are only needed for the checks
BuildRequires: python2-devel
BuildRequires: python2-pytest
@ -50,9 +45,7 @@ C++ code.
This package contains the development headers for pybind11.
%prep
%setup -q
%patch0 -p1 -b .tests
%patch1 -p1 -b .order
%autosetup -p1
%build
for py in python2 python3; do
@ -78,6 +71,9 @@ make -C python3 check %{?_smp_mflags}
%changelog
* Thu Dec 14 2017 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.2.1-1
- Update to latest version
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild