- bump to 2.3.0
This commit is contained in:
parent
fd5afdef76
commit
ba25ee79f1
@ -1 +1 @@
|
||||
protobuf-2.2.0.tar.bz2
|
||||
protobuf-2.3.0.tar.bz2
|
||||
|
@ -1,18 +1,35 @@
|
||||
From 2118fa2281c9554dd93f2fcd917e826d6b191daf Mon Sep 17 00:00:00 2001
|
||||
From: Lev Shamardin <shamardin@gmail.com>
|
||||
Date: Fri, 18 Sep 2009 13:20:48 +0400
|
||||
Subject: [PATCH] fedora-gmake.patch
|
||||
|
||||
---
|
||||
protobuf-2.2.0/Makefile.am | 21 ---------------------
|
||||
protobuf-2.2.0/autogen.sh | 9 ---------
|
||||
protobuf-2.2.0/src/Makefile.am | 13 ++++---------
|
||||
3 files changed, 4 insertions(+), 39 deletions(-)
|
||||
|
||||
diff --git a/protobuf-2.2.0/Makefile.am b/protobuf-2.2.0/Makefile.am
|
||||
index c311fe0..23ee406 100644
|
||||
--- a/protobuf-2.2.0/Makefile.am
|
||||
+++ b/protobuf-2.2.0/Makefile.am
|
||||
diff -up protobuf-2.3.0/autogen.sh.orig protobuf-2.3.0/autogen.sh
|
||||
--- protobuf-2.3.0/autogen.sh.orig 2010-04-21 18:55:43.857266895 -0600
|
||||
+++ protobuf-2.3.0/autogen.sh 2010-04-21 19:54:57.386270273 -0600
|
||||
@@ -15,25 +15,8 @@ __EOF__
|
||||
exit 1
|
||||
fi
|
||||
|
||||
-# Check that gtest is present. Usually it is already there since the
|
||||
-# directory is set up as an SVN external.
|
||||
-if test ! -e gtest; then
|
||||
- echo "Google Test not present. Fetching gtest-1.3.0 from the web..."
|
||||
- curl http://googletest.googlecode.com/files/gtest-1.3.0.tar.bz2 | tar jx
|
||||
- mv gtest-1.3.0 gtest
|
||||
-fi
|
||||
-
|
||||
set -ex
|
||||
|
||||
-# Temporary hack: Must change C runtime library to "multi-threaded DLL",
|
||||
-# otherwise it will be set to "multi-threaded static" when MSVC upgrades
|
||||
-# the project file to MSVC 2005/2008. vladl of Google Test says gtest will
|
||||
-# probably change their default to match, then this will be unnecessary.
|
||||
-# One of these mappings converts the debug configuration and the other
|
||||
-# converts the release configuration. I don't know which is which.
|
||||
-sed -i -e 's/RuntimeLibrary="5"/RuntimeLibrary="3"/g;
|
||||
- s/RuntimeLibrary="4"/RuntimeLibrary="2"/g;' gtest/msvc/*.vcproj
|
||||
-
|
||||
# TODO(kenton): Remove the ",no-obsolete" part and fix the resulting warnings.
|
||||
autoreconf -f -i -Wall,no-obsolete
|
||||
|
||||
diff -up protobuf-2.3.0/Makefile.am.orig protobuf-2.3.0/Makefile.am
|
||||
--- protobuf-2.3.0/Makefile.am.orig 2010-04-21 18:55:38.009265866 -0600
|
||||
+++ protobuf-2.3.0/Makefile.am 2010-04-21 18:56:15.068016238 -0600
|
||||
@@ -11,27 +11,6 @@ SUBDIRS = . src
|
||||
# Always include gtest in distributions.
|
||||
DIST_SUBDIRS = $(subdirs) src
|
||||
@ -41,44 +58,23 @@ index c311fe0..23ee406 100644
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = protobuf.pc protobuf-lite.pc
|
||||
|
||||
diff --git a/protobuf-2.2.0/autogen.sh b/protobuf-2.2.0/autogen.sh
|
||||
index 519bb8f..c17e316 100755
|
||||
--- a/protobuf-2.2.0/autogen.sh
|
||||
+++ b/protobuf-2.2.0/autogen.sh
|
||||
@@ -15,15 +15,6 @@ fi
|
||||
|
||||
set -ex
|
||||
|
||||
-# Temporary hack: Must change C runtime library to "multi-threaded DLL",
|
||||
-# otherwise it will be set to "multi-threaded static" when MSVC upgrades
|
||||
-# the project file to MSVC 2005/2008. vladl of Google Test says gtest will
|
||||
-# probably change their default to match, then this will be unnecessary.
|
||||
-# One of these mappings converts the debug configuration and the other
|
||||
-# converts the release configuration. I don't know which is which.
|
||||
-sed -i -e 's/RuntimeLibrary="5"/RuntimeLibrary="3"/g;
|
||||
- s/RuntimeLibrary="4"/RuntimeLibrary="2"/g;' gtest/msvc/*.vcproj
|
||||
-
|
||||
# TODO(kenton): Remove the ",no-obsolete" part and fix the resulting warnings.
|
||||
autoreconf -f -i -Wall,no-obsolete
|
||||
|
||||
diff --git a/protobuf-2.2.0/src/Makefile.am b/protobuf-2.2.0/src/Makefile.am
|
||||
index f009838..373c463 100644
|
||||
--- a/protobuf-2.2.0/src/Makefile.am
|
||||
+++ b/protobuf-2.2.0/src/Makefile.am
|
||||
@@ -267,10 +267,8 @@ COMMON_TEST_SOURCES = \
|
||||
|
||||
check_PROGRAMS = protobuf-test protobuf-lazy-descriptor-test protobuf-lite-test $(GZCHECKPROGRAMS)
|
||||
diff -up protobuf-2.3.0/src/Makefile.am.orig protobuf-2.3.0/src/Makefile.am
|
||||
--- protobuf-2.3.0/src/Makefile.am.orig 2010-04-21 18:56:57.342268786 -0600
|
||||
+++ protobuf-2.3.0/src/Makefile.am 2010-04-21 20:02:40.168268698 -0600
|
||||
@@ -276,10 +276,8 @@ COMMON_TEST_SOURCES =
|
||||
check_PROGRAMS = protoc protobuf-test protobuf-lazy-descriptor-test \
|
||||
protobuf-lite-test test_plugin $(GZCHECKPROGRAMS)
|
||||
protobuf_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
|
||||
- $(top_builddir)/gtest/lib/libgtest.la \
|
||||
- $(top_builddir)/gtest/lib/libgtest_main.la
|
||||
-protobuf_test_CPPFLAGS = -I$(top_srcdir)/gtest/include \
|
||||
- -I$(top_builddir)/gtest/include
|
||||
+ -lgtest -lgtest_main
|
||||
+protobuf_test_CPPFLAGS =
|
||||
+protobuf_test_CPPFLAGS =
|
||||
# Disable optimization for tests unless the user explicitly asked for it,
|
||||
# since test_util.cc takes forever to compile with optimization (with GCC).
|
||||
# See configure.ac for more info.
|
||||
@@ -305,11 +303,8 @@ nodist_protobuf_test_SOURCES = $(protoc_outputs)
|
||||
@@ -319,11 +317,8 @@ nodist_protobuf_test_SOURCES = $(protoc_
|
||||
|
||||
# Run cpp_unittest again with PROTOBUF_TEST_NO_DESCRIPTORS defined.
|
||||
protobuf_lazy_descriptor_test_LDADD = $(PTHREAD_LIBS) libprotobuf.la \
|
||||
@ -87,11 +83,17 @@ index f009838..373c463 100644
|
||||
-protobuf_lazy_descriptor_test_CPPFLAGS = -I$(top_srcdir)/gtest/include \
|
||||
- -I$(top_builddir)/gtest/include \
|
||||
- -DPROTOBUF_TEST_NO_DESCRIPTORS
|
||||
+ -lgtest -lgtest_main
|
||||
+ -lgtest -lgtest_main
|
||||
+protobuf_lazy_descriptor_test_CPPFLAGS = -DPROTOBUF_TEST_NO_DESCRIPTORS
|
||||
protobuf_lazy_descriptor_test_CXXFLAGS = $(NO_OPT_CXXFLAGS)
|
||||
protobuf_lazy_descriptor_test_SOURCES = \
|
||||
google/protobuf/compiler/cpp/cpp_unittest.cc \
|
||||
--
|
||||
1.6.2.5
|
||||
|
||||
@@ -341,7 +336,7 @@ nodist_protobuf_lite_test_SOURCES = $(pr
|
||||
|
||||
# Test plugin binary.
|
||||
test_plugin_LDADD = $(PTHREAD_LIBS) libprotobuf.la libprotoc.la \
|
||||
- $(top_builddir)/gtest/lib/libgtest.la
|
||||
+ -lgtest
|
||||
test_plugin_CPPFLAGS = -I$(top_srcdir)/gtest/include \
|
||||
-I$(top_builddir)/gtest/include
|
||||
test_plugin_SOURCES = \
|
@ -1,9 +1,22 @@
|
||||
--- java/pom.xml.orig 2008-10-12 13:17:47.000000000 +0400
|
||||
+++ java/pom.xml 2008-10-12 13:32:22.000000000 +0400
|
||||
@@ -47,26 +47,6 @@
|
||||
<uniqueVersion>true</uniqueVersion>
|
||||
</snapshotRepository>
|
||||
</distributionManagement>
|
||||
diff -up protobuf-2.3.0/java/pom.xml.orig protobuf-2.3.0/java/pom.xml
|
||||
--- protobuf-2.3.0/java/pom.xml.orig 2010-04-21 20:59:56.378273539 -0600
|
||||
+++ protobuf-2.3.0/java/pom.xml 2010-04-21 21:28:39.565018649 -0600
|
||||
@@ -3,11 +3,6 @@
|
||||
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
- <parent>
|
||||
- <groupId>com.google</groupId>
|
||||
- <artifactId>google</artifactId>
|
||||
- <version>1</version>
|
||||
- </parent>
|
||||
<groupId>com.google.protobuf</groupId>
|
||||
<artifactId>protobuf-java</artifactId>
|
||||
<version>2.3.0</version>
|
||||
@@ -32,26 +27,6 @@
|
||||
scm:svn:http://protobuf.googlecode.com/svn/trunk/
|
||||
</connection>
|
||||
</scm>
|
||||
- <dependencies>
|
||||
- <dependency>
|
||||
- <groupId>junit</groupId>
|
||||
@ -27,7 +40,7 @@
|
||||
<build>
|
||||
<plugins>
|
||||
<plugin>
|
||||
@@ -77,14 +57,6 @@
|
||||
@@ -62,14 +37,6 @@
|
||||
</configuration>
|
||||
</plugin>
|
||||
<plugin>
|
||||
@ -42,7 +55,7 @@
|
||||
<artifactId>maven-antrun-plugin</artifactId>
|
||||
<executions>
|
||||
<execution>
|
||||
@@ -105,33 +77,6 @@
|
||||
@@ -90,38 +57,6 @@
|
||||
<goal>run</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
@ -65,6 +78,11 @@
|
||||
- value="../src/google/protobuf/unittest_optimize_for.proto" />
|
||||
- <arg
|
||||
- value="../src/google/protobuf/unittest_custom_options.proto" />
|
||||
- <arg value="../src/google/protobuf/unittest_lite.proto" />
|
||||
- <arg value="../src/google/protobuf/unittest_import_lite.proto" />
|
||||
- <arg value="../src/google/protobuf/unittest_lite_imports_nonlite.proto" />
|
||||
- <arg value="../src/google/protobuf/unittest_enormous_descriptor.proto" />
|
||||
- <arg value="../src/google/protobuf/unittest_no_generic_services.proto" />
|
||||
- </exec>
|
||||
- </tasks>
|
||||
- <testSourceRoot>target/generated-test-sources</testSourceRoot>
|
||||
@ -76,3 +94,22 @@
|
||||
</executions>
|
||||
</plugin>
|
||||
</plugins>
|
||||
@@ -148,18 +83,6 @@
|
||||
<include>**/UninitializedMessageException.java</include>
|
||||
<include>**/WireFormat.java</include>
|
||||
</includes>
|
||||
- <testIncludes>
|
||||
- <testInclude>**/LiteTest.java</testInclude>
|
||||
- <testInclude>**/*Lite.java</testInclude>
|
||||
- </testIncludes>
|
||||
- </configuration>
|
||||
- </plugin>
|
||||
- <plugin>
|
||||
- <artifactId>maven-surefire-plugin</artifactId>
|
||||
- <configuration>
|
||||
- <includes>
|
||||
- <include>**/LiteTest.java</include>
|
||||
- </includes>
|
||||
</configuration>
|
||||
</plugin>
|
||||
<plugin>
|
@ -12,14 +12,14 @@
|
||||
|
||||
Summary: Protocol Buffers - Google's data interchange format
|
||||
Name: protobuf
|
||||
Version: 2.2.0
|
||||
Release: 2%{?dist}
|
||||
Version: 2.3.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Development/Libraries
|
||||
Source: http://protobuf.googlecode.com/files/%{name}-%{version}.tar.bz2
|
||||
Source1: ftdetect-proto.vim
|
||||
Patch1: protobuf-%{version}-fedora-gtest.patch
|
||||
Patch2: protobuf-java-notests.patch
|
||||
Patch1: protobuf-2.3.0-fedora-gtest.patch
|
||||
Patch2: protobuf-java-fixes.patch
|
||||
URL: http://code.google.com/p/protobuf/
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
BuildRequires: automake autoconf libtool pkgconfig
|
||||
@ -167,7 +167,7 @@ This package contains the API documentation for %{name}-java.
|
||||
%setup -q
|
||||
%if !%{without_gtest}
|
||||
rm -rf gtest
|
||||
%patch1 -p2
|
||||
%patch1 -p1
|
||||
%endif
|
||||
chmod 644 examples/*
|
||||
%if %{with_java}
|
||||
@ -317,6 +317,9 @@ rm -rf %{buildroot}
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue May 4 2010 Conrad Meyer <konrad@tylerc.org> - 2.3.0-1
|
||||
- bump to 2.3.0
|
||||
|
||||
* Wed Sep 30 2009 Lev Shamardin <shamardin@gmail.com> - 2.2.0-2
|
||||
- added export PTHREAD_LIBS="-lpthread"
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user