5efb5bf2b7
Fri May 07 2004 Nils Philippsen <nphilipp@redhat.com> 2.4.2-2 - don't write to /etc (#118837) Wed Mar 10 2004 Nalin Dahyabhai <nalin@redhat.com> 2.4.2-1 - update to 2.4.2
57 lines
2.1 KiB
Diff
57 lines
2.1 KiB
Diff
--- ppp-2.4.2/chat/chat.8.dontwriteetc 2002-09-07 12:37:49.000000000 +0200
|
|
+++ ppp-2.4.2/chat/chat.8 2004-05-07 10:45:30.000000000 +0200
|
|
@@ -200,7 +200,7 @@
|
|
at the terminal via standard error. If \fBchat\fR is being run by
|
|
pppd, and pppd is running as a daemon (detached from its controlling
|
|
terminal), standard error will normally be redirected to the file
|
|
-/etc/ppp/connect-errors.
|
|
+/var/log/ppp/connect-errors.
|
|
.LP
|
|
\fBSAY\fR strings must be enclosed in single or double quotes. If
|
|
carriage return and line feed are needed in the string to be output,
|
|
--- ppp-2.4.2/linux/Makefile.top.dontwriteetc 2002-09-07 12:37:49.000000000 +0200
|
|
+++ ppp-2.4.2/linux/Makefile.top 2004-05-07 10:44:40.000000000 +0200
|
|
@@ -5,6 +5,8 @@
|
|
INCDIR = $(DESTDIR)/usr/include
|
|
MANDIR = $(DESTDIR)/usr/man
|
|
ETCDIR = $(DESTDIR)/etc/ppp
|
|
+RUNDIR = $(DESTDIR)/var/run/ppp
|
|
+LOGDIR = $(DESTDIR)/var/log/ppp
|
|
|
|
# uid 0 = root
|
|
INSTALL= install
|
|
@@ -16,7 +18,7 @@
|
|
cd pppstats; $(MAKE) $(MFLAGS) all
|
|
cd pppdump; $(MAKE) $(MFLAGS) all
|
|
|
|
-install: $(BINDIR) $(MANDIR)/man8 install-progs install-etcppp install-devel
|
|
+install: $(BINDIR) $(RUNDIR) $(LOGDIR) $(MANDIR)/man8 install-progs install-etcppp install-devel
|
|
|
|
install-progs:
|
|
cd chat; $(MAKE) BINDIR=$(BINDIR) MANDIR=$(MANDIR) $(MFLAGS) install
|
|
@@ -44,6 +46,10 @@
|
|
$(INSTALL) -d -m 755 $@
|
|
$(ETCDIR):
|
|
$(INSTALL) -d -m 755 $@
|
|
+$(RUNDIR):
|
|
+ $(INSTALL) -d -m 755 $@
|
|
+$(LOGDIR):
|
|
+ $(INSTALL) -d -m 755 $@
|
|
|
|
clean:
|
|
rm -f `find . -name '*.[oas]' -print`
|
|
--- ppp-2.4.2/pppd/pathnames.h.dontwriteetc 2004-05-07 10:29:29.000000000 +0200
|
|
+++ ppp-2.4.2/pppd/pathnames.h 2004-05-07 11:40:08.000000000 +0200
|
|
@@ -27,9 +27,9 @@
|
|
#define _PATH_AUTHUP _ROOT_PATH "/etc/ppp/auth-up"
|
|
#define _PATH_AUTHDOWN _ROOT_PATH "/etc/ppp/auth-down"
|
|
#define _PATH_TTYOPT _ROOT_PATH "/etc/ppp/options."
|
|
-#define _PATH_CONNERRS _ROOT_PATH "/etc/ppp/connect-errors"
|
|
+#define _PATH_CONNERRS _ROOT_PATH "/var/log/ppp/connect-errors"
|
|
#define _PATH_PEERFILES _ROOT_PATH "/etc/ppp/peers/"
|
|
-#define _PATH_RESOLV _ROOT_PATH "/etc/ppp/resolv.conf"
|
|
+#define _PATH_RESOLV _ROOT_PATH "/var/run/ppp/resolv.conf"
|
|
|
|
#define _PATH_USEROPT ".ppprc"
|
|
#define _PATH_PSEUDONYM ".ppp_pseudonym"
|