Remove patch setting CC to gcc

This is automatically done these days, so no need for us to do it
This commit is contained in:
Timm Bäder 2020-11-10 14:50:51 +01:00
parent a9d0d03ee8
commit 4c460e431e
5 changed files with 3 additions and 29 deletions

View File

@ -1,25 +0,0 @@
From 486e36d184cbaee7e34bb582ea6fdf3bfa9ca531 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 11:23:42 +0200
Subject: [PATCH 01/27] build-sys: use gcc as our compiler of choice
---
pppd/Makefile.linux | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pppd/Makefile.linux b/pppd/Makefile.linux
index a74c914..1d9ea78 100644
--- a/pppd/Makefile.linux
+++ b/pppd/Makefile.linux
@@ -30,7 +30,7 @@ ifeq (.depend,$(wildcard .depend))
include .depend
endif
-# CC = gcc
+CC = gcc
#
COPTS = -O2 -pipe -Wall -g
LIBS =
--
1.8.3.1

View File

@ -28,7 +28,7 @@ index 63872eb..8ed56c1 100644
@@ -32,7 +33,7 @@ endif
CC = gcc
# CC = gcc
#
-COPTS = -Wall $(RPM_OPT_FLAGS)
+COPTS = -Wall $(RPM_OPT_FLAGS) -DLIBDIR=\""$(LIBDIR)"\"

View File

@ -34,7 +34,7 @@ index 5a44d30..63872eb 100644
+++ b/pppd/Makefile.linux
@@ -32,8 +32,7 @@ endif
CC = gcc
# CC = gcc
#
-COPTS = -O2 -pipe -Wall -g
-LIBS =

View File

@ -33,7 +33,7 @@ index 53df4d2..0e8107f 100644
@@ -32,6 +32,9 @@ include .depend
endif
CC = gcc
# CC = gcc
+
+LIBS = -ludev
+

View File

@ -22,7 +22,6 @@ Source11: ifdown-ppp
Source12: ppp-watch.tar.xz
# Fedora-specific
Patch0001: 0001-build-sys-use-gcc-as-our-compiler-of-choice.patch
Patch0002: ppp-2.4.8-build-sys-enable-PAM-support.patch
Patch0003: ppp-2.4.8-build-sys-utilize-compiler-flags-handed-to-us-by-rpm.patch
Patch0004: 0004-doc-add-configuration-samples.patch