Regenerate new patches from git

This commit is contained in:
Michal Sekletar 2014-04-10 13:11:38 +02:00
parent eb05fa266f
commit 45f302555f
30 changed files with 112 additions and 104 deletions

View File

@ -1,7 +1,7 @@
From 486e36d184cbaee7e34bb582ea6fdf3bfa9ca531 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 11:23:42 +0200
Subject: [PATCH] build-sys: use gcc as our compiler of choice
Subject: [PATCH 01/25] build-sys: use gcc as our compiler of choice
---
pppd/Makefile.linux | 2 +-
@ -20,3 +20,6 @@ index a74c914..1d9ea78 100644
#
COPTS = -O2 -pipe -Wall -g
LIBS =
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 0d71a32b73b71c9793d0b304320858062faf00d1 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 11:25:43 +0200
Subject: [PATCH] build-sys: enable PAM support
Subject: [PATCH 02/25] build-sys: enable PAM support
---
pppd/Makefile.linux | 2 +-
@ -20,3 +20,6 @@ index 1d9ea78..5a44d30 100644
HAVE_INET6=y
# Enable plugins
--
1.8.3.1

View File

@ -1,7 +1,8 @@
From d729b06f0ac7a5ebd3648ef60bef0499b59bf82d Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 11:29:39 +0200
Subject: [PATCH] build-sys: utilize compiler flags handed to us by rpmbuild
Subject: [PATCH 03/25] build-sys: utilize compiler flags handed to us by
rpmbuild
---
chat/Makefile.linux | 2 +-
@ -115,3 +116,6 @@ index cca6f0f..42aba73 100644
COMPILE_FLAGS = -I../include
LIBS =
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From d7faeb88f684c8b2ae193b2c5b5b358ac757fcfa Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 11:39:09 +0200
Subject: [PATCH] doc: add configuration samples
Subject: [PATCH 04/25] doc: add configuration samples
---
sample/auth-down | 17 ++++++
@ -336,3 +336,6 @@ index 0000000..098971b
+#root hostname "*" -
+#support hostname "*" -
+#stats hostname "*" -
--
1.8.3.1

View File

@ -1,8 +1,8 @@
From 69711944745af0078da77e108d30f89fd7e06108 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 12:01:33 +0200
Subject: [PATCH] build-sys: don't hardcode LIBDIR, but set it according to the
target platform
Subject: [PATCH 05/25] build-sys: don't hardcode LIBDIR, but set it according
to the target platform
---
pppd/Makefile.linux | 3 ++-
@ -115,3 +115,6 @@ index 352991a..1305ed8 100644
PPPDVERSION = $(shell awk -F '"' '/VERSION/ { print $$2; }' ../../patchlevel.h)
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 01419dfb684d501b57f1c24dcfdbcf9da93ccca2 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 18:12:47 +0200
Subject: [PATCH] scritps: use change_resolv_conf function
Subject: [PATCH 06/25] scritps: use change_resolv_conf function
Don't handle /etc/resolv.conf manually, but use a helper function from
initscripts. Also change path where we save DNS servers supplied by peer while
@ -80,3 +80,6 @@ index 8017209..26cf5f8 100644
fi
fi
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From b9fb631a493c5f1b490c8e9645eb6ebab4b25cc8 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 18:37:00 +0200
Subject: [PATCH] build-sys: don't strip binaries during installation
Subject: [PATCH 07/25] build-sys: don't strip binaries during installation
We don't want that when building rpms. rpmbuild does final stripping of binaries
for us and generetes debuginfo rpm.
@ -106,3 +106,6 @@ index 42aba73..c5ba3b1 100644
$(INSTALL) -c -m 444 pppstats.8 $(MANDIR)
pppstats: $(PPPSTATSRCS)
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 343728d5de6e44bd67923503e62eefaad50760a4 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 18:47:01 +0200
Subject: [PATCH] build-sys: use prefix /usr instead of /usr/local
Subject: [PATCH 08/25] build-sys: use prefix /usr instead of /usr/local
---
configure | 2 +-
@ -84,3 +84,6 @@ index 0002365..ae3ae50 100755
#
# This script was written by Jim Isaacson <jcisaac@crl.com>. It is
# designed to work as a script to use the SecureCARD(tm) device. This
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From abef895f9d144f05a83045136b77277352dc450f Mon Sep 17 00:00:00 2001
From: David Woodhouse <dwmw2@fedoraproject.org>
Date: Fri, 4 Apr 2014 18:53:33 +0200
Subject: [PATCH] pppd: introduce ipv6-accept-remote
Subject: [PATCH 09/25] pppd: introduce ipv6-accept-remote
---
pppd/ipv6cp.c | 5 ++++-
@ -52,3 +52,6 @@ index cc4568d..8c7552e 100644
int opt_local; /* ourtoken set by option */
int opt_remote; /* histoken set by option */
int use_ip; /* use IP as interface identifier */
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 8015a0ef23a874f288d5e77ffafe1d7f4281725d Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 18:59:24 +0200
Subject: [PATCH] build-sys: enable CBCP
Subject: [PATCH 10/25] build-sys: enable CBCP
Resolves: #199278
---
@ -21,3 +21,6 @@ index 95c2598..65700fa 100644
# Enable EAP SRP-SHA1 authentication (requires libsrp)
#USE_SRP=y
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From b4ef433be936c90e356da7a590b032cdee219a3f Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Fri, 4 Apr 2014 19:06:05 +0200
Subject: [PATCH] build-sys: don't put connect-errors log to /etc/ppp/
Subject: [PATCH 11/25] build-sys: don't put connect-errors log to /etc/ppp/
Resolves: #118837
---
@ -72,3 +72,6 @@ index a427cb8..bef3160 100644
#define _PATH_USEROPT ".ppprc"
#define _PATH_PSEUDONYM ".ppp_pseudonym"
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 82cd789df0f022eb6f3d28646e7a61d1d0715805 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Mon, 7 Apr 2014 12:23:36 +0200
Subject: [PATCH] pppd: we don't want to accidentally leak fds
Subject: [PATCH 12/25] pppd: we don't want to accidentally leak fds
---
pppd/auth.c | 20 ++++++++++----------
@ -138,3 +138,6 @@ index 72a7727..8a12fa0 100644
if (route_fd == NULL) {
error("can't open routing table %s: %m", path);
return 0;
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 302c1b736cb656c7885a0cba270fd953a672d8a8 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Mon, 7 Apr 2014 13:56:34 +0200
Subject: [PATCH] everywhere: O_CLOEXEC harder
Subject: [PATCH 13/25] everywhere: O_CLOEXEC harder
---
pppd/eap.c | 2 +-
@ -236,3 +236,6 @@ index 29bf970..6051b9a 100644
if (fd < 0) {
error("Couldn't reopen lock file %s: %m", lock_file);
lock_file[0] = 0;
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 66060ba65b1f1b4f1f760da2e156ef7755c7f3c5 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Mon, 7 Apr 2014 14:21:41 +0200
Subject: [PATCH] everywhere: use O_CLOEXEC when creating socket
Subject: [PATCH 14/23] everywhere: use O_CLOEXEC when creating socket
---
pppd/plugins/pppoatm/pppoatm.c | 2 +-
@ -169,3 +169,6 @@ index bc96695..8e76a5d 100644
if (sock < 0) {
error("Can't create socket: %m");
return -1;
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 2a97ab28ee00586e5f06b3ef3a0e43ea0c7c6499 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Mon, 7 Apr 2014 14:21:41 +0200
Subject: [PATCH] everywhere: use SOCK_CLOEXEC when creating socket
Subject: [PATCH 14/25] everywhere: use SOCK_CLOEXEC when creating socket
---
pppd/plugins/pppoatm/pppoatm.c | 2 +-
@ -169,3 +169,6 @@ index bc96695..8e76a5d 100644
if (sock < 0) {
error("Can't create socket: %m");
return -1;
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From f2c855462ff56be4121409c7e048cd2503fe0ccf Mon Sep 17 00:00:00 2001
From: Jiri Skala <jskala@fedoraproject.org>
Date: Mon, 7 Apr 2014 14:26:20 +0200
Subject: [PATCH] pppd: move pppd database to /var/run/ppp
Subject: [PATCH 15/25] pppd: move pppd database to /var/run/ppp
Resolves: #560014
---
@ -39,3 +39,6 @@ index bef3160..24e010c 100644
#endif /* __STDC__ */
#ifdef PLUGIN
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From a30efa2cc99a5b6ab220de04cbcc7db38888a17a Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Mon, 7 Apr 2014 14:29:45 +0200
Subject: [PATCH] rp-pppoe: add manpage for pppoe-discovery
Subject: [PATCH 16/25] rp-pppoe: add manpage for pppoe-discovery
---
pppd/plugins/rp-pppoe/Makefile.linux | 2 +
@ -121,3 +121,6 @@ index 0000000..d0a93db
+based on \fBpppoe\fR by David F. Skoll <dfs@roaringpenguin.com>.
+.SH SEE ALSO
+pppoe(8), pppoe-sniff(8)
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 044a5b1e5d878c519143b71a44b3d5b0ca91de3b Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Mon, 7 Apr 2014 14:56:56 +0200
Subject: [PATCH] pppd: rebase EAP-TLS patch v0.994
Subject: [PATCH 17/25] pppd: rebase EAP-TLS patch v0.994
---
README.eap-tls | 169 +++++++
@ -3040,3 +3040,6 @@ index 47e4d9a..de271c1 100644
/* Let a plugin snoop sent and received packets. Useful for L2TP */
extern void (*snoop_recv_hook) __P((unsigned char *p, int len));
extern void (*snoop_send_hook) __P((unsigned char *p, int len));
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 40960f91cdd06da387616ec838ae2599e7f01cee Mon Sep 17 00:00:00 2001
From: Jiri Skala <jskala@fedoraproject.org>
Date: Mon, 7 Apr 2014 15:24:01 +0200
Subject: [PATCH] scritps: fix ip-up.local sample
Subject: [PATCH 18/25] scritps: fix ip-up.local sample
Resolves: #613717
---
@ -22,3 +22,6 @@ index 26cf5f8..282337c 100644
change_resolv_conf $rscf
rm -f $rscf
else
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 6edc865bd02ab591b9121d4a5f6dc3cdbe5af809 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Wed, 9 Apr 2014 09:18:24 +0200
Subject: [PATCH] sys-linux: rework get_first_ethernet()
Subject: [PATCH 19/25] sys-linux: rework get_first_ethernet()
We can't assume that host has ethernet NIC named "eth0". Rather than guessing we
better ask udev. We iterate over symlinks symlinks in /sys/class/net and
@ -378,3 +378,6 @@ index 0690019..ec09c50 100644
return 0;
}
close(skfd);
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From c5a5f795b1defcb6d168e79c4d1fc371dfc556ca Mon Sep 17 00:00:00 2001
From: Jiri Skala <jskala@redhat.com>
Date: Wed, 9 Apr 2014 09:29:50 +0200
Subject: [PATCH] pppd: put lock files in /var/lock/ppp
Subject: [PATCH 20/25] pppd: put lock files in /var/lock/ppp
Resolves: #708260
---
@ -21,3 +21,6 @@ index 6051b9a..8407492 100644
#else
#ifdef SVR4
#define LOCK_DIR "/var/spool/locks"
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From d69eb9a8aa284014dd7dd282813989eda9d84d74 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Wed, 9 Apr 2014 09:56:09 +0200
Subject: [PATCH] build-sys: compile pppol2tp plugin with RPM_OPT_FLAGS
Subject: [PATCH 21/25] build-sys: compile pppol2tp plugin with RPM_OPT_FLAGS
---
pppd/plugins/pppol2tp/Makefile.linux | 2 +-
@ -18,3 +18,6 @@ index 4339566..9a635b8 100644
CFLAGS = $(COPTS) -I. -I../.. -I../../../include -fPIC
LDFLAGS = -shared
INSTALL = install
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From a0060c5d48ef742bff4fe9ba9c276a5c21795ce8 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Wed, 9 Apr 2014 09:58:38 +0200
Subject: [PATCH] build-sys: compile pppol2tp with multilink support
Subject: [PATCH 22/25] build-sys: compile pppol2tp with multilink support
Resolves: #817013
---
@ -19,3 +19,6 @@ index 9a635b8..9cb316d 100644
CFLAGS = $(COPTS) -I. -I../.. -I../../../include -fPIC
LDFLAGS = -shared
INSTALL = install
--
1.8.3.1

View File

@ -1,7 +1,8 @@
From 769521a3798fd554ddc7333cb1255cd1b40790e8 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Thu, 10 Apr 2014 10:00:55 +0200
Subject: [PATCH] build-sys: install rp-pppoe plugin files with standard perms
Subject: [PATCH 23/25] build-sys: install rp-pppoe plugin files with standard
perms
This is needed to properly generate debuginfo package.
---
@ -26,3 +27,6 @@ index b949716..fa49efb 100644
clean:
rm -f *.o *.so pppoe-discovery
--
1.8.3.1

View File

@ -1,7 +1,7 @@
From 1dc033327792ef51cb08e224b8d90e7d8571084d Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Wed, 9 Apr 2014 15:37:53 +0200
Subject: [PATCH] build-sys: make pppd first and then plugins
Subject: [PATCH 23/23] build-sys: make pppd first and then plugins
---
linux/Makefile.top | 2 +-
@ -21,3 +21,6 @@ index 9a8945a..12210f2 100644
cd pppstats; $(MAKE) $(MFLAGS) all
cd pppdump; $(MAKE) $(MFLAGS) all
--
1.8.3.1

View File

@ -1,7 +1,8 @@
From 0fdb22ef3d3cc3b297372451d60bd6c61d047d27 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Thu, 10 Apr 2014 10:08:41 +0200
Subject: [PATCH] build-sys: install pppoatm plugin files with standard perms
Subject: [PATCH 24/25] build-sys: install pppoatm plugin files with standard
perms
---
pppd/plugins/pppoatm/Makefile.linux | 2 +-
@ -20,3 +21,6 @@ index 769794b..4c5826f 100644
clean:
rm -f *.o *.so
--
1.8.3.1

View File

@ -1,28 +0,0 @@
From 6ef131e175fb06125e45129a4c4b8e8fea5b21c5 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Thu, 10 Apr 2014 10:00:55 +0200
Subject: [PATCH] build-sys: install rp-pppoe plugin files with standard perms
This is needed to properly generate debuginfo package.
---
pppd/plugins/rp-pppoe/Makefile.linux | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/pppd/plugins/rp-pppoe/Makefile.linux b/pppd/plugins/rp-pppoe/Makefile.linux
index b949716..fa49efb 100644
--- a/pppd/plugins/rp-pppoe/Makefile.linux
+++ b/pppd/plugins/rp-pppoe/Makefile.linux
@@ -44,10 +44,10 @@ rp-pppoe.so: plugin.o discovery.o if.o common.o
install: all
$(INSTALL) -d -m 755 $(LIBDIR)
- $(INSTALL) -c -m 4550 rp-pppoe.so $(LIBDIR)
+ $(INSTALL) -c -m 755 rp-pppoe.so $(LIBDIR)
$(INSTALL) -d -m 755 $(BINDIR)
- $(INSTALL) -c -m 555 pppoe-discovery $(BINDIR)
- $(INSTALL) -c -m 444 pppoe-discovery.8 $(MANDIR)
+ $(INSTALL) -c -m 755 pppoe-discovery $(BINDIR)
+ $(INSTALL) -c -m 644 pppoe-discovery.8 $(MANDIR)
clean:
rm -f *.o *.so pppoe-discovery

View File

@ -1,22 +0,0 @@
From b4d0b4ef32c3689a9de51624783ecca5ba7cfb74 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Thu, 10 Apr 2014 10:08:41 +0200
Subject: [PATCH] build-sys: install pppoatm plugin files with standard perms
---
pppd/plugins/pppoatm/Makefile.linux | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/pppd/plugins/pppoatm/Makefile.linux b/pppd/plugins/pppoatm/Makefile.linux
index 769794b..4c5826f 100644
--- a/pppd/plugins/pppoatm/Makefile.linux
+++ b/pppd/plugins/pppoatm/Makefile.linux
@@ -37,7 +37,7 @@ $(PLUGIN): $(PLUGIN_OBJS)
install: all
$(INSTALL) -d -m 755 $(LIBDIR)
- $(INSTALL) -c -m 4550 $(PLUGIN) $(LIBDIR)
+ $(INSTALL) -c -m 755 $(PLUGIN) $(LIBDIR)
clean:
rm -f *.o *.so

View File

@ -1,7 +1,7 @@
From ab8b06cdc1075abc67f77e7c3bb684e20071d614 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Thu, 10 Apr 2014 10:09:41 +0200
Subject: [PATCH] pppd: install pppd binary using standard perms (755)
Subject: [PATCH 25/25] pppd: install pppd binary using standard perms (755)
---
pppd/Makefile.linux | 4 ++--
@ -24,3 +24,6 @@ index 0e8107f..534ccc2 100644
pppd: $(PPPDOBJS)
$(CC) $(CFLAGS) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)
--
1.8.3.1

View File

@ -1,26 +0,0 @@
From 72eaf5588fef675d35079c5c6dbfe32ae8a65fc2 Mon Sep 17 00:00:00 2001
From: Michal Sekletar <msekleta@redhat.com>
Date: Thu, 10 Apr 2014 10:09:41 +0200
Subject: [PATCH] pppd: install pppd binary using standard perms (755)
---
pppd/Makefile.linux | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/pppd/Makefile.linux b/pppd/Makefile.linux
index 0e8107f..534ccc2 100644
--- a/pppd/Makefile.linux
+++ b/pppd/Makefile.linux
@@ -223,10 +223,10 @@ all: $(TARGETS)
install: pppd
mkdir -p $(BINDIR) $(MANDIR)
$(EXTRAINSTALL)
- $(INSTALL) -c -m 555 pppd $(BINDIR)/pppd
+ $(INSTALL) -c -m 755 pppd $(BINDIR)/pppd
if chgrp pppusers $(BINDIR)/pppd 2>/dev/null; then \
chmod o-rx,u+s $(BINDIR)/pppd; fi
- $(INSTALL) -c -m 444 pppd.8 $(MANDIR)
+ $(INSTALL) -c -m 644 pppd.8 $(MANDIR)
pppd: $(PPPDOBJS)
$(CC) $(CFLAGS) $(LDFLAGS) -o pppd $(PPPDOBJS) $(LIBS)