Update postgresql to 13.1 and postgresql-setup to v8.5

This commit is contained in:
Honza Horak 2020-11-18 23:15:29 +01:00 committed by Patrik Novotný
parent a9fcc54528
commit b081e11492
5 changed files with 45 additions and 40 deletions

View File

@ -3,10 +3,10 @@ PostgreSQL ecpg/initdb manual page fixes
This was generated based on automatic Red Hat manual page scan (private
RHBZ#948933).
diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
--- ./doc/src/sgml/man1/ecpg.1.man948933 2014-12-16 02:13:15.000000000 +0100
+++ ./doc/src/sgml/man1/ecpg.1 2014-12-23 11:26:37.883644047 +0100
@@ -80,6 +80,11 @@ INFORMIX_SE\&.
diff -up postgresql-13.1/doc/src/sgml/man1/ecpg.1.patch6 postgresql-13.1/doc/src/sgml/man1/ecpg.1
--- postgresql-13.1/doc/src/sgml/man1/ecpg.1.patch6 2020-11-09 23:38:03.000000000 +0100
+++ postgresql-13.1/doc/src/sgml/man1/ecpg.1 2020-11-18 09:26:40.547324791 +0100
@@ -81,6 +81,11 @@ ORACLE\&.
Define a C preprocessor symbol\&.
.RE
.PP
@ -15,10 +15,10 @@ diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
+Parse a header file, this option includes option \fB\-c\fR\&.
+.RE
+.PP
\fB\-i\fR
\fB\-h\fR
.RS 4
Parse system include files as well\&.
@@ -128,6 +133,11 @@ Allow question mark as placeholder for c
Process header files\&. When this option is specified, the output file extension becomes
@@ -144,6 +149,11 @@ Allow question mark as placeholder for c
.RE
.RE
.PP
@ -30,10 +30,10 @@ diff -up ./doc/src/sgml/man1/ecpg.1.man948933 ./doc/src/sgml/man1/ecpg.1
\fB\-t\fR
.RS 4
Turn on autocommit of transactions\&. In this mode, each SQL command is automatically committed unless it is inside an explicit transaction block\&. In the default mode, commands are committed only when
diff -up ./doc/src/sgml/man1/initdb.1.man948933 ./doc/src/sgml/man1/initdb.1
--- ./doc/src/sgml/man1/initdb.1.man948933 2014-12-16 02:13:21.000000000 +0100
+++ ./doc/src/sgml/man1/initdb.1 2014-12-23 11:26:37.883644047 +0100
@@ -281,6 +281,13 @@ determines that an error prevented it fr
diff -up postgresql-13.1/doc/src/sgml/man1/initdb.1.patch6 postgresql-13.1/doc/src/sgml/man1/initdb.1
--- postgresql-13.1/doc/src/sgml/man1/initdb.1.patch6 2020-11-09 23:38:05.000000000 +0100
+++ postgresql-13.1/doc/src/sgml/man1/initdb.1 2020-11-18 09:25:05.082348424 +0100
@@ -311,6 +311,13 @@ determines that an error prevented it fr
.PP
Other options:
.PP

View File

@ -6,11 +6,10 @@ rhbz#1618698 change, rather provide pg_server_config binary, which int urn means
that we'll have to fix only a minimal set of packages which really build
PostgreSQL server modules.
diff --git a/src/bin/pg_config/Makefile b/src/bin/pg_config/Makefile
index 02e6f9d..f7c844f 100644
--- a/src/bin/pg_config/Makefile
+++ b/src/bin/pg_config/Makefile
@@ -11,28 +11,30 @@
diff -up postgresql-13.1/src/bin/pg_config/Makefile.patch9 postgresql-13.1/src/bin/pg_config/Makefile
--- postgresql-13.1/src/bin/pg_config/Makefile.patch9 2020-11-18 09:28:30.885453275 +0100
+++ postgresql-13.1/src/bin/pg_config/Makefile 2020-11-18 09:31:33.926325327 +0100
@@ -11,6 +11,8 @@
PGFILEDESC = "pg_config - report configuration information"
PGAPPICON=win32
@ -19,8 +18,9 @@ index 02e6f9d..f7c844f 100644
subdir = src/bin/pg_config
top_builddir = ../../..
include $(top_builddir)/src/Makefile.global
OBJS= pg_config.o $(WIN32RES)
@@ -19,22 +21,22 @@ OBJS = \
$(WIN32RES) \
pg_config.o
-all: pg_config
+all: $(PG_CONFIG)
@ -43,17 +43,16 @@ index 02e6f9d..f7c844f 100644
clean distclean maintainer-clean:
- rm -f pg_config$(X) $(OBJS)
+ rm -f $(PG_CONFIG) $(OBJS)
+ rm -f $(PG_CONFIG) $(OBJS)
rm -rf tmp_check
check:
diff --git a/src/bin/pg_config/nls.mk b/src/bin/pg_config/nls.mk
index 1d41f90..0f34f37 100644
--- a/src/bin/pg_config/nls.mk
+++ b/src/bin/pg_config/nls.mk
diff -up postgresql-13.1/src/bin/pg_config/nls.mk.patch9 postgresql-13.1/src/bin/pg_config/nls.mk
--- postgresql-13.1/src/bin/pg_config/nls.mk.patch9 2020-11-18 09:28:30.885453275 +0100
+++ postgresql-13.1/src/bin/pg_config/nls.mk 2020-11-18 09:32:00.735599526 +0100
@@ -1,4 +1,4 @@
# src/bin/pg_config/nls.mk
-CATALOG_NAME = pg_config
+CATALOG_NAME = pg_server_config
AVAIL_LANGUAGES = cs de es fr he it ja ko pl pt_BR ro ru sv tr uk vi zh_CN zh_TW
AVAIL_LANGUAGES = cs de es fr he it ja ko pl pt_BR ru sv tr uk vi zh_CN
GETTEXT_FILES = pg_config.c ../../common/config_info.c ../../common/exec.c

View File

@ -42,12 +42,12 @@ diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
index e278fa0..9ee15d4 100644
--- a/src/include/pg_config_manual.h
+++ b/src/include/pg_config_manual.h
@@ -169,7 +169,7 @@
* here's where to twiddle it. You can also override this at runtime
* with the postmaster's -k switch.
@@ -201,7 +201,7 @@
* support them yet.
*/
#ifndef WIN32
-#define DEFAULT_PGSOCKET_DIR "/tmp"
+#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
/*
* This is the default event source for Windows event log.
#else
#define DEFAULT_PGSOCKET_DIR ""
#endif

View File

@ -59,8 +59,8 @@
Summary: PostgreSQL client programs
Name: postgresql
%global majorversion 12
Version: %{majorversion}.5
%global majorversion 13
Version: %{majorversion}.1
Release: 1%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
@ -72,8 +72,8 @@ Url: http://www.postgresql.org/
# in-place upgrade of an old database. In most cases it will not be critical
# that this be kept up with the latest minor release of the previous series;
# but update when bugs affecting pg_dump output are fixed.
%global prevmajorversion 11
%global prevversion %{prevmajorversion}.10
%global prevmajorversion 12
%global prevversion %{prevmajorversion}.5
%global prev_prefix %{_libdir}/pgsql/postgresql-%{prevmajorversion}
%global precise_version %{?epoch:%epoch:}%version-%release
@ -300,6 +300,7 @@ Summary: The Perl procedural language for PostgreSQL
Requires: %{name}-server%{?_isa} = %precise_version
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
%if %runselftest
BuildRequires: perl(Opcode)
BuildRequires: perl(Data::Dumper)
%endif
@ -867,7 +868,7 @@ find_lang_bins ()
find_lang_bins devel.lst pg_server_config
find_lang_bins server.lst \
initdb pg_basebackup pg_controldata pg_ctl pg_resetwal pg_rewind plpgsql \
postgres pg_checksums
postgres pg_checksums pg_verifybackup
find_lang_bins contrib.lst \
pg_archivecleanup pg_test_fsync pg_test_timing pg_waldump
find_lang_bins main.lst \
@ -1117,6 +1118,7 @@ make -C postgresql-setup-%{setup_version} check
%{_bindir}/pg_resetwal
%{_bindir}/pg_rewind
%{_bindir}/pg_checksums
%{_bindir}/pg_verifybackup
%{_bindir}/postgres
%{_bindir}/postgresql-setup
%{_bindir}/postgresql-upgrade
@ -1128,8 +1130,6 @@ make -C postgresql-setup-%{setup_version} check
%{_datadir}/pgsql/extension/plpgsql*
%{_datadir}/pgsql/information_schema.sql
%{_datadir}/pgsql/postgres.bki
%{_datadir}/pgsql/postgres.description
%{_datadir}/pgsql/postgres.shdescription
%{_datadir}/pgsql/snowball_create.sql
%{_datadir}/pgsql/sql_features.txt
%{_datadir}/pgsql/system_views.sql
@ -1159,6 +1159,7 @@ make -C postgresql-setup-%{setup_version} check
%{_mandir}/man1/pg_resetwal.*
%{_mandir}/man1/pg_rewind.*
%{_mandir}/man1/pg_checksums.*
%{_mandir}/man1/pg_verifybackup.*
%{_mandir}/man1/postgres.*
%{_mandir}/man1/postgresql-new-systemd-unit.*
%{_mandir}/man1/postgresql-setup.*
@ -1229,7 +1230,9 @@ make -C postgresql-setup-%{setup_version} check
%if %plperl
%files plperl -f plperl.lst
%{_datadir}/pgsql/extension/bool_plperl*
%{_datadir}/pgsql/extension/plperl*
%{_libdir}/pgsql/bool_plperl.so
%{_libdir}/pgsql/plperl.so
%endif
@ -1263,6 +1266,9 @@ make -C postgresql-setup-%{setup_version} check
%changelog
* Wed Nov 18 2020 Honza Horak <hhorak@redhat.com> - 13.1-1
- Rebase to usptream release 13.1
* Wed Jan 13 2021 Patrik Novotný <panovotn@redhat.com> - 12.5-1
- Rebase to upstream release 12.5
Patch for libpq 13.x build time compatibility

View File

@ -1,6 +1,6 @@
SHA512 (postgresql-11.10.tar.bz2) = 0cc0e9b0f76e00727dc699ea59a45d760d37d91ec736a62cbc9bda3e38eb1ef1565e4e399dd3ae96bad87f866e56e364f916de7740d8be6e1cfc2bf654dfbb68
SHA512 (postgresql-11.10.tar.bz2.sha256) = 18ed6c3b51010a62bd0cffa600a23b5c2630bdc0f97fc207212d22be54c1977b53dcacbe7117a8dd5621245ef730e94278cb76bec219ad2767aeefd0f76c2b19
SHA512 (postgresql-12.5.tar.bz2) = 9895bcb1bb26206500666ab4441e663ef83702d428b85a6ff177a4eaf44b0ae06b35d5c4da2672ccb4ec18296649af95bf2f0aed526afaa6a216a8c2d2c5627e
SHA512 (postgresql-12.5.tar.bz2.sha256) = 5a05064eacb02458b02e57eafb983ffd282536fee390c4f13257f747bb74a2af3d56bd00de01c5c9934f64a7eeedbe0edc7a7f219d17f0ee912f34577b398151
SHA512 (postgresql-13.1.tar.bz2) = b7bd378db1dcb74ebcd5fffba03b82d8117d182029e4caca48eef62d8bcdbeef2c2e10f18eef0cdafb9d7acf21aa164d040e56687709f97b08c51540a786eeca
SHA512 (postgresql-13.1.tar.bz2.sha256) = 58f2ad590b5946bdb3f8bc512318c60a48916ebac7df854b6b737daa609b4fd78c71fe9bf04a4103885527ed498bb46bf68ce8e656b357f9ae43b556bd48df41
SHA512 (postgresql-setup-8.5.tar.gz) = 5d31e31f3fdaa1564f6758ad7bcc17ffaac627b4665117d54b81e25e8309c03fc7d7cd53733891f80d3fc874474fa6b6d9a8d4765d1a9b9c31041baa66975241
SHA512 (postgresql-12.5-US.pdf) = 0fcd669fd521e10b066ffe57f57172f363184b873ef8a01f22c26b8fcd11f40e976ea9a0e765fe8a3590e99361d16e402279634e17721a3c57994d25f9b0df29
SHA512 (postgresql-13.1-US.pdf) = 8ca74d4ad39552d2e32481d75b8106c39ed46bc96619b0a2d0472ee4803122a9a16d20996005b80b0824cd544ec2d160c5954283cd9244d2782df3a39d8b712c