Update to PostgreSQL 8.1.0, fix bugs 167040 and 170141.

This commit is contained in:
Tom Lane 2005-11-07 21:54:56 +00:00
parent 81785f0dfe
commit 80b1caeeda
8 changed files with 196 additions and 213 deletions

View File

@ -1,8 +1,8 @@
postgresql-8.0.4.tar.bz2
PyGreSQL-3.6.2.tgz
postgresql-8.1.0.tar.bz2
PyGreSQL-3.7.tgz
pgtcl1.5.2.tar.gz
pgtcldocs-20041108.zip
postgresql-8.0-312.jdbc2.jar
postgresql-8.0-312.jdbc2ee.jar
postgresql-8.0-312.jdbc3.jar
postgresql-8.1-404.jdbc2.jar
postgresql-8.1-404.jdbc2ee.jar
postgresql-8.1-404.jdbc3.jar
postgresql-8.0-US.pdf

View File

@ -1,6 +1,6 @@
README.rpm-dist
-----------------------------------------------------------------------------
Version 8.0, for the PostgreSQL 8.0.0-1PGDG RPMset.
Version 8.1, for the PostgreSQL 8.1.0-1 RPMset.
Lamar Owen <lamar.owen@wgcr.org>
-----------------------------------------------------------------------------
@ -33,9 +33,9 @@ This document exists to explain the layout of the RPMs for PostgreSQL, to
describe various RPM specifics, and to document special features found
in the RPMset.
This document is written to be applicable to version 8.0 of PostgreSQL,
This document is written to be applicable to version 8.1 of PostgreSQL,
which is the current version of the RPMs as of this writing. More to the
point, versions prior to 8.0 are not documented here.
point, versions prior to 8.1 are not documented here.
Official PostgreSQL Global Development Group RPMs have from version 7.1.2
on carried a 'PGDG' after the release number. Other RPMsets distributed
@ -173,8 +173,8 @@ the beauty of RPM -- you don't have to keep track of the files, RPM does it
for you.
These RPMs are designed to be LSB-compliant -- if you find this not to be the
case, please let me know by way of the pgsql-ports@postgresql.org mailing
list.
case, please let us know by way of the pgsqlrpms-hackers@PostgreSQL.org
mailing list.
MULTIPLE POSTMASTERS
-------------------------------------------------------------------------------
@ -272,15 +272,13 @@ you will need to rebuild from the source RPM. Download the .src.rpm for this
release. You will need to be root to rebuild, unless you have already set up
a non-root build environment.
Install the source RPM with rpm -i, then CD to the rpm building area (on RedHat
this is /usr/src/redhat by default). You will have to have a full development
environment to rebuild the full RPM set.
Install the source RPM with rpm -i, then CD to the rpm building area (on Red
Hat or Fedora Core this is /usr/src/redhat by default). You will have to have
a full development environment to rebuild the full RPM set.
This release of the RPMset includes the ability to conditionally build
sets of packages. The parameters, their defaults, and the meanings are:
build6x undef #don't build for Red Hat 6.x. Define it to cause
# other options to be tailored to 6.x.
beta 0 #build with cassert and do not strip the binaries
perl 1 #build the postgresql-perl package.
tcl 1 #build the postgresql-tcl package.
@ -299,7 +297,7 @@ runselftest 1 #do "make check" during the build.
To use these defines, invoke a rebuild like this:
rpm --rebuild --define 'perl 0' --define 'tcl 0' \
--define 'test 0' --define 'runselftest 1' --define 'kerberos 0' \
postgresql-8.0.0-1PGDG.src.rpm
postgresql-8.1.0-1.src.rpm
This line would disable the perl, tcl, and test subpackages, enable the
regression test run during build, and disable kerberos support.
@ -324,12 +322,14 @@ MORE INFORMATION
-------------------------------------------------------------------------------
You can get more information at http://www.postgresql.org
Please help make this packaging better -- let me know if you find problems, or
better ways of doing things. You can reach me by e-mail at
pgsql-ports@postgresql.org -- please include an [RPM] string in the subject, as
I use automatic mail folder processing to put mail in the right place.
Please help make this packaging better -- let us know if you find problems, or
better ways of doing things. You can reach us by e-mail at
pgsqlrpms-hackers@PostgreSQL.org .
SuSE information is available at SuSE's website and information contacts.
A 7.4 SuSE RPM is available on ftp.postgresql.org. It is different from this
RPM due to SuSE's different needs.
-----------------------------------------------------------------------------
SUSE products usually ship with the latest version of PostgreSQL that
was available at the time they were released. RPMs for newer versions
of PostgreSQL can be found on the SUSE FTP server and it's mirrors.
ftp://ftp.suse.com/pub/projects/postgresql
http://www.novell.com/products/linuxprofessional/downloads/ftp/int_mirrors.html
-------------------------------------------------------------------------------

View File

@ -1,32 +1,36 @@
diff -Naur postgresql-8.0.0rc5.orig/src/backend/utils/misc/postgresql.conf.sample postgresql-8.0.0rc5/src/backend/utils/misc/postgresql.conf.sample
--- postgresql-8.0.0rc5.orig/src/backend/utils/misc/postgresql.conf.sample 2004-11-05 14:16:16.000000000 -0500
+++ postgresql-8.0.0rc5/src/backend/utils/misc/postgresql.conf.sample 2005-01-11 19:18:21.282906899 -0500
@@ -177,22 +177,22 @@
# platform.
diff -Naur postgresql-8.1.0.orig/src/backend/utils/misc/postgresql.conf.sample postgresql-8.1.0/src/backend/utils/misc/postgresql.conf.sample
--- postgresql-8.1.0.orig/src/backend/utils/misc/postgresql.conf.sample 2005-10-08 15:32:58.000000000 -0400
+++ postgresql-8.1.0/src/backend/utils/misc/postgresql.conf.sample 2005-11-07 15:04:13.000000000 -0500
@@ -211,15 +211,15 @@
# depending on platform.
# This is relevant when logging to stderr:
-#redirect_stderr = false # Enable capturing of stderr into log files.
+redirect_stderr = true # Enable capturing of stderr into log files.
# These are only relevant if redirect_stderr is true:
-#log_directory = 'pg_log' # Directory where log files are written.
+log_directory = 'pg_log' # Directory where log files are written.
# May be specified absolute or relative to PGDATA
# This is used when logging to stderr:
-#redirect_stderr = off # Enable capturing of stderr into log
+redirect_stderr = on # Enable capturing of stderr into log
# files
# These are only used if redirect_stderr is on:
-#log_directory = 'pg_log' # Directory where log files are written
+log_directory = 'pg_log' # Directory where log files are written
# Can be absolute or relative to PGDATA
-#log_filename = 'postgresql-%Y-%m-%d_%H%M%S.log' # Log file name pattern.
+log_filename = 'postgresql-%a.log' # Log file name pattern.
# May include strftime() escapes
-#log_truncate_on_rotation = false # If true, any existing log file of the
+log_truncate_on_rotation = true # If true, any existing log file of the
# same name as the new log file will be truncated
# rather than appended to. But such truncation
# only occurs on time-driven rotation,
# not on restarts or size-driven rotation.
# Default is false, meaning append to existing
# files in all cases.
-#log_rotation_age = 1440 # Automatic rotation of logfiles will happen after
+log_rotation_age = 1440 # Automatic rotation of logfiles will happen after
# so many minutes. 0 to disable.
-#log_rotation_size = 10240 # Automatic rotation of logfiles will happen after
+log_rotation_size = 0 # Automatic rotation of logfiles will happen after
# so many kilobytes of log output. 0 to disable.
+log_filename = 'postgresql-%a.log' # Log file name pattern.
# Can include strftime() escapes
-#log_truncate_on_rotation = off # If on, any existing log file of the same
+log_truncate_on_rotation = on # If on, any existing log file of the same
# name as the new log file will be
# truncated rather than appended to. But
# such truncation only occurs on
@@ -227,10 +227,10 @@
# or size-driven rotation. Default is
# off, meaning append to existing files
# in all cases.
-#log_rotation_age = 1440 # Automatic rotation of logfiles will
+log_rotation_age = 1440 # Automatic rotation of logfiles will
# happen after so many minutes. 0 to
# disable.
-#log_rotation_size = 10240 # Automatic rotation of logfiles will
+log_rotation_size = 0 # Automatic rotation of logfiles will
# happen after so many kilobytes of log
# output. 0 to disable.
# These are relevant when logging to syslog:

View File

@ -7,9 +7,9 @@ So work around it by adding an rpath spec to plperl.so (only).
Per bug #162198.
diff -Naur postgresql-8.0.4.orig/src/pl/plperl/GNUmakefile postgresql-8.0.4/src/pl/plperl/GNUmakefile
--- postgresql-8.0.4.orig/src/pl/plperl/GNUmakefile 2005-07-17 00:05:49.000000000 -0400
+++ postgresql-8.0.4/src/pl/plperl/GNUmakefile 2005-10-04 17:40:51.000000000 -0400
diff -Naur postgresql-8.1.0.orig/src/pl/plperl/GNUmakefile postgresql-8.1.0/src/pl/plperl/GNUmakefile
--- postgresql-8.1.0.orig/src/pl/plperl/GNUmakefile 2005-07-13 13:12:56.000000000 -0400
+++ postgresql-8.1.0/src/pl/plperl/GNUmakefile 2005-11-07 15:10:33.000000000 -0500
@@ -36,6 +36,9 @@
SHLIB_LINK = $(perl_embed_ldflags) $(BE_DLLLIBS)
@ -17,6 +17,6 @@ diff -Naur postgresql-8.0.4.orig/src/pl/plperl/GNUmakefile postgresql-8.0.4/src/
+# Force rpath to be used even though we disable it everywhere else
+SHLIB_LINK += $(rpath)
+
include $(top_srcdir)/src/Makefile.shlib
REGRESS_OPTS = --dbname=$(PL_TESTDB) --load-language=plperl
REGRESS = plperl plperl_trigger plperl_shared plperl_elog

View File

@ -1,2 +1,3 @@
#%PAM-1.0
auth include system-auth
account include system-auth

View File

@ -1,49 +1,3 @@
# build6x usage: define to 1 to build for RHL6.x. Don't define at all for others.
%{?build6x:%define kerberos 0}
%{?build6x:%define nls 0}
%{?build6x:%define ssl 0}
%{?build6x:%define tcldevel 0}
%{?build6x:%define aconfver /bin/true}
#work around the undefined or defined to 1 build 6x interaction with the pam stuff
%{!?build6x:%define non6xpamdeps 1}
%{?build6x:%define non6xpamdeps 0}
#build7x, build8, and build9 similar
%{?build8:%define build89 1}
%{?build9:%define build89 1}
%{?build7x:%define tcldevel 0}
%{?build8:%define tcldevel 0}
%{?build7x:%define aconfver autoconf-2.53}
%{!?tcldevel:%define tcldevel 1}
%{!?aconfver:%define aconfver autoconf}
%define beta 0
%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
%{!?tcl:%define tcl 1}
%{!?jdbc:%define jdbc 1}
%{!?test:%define test 1}
%{!?python:%define python 1}
%{!?pltcl:%define pltcl 1}
%{!?plperl:%define plperl 1}
%{!?pls:%define pls 1}
%{!?ssl:%define ssl 1}
%{!?kerberos:%define kerberos 1}
%{!?nls:%define nls 1}
%{!?pam:%define pam 1}
%{!?xml:%define xml 1}
%{!?pgfts:%define pgfts 1}
%{!?runselftest:%define runselftest 1}
# Python major version.
%{expand: %%define pyver %(python -c 'import sys;print(sys.version[0:3])')}
Summary: PostgreSQL client programs and libraries.
Name: postgresql
Version: 8.0.4
# Conventions for PostgreSQL Global Development Group RPM releases:
# Official PostgreSQL Development Group RPMS have a PGDG after the release number.
@ -63,71 +17,6 @@ Version: 8.0.4
# Pre-release RPM's should not be put up on the public ftp.postgresql.org server
# -- only test releases or full releases should be.
Release: 2
License: BSD
Group: Applications/Databases
Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
Source3: postgresql.init
Source4: Makefile.regress
Source6: README.rpm-dist
Source8: http://jdbc.postgresql.org/download/postgresql-8.0-312.jdbc2.jar
Source9: http://jdbc.postgresql.org/download/postgresql-8.0-312.jdbc2ee.jar
Source10: http://jdbc.postgresql.org/download/postgresql-8.0-312.jdbc3.jar
Source14: postgresql.pam
Source15: postgresql-bashprofile
Source16: filter-requires-perl-Pg.sh
Source17: postgresql-8.0-US.pdf
Source18: ftp://ftp.druid.net/pub/distrib/PyGreSQL-3.6.2.tgz
Source19: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcl1.5.2.tar.gz
Source20: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcldocs-20041108.zip
Patch1: rpm-pgsql.patch
Patch2: postgresql-src-tutorial.patch
Patch3: postgresql-logging.patch
Patch4: postgresql-test.patch
Patch5: pgtcl-no-rpath.patch
Patch6: postgresql-perl-rpath.patch
Buildrequires: perl glibc-devel bison flex
Prereq: /sbin/ldconfig initscripts
%if %python
BuildPrereq: python-devel
%endif
%if %tcl || %pltcl
BuildPrereq: tcl
%if %tcldevel
Buildrequires: tcl-devel
%endif
%endif
BuildPrereq: readline-devel
BuildPrereq: zlib-devel >= 1.0.4
%if %ssl
BuildPrereq: openssl-devel
%endif
%if %kerberos
BuildPrereq: krb5-devel
BuildPrereq: e2fsprogs-devel
%endif
%if %nls
BuildPrereq: gettext >= 0.10.35
%endif
%if %pam
%if %non6xpamdeps
BuildPrereq: pam-devel
%endif
%endif
%if %xml
BuildPrereq: libxml2-devel
%endif
Url: http://www.postgresql.org/
Obsoletes: postgresql-clients
Obsoletes: postgresql-perl
Obsoletes: postgresql-tk
Obsoletes: rh-postgresql
Buildroot: %{_tmppath}/%{name}-%{version}-root
# This is the PostgreSQL Global Development Group Official RPMset spec file,
# or a derivative thereof.
# Copyright 2003 Lamar Owen <lowen@pari.edu> <lamar.owen@wgcr.org>
@ -152,12 +41,118 @@ Buildroot: %{_tmppath}/%{name}-%{version}-root
# This spec file and ancilliary files are licensed in accordance with
# The PostgreSQL license.
# On top of this file you can find the default build package list macros. These can be overridden by defining
# In this file you can find the default build package list macros. These can be overridden by defining
# on the rpm command line:
# rpm --define 'packagename 1' .... to force the package to build.
# rpm --define 'packagename 0' .... to force the package NOT to build.
# The base package, the lib package, the devel package, and the server package always get built.
#build7x, build8, and build9 similar
%{?build8:%define build89 1}
%{?build9:%define build89 1}
%{?build7x:%define tcldevel 0}
%{?build8:%define tcldevel 0}
%{?build7x:%define aconfver autoconf-2.53}
%{!?aconfver:%define aconfver autoconf}
%define beta 0
%{?beta:%define __os_install_post /usr/lib/rpm/brp-compress}
%{!?tcldevel:%define tcldevel 1}
%{!?jdbc:%define jdbc 1}
%{!?test:%define test 1}
%{!?python:%define python 1}
%{!?pltcl:%define pltcl 1}
%{!?plperl:%define plperl 1}
%{!?tcl:%define tcl 1}
%{!?pls:%define pls 1}
%{!?ssl:%define ssl 1}
%{!?kerberos:%define kerberos 1}
%{!?nls:%define nls 1}
%{!?xml:%define xml 1}
%{!?pam:%define pam 1}
%{!?pgfts:%define pgfts 1}
%{!?runselftest:%define runselftest 1}
# Python major version.
%{expand: %%define pyver %(python -c 'import sys;print(sys.version[0:3])')}
Summary: PostgreSQL client programs and libraries.
Name: postgresql
Version: 8.1.0
Release: 1
License: BSD
Group: Applications/Databases
Url: http://www.postgresql.org/
Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
Source3: postgresql.init
Source4: Makefile.regress
Source6: README.rpm-dist
Source8: http://jdbc.postgresql.org/download/postgresql-8.1-404.jdbc2.jar
Source9: http://jdbc.postgresql.org/download/postgresql-8.1-404.jdbc2ee.jar
Source10: http://jdbc.postgresql.org/download/postgresql-8.1-404.jdbc3.jar
Source14: postgresql.pam
Source15: postgresql-bashprofile
Source16: filter-requires-perl-Pg.sh
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.0-US.pdf
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.7.tgz
Source19: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcl1.5.2.tar.gz
Source20: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcldocs-20041108.zip
Patch1: rpm-pgsql.patch
Patch2: postgresql-src-tutorial.patch
Patch3: postgresql-logging.patch
Patch4: postgresql-test.patch
Patch5: pgtcl-no-rpath.patch
Patch6: postgresql-perl-rpath.patch
Buildrequires: perl glibc-devel bison flex autoconf
Prereq: /sbin/ldconfig initscripts
%if %python
BuildPrereq: python-devel
%endif
%if %tcl || %pltcl
BuildPrereq: tcl
%if %tcldevel
Buildrequires: tcl-devel
%endif
%endif
BuildPrereq: readline-devel
BuildPrereq: zlib-devel >= 1.0.4
%if %ssl
BuildPrereq: openssl-devel
%endif
%if %kerberos
BuildPrereq: krb5-devel
BuildPrereq: e2fsprogs-devel
%endif
%if %nls
BuildPrereq: gettext >= 0.10.35
%endif
%if %xml
BuildPrereq: libxml2-devel libxslt-devel
%endif
%if %pam
BuildPrereq: pam-devel
%endif
Obsoletes: postgresql-clients
Obsoletes: postgresql-perl
Obsoletes: postgresql-tk
Obsoletes: rh-postgresql
Buildroot: %{_tmppath}/%{name}-%{version}-root
%description
PostgreSQL is an advanced Object-Relational database management system
@ -243,9 +238,7 @@ The postgresql-devel package contains the header files and libraries
needed to compile C or C++ applications which will directly interact
with a PostgreSQL database management server and the ecpg Embedded C
Postgres preprocessor. You need to install this package if you want to
develop applications which will interact with a PostgreSQL server. If
you're installing postgresql-server, you need to install this
package.
develop applications which will interact with a PostgreSQL server.
#------------
%if %pls
@ -258,7 +251,7 @@ Obsoletes: rh-postgresql-pl
%description pl
PostgreSQL is an advanced Object-Relational database management
system. The postgresql-pl package contains the the PL/Perl, PL/Tcl, and PL/Python
system. The postgresql-pl package contains the PL/Perl, PL/Tcl, and PL/Python
procedural languages for the backend. PL/Pgsql is part of the core server package.
%endif
@ -514,12 +507,6 @@ then
fi
%endif
# Remove stuff we don't want to ship.
rm -f $RPM_BUILD_ROOT%{_bindir}/findoidjoins
rm -f $RPM_BUILD_ROOT%{_bindir}/make_oidjoins_check
rm -f $RPM_BUILD_ROOT%{_docdir}/pgsql/contrib/README.findoidjoins
rm -f contrib/findoidjoins/README.findoidjoins
# PGDATA needs removal of group and world permissions due to pg_pwd hole.
install -d -m 700 $RPM_BUILD_ROOT/var/lib/pgsql/data
@ -648,6 +635,7 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/pg_dumpall
%{_bindir}/pg_restore
%{_bindir}/psql
%{_bindir}/reindexdb
%{_bindir}/vacuumdb
%{_mandir}/man1/clusterdb.*
%{_mandir}/man1/createdb.*
@ -660,6 +648,7 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/pg_dumpall.*
%{_mandir}/man1/pg_restore.*
%{_mandir}/man1/psql.*
%{_mandir}/man1/reindexdb.*
%{_mandir}/man1/vacuumdb.*
%{_mandir}/man7/*
%dir %{_libdir}/pgsql
@ -678,7 +667,6 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pgsql/chkpass.so
%{_libdir}/pgsql/cube.so
%{_libdir}/pgsql/dblink.so
%{_libdir}/pgsql/dbsize.so
%{_libdir}/pgsql/earthdistance.so
%{_libdir}/pgsql/fti.so
%{_libdir}/pgsql/fuzzystrmatch.so
@ -687,20 +675,16 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pgsql/isbn_issn.so
%{_libdir}/pgsql/lo.so
%{_libdir}/pgsql/ltree.so
%{_libdir}/pgsql/misc_utils.so
%{_libdir}/pgsql/moddatetime.so
%{_libdir}/pgsql/noup.so
%{_libdir}/pgsql/pending.so
%{_libdir}/pgsql/pgcrypto.so
%{_libdir}/pgsql/pgstattuple.so
%{_libdir}/pgsql/pg_buffercache.so
%{_libdir}/pgsql/pg_trgm.so
%{_libdir}/pgsql/refint.so
%{_libdir}/pgsql/rtree_gist.so
%{_libdir}/pgsql/seg.so
%{_libdir}/pgsql/string_io.so
%{_libdir}/pgsql/tablefunc.so
%{_libdir}/pgsql/timetravel.so
%{_libdir}/pgsql/tsearch.so
%{_libdir}/pgsql/tsearch2.so
%{_libdir}/pgsql/user_locks.so
%if %xml
@ -709,15 +693,11 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/pgsql/contrib/
%{_bindir}/DBMirror.pl
%{_bindir}/clean_pending.pl
%{_bindir}/my2pg.pl
%{_bindir}/mysql2pgsql
%{_bindir}/dbf2pg
%{_bindir}/fti.pl
%{_bindir}/oid2name
%{_bindir}/pg_dumplo
%{_bindir}/pgbench
%{_bindir}/vacuumlo
%{_bindir}/pg_autovacuum
%doc contrib/*/README.* contrib/spi/*.example
%files libs -f libpq.lang
@ -731,7 +711,7 @@ rm -rf $RPM_BUILD_ROOT
%defattr(-,root,root)
/etc/rc.d/init.d/postgresql
%if %pam
/etc/pam.d/postgresql
%config(noreplace) /etc/pam.d/postgresql
%endif
%attr (755,root,root) %dir /etc/sysconfig/pgsql
%{_bindir}/initdb
@ -829,6 +809,12 @@ rm -rf $RPM_BUILD_ROOT
%endif
%changelog
* Mon Nov 7 2005 Tom Lane <tgl@redhat.com> 8.1.0-1
- Update to PostgreSQL 8.1.0, PyGreSQL 3.7, and jdbc driver build 404
- Fix PAM config file (must have account not only auth) (bug #167040)
- Add BuildPrereq: libxslt-devel (bug #170141)
- Sync with PGDG SRPM as much as feasible
* Fri Oct 14 2005 Tomas Mraz <tmraz@redhat.com>
- use include instead of pam_stack in pam config

View File

@ -1,6 +1,6 @@
diff -Naur postgresql-8.0.0rc5.orig/src/Makefile.global.in postgresql-8.0.0rc5/src/Makefile.global.in
--- postgresql-8.0.0rc5.orig/src/Makefile.global.in 2004-12-18 21:16:18.000000000 -0500
+++ postgresql-8.0.0rc5/src/Makefile.global.in 2005-01-11 16:06:30.570550658 -0500
diff -Naur postgresql-8.1.0.orig/src/Makefile.global.in postgresql-8.1.0/src/Makefile.global.in
--- postgresql-8.1.0.orig/src/Makefile.global.in 2005-09-27 13:39:32.000000000 -0400
+++ postgresql-8.1.0/src/Makefile.global.in 2005-11-07 14:58:59.000000000 -0500
@@ -53,7 +53,7 @@
# Installation directories
#
@ -8,17 +8,9 @@ diff -Naur postgresql-8.0.0rc5.orig/src/Makefile.global.in postgresql-8.0.0rc5/s
-# append "postgresql" to some of them, if the string does not already
+# append "pgsql" to some of them, if the string does not already
# contain "pgsql" or "postgres", in order to avoid directory clutter.
prefix := @prefix@
@@ -65,21 +65,21 @@
libexecdir := @libexecdir@
ifeq "$(findstring pgsql, $(libexecdir))" ""
ifeq "$(findstring postgres, $(libexecdir))" ""
-override libexecdir := $(libexecdir)/postgresql
+override libexecdir := $(libexecdir)/pgsql
endif
endif
#
# In a PGXS build, we cannot use the values inserted into Makefile.global
@@ -73,14 +73,14 @@
datadir := @datadir@
ifeq "$(findstring pgsql, $(datadir))" ""
ifeq "$(findstring postgres, $(datadir))" ""
@ -35,7 +27,7 @@ diff -Naur postgresql-8.0.0rc5.orig/src/Makefile.global.in postgresql-8.0.0rc5/s
endif
endif
@@ -87,7 +87,7 @@
@@ -89,7 +89,7 @@
pkglibdir = $(libdir)
ifeq "$(findstring pgsql, $(pkglibdir))" ""
ifeq "$(findstring postgres, $(pkglibdir))" ""
@ -44,7 +36,7 @@ diff -Naur postgresql-8.0.0rc5.orig/src/Makefile.global.in postgresql-8.0.0rc5/s
endif
endif
@@ -95,7 +95,7 @@
@@ -98,7 +98,7 @@
pkgincludedir = $(includedir)
ifeq "$(findstring pgsql, $(pkgincludedir))" ""
ifeq "$(findstring postgres, $(pkgincludedir))" ""
@ -52,7 +44,7 @@ diff -Naur postgresql-8.0.0rc5.orig/src/Makefile.global.in postgresql-8.0.0rc5/s
+override pkgincludedir := $(pkgincludedir)/pgsql
endif
endif
includedir_server = $(pkgincludedir)/server
@@ -109,7 +109,7 @@
ifneq (,$(docdir))
ifeq "$(findstring pgsql, $(docdir))" ""

10
sources
View File

@ -1,8 +1,8 @@
381bd337cf703220aafdf1ee24dae78d postgresql-8.0.4.tar.bz2
1f2694ea546c852c5a0ba2b17f7c5ce1 PyGreSQL-3.6.2.tgz
5e1f1a7c5f62170b56a3bf2512fdec2d postgresql-8.1.0.tar.bz2
9fa4c2fc1dd0b3b93a3381c048443e16 PyGreSQL-3.7.tgz
d19dfdcb54c334495d32456a043e0232 pgtcl1.5.2.tar.gz
3d504b46231914d61fd49175f67e8715 pgtcldocs-20041108.zip
e51763911fe5ccec81bf4201f25e3f53 postgresql-8.0-312.jdbc2.jar
ebb4384c3d116482c8ed438ac96461fc postgresql-8.0-312.jdbc2ee.jar
41bcf06cdf7a3c84efd2fdd894303b24 postgresql-8.0-312.jdbc3.jar
441d73f6f3a56c1abf8970ed79f51d28 postgresql-8.1-404.jdbc2.jar
f506ae68d039bcc820641c1b1a8430c7 postgresql-8.1-404.jdbc2ee.jar
8d8788f0a8b8d2184b452e3f34d62966 postgresql-8.1-404.jdbc3.jar
2edd229aa83105175a1212a001dd030a postgresql-8.0-US.pdf