Update to PostgreSQL 8.2.1, pgtcl 1.5.3
This commit is contained in:
parent
a703279f8e
commit
721f5ecff5
@ -1,5 +1,5 @@
|
||||
postgresql-8.2.0.tar.bz2
|
||||
postgresql-8.2.1.tar.bz2
|
||||
PyGreSQL-3.8.1.tgz
|
||||
pgtcl1.5.2.tar.gz
|
||||
pgtcldocs-20041108.zip
|
||||
postgresql-8.1-US.pdf
|
||||
pgtcl1.5.3.tar.gz
|
||||
pgtcldocs-20060909.zip
|
||||
postgresql-8.2.1-US.pdf
|
||||
|
@ -1,84 +1,33 @@
|
||||
This patch removes some bogus stuff from the pgtcl configure script;
|
||||
in particular it gets rid of rpath specifications that we don't want
|
||||
or need on an RPM platform, as well as long-obsolete optimization
|
||||
bypasses.
|
||||
This patch prevents use of rpath, which isn't wanted on Fedora.
|
||||
|
||||
We also remove some direct hacks on LIBOBJS because modern Autoconf
|
||||
doesn't like them; not worth fixing properly since they won't be
|
||||
invoked on our systems anyway.
|
||||
|
||||
Finally, tweak Makefile.in to ensure that the -L switch for libpq appears
|
||||
Also, tweak Makefile.in to ensure that the -L switch for libpq appears
|
||||
before any -L for the Tcl libraries during the link. This prevents the
|
||||
generated library from being bound to the wrong version of libpq when
|
||||
building on a machine that has an older version of libpq already installed
|
||||
(bug #166665).
|
||||
|
||||
|
||||
diff -Naur Pgtcl.orig/aclocal.m4 Pgtcl/aclocal.m4
|
||||
--- Pgtcl.orig/aclocal.m4 2004-02-15 15:15:37.000000000 -0500
|
||||
+++ Pgtcl/aclocal.m4 2005-03-11 18:26:44.610459295 -0500
|
||||
@@ -293,12 +293,6 @@
|
||||
DL_OBJS="tclLoadDl.o"
|
||||
LDFLAGS=""
|
||||
|
||||
- # AIX v<=4.1 has some different flags than 4.2+
|
||||
- if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
|
||||
- LIBOBJS="$LIBOBJS tclLoadAix.o"
|
||||
- DL_LIBS="-lld"
|
||||
- fi
|
||||
-
|
||||
# On AIX <=v4 systems, libbsd.a has to be linked in to support
|
||||
# non-blocking file IO. This library has to be linked in after
|
||||
# the MATH_LIBS or it breaks the pow() function. The way to
|
||||
@@ -490,18 +484,12 @@
|
||||
SHLIB_LD_LIBS='${LIBS}'
|
||||
SHLIB_SUFFIX=".so"
|
||||
|
||||
- # egcs-2.91.66 on Redhat Linux 6.0 generates lots of warnings
|
||||
- # when you inline the string and math operations. Turn this off to
|
||||
- # get rid of the warnings.
|
||||
-
|
||||
- CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
|
||||
-
|
||||
if test "$have_dl" = yes; then
|
||||
SHLIB_LD="${CC} -shared"
|
||||
DL_OBJS="tclLoadDl.o"
|
||||
DL_LIBS="-ldl"
|
||||
LDFLAGS="-rdynamic"
|
||||
- LD_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR},-rpath,${LIB_PGTCL_RUNTIME_DIR}'
|
||||
+ LD_SEARCH_FLAGS=""
|
||||
else
|
||||
AC_CHECK_HEADER(dld.h, [
|
||||
SHLIB_LD="ld -shared"
|
||||
@@ -514,17 +502,6 @@
|
||||
EXTRA_CFLAGS="-mieee"
|
||||
fi
|
||||
|
||||
- # The combo of gcc + glibc has a bug related
|
||||
- # to inlining of functions like strtod(). The
|
||||
- # -fno-builtin flag should address this problem
|
||||
- # but it does not work. The -fno-inline flag
|
||||
- # is kind of overkill but it works.
|
||||
- # Disable inlining only when one of the
|
||||
- # files in compat/*.c is being linked in.
|
||||
- if test x"${LIBOBJS}" != x ; then
|
||||
- EXTRA_CFLAGS="${EXTRA_CFLAGS} -fno-inline"
|
||||
- fi
|
||||
-
|
||||
;;
|
||||
GNU*)
|
||||
SHLIB_CFLAGS="-fPIC"
|
||||
|
||||
|
||||
diff -Naur Pgtcl.orig/Makefile.in Pgtcl/Makefile.in
|
||||
--- Pgtcl.orig/Makefile.in 2004-06-13 17:49:14.000000000 -0400
|
||||
+++ Pgtcl/Makefile.in 2005-10-04 14:23:37.000000000 -0400
|
||||
@@ -121,7 +121,7 @@
|
||||
diff -Naur pgtcl1.5.3.orig/Makefile.in pgtcl1.5.3/Makefile.in
|
||||
--- pgtcl1.5.3.orig/Makefile.in 2006-09-09 21:59:59.000000000 -0400
|
||||
+++ pgtcl1.5.3/Makefile.in 2007-01-10 18:58:19.000000000 -0500
|
||||
@@ -101,7 +101,7 @@
|
||||
RANLIB_STUB = @RANLIB_STUB@
|
||||
SHLIB_CFLAGS = @SHLIB_CFLAGS@
|
||||
SHLIB_LD = @SHLIB_LD@
|
||||
SHLIB_LDFLAGS = @SHLIB_LDFLAGS@
|
||||
# Added EXTRA_LIBS for special cases like -lssl
|
||||
-SHLIB_LD_LIBS = @SHLIB_LD_LIBS@ $(PG_LIBS) $(TCL_LIBS) @EXTRA_LIBS@
|
||||
+SHLIB_LD_LIBS = $(PG_LIBS) @SHLIB_LD_LIBS@ $(TCL_LIBS) @EXTRA_LIBS@
|
||||
-SHLIB_LD_LIBS = @SHLIB_LD_LIBS@ $(PG_LIBS) $(TCL_LIBS)
|
||||
+SHLIB_LD_LIBS = $(PG_LIBS) @SHLIB_LD_LIBS@ $(TCL_LIBS)
|
||||
STLIB_LD = @STLIB_LD@
|
||||
TCL_DEFS = @TCL_DEFS@
|
||||
#TCL_DEFS = @TCL_DEFS@
|
||||
TCL_BIN_DIR = @TCL_BIN_DIR@
|
||||
diff -Naur pgtcl1.5.3.orig/aclocal.m4 pgtcl1.5.3/aclocal.m4
|
||||
--- pgtcl1.5.3.orig/aclocal.m4 2006-09-09 20:27:09.000000000 -0400
|
||||
+++ pgtcl1.5.3/aclocal.m4 2007-01-10 18:56:46.000000000 -0500
|
||||
@@ -844,7 +844,7 @@
|
||||
DL_OBJS="tclLoadDl.o"
|
||||
DL_LIBS="-ldl"
|
||||
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
|
||||
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR},-rpath,${LIB_PGTCL_RUNTIME_DIR}'
|
||||
+ CC_SEARCH_FLAGS=""
|
||||
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
|
||||
if test "`uname -m`" = "alpha" ; then
|
||||
CFLAGS="$CFLAGS -mieee"
|
||||
|
20
postgresql-prefer-ncurses.patch
Normal file
20
postgresql-prefer-ncurses.patch
Normal file
@ -0,0 +1,20 @@
|
||||
This patch hacks the Postgres configure script to prefer libncurses over
|
||||
libtermcap. This is needed in the current Fedora environment because while
|
||||
both are available, libtermcap is deprecated and will be removed in the
|
||||
fairly near future. Because the need for this is short-term, I'm not
|
||||
going to try to push it upstream; this patch can go away once libtermcap
|
||||
is no longer present in the standard build environment.
|
||||
|
||||
|
||||
diff -Naur postgresql-8.2.1.orig/config/programs.m4 postgresql-8.2.1/config/programs.m4
|
||||
--- postgresql-8.2.1.orig/config/programs.m4 2006-05-23 15:28:45.000000000 -0400
|
||||
+++ postgresql-8.2.1/config/programs.m4 2007-01-10 18:42:22.000000000 -0500
|
||||
@@ -88,7 +88,7 @@
|
||||
fi
|
||||
for pgac_rllib in $READLINE_ORDER ; do
|
||||
AC_MSG_CHECKING([for ${pgac_rllib}])
|
||||
- for pgac_lib in "" " -ltermcap" " -lncurses" " -lcurses" ; do
|
||||
+ for pgac_lib in "" " -lncurses" " -ltermcap" " -lcurses" ; do
|
||||
LIBS="${pgac_rllib}${pgac_lib} $pgac_save_LIBS"
|
||||
AC_TRY_LINK_FUNC([readline], [[
|
||||
# Older NetBSD, OpenBSD, and Irix have a broken linker that does not
|
@ -80,8 +80,8 @@
|
||||
|
||||
Summary: PostgreSQL client programs and libraries.
|
||||
Name: postgresql
|
||||
Version: 8.2.0
|
||||
Release: 2%{?dist}
|
||||
Version: 8.2.1
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Applications/Databases
|
||||
Url: http://www.postgresql.org/
|
||||
@ -94,17 +94,17 @@ Source6: README.rpm-dist
|
||||
Source14: postgresql.pam
|
||||
Source15: postgresql-bashprofile
|
||||
Source16: filter-requires-perl-Pg.sh
|
||||
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.1-US.pdf
|
||||
Source17: http://www.postgresql.org/docs/manuals/postgresql-8.2.1-US.pdf
|
||||
Source18: ftp://ftp.pygresql.org/pub/distrib/PyGreSQL-3.8.1.tgz
|
||||
Source19: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcl1.5.2.tar.gz
|
||||
Source20: ftp://gborg.postgresql.org/pub/pgtclng/stable/pgtcldocs-20041108.zip
|
||||
Source19: http://pgfoundry.org/projects/pgtclng/pgtcl1.5.3.tar.gz
|
||||
Source20: http://pgfoundry.org/projects/pgtclng/pgtcldocs-20060909.zip
|
||||
|
||||
Patch1: rpm-pgsql.patch
|
||||
Patch3: postgresql-logging.patch
|
||||
Patch4: postgresql-test.patch
|
||||
Patch5: pgtcl-no-rpath.patch
|
||||
Patch6: postgresql-perl-rpath.patch
|
||||
Patch7: pgtcl-quote.patch
|
||||
Patch8: postgresql-prefer-ncurses.patch
|
||||
|
||||
Buildrequires: perl glibc-devel bison flex autoconf
|
||||
Prereq: /sbin/ldconfig initscripts
|
||||
@ -308,7 +308,7 @@ system, including regression tests and benchmarks.
|
||||
%patch4 -p1
|
||||
# patch5 is applied later
|
||||
%patch6 -p1
|
||||
# patch7 is applied later
|
||||
%patch8 -p1
|
||||
|
||||
#call autoconf 2.53 or greater
|
||||
%aconfver
|
||||
@ -333,9 +333,8 @@ cp -p %{SOURCE17} .
|
||||
PGTCLDOCDIR=`basename %{SOURCE20} .zip`
|
||||
mv $PGTCLDOCDIR Pgtcl-docs
|
||||
|
||||
%patch5 -p0
|
||||
%patch7 -p0
|
||||
pushd Pgtcl
|
||||
%patch5 -p1
|
||||
%aconfver
|
||||
popd
|
||||
%endif
|
||||
@ -776,6 +775,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Jan 10 2007 Tom Lane <tgl@redhat.com> 8.2.1-1
|
||||
- Update to PostgreSQL 8.2.1
|
||||
- Update to pgtcl 1.5.3
|
||||
- Be sure we link to libncurses, not libtermcap which is disappearing in Fedora
|
||||
|
||||
* Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 8.2.0-2
|
||||
- rebuild for python 2.5
|
||||
|
||||
|
8
sources
8
sources
@ -1,5 +1,5 @@
|
||||
490cb3a614545cbd3ce9b1c75c1d2b2e postgresql-8.2.0.tar.bz2
|
||||
5cf003dfdbcab69974c091c3a0aa85eb postgresql-8.2.1.tar.bz2
|
||||
5575979dac93c9c5795d7693a8f91c86 PyGreSQL-3.8.1.tgz
|
||||
d19dfdcb54c334495d32456a043e0232 pgtcl1.5.2.tar.gz
|
||||
3d504b46231914d61fd49175f67e8715 pgtcldocs-20041108.zip
|
||||
66d80897840724917cb838c76393692b postgresql-8.1-US.pdf
|
||||
43ad97c7dd108fb7a165b4755d8aec32 pgtcl1.5.3.tar.gz
|
||||
a71b4aced6b0b068335f8e040e5b9fb6 pgtcldocs-20060909.zip
|
||||
0c25dc2055e2fa9ff9d05afc9252e1f2 postgresql-8.2.1-US.pdf
|
||||
|
Loading…
Reference in New Issue
Block a user