rebase to 2.5.0

This commit is contained in:
Petr Kubat 2018-10-19 15:21:56 +02:00
parent f892b26478
commit 91062aec69
6 changed files with 19 additions and 69 deletions

6
.gitignore vendored
View File

@ -1,3 +1,3 @@
/postgis-2.4.3.pdf
/postgis-2.3.6.tar.gz
/postgis-2.4.3.tar.gz
/postgis-2.4.5.tar.gz
/postgis-2.5.0.tar.gz
/postgis-2.5.0.pdf

View File

@ -1,12 +0,0 @@
rhbz#1503453
diff --git a/raster/test/regress/check_gdal_expected b/raster/test/regress/check_gdal_expected
index ab1eebe..0a4be7f 100644
--- a/raster/test/regress/check_gdal_expected
+++ b/raster/test/regress/check_gdal_expected
@@ -1,4 +1,5 @@
t
+t
DISABLE_ALL
ENABLE_ALL
t

View File

@ -10,7 +10,7 @@ index 878548e..3c95a2f 100644
+check: all
check-no-trailing-blanks:
! find . -name '*.c' -o -name '*.h' | \
! find . -name '*.c' -o -name '*.h' -o -name '*.proto' | \
diff --git a/doc/Makefile.in b/doc/Makefile.in
index 31fd778..6268e7f 100644
--- a/doc/Makefile.in

View File

@ -1,33 +0,0 @@
From a079dba76b209b788e9ced3641e2289b0820216c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
Date: Fri, 15 Dec 2017 13:35:40 +0100
Subject: [PATCH] geojson: Do not include private header for json-c >= 0.13
---
liblwgeom/lwin_geojson.c | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/liblwgeom/lwin_geojson.c b/liblwgeom/lwin_geojson.c
index 749d03374..ef907ee79 100644
--- a/liblwgeom/lwin_geojson.c
+++ b/liblwgeom/lwin_geojson.c
@@ -31,13 +31,19 @@
#if defined(HAVE_LIBJSON) || defined(HAVE_LIBJSON_C) /* --{ */
+#define JSON_C_VERSION_013 (13 << 8)
+
#ifdef HAVE_LIBJSON_C
#include <json-c/json.h>
+#if !defined(JSON_C_VERSION_NUM) || JSON_C_VERSION_NUM < JSON_C_VERSION_013
#include <json-c/json_object_private.h>
+#endif
#else
#include <json/json.h>
+#if !defined(JSON_C_VERSION_NUM) || JSON_C_VERSION_NUM < JSON_C_VERSION_013
#include <json/json_object_private.h>
#endif
+#endif
#ifndef JSON_C_VERSION
/* Adds support for libjson < 0.10 */

View File

@ -15,32 +15,28 @@
%undefine _hardened_build
%endif
%global majorversion 2.4
%global prevmajorversion 2.3
%global prevversion %{prevmajorversion}.6
%global majorversion 2.5
%global prevmajorversion 2.4
%global prevversion %{prevmajorversion}.5
%global so_files rtpostgis postgis_topology postgis address_standardizer
%global configure_opts --disable-rpath --enable-raster
%global pg_version_minimum 9.2
%global pg_version_minimum 9.4
%global __provides_exclude_from %{_libdir}/pgsql
Summary: Geographic Information Systems Extensions to PostgreSQL
Name: postgis
Version: %majorversion.3
Release: 6%{?dist}
Version: %majorversion.0
Release: 1%{?dist}
License: GPLv2+
Group: Applications/Databases
Source0: http://download.osgeo.org/%{name}/source/%{name}-%{version}.tar.gz
Source2: http://download.osgeo.org/%{name}/docs/%{name}-%{version}.pdf
Source3: http://download.osgeo.org/%{name}/source/%{name}-%{prevversion}.tar.gz
Source4: filter-requires-perl-Pg.sh
Patch1: postgis-configureac21.patch
Patch3: postgis-2.4.0-install-desktop.patch
Patch4: postgis-2.4.0-code-check-only.patch
Patch5: postgis-2.4.0-check-gdal.patch
# Upstreamed.
Patch6: %{name}-2.4.1_json-c_013.patch
URL: http://www.postgis.net
BuildRequires: perl-generators
@ -139,16 +135,11 @@ necessary for correct dump of schema from previous version of PostgreSQL.
%if %upgrade
(
cd %{name}-%{prevversion}
# Remove once we move to prevversion==2.4 (2.4 build works fine).
%patch1 -p0 -b .configureac21
./autogen.sh
%patch6 -p1
)
%endif
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
cp -p %{SOURCE2} .
@ -204,7 +195,7 @@ make install DESTDIR=%{buildroot}
make %{?_smp_mflags} -C utils install DESTDIR=%{buildroot}
make %{?_smp_mflags} -C extensions install DESTDIR=%{buildroot}
# hack: this requires postgis-%version-install-desktop.patch
# hack: this requires postgis-%%version-install-desktop.patch
make -C loader install-rpm-desktop DESTDIR=%{buildroot} datadir=%{_datadir}
%if %upgrade
@ -290,7 +281,7 @@ fi
%{_datadir}/postgis/postgis_proc_set_search_path.pl
# rhbz#1503456
%{_libdir}/liblwgeom-%majorversion.so.*
%{_libdir}/pgsql/address_standardizer-%{majorversion}.so
%{_libdir}/pgsql/address_standardizer.so
%{_libdir}/pgsql/rtpostgis-%{majorversion}.so
%{_libdir}/pgsql/postgis_topology-%{majorversion}.so
@ -346,6 +337,10 @@ fi
%changelog
* Mon Oct 22 2018 Petr Kubat <pkubat@redhat.com> - 2.5.0-1
- update to 2.5.0, per NEWS file:
https://svn.osgeo.org/postgis/tags/2.5.0/NEWS
* Wed Sep 05 2018 Pavel Raiskup <praiskup@redhat.com> - 2.4.3-6
- rebuild against postgresql-server-devel (rhbz#1618698)

View File

@ -1,3 +1,3 @@
SHA512 (postgis-2.4.3.pdf) = 4253e2472b56628afa79e616a762b964cadceabf222fc9bc8f59c5238d5a649b75532506363d07a30f4d2ff4c38ed5ae773b3fa05d1ede69b27cf47b62b2db23
SHA512 (postgis-2.3.6.tar.gz) = f1edb1a62224cac791e546a3b31d57680d8f280c7f8a93f8105bca2e9a486e1ea1d208a0e4e9aa87d986760682736f8bd21cac60df844930682902c5d6c7ff7c
SHA512 (postgis-2.4.3.tar.gz) = 95b2c925cb10943e7136aa3b7b08a9ad3d6ff59a3994c653bba52e4c65193d519daa49684b924f68945dd596187aa17e0c713bf0b9e29f8c5973346b279dba1b
SHA512 (postgis-2.4.5.tar.gz) = 0bdde0c0f5b34ded684fa5623801fe0b2c324a46cf18145129d2f7fc2d29ee2eb6495656503f1392234954add0cc2411ea2896928f1f2683d98b8ca5cbb9fe8d
SHA512 (postgis-2.5.0.tar.gz) = 1ba638dae9fb167e59fc5590b57277cf62b4ceb270a77026cfca3977f6727ef27acbc5505007335652480f5157e1d6c76f782553cc294ab1e5159347dd3c8934
SHA512 (postgis-2.5.0.pdf) = bea83d39d6ef788c80d60909e2d7bcb4ffb7ceb77c95a215993f577f7361deaa36897499e9343d08eaffd70d7b8277867ce2abffbc33234a195f8c4a944311c3