ADd postgis to devel

This commit is contained in:
Devrim GÜNDÜZ 2007-07-05 13:20:02 +00:00
parent 7c4834e8f4
commit 5c2a481eaf
5 changed files with 73 additions and 33 deletions

View File

@ -1,16 +0,0 @@
--- configure.old 2006-12-25 14:39:26.000000000 +0200
+++ configure 2006-12-25 14:39:35.000000000 +0200
@@ -4609,13 +4609,6 @@
GEOS_DIR=`$GEOSCONFIG --prefix`
GEOS_LDFLAGS=`$GEOSCONFIG --ldflags 2> /dev/null`
- if test x"$GEOS_LDFLAGS" = "x"; then
- # older geos-config versions did not
- # support the --ldflags switch, we'll
- # default to GEOS_DIR/lib in this case.
- #
- GEOS_LDFLAGS="$GEOS_DIR/lib"
- fi
GEOS_MAJOR=`$GEOSCONFIG --version | cut -d. -f1`
if test "$GEOS_MAJOR" = "@GEOS_VERSION@"; then

39
postgis-gnumakefile.patch Normal file
View File

@ -0,0 +1,39 @@
--- GNUmakefile.old 2007-07-02 17:13:05.000000000 +0300
+++ GNUmakefile 2007-07-02 17:13:59.000000000 +0300
@@ -4,13 +4,13 @@
#
#-----------------------------------------------------
-all: Makefile.config liblwgeom loaderdumper utils templategis
+all: Makefile.config liblwgeom loaderdumper utils
-install: all liblwgeom-install loaderdumper-install templategis-install
+install: all liblwgeom-install loaderdumper-install
-uninstall: liblwgeom-uninstall loaderdumper-uninstall docs-uninstall templategis-uninstall
+uninstall: liblwgeom-uninstall loaderdumper-uninstall docs-uninstall
-clean: Makefile.config liblwgeom-clean loaderdumper-clean docs-clean test-clean templategis-clean
+clean: Makefile.config liblwgeom-clean loaderdumper-clean docs-clean test-clean
rm -f lwpostgis.sql lwpostgis_upgrade.sql
distclean: clean
@@ -59,18 +59,6 @@
loaderdumper-uninstall:
$(MAKE) -C loader uninstall
-templategis: Makefile.config
- $(MAKE) -C extras/template_gis
-
-templategis-clean:
- $(MAKE) -C extras/template_gis clean
-
-templategis-install:
- $(MAKE) -C extras/template_gis install
-
-templategis-uninstall:
- $(MAKE) -C extras/template_gis uninstall
-
docs: Makefile.config
$(MAKE) -C doc

View File

@ -1,11 +0,0 @@
--- java/jdbc/Makefile.old 2006-12-25 15:25:19.000000000 +0200
+++ java/jdbc/Makefile 2006-12-25 15:25:26.000000000 +0200
@@ -27,7 +27,7 @@
# Configure the helper executables used during build.
-JAVAC?=javac -target 1.2 -source 1.2
+JAVAC?=javac -target 1.5 -source 1.5
JAVA?=java
JAR?=jar
MKDIR?=mkdir -p

View File

@ -0,0 +1,25 @@
--- java/jdbc/Makefile.old 2007-01-08 12:12:01.000000000 +0200
+++ java/jdbc/Makefile 2007-06-26 21:41:57.000000000 +0300
@@ -27,7 +27,7 @@
# Configure the helper executables used during build.
-JAVAC?=javac -target 1.2 -source 1.2
+JAVAC?=javac -target 1.5 -source 1.5
JAVA?=java
JAR?=jar
MKDIR?=mkdir -p
@@ -249,9 +249,11 @@
postgis-jdbc-javadoc.zip: javadoc-build
$(JAR) -cf postgis-jdbc-javadoc.zip -C javadoc-build .
-javadoc-build: jtscompile compile
+javadoc-build:
$(MKDIR) javadoc-build
- javadoc -d javadoc-build -sourcepath src:jtssrc \
+ # We use an ugly trick to build on windows and unix -
+ # javadoc command line options are not portable wr/t path separators
+ javadoc -d javadoc-build -sourcepath "src:jtssrc:;src;jtssrc" \
org.postgis org.postgis.jts org.postgis.binary org.postgis.java2d examples
# Preliminary JTS support

View File

@ -5,13 +5,13 @@
Summary: Geographic Information Systems Extensions to PostgreSQL
Name: postgis
Version: 1.2.1
Release: 1%{?dist}
Release: 2%{?dist}
License: GPL
Group: Applications/Databases
Source0: http://postgis.refractions.net/download/%{name}-%{version}.tar.gz
Source4: filter-requires-perl-Pg.sh
Patch1: postgis-jdbc-makefile.patch
Patch2: postgis-javamakefile.patch
Patch1: postgis-gnumakefile.patch
Patch2: postgis-jdbcmakefile.patch
URL: http://postgis.refractions.net/
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -58,8 +58,8 @@ The postgis-utils package provides the utilities for PostGIS.
%prep
%setup -q
# To be removed in 1.2.1
%patch1 -p0
# To be removed in 1.2.2
%patch2 -p0
%build
@ -115,7 +115,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root)
%doc COPYING CREDITS NEWS TODO README.%{name} TODO doc/html loader/README.* doc/%{name}.xml doc/ZMSgeoms.txt
%doc COPYING CREDITS NEWS TODO README.%{name} doc/html loader/README.* doc/%{name}.xml doc/ZMSgeoms.txt
%attr(755,root,root) %{_bindir}/*
%attr(755,root,root) %{_libdir}/pgsql/postgis.so*
%attr(755,root,root) %{_libdir}/pgsql/liblwgeom.so*
@ -146,10 +146,13 @@ rm -rf %{buildroot}
%endif
%changelog
* Mon Jul 2 2007 - Devrim GUNDUZ <devrim@commandprompt.com> 1.2.1-2
- Fix build problems (removed template_gis, per discussion with upsteam).
* Mon Feb 19 2007 - Devrim GUNDUZ <devrim@commandprompt.com> 1.2.1-1
- Update to 1.2.1
- Added postgresql-jdb as as dependency to -jdbc package, per Guillaume
- Removed configure patch (it is in the upstream now)
- Added postgresql-jdbc as as dependency to -jdbc package, per Guillaume
- move strip to correct place, per Guillaume
- Fix long-standing post/postun problem, per Guillaume