New version
Resolves: rhbz#1797383 Dropped ref-search patch (upstreamed) Built with -fcommon to overcome FTBFS with gcc-10, problem reported upstream
This commit is contained in:
parent
8c4e3f2c27
commit
efb210f609
@ -1,13 +0,0 @@
|
||||
diff --git a/src/dns/dns_lookup.c b/src/dns/dns_lookup.c
|
||||
index 1ea98b3..1bfeb7e 100644
|
||||
--- a/src/dns/dns_lookup.c
|
||||
+++ b/src/dns/dns_lookup.c
|
||||
@@ -396,7 +396,7 @@ static int dns_res_search(const char *name, int class, int type,
|
||||
if (keep_notfound)
|
||||
/* Prepare for returning a null-padded server reply. */
|
||||
memset(answer, 0, anslen);
|
||||
- len = res_query(name, class, type, answer, anslen);
|
||||
+ len = res_search(name, class, type, answer, anslen);
|
||||
/* Begin API creep workaround. */
|
||||
if (len < 0 && h_errno == 0) {
|
||||
SET_H_ERRNO(TRY_AGAIN);
|
15
postfix.spec
15
postfix.spec
@ -47,8 +47,8 @@
|
||||
|
||||
Name: postfix
|
||||
Summary: Postfix Mail Transport Agent
|
||||
Version: 3.4.8
|
||||
Release: 3%{?dist}
|
||||
Version: 3.4.9
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
URL: http://www.postfix.org
|
||||
License: (IBM and GPLv2+) or (EPL-2.0 and GPLv2+)
|
||||
@ -94,8 +94,6 @@ Patch9: pflogsumm-1.1.5-datecalc.patch
|
||||
Patch10: pflogsumm-1.1.5-ipv6-warnings-fix.patch
|
||||
Patch11: postfix-3.4.4-chroot-example-fix.patch
|
||||
Patch12: postfix-3.4.4-res-macros-fix.patch
|
||||
# rhbz#1723950, included upstream
|
||||
Patch13: postfix-3.4.8-ref-search-fix.patch
|
||||
|
||||
# Optional patches - set the appropriate environment variables to include
|
||||
# them when building the package/spec file
|
||||
@ -232,7 +230,6 @@ popd
|
||||
%endif
|
||||
%patch11 -p1 -b .chroot-example-fix
|
||||
%patch12 -p1 -b .res-macros-fix
|
||||
%patch13 -p1 -b .ref-search-fix
|
||||
|
||||
for f in README_FILES/TLS_{LEGACY_,}README TLS_ACKNOWLEDGEMENTS; do
|
||||
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
|
||||
@ -241,7 +238,7 @@ done
|
||||
|
||||
%build
|
||||
unset AUXLIBS AUXLIBS_LDAP AUXLIBS_PCRE AUXLIBS_MYSQL AUXLIBS_PGSQL AUXLIBS_SQLITE AUXLIBS_CDB
|
||||
CCARGS="-fPIC"
|
||||
CCARGS="-fPIC -fcommon"
|
||||
AUXLIBS="-lnsl"
|
||||
|
||||
%ifarch s390 s390x ppc
|
||||
@ -760,6 +757,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Feb 3 2020 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.4.9-1
|
||||
- New version
|
||||
Resolves: rhbz#1797383
|
||||
- Dropped ref-search patch (upstreamed)
|
||||
- Built with -fcommon to overcome FTBFS with gcc-10, problem reported upstream
|
||||
|
||||
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2:3.4.8-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (pflogsumm-1.1.5.tar.gz) = 994d660692dfea38a1dd9866d15f15035657e85131c1f5a2cd82baa5bd4ad987a00939cb5233f316d2090014c52ae68ef20db0c893f8634969484e0e74678f4d
|
||||
SHA512 (postfix-3.4.8.tar.gz) = 782fe83e4b40c7aadfb4c55850db4c7163dd0f647f4ef133e59f7b47c993b2b4fa6c43ebbc45131caa54d968259f9c8568f47e81bfccda02ab142be52aa95d45
|
||||
SHA512 (postfix-3.4.9.tar.gz) = 9038850d79bf19460d55dede2dd97e6f4bd8255363b4004704e5f0493bf9b1c0729f5bb11663ba6f6ed34177205609f72401b0f55d1d9dbce5398b4603a0a991
|
||||
|
Loading…
Reference in New Issue
Block a user