New version
Resolves: rhbz#2051046
This commit is contained in:
parent
e45367e31c
commit
61cd20692d
@ -1,14 +0,0 @@
|
||||
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
||||
index 99bec9b..95c78ec 100644
|
||||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -802,6 +803,9 @@ extern int initgroups(const char *, int);
|
||||
#define _PATH_PROCNET_IFINET6 "/proc/net/if_inet6"
|
||||
#endif
|
||||
#endif
|
||||
+#if HAVE_GLIBC_API_VERSION_SUPPORT(2, 34)
|
||||
+#define HAS_CLOSEFROM
|
||||
+#endif
|
||||
#include <linux/version.h>
|
||||
#if !defined(KERNEL_VERSION)
|
||||
#define KERNEL_VERSION(a,b,c) (LINUX_VERSION_CODE + 1)
|
@ -1,8 +1,8 @@
|
||||
diff --git a/conf/main.cf b/conf/main.cf
|
||||
index 7af8bde..495e346 100644
|
||||
index 47de434..112c1f1 100644
|
||||
--- a/conf/main.cf
|
||||
+++ b/conf/main.cf
|
||||
@@ -132,6 +132,10 @@ mail_owner = postfix
|
||||
@@ -136,6 +136,10 @@ mail_owner = postfix
|
||||
#inet_interfaces = all
|
||||
#inet_interfaces = $myhostname
|
||||
#inet_interfaces = $myhostname, localhost
|
||||
@ -13,7 +13,7 @@ index 7af8bde..495e346 100644
|
||||
|
||||
# The proxy_interfaces parameter specifies the network interface
|
||||
# addresses that this mail system receives mail on by way of a
|
||||
@@ -176,7 +180,7 @@ mail_owner = postfix
|
||||
@@ -180,7 +184,7 @@ mail_owner = postfix
|
||||
#
|
||||
# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
|
||||
#
|
||||
@ -22,7 +22,7 @@ index 7af8bde..495e346 100644
|
||||
#mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
|
||||
#mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,
|
||||
# mail.$mydomain, www.$mydomain, ftp.$mydomain
|
||||
@@ -398,7 +402,7 @@ unknown_local_recipient_reject_code = 550
|
||||
@@ -407,7 +411,7 @@ unknown_local_recipient_reject_code = 550
|
||||
# "postfix reload" to eliminate the delay.
|
||||
#
|
||||
#alias_maps = dbm:/etc/aliases
|
||||
@ -31,7 +31,7 @@ index 7af8bde..495e346 100644
|
||||
#alias_maps = hash:/etc/aliases, nis:mail.aliases
|
||||
#alias_maps = netinfo:/aliases
|
||||
|
||||
@@ -409,7 +413,7 @@ unknown_local_recipient_reject_code = 550
|
||||
@@ -418,7 +422,7 @@ unknown_local_recipient_reject_code = 550
|
||||
#
|
||||
#alias_database = dbm:/etc/aliases
|
||||
#alias_database = dbm:/etc/mail/aliases
|
||||
@ -40,7 +40,7 @@ index 7af8bde..495e346 100644
|
||||
#alias_database = hash:/etc/aliases, hash:/opt/majordomo/aliases
|
||||
|
||||
# ADDRESS EXTENSIONS (e.g., user+foo)
|
||||
@@ -479,7 +483,27 @@ unknown_local_recipient_reject_code = 550
|
||||
@@ -488,7 +492,27 @@ unknown_local_recipient_reject_code = 550
|
||||
#
|
||||
# Cyrus IMAP over LMTP. Specify ``lmtpunix cmd="lmtpd"
|
||||
# listen="/var/imap/socket/lmtp" prefork=0'' in cyrus.conf.
|
||||
@ -69,7 +69,7 @@ index 7af8bde..495e346 100644
|
||||
#
|
||||
# Cyrus IMAP via command line. Uncomment the "cyrus...pipe" and
|
||||
# subsequent line in master.cf.
|
||||
@@ -499,8 +523,7 @@ unknown_local_recipient_reject_code = 550
|
||||
@@ -508,8 +532,7 @@ unknown_local_recipient_reject_code = 550
|
||||
# the main.cf file, otherwise the SMTP server will reject mail for
|
||||
# non-UNIX accounts with "User unknown in local recipient table".
|
||||
#
|
||||
@ -79,7 +79,7 @@ index 7af8bde..495e346 100644
|
||||
#fallback_transport =
|
||||
|
||||
# The luser_relay parameter specifies an optional destination address
|
||||
@@ -673,4 +696,41 @@ sample_directory =
|
||||
@@ -682,4 +705,41 @@ sample_directory =
|
||||
# readme_directory: The location of the Postfix README files.
|
||||
#
|
||||
readme_directory =
|
||||
@ -123,10 +123,10 @@ index 7af8bde..495e346 100644
|
||||
+#
|
||||
+smtp_tls_security_level = may
|
||||
diff --git a/conf/master.cf b/conf/master.cf
|
||||
index c0f2508..05c5d07 100644
|
||||
index 83fc6fd..bb0eae9 100644
|
||||
--- a/conf/master.cf
|
||||
+++ b/conf/master.cf
|
||||
@@ -98,14 +98,14 @@ postlog unix-dgram n - n - 1 postlogd
|
||||
@@ -110,14 +110,14 @@ postlog unix-dgram n - n - 1 postlogd
|
||||
# Also specify in main.cf: cyrus_destination_recipient_limit=1
|
||||
#
|
||||
#cyrus unix - n n - - pipe
|
@ -21,10 +21,10 @@ index 50a4aa7..beef3db 100644
|
||||
if (msg_verbose)
|
||||
msg_info("%s: %s: block size %lu, blocks free %lu",
|
||||
diff --git a/src/util/sys_defs.h b/src/util/sys_defs.h
|
||||
index a8d2571..ad07498 100644
|
||||
index c9ebc33..f2be0e2 100644
|
||||
--- a/src/util/sys_defs.h
|
||||
+++ b/src/util/sys_defs.h
|
||||
@@ -769,8 +769,8 @@ extern int initgroups(const char *, int);
|
||||
@@ -771,8 +771,8 @@ extern int initgroups(const char *, int);
|
||||
#define GETTIMEOFDAY(t) gettimeofday(t,(struct timezone *) 0)
|
||||
#define ROOT_PATH "/bin:/usr/bin:/sbin:/usr/sbin"
|
||||
#define FIONREAD_IN_TERMIOS_H
|
@ -1,8 +1,8 @@
|
||||
diff --git a/src/cleanup/cleanup_message.c b/src/cleanup/cleanup_message.c
|
||||
index 391c711..be5ce42 100644
|
||||
index f2b86d0..018e39e 100644
|
||||
--- a/src/cleanup/cleanup_message.c
|
||||
+++ b/src/cleanup/cleanup_message.c
|
||||
@@ -773,6 +773,8 @@ static void cleanup_header_done_callback(void *context)
|
||||
@@ -772,6 +772,8 @@ static void cleanup_header_done_callback(void *context)
|
||||
/* Normalize whitespace. */
|
||||
token = tok822_scan_limit(state->fullname, &dummy_token,
|
||||
var_token_limit);
|
21
postfix.spec
21
postfix.spec
@ -48,7 +48,7 @@
|
||||
|
||||
Name: postfix
|
||||
Summary: Postfix Mail Transport Agent
|
||||
Version: 3.6.4
|
||||
Version: 3.7.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
URL: http://www.postfix.org
|
||||
@ -89,20 +89,18 @@ Source101: postfix-pam.conf
|
||||
|
||||
# Patches
|
||||
|
||||
Patch1: postfix-3.5.0-config.patch
|
||||
Patch1: postfix-3.7.0-config.patch
|
||||
Patch2: postfix-3.4.0-files.patch
|
||||
Patch3: postfix-3.3.3-alternatives.patch
|
||||
Patch4: postfix-3.4.0-large-fs.patch
|
||||
Patch4: postfix-3.7.0-large-fs.patch
|
||||
Patch9: pflogsumm-1.1.5-datecalc.patch
|
||||
# rhbz#1384871, sent upstream
|
||||
Patch10: pflogsumm-1.1.5-ipv6-warnings-fix.patch
|
||||
Patch11: postfix-3.4.4-chroot-example-fix.patch
|
||||
# upstream patch
|
||||
Patch12: postfix-3.6.2-glibc-234-build-fix.patch
|
||||
# sent upstream
|
||||
Patch13: postfix-3.6.2-whitespace-name-fix.patch
|
||||
Patch12: postfix-3.7.0-whitespace-name-fix.patch
|
||||
# rhbz#1931403, sent upstream
|
||||
Patch14: pflogsumm-1.1.5-syslog-name-underscore-fix.patch
|
||||
Patch13: pflogsumm-1.1.5-syslog-name-underscore-fix.patch
|
||||
|
||||
# Optional patches - set the appropriate environment variables to include
|
||||
# them when building the package/spec file
|
||||
@ -253,9 +251,8 @@ pushd pflogsumm-%{pflogsumm_ver}
|
||||
popd
|
||||
%endif
|
||||
%patch11 -p1 -b .chroot-example-fix
|
||||
%patch12 -p1 -b .glibc-234-build-fix
|
||||
%patch13 -p1 -b .whitespace-name-fix
|
||||
%patch14 -p1 -b .pflogsumm-1.1.5-syslog-name-underscore-fix
|
||||
%patch12 -p1 -b .whitespace-name-fix
|
||||
%patch13 -p1 -b .pflogsumm-1.1.5-syslog-name-underscore-fix
|
||||
|
||||
for f in README_FILES/TLS_{LEGACY_,}README TLS_ACKNOWLEDGEMENTS; do
|
||||
iconv -f iso8859-1 -t utf8 -o ${f}{_,} &&
|
||||
@ -806,6 +803,10 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Tue Feb 22 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.7.0-1
|
||||
- New version
|
||||
Resolves: rhbz#2051046
|
||||
|
||||
* Thu Jan 20 2022 Jaroslav Škarvada <jskarvad@redhat.com> - 2:3.6.4-1
|
||||
- New version
|
||||
Resolves: rhbz#2040977
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (pflogsumm-1.1.5.tar.gz) = 994d660692dfea38a1dd9866d15f15035657e85131c1f5a2cd82baa5bd4ad987a00939cb5233f316d2090014c52ae68ef20db0c893f8634969484e0e74678f4d
|
||||
SHA512 (postfix-3.6.4.tar.gz) = f5813801377a5887d27720cc7f85a6a68f8ca82fc7a9e852b27c8967996b3d64f651cc16e2b021d55316a074b4778e19155bb60c8f0885d4aaf72766cab7c4cd
|
||||
SHA512 (postfix-3.7.0.tar.gz) = f2fb5c0399100c19e428b68728a8ce62b1fb74d365038373f22ed698c1d0fece506b3f1335c322b949875a4a9fa96fa0a7680b12641d596d09615e8fef061da4
|
||||
|
Loading…
Reference in New Issue
Block a user