polkit/125.patch
František Zatloukal 97422bf9a4 switch to mozjs102
2022-08-15 11:30:58 +02:00

47 lines
1.5 KiB
Diff

From d9b90188ead25d15181bab7ae5a2a8a2d4eff1e5 Mon Sep 17 00:00:00 2001
From: Xi Ruoyao <xry111@xry111.site>
Date: Wed, 29 Jun 2022 20:22:40 +0800
Subject: [PATCH] jsauthority: port to mozjs-102
---
meson.build | 2 +-
src/polkitbackend/polkitbackendjsauthority.cpp | 2 --
2 files changed, 1 insertion(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
index da60930..ccf5b62 100644
--- a/meson.build
+++ b/meson.build
@@ -147,7 +147,7 @@ if js_engine == 'duktape'
func = 'pthread_condattr_setclock'
config_h.set('HAVE_' + func.to_upper(), cc.has_function(func, prefix : '#include <pthread.h>'))
elif js_engine == 'mozjs'
- js_dep = dependency('mozjs-91')
+ js_dep = dependency('mozjs-102')
endif
dbus_dep = dependency('dbus-1', required: false)
diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
index 2568e8e..866ea31 100644
--- a/src/polkitbackend/polkitbackendjsauthority.cpp
+++ b/src/polkitbackend/polkitbackendjsauthority.cpp
@@ -103,7 +103,6 @@ static const struct JSClassOps js_global_class_ops = {
nullptr, // mayResolve
nullptr, // finalize
nullptr, // call
- nullptr, // hasInstance
nullptr, // construct
JS_GlobalObjectTraceHook
};
@@ -124,7 +123,6 @@ static const struct JSClassOps js_polkit_class_ops = {
nullptr, // mayResolve
nullptr, // finalize
nullptr, // call
- nullptr, // hasInstance
nullptr, // construct
nullptr // trace
};
--
GitLab