switch to mozjs102
This commit is contained in:
parent
95fa2ee242
commit
97422bf9a4
46
125.patch
Normal file
46
125.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From d9b90188ead25d15181bab7ae5a2a8a2d4eff1e5 Mon Sep 17 00:00:00 2001
|
||||
From: Xi Ruoyao <xry111@xry111.site>
|
||||
Date: Wed, 29 Jun 2022 20:22:40 +0800
|
||||
Subject: [PATCH] jsauthority: port to mozjs-102
|
||||
|
||||
---
|
||||
meson.build | 2 +-
|
||||
src/polkitbackend/polkitbackendjsauthority.cpp | 2 --
|
||||
2 files changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index da60930..ccf5b62 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -147,7 +147,7 @@ if js_engine == 'duktape'
|
||||
func = 'pthread_condattr_setclock'
|
||||
config_h.set('HAVE_' + func.to_upper(), cc.has_function(func, prefix : '#include <pthread.h>'))
|
||||
elif js_engine == 'mozjs'
|
||||
- js_dep = dependency('mozjs-91')
|
||||
+ js_dep = dependency('mozjs-102')
|
||||
endif
|
||||
|
||||
dbus_dep = dependency('dbus-1', required: false)
|
||||
diff --git a/src/polkitbackend/polkitbackendjsauthority.cpp b/src/polkitbackend/polkitbackendjsauthority.cpp
|
||||
index 2568e8e..866ea31 100644
|
||||
--- a/src/polkitbackend/polkitbackendjsauthority.cpp
|
||||
+++ b/src/polkitbackend/polkitbackendjsauthority.cpp
|
||||
@@ -103,7 +103,6 @@ static const struct JSClassOps js_global_class_ops = {
|
||||
nullptr, // mayResolve
|
||||
nullptr, // finalize
|
||||
nullptr, // call
|
||||
- nullptr, // hasInstance
|
||||
nullptr, // construct
|
||||
JS_GlobalObjectTraceHook
|
||||
};
|
||||
@@ -124,7 +123,6 @@ static const struct JSClassOps js_polkit_class_ops = {
|
||||
nullptr, // mayResolve
|
||||
nullptr, // finalize
|
||||
nullptr, // call
|
||||
- nullptr, // hasInstance
|
||||
nullptr, // construct
|
||||
nullptr // trace
|
||||
};
|
||||
--
|
||||
GitLab
|
||||
|
@ -4,11 +4,13 @@
|
||||
Summary: An authorization framework
|
||||
Name: polkit
|
||||
Version: 121
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
License: LGPLv2+
|
||||
URL: http://www.freedesktop.org/wiki/Software/polkit
|
||||
Source0: http://www.freedesktop.org/software/polkit/releases/%{name}-%{version}.tar.xz
|
||||
Source1: http://www.freedesktop.org/software/polkit/releases/%{name}-%{version}.tar.xz.sign
|
||||
# mozjs91 > mozjs102
|
||||
Patch01: 125.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: glib2-devel >= 2.30.0
|
||||
@ -19,7 +21,7 @@ BuildRequires: gettext-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: systemd, systemd-devel
|
||||
BuildRequires: dbus-devel
|
||||
BuildRequires: pkgconfig(mozjs-91)
|
||||
BuildRequires: pkgconfig(mozjs-102)
|
||||
BuildRequires: meson
|
||||
BuildRequires: git
|
||||
|
||||
@ -163,6 +165,9 @@ exit 0
|
||||
%{_libdir}/girepository-1.0/*.typelib
|
||||
|
||||
%changelog
|
||||
* Wed Aug 10 2022 Frantisek Zatloukal <fzatlouk@redhat.com> - 121-4
|
||||
- switch to mozjs102
|
||||
|
||||
* Tue Aug 02 2022 Jan Rybar <jrybar@redhat.com> - 121-3
|
||||
- switched back to mozjs until problems with duktape are fixed
|
||||
- Related: bz#2109145
|
||||
|
Loading…
Reference in New Issue
Block a user