policycoreutils/policycoreutils-rhat.patch
Daniel J Walsh 105dca2943 * Sun Oct 7 2007 Dan Walsh <dwalsh@redhat.com> 2.0.29-1
- Update to upstream
	* Add genhomedircon script to invoke semodule -Bn from Dan Walsh.
- Add deleteall for ports and fcontext
2007-10-08 14:44:26 +00:00

129 lines
5.5 KiB
Diff

diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.28/Makefile
--- nsapolicycoreutils/Makefile 2007-07-16 14:20:43.000000000 -0400
+++ policycoreutils-2.0.28/Makefile 2007-10-07 21:43:11.000000000 -0400
@@ -1,4 +1,4 @@
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
all install relabel clean indent:
@for subdir in $(SUBDIRS); do \
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.28/restorecond/restorecond.c
--- nsapolicycoreutils/restorecond/restorecond.c 2007-07-16 14:20:41.000000000 -0400
+++ policycoreutils-2.0.28/restorecond/restorecond.c 2007-10-07 21:43:11.000000000 -0400
@@ -210,9 +210,10 @@
}
if (fsetfilecon(fd, scontext) < 0) {
- syslog(LOG_ERR,
- "set context %s->%s failed:'%s'\n",
- filename, scontext, strerror(errno));
+ if (errno != EOPNOTSUPP)
+ syslog(LOG_ERR,
+ "set context %s->%s failed:'%s'\n",
+ filename, scontext, strerror(errno));
if (retcontext >= 0)
free(prev_context);
free(scontext);
@@ -225,8 +226,9 @@
if (retcontext >= 0)
free(prev_context);
} else {
- syslog(LOG_ERR, "get context on %s failed: '%s'\n",
- filename, strerror(errno));
+ if (errno != EOPNOTSUPP)
+ syslog(LOG_ERR, "get context on %s failed: '%s'\n",
+ filename, strerror(errno));
}
free(scontext);
close(fd);
diff --exclude-from=exclude --exclude=sepolgen-1.0.10 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.28/semanage/seobject.py
--- nsapolicycoreutils/semanage/seobject.py 2007-10-07 21:46:43.000000000 -0400
+++ policycoreutils-2.0.28/semanage/seobject.py 2007-10-05 13:10:29.000000000 -0400
@@ -139,7 +139,7 @@
translations = fd.readlines()
fd.close()
except IOError, e:
- raise ValueError(_("Unable to open %s: translations not supported on non-MLS machines: %s") % (self.filename, e) )
+ raise ValueError(_("Unable to open %s: translations not supported on non-MLS machines") % (self.filename) )
self.ddict = {}
self.comments = []
@@ -236,9 +236,6 @@
if rc < 0:
semanage_handle_destroy(self.sh)
raise ValueError(_("Could not establish semanage connection"))
- def deleteall(self):
- raise ValueError(_("Not yet implemented"))
-
class loginRecords(semanageRecords):
def __init__(self, store = ""):
@@ -779,34 +776,6 @@
semanage_port_key_free(k)
semanage_port_free(p)
- def deleteall(self):
- (rc, plist) = semanage_port_list_local(self.sh)
- if rc < 0:
- raise ValueError(_("Could not list the ports"))
-
- rc = semanage_begin_transaction(self.sh)
- if rc < 0:
- raise ValueError(_("Could not start semanage transaction"))
-
- for port in plist:
- proto = semanage_port_get_proto(port)
- proto_str = semanage_port_get_proto_str(proto)
- low = semanage_port_get_low(port)
- high = semanage_port_get_high(port)
- port_str = "%s-%s" % (low, high)
- ( k, proto_d, low, high ) = self.__genkey(port_str , proto_str)
- if rc < 0:
- raise ValueError(_("Could not create a key for %s") % port_str)
-
- rc = semanage_port_del_local(self.sh, k)
- if rc < 0:
- raise ValueError(_("Could not delete the port %s") % port_str)
- semanage_port_key_free(k)
-
- rc = semanage_commit(self.sh)
- if rc < 0:
- raise ValueError(_("Could not delete the %s") % port_str)
-
def delete(self, port, proto):
( k, proto_d, low, high ) = self.__genkey(port, proto)
(rc,exists) = semanage_port_exists(self.sh, k)
@@ -1206,32 +1175,6 @@
semanage_fcontext_key_free(k)
semanage_fcontext_free(fcontext)
- def deleteall(self):
- (rc, flist) = semanage_fcontext_list_local(self.sh)
- if rc < 0:
- raise ValueError(_("Could not list the file contexts"))
-
- rc = semanage_begin_transaction(self.sh)
- if rc < 0:
- raise ValueError(_("Could not start semanage transaction"))
-
- for fcontext in flist:
- target = semanage_fcontext_get_expr(fcontext)
- ftype = semanage_fcontext_get_type(fcontext)
- ftype_str = semanage_fcontext_get_type_str(ftype)
- (rc,k) = semanage_fcontext_key_create(self.sh, target, file_types[ftype_str])
- if rc < 0:
- raise ValueError(_("Could not create a key for %s") % target)
-
- rc = semanage_fcontext_del_local(self.sh, k)
- if rc < 0:
- raise ValueError(_("Could not delete the file context %s") % target)
- semanage_fcontext_key_free(k)
-
- rc = semanage_commit(self.sh)
- if rc < 0:
- raise ValueError(_("Could not delete the file context %s") % target)
-
def delete(self, target, ftype):
(rc,k) = semanage_fcontext_key_create(self.sh, target, file_types[ftype])
if rc < 0: