* Tue Nov 24 2009 Dan Walsh <dwalsh@redhat.com> 2.0.77-1

- Update to upstream
	* Fixed bug preventing semanage node -a from working
	  from Chad Sellers
	* Fixed bug preventing semanage fcontext -l from working
	  from Chad Sellers
- Change semanage to use unicode
This commit is contained in:
Daniel J Walsh 2009-11-24 15:30:53 +00:00
parent e973847bf6
commit f3a1cbae2a
4 changed files with 37 additions and 66 deletions

View File

@ -210,3 +210,4 @@ policycoreutils-2.0.73.tgz
policycoreutils-2.0.74.tgz
policycoreutils-2.0.75.tgz
policycoreutils-2.0.76.tgz
policycoreutils-2.0.77.tgz

View File

@ -38,18 +38,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
else:
# This is the default if no input is specified
f = sys.stdin
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/load_policy/Makefile policycoreutils-2.0.75/load_policy/Makefile
--- nsapolicycoreutils/load_policy/Makefile 2009-11-18 17:06:03.000000000 -0500
+++ policycoreutils-2.0.75/load_policy/Makefile 2009-11-03 09:44:56.000000000 -0500
@@ -19,7 +19,7 @@
test -d $(MANDIR)/man8 || install -m 755 -d $(MANDIR)/man8
install -m 644 load_policy.8 $(MANDIR)/man8/
-mkdir -p $(USRSBINDIR)
- ln -sf /sbin/load_policy $(USRSBINDIR)/load_policy
+ ln -s /sbin/load_policy $(USRSBINDIR)/load_policy
clean:
-rm -f $(TARGETS) *.o
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.75/Makefile
--- nsapolicycoreutils/Makefile 2008-08-28 09:34:24.000000000 -0400
+++ policycoreutils-2.0.75/Makefile 2009-11-03 09:44:56.000000000 -0500
@ -1884,7 +1872,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
+ kill -HUP 0
+ break
+done
Binary files nsapolicycoreutils/sandbox/seunshare and policycoreutils-2.0.75/sandbox/seunshare differ
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/sandbox/seunshare.c policycoreutils-2.0.75/sandbox/seunshare.c
--- nsapolicycoreutils/sandbox/seunshare.c 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.75/sandbox/seunshare.c 2009-11-11 16:00:27.000000000 -0500
@ -2154,7 +2141,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
+
+ return status;
+}
Binary files nsapolicycoreutils/sandbox/seunshare.o and policycoreutils-2.0.75/sandbox/seunshare.o differ
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.75/scripts/chcat
--- nsapolicycoreutils/scripts/chcat 2009-06-23 15:36:07.000000000 -0400
+++ policycoreutils-2.0.75/scripts/chcat 2009-11-03 09:44:56.000000000 -0500
@ -2295,8 +2281,16 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
-mkdir -p $(BINDIR)
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.75/semanage/semanage
--- nsapolicycoreutils/semanage/semanage 2009-11-18 17:06:03.000000000 -0500
+++ policycoreutils-2.0.75/semanage/semanage 2009-11-03 09:44:56.000000000 -0500
@@ -39,16 +39,25 @@
+++ policycoreutils-2.0.75/semanage/semanage 2009-11-24 10:18:58.000000000 -0500
@@ -32,23 +32,32 @@
try:
gettext.install(PROGNAME,
localedir="/usr/share/locale",
- unicode=False,
+ unicode=True,
codeset = 'utf-8')
except IOError:
import __builtin__
__builtin__.__dict__['_'] = unicode
if __name__ == '__main__':
@ -2616,39 +2610,8 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
process_args(mkargv(l))
trans.finish()
else:
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-2.0.75/semanage/semanage.8
--- nsapolicycoreutils/semanage/semanage.8 2009-11-18 17:06:03.000000000 -0500
+++ policycoreutils-2.0.75/semanage/semanage.8 2009-11-03 09:21:41.000000000 -0500
@@ -3,7 +3,7 @@
semanage \- SELinux Policy Management tool
.SH "SYNOPSIS"
-.B semanage {boolean|login|user|port|interface|node|fcontext} \-{l|D} [\-n] [\-S store]
+.B semanage {boolean|login|user|port|interface|node|fcontext|translation} \-{l|D} [\-n] [\-S store]
.br
.B semanage boolean \-{d|m} [\-\-on|\-\-off|\-1|\-0] -F boolean | boolean_file
.br
@@ -22,6 +22,8 @@
.B semanage permissive \-{a|d} type
.br
.B semanage dontaudit [ on | off ]
+.br
+.B semanage translation \-{a|d|m} [\-T] level
.P
.SH "DESCRIPTION"
@@ -99,6 +101,9 @@
.TP
.I \-t, \-\-type
SELinux Type for the object
+.TP
+.I \-T, \-\-trans
+SELinux Translation
.SH EXAMPLE
.nf
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.75/semanage/seobject.py
--- nsapolicycoreutils/semanage/seobject.py 2009-11-18 17:06:03.000000000 -0500
--- nsapolicycoreutils/semanage/seobject.py 2009-11-20 10:51:25.000000000 -0500
+++ policycoreutils-2.0.75/semanage/seobject.py 2009-11-16 16:52:53.000000000 -0500
@@ -37,40 +37,6 @@
@ -3034,15 +2997,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
(rc, node) = semanage_node_create(self.sh)
if rc < 0:
@@ -1038,7 +1169,7 @@
def add(self, addr, mask, proto, serange, ctype):
self.begin()
- self.__add(self, addr, mask, proto, serange, ctype)
+ self.__add(addr, mask, proto, serange, ctype)
self.commit()
def __modify(self, addr, mask, proto, serange, setype):
@@ -1047,13 +1178,10 @@
if mask == "":
@ -3272,7 +3226,20 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
for k in keys:
if fcon_dict[k]:
if is_mls_enabled:
@@ -1712,6 +1935,16 @@
@@ -1575,6 +1798,12 @@
print "%-50s %-18s %s:%s:%s " % (k[0], k[1], fcon_dict[k][0], fcon_dict[k][1],fcon_dict[k][2])
else:
print "%-50s %-18s <<None>>" % (k[0], k[1])
+ if len(self.equiv.keys()) > 0:
+ if heading:
+ print _("\nSELinux fcontext Equivalence \n")
+
+ for src in self.equiv.keys():
+ print "%s == %s" % (src, self.equiv[src])
class booleanRecords(semanageRecords):
def __init__(self, store = ""):
@@ -1706,6 +1935,16 @@
else:
return _("unknown")
@ -3508,9 +3475,3 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po
argv[0]);
exit(1);
}
diff --exclude-from=exclude --exclude=sepolgen-1.0.17 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/VERSION policycoreutils-2.0.75/VERSION
--- nsapolicycoreutils/VERSION 2009-11-18 17:06:03.000000000 -0500
+++ policycoreutils-2.0.75/VERSION 2009-11-03 09:21:41.000000000 -0500
@@ -1 +1 @@
-2.0.76
+2.0.75

View File

@ -5,7 +5,7 @@
%define sepolgenver 1.0.17
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.0.76
Version: 2.0.77
Release: 1%{?dist}
License: GPLv2+
Group: System Environment/Base
@ -296,6 +296,14 @@ fi
exit 0
%changelog
* Tue Nov 24 2009 Dan Walsh <dwalsh@redhat.com> 2.0.77-1
- Update to upstream
* Fixed bug preventing semanage node -a from working
from Chad Sellers
* Fixed bug preventing semanage fcontext -l from working
from Chad Sellers
- Change semanage to use unicode
* Wed Nov 18 2009 Dan Walsh <dwalsh@redhat.com> 2.0.76-1
- Update to upstream
* Remove setrans management from semanage, as it does not work

View File

@ -1,2 +1,3 @@
480cc64a050735fa1163a87dc89c4f49 sepolgen-1.0.17.tgz
0762f1174561dacad12bc9b30aa12307 policycoreutils-2.0.76.tgz
283c1d0d776dc9db6af9b0f02a49fccb policycoreutils-2.0.77.tgz
59d33101d57378ce69889cc078addf90 policycoreutils_man_ru2.tar.bz2