policycoreutils-2.8-16

- restorecond: Install DBUS service file with 644 permissions
This commit is contained in:
Petr Lautrbach 2019-01-22 14:22:37 +01:00
parent e3a75fa174
commit ea40a6c901
2 changed files with 20 additions and 4 deletions

View File

@ -12,7 +12,7 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.8
Release: 15%{?dist}
Release: 16%{?dist}
License: GPLv2
# https://github.com/SELinuxProject/selinux/wiki/Releases
Source0: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/policycoreutils-2.8.tar.gz
@ -37,7 +37,7 @@ Source22: gui-po.tgz
Source23: sandbox-po.tgz
# download https://raw.githubusercontent.com/fedora-selinux/scripts/master/selinux/make-fedora-selinux-patch.sh
# run:
# HEAD https://github.com/fedora-selinux/selinux/commit/10767636b5d9b8f3fa3cf3815e860f4ca4fcb247
# HEAD https://github.com/fedora-selinux/selinux/commit/c19a6cbd95123e7f6088f6d95698800c8bc9f5ae
# $ for i in policycoreutils selinux-python selinux-gui selinux-sandbox selinux-dbus semodule-utils restorecond; do
# VERSION=2.8 ./make-fedora-selinux-patch.sh $i
# done
@ -96,8 +96,8 @@ tar -xvf %{SOURCE14} -C selinux-python-%{version}/sepolicy/
%patch2 -p0 -b .selinux-gui
%patch3 -p0 -b .selinux-sandbox
%patch4 -p0 -b .selinux-dbus
#%%patch5 -p0 -b .semodule-utils
#%%patch6 -p0 -b .restorecond
%patch5 -p0 -b .semodule-utils
%patch6 -p0 -b .restorecond
# Since patches containing translation changes were too big, translations were moved to separate tarballs
# For more information see README.translations
@ -530,6 +530,9 @@ The policycoreutils-restorecond package contains the restorecond service.
%systemd_postun_with_restart restorecond.service
%changelog
* Tue Jan 22 2019 Petr Lautrbach <plautrba@redhat.com> - 2.8-16
- restorecond: Install DBUS service file with 644 permissions
* Mon Jan 21 2019 Petr Lautrbach <plautrba@redhat.com> - 2.8-15
- setsebool: support use of -P on SELinux-disabled hosts
- sepolicy: initialize mislabeled_files in __init__()

View File

@ -1,3 +1,16 @@
diff --git restorecond-2.8/Makefile restorecond-2.8/Makefile
index 25be18d..26eb411 100644
--- restorecond-2.8/Makefile
+++ restorecond-2.8/Makefile
@@ -50,7 +50,7 @@ install: all
-mkdir -p $(DESTDIR)$(AUTOSTARTDIR)
install -m 644 restorecond.desktop $(DESTDIR)$(AUTOSTARTDIR)/restorecond.desktop
-mkdir -p $(DESTDIR)$(DBUSSERVICEDIR)
- install -m 600 org.selinux.Restorecond.service $(DESTDIR)$(DBUSSERVICEDIR)/org.selinux.Restorecond.service
+ install -m 644 org.selinux.Restorecond.service $(DESTDIR)$(DBUSSERVICEDIR)/org.selinux.Restorecond.service
-mkdir -p $(DESTDIR)$(SYSTEMDDIR)/system
install -m 644 restorecond.service $(DESTDIR)$(SYSTEMDDIR)/system/
relabel: install
diff --git restorecond-2.8/restorecond.c restorecond-2.8/restorecond.c
index 6fbbd35..e1d26cb 100644
--- restorecond-2.8/restorecond.c