* Wed Aug 17 2005 Dan Walsh <dwalsh@redhat.com> 1.25.5-2

- Change fixfiles to ignore /home directory on updates
This commit is contained in:
Daniel J Walsh 2005-08-17 16:26:54 +00:00
parent 3bab395eb3
commit e817f89adf
2 changed files with 26 additions and 10 deletions

View File

@ -1,9 +1,20 @@
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.25.3/Makefile
--- nsapolicycoreutils/Makefile 2005-07-18 15:07:46.000000000 -0400
+++ policycoreutils-1.25.3/Makefile 2005-07-27 10:02:12.000000000 -0400
@@ -1,4 +1,4 @@
-SUBDIRS=setfiles load_policy newrole run_init restorecon audit2allow audit2why scripts po sestatus semodule_link semodule_expand semodule
+SUBDIRS=setfiles load_policy newrole run_init restorecon audit2allow audit2why scripts po sestatus
all install relabel clean:
@for subdir in $(SUBDIRS); do \
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-1.25.5/scripts/fixfiles
--- nsapolicycoreutils/scripts/fixfiles 2005-05-20 13:15:12.000000000 -0400
+++ policycoreutils-1.25.5/scripts/fixfiles 2005-08-17 10:58:52.000000000 -0400
@@ -62,6 +62,7 @@
TEMPFILE=`mktemp ${FC}.XXXXXXXXXX`
test -z "$TEMPFILE" && exit
/usr/bin/diff $PREFC $FC | grep '^[<>]'|cut -c3-| grep ^/ | \
+ egrep -v '(^/home|^/root|^/tmp|^/dev)' |\
sed -r -e 's,[[:blank:]].*,,g' \
-e 's|\(([/[:alnum:]]+)\)\?|{\1,}|g' \
-e 's|([/[:alnum:]])\?|{\1,}|g' \
@@ -80,7 +81,7 @@
fi; \
done | \
while read pattern ; do find $pattern \( -fstype ext2 -o -fstype ext3 -o -fstype jfs -o -fstype xfs \) -print; done 2> /dev/null | \
- ${RESTORECON} $2 -v -e /root -e /home -e /tmp -e /var/tmp -e /dev -f -
+ ${RESTORECON} $2 -v -f -
rm -f ${TEMPFILE}
fi
}

View File

@ -4,7 +4,7 @@
Summary: SELinux policy core utilities.
Name: policycoreutils
Version: 1.25.5
Release: 1
Release: 2
License: GPL
Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@ -36,6 +36,7 @@ context.
%prep
%setup -q
%patch -p1 -b .rhat
%build
make LIBDIR="%{_libdir}" CFLAGS="%{optflags}" all
@ -71,6 +72,7 @@ rm -rf ${RPM_BUILD_ROOT}
%{_bindir}/audit2allow
%{_bindir}/semodule_expand
%{_bindir}/semodule_link
%{_bindir}/semodule_package
%{_mandir}/man8/restorecon.8.gz
%{_mandir}/man8/sestatus.8.gz
%{_mandir}/man8/setfiles.8.gz
@ -87,6 +89,9 @@ rm -rf ${RPM_BUILD_ROOT}
%config(noreplace) %{_sysconfdir}/sestatus.conf
%changelog
* Wed Aug 17 2005 Dan Walsh <dwalsh@redhat.com> 1.25.5-2
- Change fixfiles to ignore /home directory on updates
* Fri Aug 5 2005 Dan Walsh <dwalsh@redhat.com> 1.25.5-1
- Update to match NSA
* Merged patch to move module read/write code from libsemanage