SELinux userspace 2.9-rc1 release candidate

This commit is contained in:
Petr Lautrbach 2019-01-30 10:09:38 +01:00
parent 3a6c8251f5
commit a21e2f9484
10 changed files with 200 additions and 2537 deletions

7
.gitignore vendored
View File

@ -280,3 +280,10 @@ policycoreutils-2.0.83.tgz
/policycoreutils-po.tgz
/python-po.tgz
/sandbox-po.tgz
/policycoreutils-2.9-rc1.tar.gz
/selinux-python-2.9-rc1.tar.gz
/selinux-gui-2.9-rc1.tar.gz
/selinux-sandbox-2.9-rc1.tar.gz
/selinux-dbus-2.9-rc1.tar.gz
/semodule-utils-2.9-rc1.tar.gz
/restorecond-2.9-rc1.tar.gz

View File

@ -1,20 +1,7 @@
diff --git policycoreutils-2.8/newrole/newrole.1 policycoreutils-2.8/newrole/newrole.1
index 0d9738a..893c42f 100644
--- policycoreutils-2.8/newrole/newrole.1
+++ policycoreutils-2.8/newrole/newrole.1
@@ -44,7 +44,7 @@ specified by that range. If the
or
.B --preserve-environment
option is specified, the shell with the new SELinux context will preserve environment variables,
-otherwise a new minimal enviroment is created.
+otherwise a new minimal environment is created.
.PP
Additional arguments
.I ARGS
diff --git policycoreutils-2.8/po/Makefile policycoreutils-2.8/po/Makefile
diff --git policycoreutils-2.9-rc1/po/Makefile policycoreutils-2.9-rc1/po/Makefile
index 575e143..18bc1df 100644
--- policycoreutils-2.8/po/Makefile
+++ policycoreutils-2.8/po/Makefile
--- policycoreutils-2.9-rc1/po/Makefile
+++ policycoreutils-2.9-rc1/po/Makefile
@@ -3,7 +3,6 @@
#
@ -110,11 +97,11 @@ index 575e143..18bc1df 100644
refresh-po: Makefile
for cat in $(POFILES); do \
diff --git policycoreutils-2.8/po/POTFILES policycoreutils-2.8/po/POTFILES
diff --git policycoreutils-2.9-rc1/po/POTFILES policycoreutils-2.9-rc1/po/POTFILES
new file mode 100644
index 0000000..12237dc
--- /dev/null
+++ policycoreutils-2.8/po/POTFILES
+++ policycoreutils-2.9-rc1/po/POTFILES
@@ -0,0 +1,9 @@
+../run_init/open_init_pty.c
+../run_init/run_init.c
@ -125,10 +112,10 @@ index 0000000..12237dc
+../semodule/semodule.c
+../setfiles/setfiles.c
+../secon/secon.c
diff --git policycoreutils-2.8/scripts/fixfiles policycoreutils-2.8/scripts/fixfiles
diff --git policycoreutils-2.9-rc1/scripts/fixfiles policycoreutils-2.9-rc1/scripts/fixfiles
index b277958..53d28c7 100755
--- policycoreutils-2.8/scripts/fixfiles
+++ policycoreutils-2.8/scripts/fixfiles
--- policycoreutils-2.9-rc1/scripts/fixfiles
+++ policycoreutils-2.9-rc1/scripts/fixfiles
@@ -108,6 +108,7 @@ exclude_dirs_from_relabelling() {
fullFlag=0
BOOTTIME=""
@ -137,10 +124,10 @@ index b277958..53d28c7 100755
FORCEFLAG=""
RPMFILES=""
PREFC=""
diff --git policycoreutils-2.8/setfiles/setfiles.8 policycoreutils-2.8/setfiles/setfiles.8
diff --git policycoreutils-2.9-rc1/setfiles/setfiles.8 policycoreutils-2.9-rc1/setfiles/setfiles.8
index ccaaf4d..a8a76c8 100644
--- policycoreutils-2.8/setfiles/setfiles.8
+++ policycoreutils-2.8/setfiles/setfiles.8
--- policycoreutils-2.9-rc1/setfiles/setfiles.8
+++ policycoreutils-2.9-rc1/setfiles/setfiles.8
@@ -57,7 +57,7 @@ check the validity of the contexts against the specified binary policy.
.TP
.B \-d
@ -150,64 +137,3 @@ index ccaaf4d..a8a76c8 100644
.TP
.BI \-e \ directory
directory to exclude (repeat option for more than one directory).
diff --git policycoreutils-2.8/setsebool/setsebool.c policycoreutils-2.8/setsebool/setsebool.c
index 53d3566..a5157ef 100644
--- policycoreutils-2.8/setsebool/setsebool.c
+++ policycoreutils-2.8/setsebool/setsebool.c
@@ -18,7 +18,7 @@
#include <errno.h>
int permanent = 0;
-int reload = 1;
+int no_reload = 0;
int verbose = 0;
int setbool(char **list, size_t start, size_t end);
@@ -38,11 +38,6 @@ int main(int argc, char **argv)
if (argc < 2)
usage();
- if (is_selinux_enabled() <= 0) {
- fputs("setsebool: SELinux is disabled.\n", stderr);
- return 1;
- }
-
while (1) {
clflag = getopt(argc, argv, "PNV");
if (clflag == -1)
@@ -53,7 +48,7 @@ int main(int argc, char **argv)
permanent = 1;
break;
case 'N':
- reload = 0;
+ no_reload = 1;
break;
case 'V':
verbose = 1;
@@ -130,6 +125,7 @@ static int semanage_set_boolean_list(size_t boolcnt,
semanage_bool_key_t *bool_key = NULL;
int managed;
int result;
+ int enabled = is_selinux_enabled();
handle = semanage_handle_create();
if (handle == NULL) {
@@ -191,7 +187,7 @@ static int semanage_set_boolean_list(size_t boolcnt,
boolean) < 0)
goto err;
- if (semanage_bool_set_active(handle, bool_key, boolean) < 0) {
+ if (enabled && semanage_bool_set_active(handle, bool_key, boolean) < 0) {
fprintf(stderr, "Failed to change boolean %s: %m\n",
boollist[j].name);
goto err;
@@ -202,7 +198,8 @@ static int semanage_set_boolean_list(size_t boolcnt,
boolean = NULL;
}
- semanage_set_reload(handle, reload);
+ if (no_reload)
+ semanage_set_reload(handle, 0);
if (semanage_commit(handle) < 0)
goto err;

View File

@ -1,8 +1,8 @@
%global libauditver 2.1.3-4
%global libsepolver 2.8-3
%global libsemanagever 2.8-8
%global libselinuxver 2.8-7
%global sepolgenver 2.8
%global libsepolver 2.9-0
%global libsemanagever 2.9-0
%global libselinuxver 2.9-0
%global sepolgenver 2.9
%global generatorsdir %{_prefix}/lib/systemd/system-generators
@ -11,18 +11,18 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.8
Release: 17%{?dist}
Version: 2.9
Release: 0.rc1.1%{?dist}
License: GPLv2
# https://github.com/SELinuxProject/selinux/wiki/Releases
Source0: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/policycoreutils-2.8.tar.gz
Source1: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/selinux-python-2.8.tar.gz
Source2: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/selinux-gui-2.8.tar.gz
Source3: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/selinux-sandbox-2.8.tar.gz
Source4: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/selinux-dbus-2.8.tar.gz
Source5: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/semodule-utils-2.8.tar.gz
Source6: https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/restorecond-2.8.tar.gz
URL: https://github.com/SELinuxProject
Source0: https://github.com/SELinuxProject/selinux/releases/download/20190125/policycoreutils-2.9-rc1.tar.gz
Source1: https://github.com/SELinuxProject/selinux/releases/download/20190125/selinux-python-2.9-rc1.tar.gz
Source2: https://github.com/SELinuxProject/selinux/releases/download/20190125/selinux-gui-2.9-rc1.tar.gz
Source3: https://github.com/SELinuxProject/selinux/releases/download/20190125/selinux-sandbox-2.9-rc1.tar.gz
Source4: https://github.com/SELinuxProject/selinux/releases/download/20190125/selinux-dbus-2.9-rc1.tar.gz
Source5: https://github.com/SELinuxProject/selinux/releases/download/20190125/semodule-utils-2.9-rc1.tar.gz
Source6: https://github.com/SELinuxProject/selinux/releases/download/20190125/restorecond-2.9-rc1.tar.gz
URL: https://github.com/SELinuxProject/selinux
Source12: policycoreutils_man_ru2.tar.bz2
Source13: system-config-selinux.png
Source14: sepolicy-icons.tgz
@ -37,9 +37,9 @@ Source22: gui-po.tgz
Source23: sandbox-po.tgz
# download https://raw.githubusercontent.com/fedora-selinux/scripts/master/selinux/make-fedora-selinux-patch.sh
# run:
# HEAD https://github.com/fedora-selinux/selinux/commit/c19a6cbd95123e7f6088f6d95698800c8bc9f5ae
# HEAD https://github.com/fedora-selinux/selinux/commit/a69fe203e41c9493e13ffafa51908d17da6fa7a2
# $ for i in policycoreutils selinux-python selinux-gui selinux-sandbox selinux-dbus semodule-utils restorecond; do
# VERSION=2.8 ./make-fedora-selinux-patch.sh $i
# VERSION=2.9-rc1 ./make-fedora-selinux-patch.sh $i
# done
Patch: policycoreutils-fedora.patch
Patch1: selinux-python-fedora.patch
@ -90,8 +90,8 @@ to switch roles.
%setup -q -T -D -a 6 -n selinux
%patch -p0 -b .policycoreutils-fedora
cp %{SOURCE13} selinux-gui-%{version}/
tar -xvf %{SOURCE14} -C selinux-python-%{version}/sepolicy/
cp %{SOURCE13} selinux-gui-%{version}-rc1/
tar -xvf %{SOURCE14} -C selinux-python-%{version}-rc1/sepolicy/
%patch1 -p0 -b .selinux-python
%patch2 -p0 -b .selinux-gui
%patch3 -p0 -b .selinux-sandbox
@ -101,22 +101,22 @@ tar -xvf %{SOURCE14} -C selinux-python-%{version}/sepolicy/
# Since patches containing translation changes were too big, translations were moved to separate tarballs
# For more information see README.translations
tar -x -f %{SOURCE20} -C policycoreutils-%{version} -z
tar -x -f %{SOURCE21} -C selinux-python-%{version} -z
tar -x -f %{SOURCE22} -C selinux-gui-%{version} -z
tar -x -f %{SOURCE23} -C selinux-sandbox-%{version} -z
tar -x -f %{SOURCE20} -C policycoreutils-%{version}-rc1 -z
tar -x -f %{SOURCE21} -C selinux-python-%{version}-rc1 -z
tar -x -f %{SOURCE22} -C selinux-gui-%{version}-rc1 -z
tar -x -f %{SOURCE23} -C selinux-sandbox-%{version}-rc1 -z
%build
%set_build_flags
export PYTHON=%{__python3}
make -C policycoreutils-%{version} LSPP_PRIV=y SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" SEMODULE_PATH="/usr/sbin" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-python-%{version} SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-gui-%{version} SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-sandbox-%{version} SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-dbus-%{version} SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C semodule-utils-%{version} SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C restorecond-%{version} SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C policycoreutils-%{version}-rc1 LSPP_PRIV=y SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" SEMODULE_PATH="/usr/sbin" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-python-%{version}-rc1 SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-gui-%{version}-rc1 SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-sandbox-%{version}-rc1 SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C selinux-dbus-%{version}-rc1 SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C semodule-utils-%{version}-rc1 SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
make -C restorecond-%{version}-rc1 SBINDIR="%{_sbindir}" LSPP_PRIV=y LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" all
%install
mkdir -p %{buildroot}%{_bindir}
@ -126,20 +126,20 @@ mkdir -p %{buildroot}%{_mandir}/man5
mkdir -p %{buildroot}%{_mandir}/man8
%{__mkdir} -p %{buildroot}/%{_usr}/share/doc/%{name}/
make -C policycoreutils-%{version} LSPP_PRIV=y DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" SEMODULE_PATH="/usr/sbin" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C policycoreutils-%{version}-rc1 LSPP_PRIV=y DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" SEMODULE_PATH="/usr/sbin" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-python-%{version} PYTHON=%{__python2} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-python-%{version} PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-python-%{version}-rc1 PYTHON=%{__python2} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-python-%{version}-rc1 PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-gui-%{version} PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-gui-%{version}-rc1 PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-sandbox-%{version} PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-sandbox-%{version}-rc1 PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-dbus-%{version} PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C selinux-dbus-%{version}-rc1 PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C semodule-utils-%{version} PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C semodule-utils-%{version}-rc1 PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C restorecond-%{version} PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
make -C restorecond-%{version}-rc1 PYTHON=%{__python3} DESTDIR="%{buildroot}" SBINDIR="%{_sbindir}" LIBDIR="%{_libdir}" LIBSEPOLA="%{_libdir}/libsepol.a" install
# Systemd
@ -426,8 +426,6 @@ system-config-selinux is a utility for managing the SELinux environment
%{_datadir}/system-config-selinux/system-config-selinux.png
%{_datadir}/system-config-selinux/*Page.py
%{_datadir}/system-config-selinux/__pycache__/*Page.*
%{_datadir}/system-config-selinux/html_util.py
%{_datadir}/system-config-selinux/__pycache__/html_util.*
%{_datadir}/system-config-selinux/polgengui.py
%{_datadir}/system-config-selinux/__pycache__/polgengui.*
%{_datadir}/system-config-selinux/system-config-selinux.py
@ -493,7 +491,7 @@ system-config-selinux is a utility for managing the SELinux environment
%dir %{_datadir}/bash-completion
%{_datadir}/bash-completion/completions/setsebool
%{!?_licensedir:%global license %%doc}
%license policycoreutils-%{version}/COPYING
%license policycoreutils-%{version}-rc1/COPYING
%doc %{_usr}/share/doc/%{name}
%package restorecond
@ -513,7 +511,7 @@ The policycoreutils-restorecond package contains the restorecond service.
%{_mandir}/man8/restorecond.8*
%{_mandir}/ru/man8/restorecond.8*
%{!?_licensedir:%global license %%doc}
%license policycoreutils-%{version}/COPYING
%license policycoreutils-%{version}-rc1/COPYING
%post
%systemd_post selinux-autorelabel-mark.service
@ -531,6 +529,9 @@ The policycoreutils-restorecond package contains the restorecond service.
%systemd_postun_with_restart restorecond.service
%changelog
* Fri Jan 25 2019 Petr Lautrbach <plautrba@redhat.com> - 2.9-0.rc1.1
- SELinux userspace 2.9-rc1 release candidate
* Fri Jan 25 2019 Petr Lautrbach <plautrba@redhat.com> - 2.8-17
- python2-policycoreutils requires python2-ipaddress (#1669230)

View File

@ -1,7 +1,7 @@
diff --git restorecond-2.8/Makefile restorecond-2.8/Makefile
index 25be18d..26eb411 100644
--- restorecond-2.8/Makefile
+++ restorecond-2.8/Makefile
diff --git restorecond-2.9-rc1/Makefile restorecond-2.9-rc1/Makefile
index 8a0ada1..6155ca4 100644
--- restorecond-2.9-rc1/Makefile
+++ restorecond-2.9-rc1/Makefile
@@ -50,7 +50,7 @@ install: all
-mkdir -p $(DESTDIR)$(AUTOSTARTDIR)
install -m 644 restorecond.desktop $(DESTDIR)$(AUTOSTARTDIR)/restorecond.desktop
@ -11,15 +11,3 @@ index 25be18d..26eb411 100644
-mkdir -p $(DESTDIR)$(SYSTEMDDIR)/system
install -m 644 restorecond.service $(DESTDIR)$(SYSTEMDDIR)/system/
relabel: install
diff --git restorecond-2.8/restorecond.c restorecond-2.8/restorecond.c
index 6fbbd35..e1d26cb 100644
--- restorecond-2.8/restorecond.c
+++ restorecond-2.8/restorecond.c
@@ -105,6 +105,7 @@ static int write_pid_file(void)
}
if (write(pidfd, val, (unsigned int)len) != len) {
syslog(LOG_ERR, "Unable to write to pidfile (%s)", strerror(errno));
+ close(pidfd);
return 1;
}
close(pidfd);

View File

@ -1,25 +1,7 @@
diff --git selinux-dbus-2.8/org.selinux.conf selinux-dbus-2.8/org.selinux.conf
index a350978..1ae079d 100644
--- selinux-dbus-2.8/org.selinux.conf
+++ selinux-dbus-2.8/org.selinux.conf
@@ -12,12 +12,8 @@
<!-- Allow anyone to invoke methods on the interfaces,
authorization is performed by PolicyKit -->
- <policy at_console="true">
- <allow send_destination="org.selinux"/>
- </policy>
<policy context="default">
- <allow send_destination="org.selinux"
- send_interface="org.freedesktop.DBus.Introspectable"/>
+ <allow send_destination="org.selinux"/>
</policy>
</busconfig>
diff --git selinux-dbus-2.8/org.selinux.policy selinux-dbus-2.8/org.selinux.policy
diff --git selinux-dbus-2.9-rc1/org.selinux.policy selinux-dbus-2.9-rc1/org.selinux.policy
index 0126610..9772127 100644
--- selinux-dbus-2.8/org.selinux.policy
+++ selinux-dbus-2.8/org.selinux.policy
--- selinux-dbus-2.9-rc1/org.selinux.policy
+++ selinux-dbus-2.9-rc1/org.selinux.policy
@@ -70,9 +70,9 @@
<allow_active>auth_admin_keep</allow_active>
</defaults>

View File

@ -1,8 +1,8 @@
diff --git selinux-gui-2.8/Makefile selinux-gui-2.8/Makefile
index a72e58c..ffe8b97 100644
--- selinux-gui-2.8/Makefile
+++ selinux-gui-2.8/Makefile
@@ -21,6 +21,7 @@ system-config-selinux.ui \
diff --git selinux-gui-2.9-rc1/Makefile selinux-gui-2.9-rc1/Makefile
index d42348b..1959e7d 100644
--- selinux-gui-2.9-rc1/Makefile
+++ selinux-gui-2.9-rc1/Makefile
@@ -20,6 +20,7 @@ system-config-selinux.ui \
usersPage.py
all: $(TARGETS) system-config-selinux.py polgengui.py
@ -10,7 +10,7 @@ index a72e58c..ffe8b97 100644
install: all
-mkdir -p $(DESTDIR)$(MANDIR)/man8
@@ -46,6 +47,8 @@ install: all
@@ -45,6 +46,8 @@ install: all
install -m 644 sepolicy_$${i}.png $(DESTDIR)$(DATADIR)/icons/hicolor/$${i}x$${i}/apps/sepolicy.png; \
done
install -m 644 org.selinux.config.policy $(DESTDIR)$(DATADIR)/polkit-1/actions/
@ -19,10 +19,10 @@ index a72e58c..ffe8b97 100644
clean:
indent:
diff --git selinux-gui-2.8/booleansPage.py selinux-gui-2.8/booleansPage.py
diff --git selinux-gui-2.9-rc1/booleansPage.py selinux-gui-2.9-rc1/booleansPage.py
index 7849bea..dd12b6d 100644
--- selinux-gui-2.8/booleansPage.py
+++ selinux-gui-2.8/booleansPage.py
--- selinux-gui-2.9-rc1/booleansPage.py
+++ selinux-gui-2.9-rc1/booleansPage.py
@@ -38,7 +38,7 @@ DISABLED = 2
##
## I18N
@ -32,10 +32,10 @@ index 7849bea..dd12b6d 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/domainsPage.py selinux-gui-2.8/domainsPage.py
diff --git selinux-gui-2.9-rc1/domainsPage.py selinux-gui-2.9-rc1/domainsPage.py
index bad5140..6bbe4de 100644
--- selinux-gui-2.8/domainsPage.py
+++ selinux-gui-2.8/domainsPage.py
--- selinux-gui-2.9-rc1/domainsPage.py
+++ selinux-gui-2.9-rc1/domainsPage.py
@@ -30,7 +30,7 @@ from semanagePage import *
##
## I18N
@ -45,10 +45,10 @@ index bad5140..6bbe4de 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/fcontextPage.py selinux-gui-2.8/fcontextPage.py
diff --git selinux-gui-2.9-rc1/fcontextPage.py selinux-gui-2.9-rc1/fcontextPage.py
index 370bbee..e424366 100644
--- selinux-gui-2.8/fcontextPage.py
+++ selinux-gui-2.8/fcontextPage.py
--- selinux-gui-2.9-rc1/fcontextPage.py
+++ selinux-gui-2.9-rc1/fcontextPage.py
@@ -47,7 +47,7 @@ class context:
##
## I18N
@ -58,10 +58,10 @@ index 370bbee..e424366 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/loginsPage.py selinux-gui-2.8/loginsPage.py
diff --git selinux-gui-2.9-rc1/loginsPage.py selinux-gui-2.9-rc1/loginsPage.py
index b67eb8b..cbfb0cc 100644
--- selinux-gui-2.8/loginsPage.py
+++ selinux-gui-2.8/loginsPage.py
--- selinux-gui-2.9-rc1/loginsPage.py
+++ selinux-gui-2.9-rc1/loginsPage.py
@@ -29,7 +29,7 @@ from semanagePage import *
##
## I18N
@ -71,10 +71,10 @@ index b67eb8b..cbfb0cc 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/modulesPage.py selinux-gui-2.8/modulesPage.py
diff --git selinux-gui-2.9-rc1/modulesPage.py selinux-gui-2.9-rc1/modulesPage.py
index 34c5d9e..627ad95 100644
--- selinux-gui-2.8/modulesPage.py
+++ selinux-gui-2.8/modulesPage.py
--- selinux-gui-2.9-rc1/modulesPage.py
+++ selinux-gui-2.9-rc1/modulesPage.py
@@ -30,7 +30,7 @@ from semanagePage import *
##
## I18N
@ -84,11 +84,11 @@ index 34c5d9e..627ad95 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/po/Makefile selinux-gui-2.8/po/Makefile
diff --git selinux-gui-2.9-rc1/po/Makefile selinux-gui-2.9-rc1/po/Makefile
new file mode 100644
index 0000000..a0f5439
--- /dev/null
+++ selinux-gui-2.8/po/Makefile
+++ selinux-gui-2.9-rc1/po/Makefile
@@ -0,0 +1,82 @@
+#
+# Makefile for the PO files (translation) catalog
@ -172,11 +172,11 @@ index 0000000..a0f5439
+.PHONY: missing depend
+
+relabel:
diff --git selinux-gui-2.8/po/POTFILES selinux-gui-2.8/po/POTFILES
diff --git selinux-gui-2.9-rc1/po/POTFILES selinux-gui-2.9-rc1/po/POTFILES
new file mode 100644
index 0000000..1795c5c
--- /dev/null
+++ selinux-gui-2.8/po/POTFILES
+++ selinux-gui-2.9-rc1/po/POTFILES
@@ -0,0 +1,17 @@
+../booleansPage.py
+../domainsPage.py
@ -195,10 +195,10 @@ index 0000000..1795c5c
+../system-config-selinux.py
+../system-config-selinux.ui
+../usersPage.py
diff --git selinux-gui-2.8/polgen.ui selinux-gui-2.8/polgen.ui
diff --git selinux-gui-2.9-rc1/polgen.ui selinux-gui-2.9-rc1/polgen.ui
index aa4c70a..6a8c067 100644
--- selinux-gui-2.8/polgen.ui
+++ selinux-gui-2.8/polgen.ui
--- selinux-gui-2.9-rc1/polgen.ui
+++ selinux-gui-2.9-rc1/polgen.ui
@@ -1975,7 +1975,7 @@ Tab</property>
<object class="GtkLabel" id="label17">
<property name="visible">True</property>
@ -226,10 +226,10 @@ index aa4c70a..6a8c067 100644
<property name="use_underline">True</property>
</object>
<packing>
diff --git selinux-gui-2.8/polgengui.py selinux-gui-2.8/polgengui.py
diff --git selinux-gui-2.9-rc1/polgengui.py selinux-gui-2.9-rc1/polgengui.py
index 1601dbe..7e0d9d0 100644
--- selinux-gui-2.8/polgengui.py
+++ selinux-gui-2.8/polgengui.py
--- selinux-gui-2.9-rc1/polgengui.py
+++ selinux-gui-2.9-rc1/polgengui.py
@@ -63,7 +63,7 @@ def get_all_modules():
##
## I18N
@ -239,10 +239,10 @@ index 1601dbe..7e0d9d0 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/portsPage.py selinux-gui-2.8/portsPage.py
diff --git selinux-gui-2.9-rc1/portsPage.py selinux-gui-2.9-rc1/portsPage.py
index 30f5838..a537ecc 100644
--- selinux-gui-2.8/portsPage.py
+++ selinux-gui-2.8/portsPage.py
--- selinux-gui-2.9-rc1/portsPage.py
+++ selinux-gui-2.9-rc1/portsPage.py
@@ -35,7 +35,7 @@ from semanagePage import *
##
## I18N
@ -252,10 +252,10 @@ index 30f5838..a537ecc 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/semanagePage.py selinux-gui-2.8/semanagePage.py
diff --git selinux-gui-2.9-rc1/semanagePage.py selinux-gui-2.9-rc1/semanagePage.py
index 4127804..5361d69 100644
--- selinux-gui-2.8/semanagePage.py
+++ selinux-gui-2.8/semanagePage.py
--- selinux-gui-2.9-rc1/semanagePage.py
+++ selinux-gui-2.9-rc1/semanagePage.py
@@ -22,7 +22,7 @@ from gi.repository import Gdk, Gtk
##
## I18N
@ -265,10 +265,10 @@ index 4127804..5361d69 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/statusPage.py selinux-gui-2.8/statusPage.py
diff --git selinux-gui-2.9-rc1/statusPage.py selinux-gui-2.9-rc1/statusPage.py
index 766854b..a8f079b 100644
--- selinux-gui-2.8/statusPage.py
+++ selinux-gui-2.8/statusPage.py
--- selinux-gui-2.9-rc1/statusPage.py
+++ selinux-gui-2.9-rc1/statusPage.py
@@ -35,7 +35,7 @@ RELABELFILE = "/.autorelabel"
##
## I18N
@ -278,10 +278,10 @@ index 766854b..a8f079b 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/system-config-selinux.py selinux-gui-2.8/system-config-selinux.py
diff --git selinux-gui-2.9-rc1/system-config-selinux.py selinux-gui-2.9-rc1/system-config-selinux.py
index ce7c74b..a81e9dd 100644
--- selinux-gui-2.8/system-config-selinux.py
+++ selinux-gui-2.8/system-config-selinux.py
--- selinux-gui-2.9-rc1/system-config-selinux.py
+++ selinux-gui-2.9-rc1/system-config-selinux.py
@@ -45,7 +45,7 @@ import selinux
##
## I18N
@ -291,10 +291,10 @@ index ce7c74b..a81e9dd 100644
try:
import gettext
kwargs = {}
diff --git selinux-gui-2.8/usersPage.py selinux-gui-2.8/usersPage.py
diff --git selinux-gui-2.9-rc1/usersPage.py selinux-gui-2.9-rc1/usersPage.py
index 26794ed..d15d4c5 100644
--- selinux-gui-2.8/usersPage.py
+++ selinux-gui-2.8/usersPage.py
--- selinux-gui-2.9-rc1/usersPage.py
+++ selinux-gui-2.9-rc1/usersPage.py
@@ -29,7 +29,7 @@ from semanagePage import *
##
## I18N

File diff suppressed because it is too large Load Diff

View File

@ -1,7 +1,7 @@
diff --git selinux-sandbox-2.8/Makefile selinux-sandbox-2.8/Makefile
diff --git selinux-sandbox-2.9-rc1/Makefile selinux-sandbox-2.9-rc1/Makefile
index 49c1d3f..9e45329 100644
--- selinux-sandbox-2.8/Makefile
+++ selinux-sandbox-2.8/Makefile
--- selinux-sandbox-2.9-rc1/Makefile
+++ selinux-sandbox-2.9-rc1/Makefile
@@ -12,6 +12,7 @@ override LDLIBS += -lselinux -lcap-ng
SEUNSHARE_OBJS = seunshare.o
@ -18,11 +18,11 @@ index 49c1d3f..9e45329 100644
test:
@$(PYTHON) test_sandbox.py -v
diff --git selinux-sandbox-2.8/po/Makefile selinux-sandbox-2.8/po/Makefile
diff --git selinux-sandbox-2.9-rc1/po/Makefile selinux-sandbox-2.9-rc1/po/Makefile
new file mode 100644
index 0000000..0556bbe
--- /dev/null
+++ selinux-sandbox-2.8/po/Makefile
+++ selinux-sandbox-2.9-rc1/po/Makefile
@@ -0,0 +1,82 @@
+#
+# Makefile for the PO files (translation) catalog
@ -106,17 +106,17 @@ index 0000000..0556bbe
+.PHONY: missing depend
+
+relabel:
diff --git selinux-sandbox-2.8/po/POTFILES selinux-sandbox-2.8/po/POTFILES
diff --git selinux-sandbox-2.9-rc1/po/POTFILES selinux-sandbox-2.9-rc1/po/POTFILES
new file mode 100644
index 0000000..deff3f2
--- /dev/null
+++ selinux-sandbox-2.8/po/POTFILES
+++ selinux-sandbox-2.9-rc1/po/POTFILES
@@ -0,0 +1 @@
+../sandbox
diff --git selinux-sandbox-2.8/sandbox selinux-sandbox-2.8/sandbox
diff --git selinux-sandbox-2.9-rc1/sandbox selinux-sandbox-2.9-rc1/sandbox
index c07a1d8..948496d 100644
--- selinux-sandbox-2.8/sandbox
+++ selinux-sandbox-2.8/sandbox
--- selinux-sandbox-2.9-rc1/sandbox
+++ selinux-sandbox-2.9-rc1/sandbox
@@ -37,7 +37,7 @@ import sepolicy
SEUNSHARE = "/usr/sbin/seunshare"
@ -144,10 +144,10 @@ index c07a1d8..948496d 100644
help=_("alternate window manager"))
parser.add_option("-l", "--level", dest="level",
diff --git selinux-sandbox-2.8/sandbox.8 selinux-sandbox-2.8/sandbox.8
diff --git selinux-sandbox-2.9-rc1/sandbox.8 selinux-sandbox-2.9-rc1/sandbox.8
index d83fee7..90ef495 100644
--- selinux-sandbox-2.8/sandbox.8
+++ selinux-sandbox-2.8/sandbox.8
--- selinux-sandbox-2.9-rc1/sandbox.8
+++ selinux-sandbox-2.9-rc1/sandbox.8
@@ -77,7 +77,7 @@ Specifies the windowsize when creating an X based Sandbox. The default windowsiz
\fB\-W\fR \fB\-\-windowmanager\fR
Select alternative window manager to run within
@ -157,10 +157,10 @@ index d83fee7..90ef495 100644
.TP
\fB\-X\fR
Create an X based Sandbox for gui apps, temporary files for
diff --git selinux-sandbox-2.8/sandboxX.sh selinux-sandbox-2.8/sandboxX.sh
diff --git selinux-sandbox-2.9-rc1/sandboxX.sh selinux-sandbox-2.9-rc1/sandboxX.sh
index eaa500d..c211ebc 100644
--- selinux-sandbox-2.8/sandboxX.sh
+++ selinux-sandbox-2.8/sandboxX.sh
--- selinux-sandbox-2.9-rc1/sandboxX.sh
+++ selinux-sandbox-2.9-rc1/sandboxX.sh
@@ -6,21 +6,7 @@ export TITLE="Sandbox $context -- `grep ^#TITLE: ~/.sandboxrc | /usr/bin/cut -b8
[ -z $2 ] && export DPI="96" || export DPI="$2"
trap "exit 0" HUP

View File

@ -1,7 +1,7 @@
diff --git semodule-utils-2.8/semodule_package/semodule_package.c semodule-utils-2.8/semodule_package/semodule_package.c
diff --git semodule-utils-2.9-rc1/semodule_package/semodule_package.c semodule-utils-2.9-rc1/semodule_package/semodule_package.c
index 3515234..7b75b3f 100644
--- semodule-utils-2.8/semodule_package/semodule_package.c
+++ semodule-utils-2.8/semodule_package/semodule_package.c
--- semodule-utils-2.9-rc1/semodule_package/semodule_package.c
+++ semodule-utils-2.9-rc1/semodule_package/semodule_package.c
@@ -74,6 +74,7 @@ static int file_to_data(const char *path, char **data, size_t * len)
}
if (!sb.st_size) {

14
sources
View File

@ -1,11 +1,11 @@
SHA512 (policycoreutils-2.9-rc1.tar.gz) = 6a3a7d4652b44e54c287b327ad691dd0575c6a45fbf1f4676b8182e05760defc37dfa6aaf2e6ab5a77e124d76d1f699c4859c0595a3f9e8ade04ff5ad186fb32
SHA512 (selinux-python-2.9-rc1.tar.gz) = afd7686ed21c55aa3fc45934d252da1a7d8a44651ef210bf54d4feeedcb72b9092be2d3becc9ff9c8caba53088d33ad97824e0655e04a47c122b45ea6c3e6455
SHA512 (selinux-gui-2.9-rc1.tar.gz) = 611e3a2cf55c5def9ec60a1ffd59ab30c3c394a8bf20fa6c83b84af5672813c435b3469c8490ff5f75a5ae75fec9ac3014c0aacb4a9fadecc90f683fb61e5722
SHA512 (selinux-sandbox-2.9-rc1.tar.gz) = 324b0448aa2656e401f2aeebb162626844f5b43f65c305e05c64284964d18ee4e38e98bb9e767e7f4fbf405fd8475fa70a9c5aa0c60d43880036adea0c146779
SHA512 (selinux-dbus-2.9-rc1.tar.gz) = f20357788250fe3e6ad3985d093877abdc09deda485a0a69f6563f6540c28c7ad61402bde09f53086d1f73fdc174c959bae50a223962eea3ffa6f4db09cdcec4
SHA512 (semodule-utils-2.9-rc1.tar.gz) = 2e03dd8c23ad1b2f2492194ccd4a6fc39d4ee2d513778264b794011121c3b6eb896dab4a2236cf3934d1e200ad1f86ba6223bb6ac7aa81b1fd4c2a700dc7081a
SHA512 (restorecond-2.9-rc1.tar.gz) = 6d0b0e3e36dfe567cf5349801078bc6ff9c6a7e7f2afc13f7ae775c9ae1d74fddfce14f3c83933f386e110ae5b4836c633d8307c9c4bce2000a3230bfcdb64eb
SHA512 (policycoreutils_man_ru2.tar.bz2) = 7272801da169b8d7dd3f8b7e368a63a4fbb7ae94599f9384bc450d142e6b2a3805ab542d650cbe9c8978c2d8e5c56ef4c11f361abfefeaf184ec3a4b0d2afb4c
SHA512 (policycoreutils-2.8.tar.gz) = 2b4a70836fd8727a16b8f8d4afcc39c9461ab6f5bc1ba5ce5833d41150da921ebb3c9bdbd1cfa7dd31fd382ba18b5433ca9b63bce58bd290db81fa9bedfe29f3
SHA512 (restorecond-2.8.tar.gz) = 5d72336782c3ad095746f8e6fa67e36448e5e76ca29586d8fe4962c64e505fa95c1458e8fc8f7d5bd589fff71b4be3758fb0cee3dacd2ccd0bc8476423e2540e
SHA512 (selinux-dbus-2.8.tar.gz) = 241b308a4754fdc618466fc0f60234c1a80583eaeca22fab96f2d2779ac91ae03437cdfa8320fcfe5f142cdab543f025425c90eded5ff55d06960f55704a99f2
SHA512 (selinux-gui-2.8.tar.gz) = 616323d0516cda80cdc13b8e66890b2c872695c276587304dd88a0948420011f5967ef46053f769f39863a9a9194f6e203102308c89f938ed66331f37c8a8d25
SHA512 (selinux-python-2.8.tar.gz) = e695c11122f7f8105b75d1ef98355fd2b82b40d93c2fd9e733dcd95d4d7c392f60b646df81203c43ad2a0e8447f9901083007e1572b78e17368ad2764ffa1aad
SHA512 (selinux-sandbox-2.8.tar.gz) = d86582639d1afc532998c2e94e0cc1fe9f7ce1daaa912a39b1b5dddf52c33965c063abe0cdcbcbe4017d5cbcabe351dcd9861323753dffc755de355b87c821b2
SHA512 (semodule-utils-2.8.tar.gz) = 13d79a22115f5448dafc5202dc3dec66b9ad826051d61d7c126defe823407959511db35713d97c7dfe9e79de96193fec91a10b98c13743e06a1213f5734f4ae7
SHA512 (gui-po.tgz) = 8b4a2ed5f246ea3d6086e2f8b7df37b0e43318b1a1d4dc5aae7cfa32ee6b4e0a39fc0b8f08ff062fd776d54a4c9b88f641d3109f7d8b5ec11b44383c902fefa5
SHA512 (policycoreutils-po.tgz) = 8dd151bc67345106fec5daae1a133e74202484509357883e21e1eaccb8283098dc153a8f77e2d4dd0e899995eb07dedf0f7fca68507df35593a7f95482a4cb28
SHA512 (python-po.tgz) = c9d88b9523f41b13f53403c0a98fe2fd6ba67afa51d41b56a856340e387eee00d6bd5416cd595a4bf657eaa02797ac3fe25a2a5de17b5f6bb6a2566d14c6c63f