* Mon Jun 11 2007 Dan Walsh <dwalsh@redhat.com> 2.0.20-1

- Update to match NSA
	* Merged genhomedircon fixes from Dan Walsh.
	* Merged setfiles -c usage fix from Dan Walsh.
	* Merged restorecon fix from Yuichi Nakamura.
	* Dropped -lsepol where no longer needed.
This commit is contained in:
Daniel J Walsh 2007-06-11 18:44:01 +00:00
parent 23b8362100
commit a0ef77a17e
4 changed files with 16 additions and 41 deletions

View File

@ -151,3 +151,4 @@ policycoreutils-2.0.14.tgz
policycoreutils-2.0.15.tgz
policycoreutils-2.0.16.tgz
policycoreutils-2.0.19.tgz
policycoreutils-2.0.20.tgz

View File

@ -1,6 +1,6 @@
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-2.0.19/audit2allow/Makefile
--- nsapolicycoreutils/audit2allow/Makefile 2007-02-07 12:11:49.000000000 -0500
+++ policycoreutils-2.0.19/audit2allow/Makefile 2007-06-01 10:29:17.000000000 -0400
+++ policycoreutils-2.0.19/audit2allow/Makefile 2007-06-11 14:41:13.000000000 -0400
@@ -1,6 +1,7 @@
# Installation directories.
PREFIX ?= ${DESTDIR}/usr
@ -20,7 +20,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.19/Makefile
--- nsapolicycoreutils/Makefile 2007-05-18 09:58:33.000000000 -0400
+++ policycoreutils-2.0.19/Makefile 2007-06-01 10:29:17.000000000 -0400
+++ policycoreutils-2.0.19/Makefile 2007-06-11 14:41:13.000000000 -0400
@@ -1,4 +1,4 @@
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
@ -29,7 +29,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
@for subdir in $(SUBDIRS); do \
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.19/restorecond/restorecond.c
--- nsapolicycoreutils/restorecond/restorecond.c 2007-02-22 08:53:22.000000000 -0500
+++ policycoreutils-2.0.19/restorecond/restorecond.c 2007-06-01 10:29:17.000000000 -0400
+++ policycoreutils-2.0.19/restorecond/restorecond.c 2007-06-11 14:41:13.000000000 -0400
@@ -210,9 +210,10 @@
}
@ -56,30 +56,9 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
}
free(scontext);
close(fd);
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/genhomedircon policycoreutils-2.0.19/scripts/genhomedircon
--- nsapolicycoreutils/scripts/genhomedircon 2007-05-18 09:58:33.000000000 -0400
+++ policycoreutils-2.0.19/scripts/genhomedircon 2007-06-01 10:29:32.000000000 -0400
@@ -193,7 +193,7 @@
return prefix
def adduser(self, udict, user, seuser, prefix):
- if seuser == "user_u" or user == "__default__" or user == "system_u":
+ if seuser == self.default_user or user == "__default__" or user == "system_u":
return
# !!! chooses first prefix in the list to use in the file context !!!
try:
@@ -263,7 +263,7 @@
i = i.replace("system_u", seuser)
# Validate if the generated context exists. Some user types may not exist
scon = i.split()[-1]
- if selinux.security_check_context(scon) == 0:
+ if selinux.is_selinux_enabled() < 1 or selinux.security_check_context(scon) == 0:
ret = ret+i
fd.close()
return ret
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.19/semanage/semanage
--- nsapolicycoreutils/semanage/semanage 2007-05-04 09:14:39.000000000 -0400
+++ policycoreutils-2.0.19/semanage/semanage 2007-06-11 12:36:56.000000000 -0400
+++ policycoreutils-2.0.19/semanage/semanage 2007-06-11 14:41:13.000000000 -0400
@@ -34,7 +34,10 @@
sys.stdout = codecs.getwriter(locale.getpreferredencoding())(sys.__stdout__, 'replace')
@ -94,7 +73,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
__builtin__.__dict__['_'] = unicode
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.19/semanage/seobject.py
--- nsapolicycoreutils/semanage/seobject.py 2007-04-12 12:43:06.000000000 -0400
+++ policycoreutils-2.0.19/semanage/seobject.py 2007-06-01 10:29:17.000000000 -0400
+++ policycoreutils-2.0.19/semanage/seobject.py 2007-06-11 14:41:13.000000000 -0400
@@ -210,6 +210,7 @@
os.write(fd, self.out())
os.close(fd)
@ -119,15 +98,3 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po
return ddict
diff --exclude-from=exclude --exclude=sepolgen-1.0.8 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/setfiles/setfiles.c policycoreutils-2.0.19/setfiles/setfiles.c
--- nsapolicycoreutils/setfiles/setfiles.c 2007-05-18 09:58:33.000000000 -0400
+++ policycoreutils-2.0.19/setfiles/setfiles.c 2007-06-04 17:42:44.000000000 -0400
@@ -858,8 +858,6 @@
if (strcmp(input_filename, "-") != 0)
fclose(f);
} else {
- if (optind >= argc)
- usage(argv[0]);
for (i = optind; i < argc; i++) {
errors |= process_one(argv[i]);
}

View File

@ -5,8 +5,8 @@
%define sepolgenver 1.0.8
Summary: SELinux policy core utilities.
Name: policycoreutils
Version: 2.0.19
Release: 5%{?dist}
Version: 2.0.20
Release: 1%{?dist}
License: GPL
Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@ -192,6 +192,13 @@ if [ "$1" -ge "1" ]; then
fi
%changelog
* Mon Jun 11 2007 Dan Walsh <dwalsh@redhat.com> 2.0.20-1
- Update to match NSA
* Merged genhomedircon fixes from Dan Walsh.
* Merged setfiles -c usage fix from Dan Walsh.
* Merged restorecon fix from Yuichi Nakamura.
* Dropped -lsepol where no longer needed.
* Mon Jun 11 2007 Dan Walsh <dwalsh@redhat.com> 2.0.19-5
- Fix translations code, Add more filters to gui

View File

@ -1,2 +1,2 @@
4d6e57c7fc396efbcf96b7accab4ba30 sepolgen-1.0.8.tgz
bd32594844a81cb3116ecd131bce027c policycoreutils-2.0.19.tgz
7519accdbd77080a749278f40f186e8c policycoreutils-2.0.20.tgz