sepolicy gui

- mgrepl added delete screens for users and login
  - Fix lots of bugs.
- Update Translations.
This commit is contained in:
Dan Walsh 2013-10-11 17:15:18 -04:00
parent 58b140fa6b
commit 9f7fe58ac4
2 changed files with 22 additions and 10 deletions

View File

@ -352,11 +352,11 @@ index b5abbb9..9d9f820 100644
clean:
indent:
diff --git a/policycoreutils/gui/org.selinux.config.selinux.policy b/policycoreutils/gui/org.selinux.config.selinux.policy
diff --git a/policycoreutils/gui/org.selinux.config.policy b/policycoreutils/gui/org.selinux.config.policy
new file mode 100644
index 0000000..fb2adf6
--- /dev/null
+++ b/policycoreutils/gui/org.selinux.config.selinux.policy
+++ b/policycoreutils/gui/org.selinux.config.policy
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC
@ -670723,12 +670723,19 @@ index 378eac2..3186c86 100644
+tmp
+*.bak
diff --git a/policycoreutils/sepolicy/Makefile b/policycoreutils/sepolicy/Makefile
index 11b534f..9e498f8 100644
index 11b534f..90e31dd 100644
--- a/policycoreutils/sepolicy/Makefile
+++ b/policycoreutils/sepolicy/Makefile
@@ -9,9 +9,9 @@ LOCALEDIR ?= /usr/share/locale
@@ -4,14 +4,15 @@ SYSCONFDIR ?= $(DESTDIR)/etc/sysconfig
LIBDIR ?= $(PREFIX)/lib
BINDIR ?= $(PREFIX)/bin
SBINDIR ?= $(PREFIX)/sbin
+DATADIR ?= $(PREFIX)/share
MANDIR ?= $(PREFIX)/share/man
LOCALEDIR ?= /usr/share/locale
PYTHON ?= /usr/bin/python
BASHCOMPLETIONDIR ?= $(DESTDIR)/etc/bash_completion.d/
-BASHCOMPLETIONDIR ?= $(DESTDIR)/etc/bash_completion.d/
+BASHCOMPLETIONDIR ?= $(DESTDIR)/usr/share/bash-completion/completions
SHAREDIR ?= $(PREFIX)/share/sandbox
-override CFLAGS = $(LDFLAGS) -I$(PREFIX)/include -DPACKAGE="policycoreutils" -Wall -Werror -Wextra -W -DSHARED -shared
+override CFLAGS = -I$(PREFIX)/include -DPACKAGE="policycoreutils" -Wall -Werror -Wextra -W -DSHARED -shared
@ -670738,7 +670745,7 @@ index 11b534f..9e498f8 100644
all: python-build
@@ -22,11 +22,27 @@ clean:
@@ -22,11 +23,27 @@ clean:
$(PYTHON) setup.py clean
-rm -rf build *~ \#* *pyc .#*
@ -670756,7 +670763,8 @@ index 11b534f..9e498f8 100644
-mkdir -p $(MANDIR)/man8
install -m 644 *.8 $(MANDIR)/man8
-mkdir -p $(BASHCOMPLETIONDIR)
install -m 644 $(BASHCOMPLETIONS) $(BASHCOMPLETIONDIR)
- install -m 644 $(BASHCOMPLETIONS) $(BASHCOMPLETIONDIR)
+ install -m 644 $(BASHCOMPLETIONS) $(BASHCOMPLETIONDIR)/sepolicy
+ -mkdir -p $(DESTDIR)/etc/dbus-1/system.d/
+ install -m 644 org.selinux.conf $(DESTDIR)/etc/dbus-1/system.d/
+ -mkdir -p $(DESTDIR)/usr/share/dbus-1/system-services
@ -670765,7 +670773,7 @@ index 11b534f..9e498f8 100644
+ install -m 644 org.selinux.policy $(DESTDIR)/usr/share/polkit-1/actions/
+ -mkdir -p $(DESTDIR)/usr/share/system-config-selinux
+ install -m 755 selinux_server.py $(DESTDIR)/usr/share/system-config-selinux
+ install -m 644 *.desktop $(DESTDIR)/usr/share/system-config-selinux
+ install -m 644 *.desktop $(DATADIR)/system-config-selinux
diff --git a/policycoreutils/sepolicy/info.c b/policycoreutils/sepolicy/info.c
index 65458e6..cd1026a 100644
--- a/policycoreutils/sepolicy/info.c

View File

@ -150,7 +150,7 @@ an SELinux environment.
%{_datadir}/system-config-selinux/selinux_server.py
%{_datadir}/dbus-1/system-services/org.selinux.service
%{_datadir}/polkit-1/actions/org.selinux.policy
%{_datadir}/polkit-1/actions/org.fedoraproject.config.selinux.policy
%{_datadir}/polkit-1/actions/org.selinux.config.policy
%{_datadir}/bash-completion/completions/semanage
%{_datadir}/bash-completion/completions/setsebool
@ -345,7 +345,11 @@ The policycoreutils-restorecond package contains the restorecond service.
%changelog
* Fri Oct 11 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.14-86
- mgrepl added delete screens for users and login
- sepolicy gui
- mgrepl added delete screens for users and login
- Fix lots of bugs.
- Update Translations.
* Fri Oct 4 2013 Dan Walsh <dwalsh@redhat.com> - 2.1.14-85
- Fixes for fixfiles