- Fix bug preventing sandbox from using -l
This commit is contained in:
parent
9c23983b71
commit
9d740110e6
@ -13953,7 +13953,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/rw.py poli
|
||||
+"""
|
||||
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py policycoreutils-2.0.83/gui/templates/script.py
|
||||
--- nsapolicycoreutils/gui/templates/script.py 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ policycoreutils-2.0.83/gui/templates/script.py 2010-07-30 13:50:41.000000000 -0400
|
||||
+++ policycoreutils-2.0.83/gui/templates/script.py 2010-09-09 07:02:41.000000000 -0400
|
||||
@@ -0,0 +1,126 @@
|
||||
+# Copyright (C) 2007 Red Hat
|
||||
+# see file 'COPYING' for use and warranty information
|
||||
@ -14020,7 +14020,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py
|
||||
+
|
||||
+echo "Building and Loading Policy"
|
||||
+set -x
|
||||
+make -f /usr/share/selinux/devel/Makefile
|
||||
+make -f /usr/share/selinux/devel/Makefile || exit
|
||||
+/usr/sbin/semodule -i TEMPLATEFILE.pp
|
||||
+
|
||||
+"""
|
||||
|
@ -1647,7 +1647,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.23 --exclude=gui --exclude=po
|
||||
@python test_sandbox.py -v
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.23 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/sandbox/sandbox policycoreutils-2.0.83/sandbox/sandbox
|
||||
--- nsapolicycoreutils/sandbox/sandbox 2010-06-16 08:03:38.000000000 -0400
|
||||
+++ policycoreutils-2.0.83/sandbox/sandbox 2010-09-07 11:24:03.000000000 -0400
|
||||
+++ policycoreutils-2.0.83/sandbox/sandbox 2010-09-09 16:28:25.000000000 -0400
|
||||
@@ -1,5 +1,6 @@
|
||||
-#! /usr/bin/python -E
|
||||
+#! /usr/bin/python -Es
|
||||
@ -1775,7 +1775,7 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.23 --exclude=gui --exclude=po
|
||||
parser.add_option("-W", "--windowmanager", dest="wm",
|
||||
type="string",
|
||||
default="/usr/bin/matchbox-window-manager -use_titlebar no",
|
||||
@@ -276,6 +293,10 @@
|
||||
@@ -276,13 +293,17 @@
|
||||
parser.add_option("-l", "--level", dest="level",
|
||||
help=_("MCS/MLS level for the sandbox"))
|
||||
|
||||
@ -1786,7 +1786,25 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.23 --exclude=gui --exclude=po
|
||||
self.__parser=parser
|
||||
|
||||
self.__options, cmds = parser.parse_args()
|
||||
@@ -351,22 +372,24 @@
|
||||
|
||||
if self.__options.X_ind:
|
||||
self.setype = DEFAULT_X_TYPE
|
||||
-
|
||||
+
|
||||
if self.__options.setype:
|
||||
self.setype = self.__options.setype
|
||||
|
||||
@@ -299,6 +320,9 @@
|
||||
self.__options.X_ind = True
|
||||
self.__homedir = self.__options.homedir
|
||||
self.__tmpdir = self.__options.tmpdir
|
||||
+ elif self.__options.level:
|
||||
+ self.__homedir = self.__options.homedir
|
||||
+ self.__tmpdir = self.__options.tmpdir
|
||||
else:
|
||||
if len(cmds) == 0:
|
||||
self.usage(_("Command required"))
|
||||
@@ -351,22 +375,24 @@
|
||||
|
||||
def __execute(self):
|
||||
try:
|
||||
|
@ -7,7 +7,7 @@
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.83
|
||||
Release: 24%{?dist}
|
||||
Release: 25%{?dist}
|
||||
License: GPLv2
|
||||
Group: System Environment/Base
|
||||
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
|
||||
@ -315,6 +315,9 @@ fi
|
||||
exit 0
|
||||
|
||||
%changelog
|
||||
* Thu Sep 8 2010 Dan Walsh <dwalsh@redhat.com> 2.0.83-25
|
||||
- Fix bug preventing sandbox from using -l
|
||||
|
||||
* Tue Sep 7 2010 Dan Walsh <dwalsh@redhat.com> 2.0.83-24
|
||||
- Eliminate quotes fro desktop files
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user