* Wed Aug 5 2009 Dan Walsh <dwalsh@redhat.com> 2.0.70-1
- Update to upstream * Modify restorecon to only call realpath() on user-supplied pathnames from Stephen Smalley. * Fix typo in fixfiles that prevented it from relabeling btrfs filesystems from Dan Walsh.
This commit is contained in:
parent
c57e98ae82
commit
886ea9345c
@ -202,3 +202,4 @@ policycoreutils-2.0.64.tgz
|
||||
policycoreutils-2.0.65.tgz
|
||||
policycoreutils-2.0.67.tgz
|
||||
policycoreutils-2.0.68.tgz
|
||||
policycoreutils-2.0.70.tgz
|
||||
|
@ -1195,18 +1195,6 @@ diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po
|
||||
+ exitApp("Error watching config file.");
|
||||
+}
|
||||
+
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/fixfiles policycoreutils-2.0.68/scripts/fixfiles
|
||||
--- nsapolicycoreutils/scripts/fixfiles 2009-06-23 15:36:07.000000000 -0400
|
||||
+++ policycoreutils-2.0.68/scripts/fixfiles 2009-07-29 09:31:44.000000000 -0400
|
||||
@@ -129,7 +129,7 @@
|
||||
if [ ! -z "$FILEPATH" ]; then
|
||||
if [ -x /usr/bin/find ]; then
|
||||
/usr/bin/find "$FILEPATH" \
|
||||
- ! \( -fstype ext2 -o -fstype ext3 -o -fstype ext4 -o -fstype ext4dev -o -fstype gfs2 -o -fstype jfs -o -fstype xfs -o fstype btrfs \) -prune -o -print0 | \
|
||||
+ ! \( -fstype ext2 -o -fstype ext3 -o -fstype ext4 -o -fstype ext4dev -o -fstype gfs2 -o -fstype jfs -o -fstype xfs -o -fstype btrfs \) -prune -o -print0 | \
|
||||
${RESTORECON} ${OUTFILES} ${FORCEFLAG} $* -0 -f - 2>&1 >> $LOGFILE
|
||||
else
|
||||
${RESTORECON} ${OUTFILES} ${FORCEFLAG} -R $* $FILEPATH 2>&1 >> $LOGFILE
|
||||
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/Makefile policycoreutils-2.0.68/scripts/Makefile
|
||||
--- nsapolicycoreutils/scripts/Makefile 2008-08-28 09:34:24.000000000 -0400
|
||||
+++ policycoreutils-2.0.68/scripts/Makefile 2009-07-29 09:30:07.000000000 -0400
|
||||
|
@ -5,7 +5,7 @@
|
||||
%define sepolgenver 1.0.16
|
||||
Summary: SELinux policy core utilities
|
||||
Name: policycoreutils
|
||||
Version: 2.0.68
|
||||
Version: 2.0.70
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
@ -266,6 +266,13 @@ else
|
||||
fi
|
||||
|
||||
%changelog
|
||||
* Wed Aug 5 2009 Dan Walsh <dwalsh@redhat.com> 2.0.70-1
|
||||
- Update to upstream
|
||||
* Modify restorecon to only call realpath() on user-supplied pathnames
|
||||
from Stephen Smalley.
|
||||
* Fix typo in fixfiles that prevented it from relabeling btrfs
|
||||
filesystems from Dan Walsh.
|
||||
|
||||
* Sun Jul 29 2009 Dan Walsh <dwalsh@redhat.com> 2.0.68-1
|
||||
- Fix location of man pages
|
||||
- Update to upstream
|
||||
|
Loading…
Reference in New Issue
Block a user