* Thu Apr 20 2006 Dan Walsh <dwalsh@redhat.com> 1.30.6-3

- Fix check for "msg"
This commit is contained in:
Daniel J Walsh 2006-04-20 16:05:33 +00:00
parent e974661b02
commit 5157d709ec
2 changed files with 32 additions and 22 deletions

View File

@ -1,6 +1,6 @@
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.30.6/audit2allow/audit2allow diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.30.6/audit2allow/audit2allow
--- nsapolicycoreutils/audit2allow/audit2allow 2006-03-29 15:35:22.000000000 -0500 --- nsapolicycoreutils/audit2allow/audit2allow 2006-03-29 15:35:22.000000000 -0500
+++ policycoreutils-1.30.6/audit2allow/audit2allow 2006-04-14 15:07:36.000000000 -0400 +++ policycoreutils-1.30.6/audit2allow/audit2allow 2006-04-20 09:47:19.000000000 -0400
@@ -24,431 +24,8 @@ @@ -24,431 +24,8 @@
# 02111-1307 USA # 02111-1307 USA
# #
@ -483,7 +483,13 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow
usage() usage()
input=open("/var/log/messages", "r") input=open("/var/log/messages", "r")
auditlogs=1 auditlogs=1
@@ -551,9 +131,8 @@ @@ -547,13 +127,14 @@
module=a
outfile=a+".te"
buildPP=1
+ if not os.path.exists("/usr/bin/checkmodule"):
+ errorExit("-M Requires the checkmodule command, you need to install the checkpolicy rpm package")
output=open(outfile, "w")
if o == "-r" or o == "--requires": if o == "-r" or o == "--requires":
requires=1 requires=1
if o == "-t" or o == "--tefile": if o == "-t" or o == "--tefile":
@ -495,7 +501,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow
if o == "-R" or o == "--reference": if o == "-R" or o == "--reference":
ref_ind=True ref_ind=True
@@ -565,25 +144,38 @@ @@ -565,25 +146,38 @@
if o == "-v" or o == "--verbose": if o == "-v" or o == "--verbose":
verbose=1 verbose=1
@ -541,7 +547,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow
cmd="checkmodule %s -m -o %s.mod %s.te" % (get_mls_flag(), module, module) cmd="checkmodule %s -m -o %s.mod %s.te" % (get_mls_flag(), module, module)
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow.1 policycoreutils-1.30.6/audit2allow/audit2allow.1 diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow.1 policycoreutils-1.30.6/audit2allow/audit2allow.1
--- nsapolicycoreutils/audit2allow/audit2allow.1 2006-03-10 09:48:04.000000000 -0500 --- nsapolicycoreutils/audit2allow/audit2allow.1 2006-03-10 09:48:04.000000000 -0500
+++ policycoreutils-1.30.6/audit2allow/audit2allow.1 2006-04-14 13:50:16.000000000 -0400 +++ policycoreutils-1.30.6/audit2allow/audit2allow.1 2006-04-20 09:47:19.000000000 -0400
@@ -98,6 +98,11 @@ @@ -98,6 +98,11 @@
.PP .PP
.SH EXAMPLE .SH EXAMPLE
@ -556,8 +562,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/audit2allow.
$ cat /var/log/audit/audit.log | audit2allow >> domains/misc/local.te $ cat /var/log/audit/audit.log | audit2allow >> domains/misc/local.te
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/avc.py policycoreutils-1.30.6/audit2allow/avc.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/avc.py policycoreutils-1.30.6/audit2allow/avc.py
--- nsapolicycoreutils/audit2allow/avc.py 1969-12-31 19:00:00.000000000 -0500 --- nsapolicycoreutils/audit2allow/avc.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.30.6/audit2allow/avc.py 2006-04-14 15:46:22.000000000 -0400 +++ policycoreutils-1.30.6/audit2allow/avc.py 2006-04-20 11:53:56.000000000 -0400
@@ -0,0 +1,518 @@ @@ -0,0 +1,519 @@
+#! /usr/bin/env python +#! /usr/bin/env python
+# Copyright (C) 2006 Red Hat +# Copyright (C) 2006 Red Hat
+# see file 'COPYING' for use and warranty information +# see file 'COPYING' for use and warranty information
@ -909,10 +915,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/avc.py polic
+ found=1 + found=1
+ else: + else:
+ dict.append(i) + dict.append(i)
+ if found: + if found:
+ self.translate(dict) + self.translate(dict)
+ found=0 + found=0
+ dict=[] + dict=[]
+ line = input.readline() + line = input.readline()
+ +
+ +
@ -988,10 +994,11 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/avc.py polic
+ key=("allow", scontext.type, tcontext.type, AVC["tclass"]) + key=("allow", scontext.type, tcontext.type, AVC["tclass"])
+ if key not in self.seRules.keys(): + if key not in self.seRules.keys():
+ self.seRules[key]=serule(key) + self.seRules[key]=serule(key)
+ if "name" not in AVC.keys(): +
+ AVC["name"]="" + avckeys=AVC.keys()
+ if "comm" not in AVC.keys(): + for i in ( "name", "comm", "msg" ):
+ AVC["comm"]="" + if i not in avckeys:
+ AVC[i]=""
+ +
+ self.add_avc(AVC) + self.add_avc(AVC)
+ self.seRules[key].add((AVC["access"], AVC["msg"], AVC["comm"], AVC["name"])) + self.seRules[key].add((AVC["access"], AVC["msg"], AVC["comm"], AVC["name"]))
@ -1078,7 +1085,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/avc.py polic
+ +
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-1.30.6/audit2allow/Makefile diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/Makefile policycoreutils-1.30.6/audit2allow/Makefile
--- nsapolicycoreutils/audit2allow/Makefile 2005-01-21 09:01:35.000000000 -0500 --- nsapolicycoreutils/audit2allow/Makefile 2005-01-21 09:01:35.000000000 -0500
+++ policycoreutils-1.30.6/audit2allow/Makefile 2006-04-18 16:51:11.000000000 -0400 +++ policycoreutils-1.30.6/audit2allow/Makefile 2006-04-20 09:47:19.000000000 -0400
@@ -3,6 +3,8 @@ @@ -3,6 +3,8 @@
BINDIR ?= $(PREFIX)/bin BINDIR ?= $(PREFIX)/bin
MANDIR ?= $(PREFIX)/share/man MANDIR ?= $(PREFIX)/share/man
@ -1099,7 +1106,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/audit2allow/Makefile pol
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-1.30.6/restorecond/restorecond.conf diff --exclude-from=exclude -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-1.30.6/restorecond/restorecond.conf
--- nsapolicycoreutils/restorecond/restorecond.conf 2006-03-29 11:08:21.000000000 -0500 --- nsapolicycoreutils/restorecond/restorecond.conf 2006-03-29 11:08:21.000000000 -0500
+++ policycoreutils-1.30.6/restorecond/restorecond.conf 2006-04-14 13:50:16.000000000 -0400 +++ policycoreutils-1.30.6/restorecond/restorecond.conf 2006-04-20 09:47:19.000000000 -0400
@@ -1,4 +1,6 @@ @@ -1,4 +1,6 @@
/etc/resolv.conf /etc/resolv.conf
+/etc/samba/secrets.tdb +/etc/samba/secrets.tdb
@ -1109,7 +1116,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/restorecond/restorecond.
+~/.mozilla/plugins/libflashplayer.so +~/.mozilla/plugins/libflashplayer.so
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-1.30.6/semanage/semanage diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-1.30.6/semanage/semanage
--- nsapolicycoreutils/semanage/semanage 2006-04-14 13:10:51.000000000 -0400 --- nsapolicycoreutils/semanage/semanage 2006-04-14 13:10:51.000000000 -0400
+++ policycoreutils-1.30.6/semanage/semanage 2006-04-14 13:50:16.000000000 -0400 +++ policycoreutils-1.30.6/semanage/semanage 2006-04-20 09:47:19.000000000 -0400
@@ -292,6 +292,8 @@ @@ -292,6 +292,8 @@
errorExit("Options Error " + error.msg) errorExit("Options Error " + error.msg)
except ValueError, error: except ValueError, error:
@ -1121,7 +1128,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semanage/semanage policy
except KeyboardInterrupt, error: except KeyboardInterrupt, error:
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.30.6/semanage/seobject.py diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.30.6/semanage/seobject.py
--- nsapolicycoreutils/semanage/seobject.py 2006-04-14 13:10:51.000000000 -0400 --- nsapolicycoreutils/semanage/seobject.py 2006-04-14 13:10:51.000000000 -0400
+++ policycoreutils-1.30.6/semanage/seobject.py 2006-04-14 13:52:19.000000000 -0400 +++ policycoreutils-1.30.6/semanage/seobject.py 2006-04-20 09:47:19.000000000 -0400
@@ -455,6 +455,8 @@ @@ -455,6 +455,8 @@
semanage_user_free(u) semanage_user_free(u)
@ -1161,7 +1168,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/semanage/seobject.py pol
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/setsebool/setsebool.8 policycoreutils-1.30.6/setsebool/setsebool.8 diff --exclude-from=exclude -N -u -r nsapolicycoreutils/setsebool/setsebool.8 policycoreutils-1.30.6/setsebool/setsebool.8
--- nsapolicycoreutils/setsebool/setsebool.8 2005-11-04 15:37:49.000000000 -0500 --- nsapolicycoreutils/setsebool/setsebool.8 2005-11-04 15:37:49.000000000 -0500
+++ policycoreutils-1.30.6/setsebool/setsebool.8 2006-04-14 13:50:16.000000000 -0400 +++ policycoreutils-1.30.6/setsebool/setsebool.8 2006-04-20 09:47:19.000000000 -0400
@@ -17,7 +17,7 @@ @@ -17,7 +17,7 @@
are not changed. are not changed.

View File

@ -5,7 +5,7 @@
Summary: SELinux policy core utilities. Summary: SELinux policy core utilities.
Name: policycoreutils Name: policycoreutils
Version: 1.30.6 Version: 1.30.6
Release: 2 Release: 3
License: GPL License: GPL
Group: System Environment/Base Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@ -106,10 +106,13 @@ rm -rf ${RPM_BUILD_ROOT}
%config(noreplace) /etc/selinux/restorecond.conf %config(noreplace) /etc/selinux/restorecond.conf
%post %post
/sbin/service restorecond condrestart [ -x /sbin/service ] && /sbin/service restorecond condrestart
%changelog %changelog
* Mon Apr 18 2006 Dan Walsh <dwalsh@redhat.com> 1.30.6-2 * Thu Apr 20 2006 Dan Walsh <dwalsh@redhat.com> 1.30.6-3
- Fix check for "msg"
* Mon Apr 17 2006 Dan Walsh <dwalsh@redhat.com> 1.30.6-2
- Ship avc.py - Ship avc.py
* Fri Apr 14 2006 Dan Walsh <dwalsh@redhat.com> 1.30.6-1 * Fri Apr 14 2006 Dan Walsh <dwalsh@redhat.com> 1.30.6-1