* Sat Apr 14 2007 Dan Walsh <dwalsh@redhat.com> 2.0.9-3

- Fixes for policygengui
This commit is contained in:
Daniel J Walsh 2007-04-15 01:42:09 +00:00
parent c3f42435f3
commit 3b8fa49a15
2 changed files with 164 additions and 55 deletions

View File

@ -1,6 +1,6 @@
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-2.0.9/gui/booleansPage.py
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/booleansPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/booleansPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,224 @@
+#
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
@ -228,8 +228,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/booleansPage.py poli
+ commands.getstatusoutput(setsebool)
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-2.0.9/gui/fcontextPage.py
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/fcontextPage.py 2007-04-13 13:16:13.000000000 -0400
@@ -0,0 +1,185 @@
+++ policycoreutils-2.0.9/gui/fcontextPage.py 2007-04-14 19:43:20.000000000 -0400
@@ -0,0 +1,207 @@
+## fcontextPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@ -293,6 +293,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+class fcontextPage(semanagePage):
+ def __init__(self, xml):
+ semanagePage.__init__(self, xml, "fcontext", _("File Labeling"))
+ self.fcontextFilter = xml.get_widget("fcontextFilterEntry")
+ self.fcontextFilter.connect("focus_out_event", self.filter_changed)
+ self.fcontextFilter.connect("activate", self.filter_changed)
+ self.view = xml.get_widget("fcontextView")
+ self.store = gtk.ListStore(gobject.TYPE_STRING, gobject.TYPE_STRING, gobject.TYPE_STRING)
+ self.view.set_model(self.store)
@ -329,11 +332,25 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ self.fcontextTypeEntry = xml.get_widget("fcontextTypeEntry")
+ self.fcontextMLSEntry = xml.get_widget("fcontextMLSEntry")
+
+ def load(self):
+ def match(self, fcon, filter):
+ try:
+ f=filter.lower()
+ for con in fcon:
+ k=con.lower()
+ if k.find(f) >= 0:
+ return True
+ except:
+ pass
+ return False
+
+ def load(self, filter=""):
+ self.filter=filter
+ self.fcontext=seobject.fcontextRecords()
+ fcon_list=self.fcontext.get_all()
+ self.store.clear()
+ for fcon in fcon_list:
+ if not self.match(fcon, filter):
+ continue
+ iter=self.store.append()
+ self.store.set_value(iter, SPEC_COL, fcon[0])
+ self.store.set_value(iter, FTYPE_COL, fcon[1])
@ -344,6 +361,11 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ self.store.set_value(iter, 1, rec)
+ self.view.get_selection().select_path ((0,))
+
+ def filter_changed(self, *arg):
+ filter = arg[0].get_text()
+ if filter != self.filter:
+ self.load(filter)
+
+ def dialogInit(self):
+ store, iter = self.view.get_selection().get_selected()
+ self.fcontextEntry.set_text(store.get_value(iter, SPEC_COL))
@ -417,7 +439,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/fcontextPage.py poli
+ self.store.set_value(iter, TYPE_COL, "system_u:object_r:%s:%s" % (type, mls))
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-2.0.9/gui/loginsPage.py
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/loginsPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/loginsPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,173 @@
+## loginsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -594,7 +616,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/loginsPage.py policy
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-2.0.9/gui/Makefile
--- nsapolicycoreutils/gui/Makefile 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/Makefile 2007-04-13 13:17:40.000000000 -0400
+++ policycoreutils-2.0.9/gui/Makefile 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,34 @@
+# Installation directories.
+PREFIX ?= ${DESTDIR}/usr
@ -632,7 +654,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/Makefile policycoreu
+relabel:
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-2.0.9/gui/mappingsPage.py
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/mappingsPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/mappingsPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,54 @@
+## mappingsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -690,7 +712,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/mappingsPage.py poli
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-2.0.9/gui/modulesPage.py
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/modulesPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/modulesPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,172 @@
+## modulesPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -866,7 +888,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/modulesPage.py polic
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.glade policycoreutils-2.0.9/gui/polgen.glade
--- nsapolicycoreutils/gui/polgen.glade 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/polgen.glade 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/polgen.glade 2007-04-14 19:43:04.000000000 -0400
@@ -0,0 +1,1127 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
@ -1997,7 +2019,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.glade policyc
+</glade-interface>
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgengui.py policycoreutils-2.0.9/gui/polgengui.py
--- nsapolicycoreutils/gui/polgengui.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/polgengui.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/polgengui.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,211 @@
+#!/usr/bin/python
+#
@ -2212,8 +2234,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgengui.py policyc
+ app.stand_alone()
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycoreutils-2.0.9/gui/polgen.py
--- nsapolicycoreutils/gui/polgen.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/polgen.py 2007-04-13 13:16:13.000000000 -0400
@@ -0,0 +1,436 @@
+++ policycoreutils-2.0.9/gui/polgen.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,440 @@
+#! /usr/bin/python
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -2380,7 +2402,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+ self.need_tcp_type = True;
+ else:
+ port_name = rec[0][:-2]
+ line = "corenet_tcp_bind_%s(%s)\n" % (port_name, self.name)
+ line = "corenet_tcp_bind_%s(%s_t)\n" % (port_name, self.name)
+ if line not in self.found_tcp_ports:
+ self.found_tcp_ports.append(line)
+
@ -2390,7 +2412,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+ self.need_tcp_type = True;
+ else:
+ port_name = rec[0][:-2]
+ line = "corenet_tcp_connect_%s(%s)\n" % (port_name, self.name)
+ line = "corenet_tcp_connect_%s(%s_t)\n" % (port_name, self.name)
+ if line not in self.found_tcp_ports:
+ self.found_tcp_ports.append(line)
+
@ -2400,10 +2422,10 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+ self.need_udp_type = True;
+ else:
+ port_name = rec[0][:-2]
+ line = "corenet_udp_bind_%s(%s)\n" % (port_name, self.name)
+ line = "corenet_udp_bind_%s(%s_t)\n" % (port_name, self.name)
+ if line not in self.found_udp_ports:
+ self.found_udp_ports.append(line)
+
+
+ if self.need_udp_type == True or self.need_tcp_type == True:
+ return re.sub("TEMPLATETYPE", self.name, network.te_port_types)
+ return ""
@ -2447,9 +2469,9 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+ newte += "\n"
+ newte += re.sub("TEMPLATETYPE", self.name, network.te_udp)
+ if self.need_udp_type and len(self.in_udp) > 0:
+ newte += re.sub("TEMPLATETYPE", self.name, network.te_in_udp)
+ if len(self.in_udp) > 0:
+ newte += re.sub("TEMPLATETYPE", self.name, network.te_in_need_port_udp)
+ if len(self.in_udp) > 0:
+ newte += re.sub("TEMPLATETYPE", self.name, network.te_in_udp)
+ for i in self.found_udp_ports:
+ newte += i
+ return newte
@ -2573,11 +2595,14 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+
+ for i in self.dirs.keys():
+ newsh += re.sub("FILENAME", i, script.restorecon)
+ for i in self.in_tcp + self.out_tcp:
+ t1 = re.sub("PORTNUM", "%d" % i, script.tcp_ports)
+ newsh += re.sub("TEMPLATETYPE", self.name, t1)
+
+ for i in self.in_udp + self.out_udp:
+ for i in self.in_tcp + self.out_tcp:
+ if self.find_port(i) == None:
+ t1 = re.sub("PORTNUM", "%d" % i, script.tcp_ports)
+ newsh += re.sub("TEMPLATETYPE", self.name, t1)
+
+ for i in self.in_udp + self.out_udp:
+ if self.find_port(i) == None:
+ t1 = re.sub("PORTNUM", "%d" % i, script.udp_ports)
+ newsh += re.sub("TEMPLATETYPE", self.name, t1)
+
@ -2628,7 +2653,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+
+if __name__ == '__main__':
+ mypolicy = policy("cgi", "/var/www/cgi-bin/cgi", 3)
+ mypolicy.set_in_tcp("8810")
+ mypolicy.set_in_tcp("513")
+ mypolicy.set_in_udp("513")
+ mypolicy.set_use_uid(True)
+ mypolicy.set_use_tmp(True)
+ mypolicy.set_use_syslog(True)
@ -2652,7 +2678,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/polgen.py policycore
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-2.0.9/gui/portsPage.py
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/portsPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/portsPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,227 @@
+## portsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -2883,7 +2909,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/portsPage.py policyc
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policycoreutils-2.0.9/gui/selinux.tbl
--- nsapolicycoreutils/gui/selinux.tbl 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/selinux.tbl 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/selinux.tbl 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,274 @@
+acct_disable_trans _("SELinux Service Protection") _("Disable SELinux protection for acct daemon")
+allow_cvs_read_shadow _("CVS") _("Allow cvs daemon to read shadow")
@ -3161,7 +3187,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/selinux.tbl policyco
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-2.0.9/gui/semanagePage.py
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/semanagePage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/semanagePage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,115 @@
+## semanagePage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -3280,7 +3306,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/semanagePage.py poli
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-2.0.9/gui/statusPage.py
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/statusPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/statusPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,220 @@
+## statusPage.py - show selinux status
+## Copyright (C) 2006 Red Hat, Inc.
@ -3504,8 +3530,8 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/statusPage.py policy
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-2.0.9/gui/system-config-selinux.glade
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/system-config-selinux.glade 2007-04-13 13:16:13.000000000 -0400
@@ -0,0 +1,2956 @@
+++ policycoreutils-2.0.9/gui/system-config-selinux.glade 2007-04-14 19:43:07.000000000 -0400
@@ -0,0 +1,3034 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
+
@ -5577,16 +5603,94 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ <property name="window_placement">GTK_CORNER_TOP_LEFT</property>
+
+ <child>
+ <widget class="GtkTreeView" id="fcontextView">
+ <widget class="GtkViewport" id="viewport1">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="headers_visible">True</property>
+ <property name="rules_hint">False</property>
+ <property name="reorderable">False</property>
+ <property name="enable_search">True</property>
+ <property name="fixed_height_mode">False</property>
+ <property name="hover_selection">False</property>
+ <property name="hover_expand">False</property>
+ <property name="shadow_type">GTK_SHADOW_IN</property>
+
+ <child>
+ <widget class="GtkVBox" id="vbox19">
+ <property name="visible">True</property>
+ <property name="homogeneous">False</property>
+ <property name="spacing">0</property>
+
+ <child>
+ <widget class="GtkHBox" id="hbox8">
+ <property name="visible">True</property>
+ <property name="homogeneous">False</property>
+ <property name="spacing">0</property>
+
+ <child>
+ <widget class="GtkLabel" id="label52">
+ <property name="visible">True</property>
+ <property name="label" translatable="yes">Filter</property>
+ <property name="use_underline">False</property>
+ <property name="use_markup">False</property>
+ <property name="justify">GTK_JUSTIFY_LEFT</property>
+ <property name="wrap">False</property>
+ <property name="selectable">False</property>
+ <property name="xalign">0.5</property>
+ <property name="yalign">0.5</property>
+ <property name="xpad">0</property>
+ <property name="ypad">0</property>
+ <property name="ellipsize">PANGO_ELLIPSIZE_NONE</property>
+ <property name="width_chars">-1</property>
+ <property name="single_line_mode">False</property>
+ <property name="angle">0</property>
+ </widget>
+ <packing>
+ <property name="padding">10</property>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkEntry" id="fcontextFilterEntry">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="editable">True</property>
+ <property name="visibility">True</property>
+ <property name="max_length">0</property>
+ <property name="text" translatable="yes"></property>
+ <property name="has_frame">True</property>
+ <property name="invisible_char">•</property>
+ <property name="activates_default">False</property>
+ <signal name="changed" handler="on_booleansFilter_changed" last_modification_time="Fri, 06 Apr 2007 12:39:26 GMT"/>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+ </widget>
+ <packing>
+ <property name="padding">5</property>
+ <property name="expand">False</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+
+ <child>
+ <widget class="GtkTreeView" id="fcontextView">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="headers_visible">True</property>
+ <property name="rules_hint">False</property>
+ <property name="reorderable">False</property>
+ <property name="enable_search">True</property>
+ <property name="fixed_height_mode">False</property>
+ <property name="hover_selection">False</property>
+ <property name="hover_expand">False</property>
+ </widget>
+ <packing>
+ <property name="padding">0</property>
+ <property name="expand">True</property>
+ <property name="fill">True</property>
+ </packing>
+ </child>
+ </widget>
+ </child>
+ </widget>
+ </child>
+ </widget>
@ -6464,7 +6568,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+</glade-interface>
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-2.0.9/gui/system-config-selinux.py
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/system-config-selinux.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/system-config-selinux.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,169 @@
+#!/usr/bin/python
+#
@ -6637,7 +6741,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/system-config-selinu
+ app.stand_alone()
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/executable.py policycoreutils-2.0.9/gui/templates/executable.py
--- nsapolicycoreutils/gui/templates/executable.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/executable.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/executable.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,156 @@
+#! /usr/bin/env python
+# Copyright (C) 2007 Red Hat
@ -6797,7 +6901,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/executable
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/__init__.py policycoreutils-2.0.9/gui/templates/__init__.py
--- nsapolicycoreutils/gui/templates/__init__.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/__init__.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/__init__.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007 Red Hat, Inc.
@ -6819,7 +6923,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/__init__.p
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/network.py policycoreutils-2.0.9/gui/templates/network.py
--- nsapolicycoreutils/gui/templates/network.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/network.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/network.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,46 @@
+te_port_types="""\
+# Default Networking
@ -6869,7 +6973,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/network.py
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/rw.py policycoreutils-2.0.9/gui/templates/rw.py
--- nsapolicycoreutils/gui/templates/rw.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/rw.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/rw.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,106 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -6979,7 +7083,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/rw.py poli
+"""
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py policycoreutils-2.0.9/gui/templates/script.py
--- nsapolicycoreutils/gui/templates/script.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/script.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/script.py 2007-04-13 14:15:33.000000000 -0400
@@ -0,0 +1,42 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7016,16 +7120,16 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/script.py
+"""
+
+tcp_ports="""\
+semanage ports -a -t TEMPLATETYPE_port_t -p tcp PORTNUM
+semanage port -a -t TEMPLATETYPE_port_t -p tcp PORTNUM
+"""
+
+udp_ports="""\
+semanage ports -a -t TEMPLATETYPE_port_t -p udp PORTNUM
+semanage port -a -t TEMPLATETYPE_port_t -p udp PORTNUM
+"""
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/semodule.py policycoreutils-2.0.9/gui/templates/semodule.py
--- nsapolicycoreutils/gui/templates/semodule.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/semodule.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/semodule.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,41 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7070,7 +7174,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/semodule.p
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/tmp.py policycoreutils-2.0.9/gui/templates/tmp.py
--- nsapolicycoreutils/gui/templates/tmp.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/tmp.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/tmp.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,74 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7148,7 +7252,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/tmp.py pol
+"""
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_lib.py policycoreutils-2.0.9/gui/templates/var_lib.py
--- nsapolicycoreutils/gui/templates/var_lib.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/var_lib.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/var_lib.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,107 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7259,7 +7363,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_lib.py
+"""
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_log.py policycoreutils-2.0.9/gui/templates/var_log.py
--- nsapolicycoreutils/gui/templates/var_log.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/var_log.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/var_log.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,91 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7354,7 +7458,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_log.py
+"""
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_run.py policycoreutils-2.0.9/gui/templates/var_run.py
--- nsapolicycoreutils/gui/templates/var_run.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/var_run.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/var_run.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,93 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7451,7 +7555,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_run.py
+
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_spool.py policycoreutils-2.0.9/gui/templates/var_spool.py
--- nsapolicycoreutils/gui/templates/var_spool.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/templates/var_spool.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/templates/var_spool.py 2007-04-13 13:28:43.000000000 -0400
@@ -0,0 +1,107 @@
+# Copyright (C) 2007 Red Hat
+# see file 'COPYING' for use and warranty information
@ -7562,7 +7666,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/templates/var_spool.
+"""
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-2.0.9/gui/translationsPage.py
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/translationsPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/translationsPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,111 @@
+## translationsPage.py - show selinux translations
+## Copyright (C) 2006 Red Hat, Inc.
@ -7677,7 +7781,7 @@ diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/translationsPage.py
+ self.store.set_value(iter, 1, translation)
diff --exclude-from=exclude -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-2.0.9/gui/usersPage.py
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.9/gui/usersPage.py 2007-04-13 13:16:13.000000000 -0400
+++ policycoreutils-2.0.9/gui/usersPage.py 2007-04-14 18:20:06.000000000 -0400
@@ -0,0 +1,166 @@
+## usersPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.

View File

@ -6,7 +6,7 @@
Summary: SELinux policy core utilities.
Name: policycoreutils
Version: 2.0.9
Release: 2%{?dist}
Release: 3%{?dist}
License: GPL
Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@ -108,6 +108,8 @@ system-config-selinux is a utility for managing the SELinux environment
%files gui
%{_bindir}/system-config-selinux
%{_datadir}/applications/fedora-system-config-selinux.desktop
%dir %{_datadir}/system-config-selinux
%dir %{_datadir}/system-config-selinux/templates
%{_datadir}/system-config-selinux/*.py*
%{_datadir}/system-config-selinux/selinux.tbl
%{_datadir}/system-config-selinux/*png
@ -190,6 +192,9 @@ if [ "$1" -ge "1" ]; then
fi
%changelog
* Sat Apr 14 2007 Dan Walsh <dwalsh@redhat.com> 2.0.9-3
- Fixes for policygengui
* Fri Apr 13 2007 Dan Walsh <dwalsh@redhat.com> 2.0.9-2
- Add polgengui