* Tue Aug 18 2009 Dan Walsh <dwalsh@redhat.com> 2.0.71-3

- Fix semanage command
This commit is contained in:
Daniel J Walsh 2009-08-18 12:32:44 +00:00
parent a66c52cf6b
commit 2b1f1bd524
2 changed files with 65 additions and 60 deletions

View File

@ -1,15 +1,15 @@
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.71/Makefile
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/Makefile policycoreutils-2.0.71/Makefile
--- nsapolicycoreutils/Makefile 2008-08-28 09:34:24.000000000 -0400
+++ policycoreutils-2.0.71/Makefile 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/Makefile 2009-08-13 17:57:54.000000000 -0400
@@ -1,4 +1,4 @@
-SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
+SUBDIRS = setfiles semanage load_policy newrole run_init secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
INOTIFYH = $(shell ls /usr/include/sys/inotify.h 2>/dev/null)
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/Makefile policycoreutils-2.0.71/restorecond/Makefile
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/Makefile policycoreutils-2.0.71/restorecond/Makefile
--- nsapolicycoreutils/restorecond/Makefile 2009-02-18 16:44:47.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/Makefile 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/Makefile 2009-08-13 17:57:54.000000000 -0400
@@ -2,16 +2,23 @@
PREFIX ?= ${DESTDIR}/usr
SBINDIR ?= $(PREFIX)/sbin
@ -51,16 +51,16 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
relabel: install
/sbin/restorecon $(SBINDIR)/restorecond
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/org.selinux.Restorecond.service policycoreutils-2.0.71/restorecond/org.selinux.Restorecond.service
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/org.selinux.Restorecond.service policycoreutils-2.0.71/restorecond/org.selinux.Restorecond.service
--- nsapolicycoreutils/restorecond/org.selinux.Restorecond.service 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/org.selinux.Restorecond.service 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/org.selinux.Restorecond.service 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,3 @@
+[D-BUS Service]
+Name=org.selinux.Restorecond
+Exec=/usr/sbin/restorecond -u
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.71/restorecond/restorecond.c
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.c policycoreutils-2.0.71/restorecond/restorecond.c
--- nsapolicycoreutils/restorecond/restorecond.c 2009-02-18 16:44:47.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/restorecond.c 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond.c 2009-08-13 17:57:54.000000000 -0400
@@ -48,294 +48,37 @@
#include <signal.h>
#include <string.h>
@ -263,7 +263,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
-{
- char *line_buf = NULL;
- size_t len = 0;
-
- while (getline(&line_buf, &len, cfg) > 0) {
- char *buffer = line_buf;
- while (isspace(*buffer))
@ -282,7 +282,10 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
- }
- free(line_buf);
-}
-
+static char *server_watch_file = "/etc/selinux/restorecond.conf";
+static char *user_watch_file = "/etc/selinux/restorecond_user.conf";
+static char *watch_file;
-/*
- Read config file ignoring Comment lines
- Files specified one per line. Files with "~" will be expanded to the logged in users
@ -292,7 +295,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
-static void read_config(int fd)
-{
- char *watch_file_path = "/etc/selinux/restorecond.conf";
-
- FILE *cfg = NULL;
- if (debug_mode)
- printf("Read Config\n");
@ -311,9 +314,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
- if (master_wd == -1)
- exitApp("Error watching config file.");
-}
+static char *server_watch_file = "/etc/selinux/restorecond.conf";
+static char *user_watch_file = "/etc/selinux/restorecond_user.conf";
+static char *watch_file;
+#include <selinux/selinux.h>
-/*
- Inotify watch loop
@ -348,22 +349,21 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
- if (event->len)
- watch_list_find(event->wd, event->name);
- break;
+#include <selinux/selinux.h>
-
- case 1: /* utmp has changed need to reload */
- read_config(fd);
- break;
-
- default: /* No users logged in or out */
- break;
- }
- }
+int debug_mode = 0;
+int verbose_mode = 0;
+int terminate = 0;
+int master_wd = -1;
+int run_as_user = 0;
- default: /* No users logged in or out */
- break;
- }
- }
-
- i += EVENT_SIZE + event->len;
- }
- return 0;
@ -525,9 +525,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
if (pidfile)
unlink(pidfile);
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-2.0.71/restorecond/restorecond.conf
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.conf policycoreutils-2.0.71/restorecond/restorecond.conf
--- nsapolicycoreutils/restorecond/restorecond.conf 2009-05-18 13:53:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond.conf 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond.conf 2009-08-13 17:57:54.000000000 -0400
@@ -4,8 +4,5 @@
/etc/mtab
/var/run/utmp
@ -538,9 +538,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
/root/.ssh/*
-
-
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.desktop policycoreutils-2.0.71/restorecond/restorecond.desktop
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.desktop policycoreutils-2.0.71/restorecond/restorecond.desktop
--- nsapolicycoreutils/restorecond/restorecond.desktop 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/restorecond.desktop 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond.desktop 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=File Context maintainer
@ -549,9 +549,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+Encoding=UTF-8
+Type=Application
+StartupNotify=false
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.h policycoreutils-2.0.71/restorecond/restorecond.h
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond.h policycoreutils-2.0.71/restorecond/restorecond.h
--- nsapolicycoreutils/restorecond/restorecond.h 2008-08-28 09:34:24.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond.h 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond.h 2009-08-13 17:57:54.000000000 -0400
@@ -24,7 +24,22 @@
#ifndef RESTORED_CONFIG_H
#define RESTORED_CONFIG_H
@ -577,15 +577,15 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+extern void watch_list_free(int fd);
#endif
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond_user.conf policycoreutils-2.0.71/restorecond/restorecond_user.conf
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/restorecond_user.conf policycoreutils-2.0.71/restorecond/restorecond_user.conf
--- nsapolicycoreutils/restorecond/restorecond_user.conf 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/restorecond_user.conf 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/restorecond_user.conf 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,2 @@
+~/*
+~/public_html/*
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/user.c policycoreutils-2.0.71/restorecond/user.c
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/user.c policycoreutils-2.0.71/restorecond/user.c
--- nsapolicycoreutils/restorecond/user.c 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/user.c 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/user.c 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,220 @@
+/*
+ * restorecond
@ -807,9 +807,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+ return 0;
+}
+
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/walk.c policycoreutils-2.0.71/restorecond/walk.c
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/walk.c policycoreutils-2.0.71/restorecond/walk.c
--- nsapolicycoreutils/restorecond/walk.c 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/walk.c 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/walk.c 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,30 @@
+#define _XOPEN_SOURCE 500
+#include <ftw.h>
@ -841,9 +841,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+ printf("Total Dirs %d\n",ctr);
+ exit(EXIT_SUCCESS);
+}
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/watch.c policycoreutils-2.0.71/restorecond/watch.c
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/restorecond/watch.c policycoreutils-2.0.71/restorecond/watch.c
--- nsapolicycoreutils/restorecond/watch.c 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/restorecond/watch.c 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/restorecond/watch.c 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,346 @@
+#define _GNU_SOURCE
+#include <sys/inotify.h>
@ -1191,9 +1191,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+ exitApp("Error watching config file.");
+}
+
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.71/scripts/chcat
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/chcat policycoreutils-2.0.71/scripts/chcat
--- nsapolicycoreutils/scripts/chcat 2009-06-23 15:36:07.000000000 -0400
+++ policycoreutils-2.0.71/scripts/chcat 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/scripts/chcat 2009-08-13 17:57:54.000000000 -0400
@@ -435,6 +435,8 @@
continue
except ValueError, e:
@ -1203,9 +1203,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
sys.exit(errors)
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/Makefile policycoreutils-2.0.71/scripts/Makefile
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/Makefile policycoreutils-2.0.71/scripts/Makefile
--- nsapolicycoreutils/scripts/Makefile 2008-08-28 09:34:24.000000000 -0400
+++ policycoreutils-2.0.71/scripts/Makefile 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/scripts/Makefile 2009-08-13 17:57:54.000000000 -0400
@@ -5,11 +5,12 @@
MANDIR ?= $(PREFIX)/share/man
LOCALEDIR ?= /usr/share/locale
@ -1220,9 +1220,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
install -m 755 fixfiles $(DESTDIR)/sbin
install -m 755 genhomedircon $(SBINDIR)
-mkdir -p $(MANDIR)/man8
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/sandbox policycoreutils-2.0.71/scripts/sandbox
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/sandbox policycoreutils-2.0.71/scripts/sandbox
--- nsapolicycoreutils/scripts/sandbox 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/scripts/sandbox 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/scripts/sandbox 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,139 @@
+#!/usr/bin/python -E
+import os, sys, getopt, socket, random, fcntl
@ -1363,9 +1363,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+ error_exit(error.args[1])
+
+ sys.exit(rc)
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/sandbox.8 policycoreutils-2.0.71/scripts/sandbox.8
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/sandbox.8 policycoreutils-2.0.71/scripts/sandbox.8
--- nsapolicycoreutils/scripts/sandbox.8 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/scripts/sandbox.8 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/scripts/sandbox.8 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,22 @@
+.TH SANDBOX "8" "May 2009" "chcat" "User Commands"
+.SH NAME
@ -1389,9 +1389,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+.TP
+runcon(1)
+.PP
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/sandbox.py policycoreutils-2.0.71/scripts/sandbox.py
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/scripts/sandbox.py policycoreutils-2.0.71/scripts/sandbox.py
--- nsapolicycoreutils/scripts/sandbox.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-2.0.71/scripts/sandbox.py 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/scripts/sandbox.py 2009-08-13 17:57:54.000000000 -0400
@@ -0,0 +1,67 @@
+#!/usr/bin/python
+import os, sys, getopt, socket, random, fcntl
@ -1460,9 +1460,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
+ mount(mount_src, filecon)
+ umount(filecon)
+os.execvp(cmds[0], cmds)
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.71/semanage/semanage
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage policycoreutils-2.0.71/semanage/semanage
--- nsapolicycoreutils/semanage/semanage 2009-05-18 13:53:14.000000000 -0400
+++ policycoreutils-2.0.71/semanage/semanage 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/semanage/semanage 2009-08-18 08:16:04.000000000 -0400
@@ -44,16 +44,17 @@
text = _("""
semanage [ -S store ] -i [ input_file | - ]
@ -1540,7 +1540,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
'ftype=',
'file',
'help',
@@ -248,9 +261,15 @@
@@ -248,9 +259,15 @@
if o == "-f" or o == "--ftype":
ftype=a
@ -1556,7 +1556,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
if o == "-h" or o == "--help":
raise ValueError(_("%s bad option") % o)
@@ -324,6 +343,9 @@
@@ -324,6 +341,9 @@
if object == "boolean":
OBJECT = seobject.booleanRecords(store)
@ -1566,7 +1566,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
if object == "translation":
OBJECT = seobject.setransRecords()
@@ -341,6 +363,13 @@
@@ -341,6 +361,13 @@
OBJECT.deleteall()
return
@ -1580,7 +1580,7 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
if len(cmds) != 1:
raise ValueError(_("%s bad option") % o)
@@ -362,11 +391,17 @@
@@ -362,11 +389,17 @@
if object == "interface":
OBJECT.add(target, serange, setype)
@ -1591,14 +1591,15 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
OBJECT.add(target, mask, proto, serange, setype)
if object == "fcontext":
- OBJECT.add(target, setype, ftype, serange, seuser)
+ if equal == "":
OBJECT.add(target, setype, ftype, serange, seuser)
+ OBJECT.add(target, setype, ftype, serange, seuser)
+ else:
+ OBJECT.add_equal(target, equal)
if object == "permissive":
OBJECT.add(target)
@@ -386,6 +421,9 @@
@@ -386,6 +419,9 @@
rlist = roles.split()
OBJECT.modify(target, rlist, selevel, serange, prefix)
@ -1608,20 +1609,21 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
if object == "port":
OBJECT.modify(target, proto, serange, setype)
@@ -396,7 +434,10 @@
@@ -396,7 +432,10 @@
OBJECT.modify(target, mask, proto, serange, setype)
if object == "fcontext":
- OBJECT.modify(target, setype, ftype, serange, seuser)
+ if equal == "":
OBJECT.modify(target, setype, ftype, serange, seuser)
+ OBJECT.modify(target, setype, ftype, serange, seuser)
+ else:
+ OBJECT.modify_equal(target, equal)
return
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-2.0.71/semanage/semanage.8
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-2.0.71/semanage/semanage.8
--- nsapolicycoreutils/semanage/semanage.8 2008-08-28 09:34:24.000000000 -0400
+++ policycoreutils-2.0.71/semanage/semanage.8 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/semanage/semanage.8 2009-08-13 17:57:54.000000000 -0400
@@ -21,6 +21,8 @@
.br
.B semanage permissive \-{a|d} type
@ -1631,9 +1633,9 @@ diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 -
.B semanage translation \-{a|d|m} [\-T] level
.P
diff -b -B --ignore-all-space --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.71/semanage/seobject.py
diff --exclude-from=exclude --exclude=sepolgen-1.0.16 --exclude=gui --exclude=po -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-2.0.71/semanage/seobject.py
--- nsapolicycoreutils/semanage/seobject.py 2009-05-18 13:53:14.000000000 -0400
+++ policycoreutils-2.0.71/semanage/seobject.py 2009-08-13 11:48:14.000000000 -0400
+++ policycoreutils-2.0.71/semanage/seobject.py 2009-08-13 17:57:54.000000000 -0400
@@ -1,5 +1,5 @@
#! /usr/bin/python -E
-# Copyright (C) 2005, 2006, 2007, 2008 Red Hat

View File

@ -6,7 +6,7 @@
Summary: SELinux policy core utilities
Name: policycoreutils
Version: 2.0.71
Release: 2%{?dist}
Release: 3%{?dist}
License: GPLv2+
Group: System Environment/Base
Source: http://www.nsa.gov/selinux/archives/policycoreutils-%{version}.tgz
@ -265,6 +265,9 @@ else
fi
%changelog
* Tue Aug 18 2009 Dan Walsh <dwalsh@redhat.com> 2.0.71-3
- Fix semanage command
* Thu Aug 13 2009 Dan Walsh <dwalsh@redhat.com> 2.0.71-2
- exclude unconfined.if from sepolgen