* Mon Nov 20 2006 Dan Walsh <dwalsh@redhat.com> 1.33.2-1

- Upstream accepted my patches
This commit is contained in:
Daniel J Walsh 2006-11-20 23:41:27 +00:00
parent ebdc59a2ed
commit 159de8e8cd
2 changed files with 68 additions and 57 deletions

View File

@ -1,6 +1,6 @@
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.33.1/audit2allow/audit2allow
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/audit2allow/audit2allow policycoreutils-1.33.2/audit2allow/audit2allow
--- nsapolicycoreutils/audit2allow/audit2allow 2006-11-16 17:14:29.000000000 -0500
+++ policycoreutils-1.33.1/audit2allow/audit2allow 2006-11-15 16:29:10.000000000 -0500
+++ policycoreutils-1.33.2/audit2allow/audit2allow 2006-11-20 18:27:22.000000000 -0500
@@ -184,22 +184,26 @@
output.write(serules.out(requires, module))
output.flush()
@ -41,9 +41,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
else:
errorExit(rc[1])
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.33.1/gui/booleansPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/booleansPage.py policycoreutils-1.33.2/gui/booleansPage.py
--- nsapolicycoreutils/gui/booleansPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/booleansPage.py 2006-11-17 12:09:55.000000000 -0500
+++ policycoreutils-1.33.2/gui/booleansPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,200 @@
+#
+# booleansPage.py - GUI for Booleans page in system-config-securitylevel
@ -245,9 +245,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+ setsebool="/usr/sbin/setsebool -P %s=%d" % (key, not val)
+ commands.getstatusoutput(setsebool)
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.33.1/gui/fcontextPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/fcontextPage.py policycoreutils-1.33.2/gui/fcontextPage.py
--- nsapolicycoreutils/gui/fcontextPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/fcontextPage.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/fcontextPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,158 @@
+## fcontextPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -407,9 +407,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_value(iter, 0, fspec)
+ self.store.set_value(iter, 2, ftype)
+ self.store.set_value(iter, 1, "system_u:object_r:%s:%s" % (type, mls))
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.33.1/gui/loginsPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/loginsPage.py policycoreutils-1.33.2/gui/loginsPage.py
--- nsapolicycoreutils/gui/loginsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/loginsPage.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/loginsPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,161 @@
+## loginsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -572,9 +572,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_value(iter, 1, seuser)
+ self.store.set_value(iter, 2, seobject.translate(serange))
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-1.33.1/gui/Makefile
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/Makefile policycoreutils-1.33.2/gui/Makefile
--- nsapolicycoreutils/gui/Makefile 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/Makefile 2006-11-15 10:09:02.000000000 -0500
+++ policycoreutils-1.33.2/gui/Makefile 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,29 @@
+# Installation directories.
+PREFIX ?= ${DESTDIR}/usr
@ -605,9 +605,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+indent:
+
+relabel:
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.33.1/gui/mappingsPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/mappingsPage.py policycoreutils-1.33.2/gui/mappingsPage.py
--- nsapolicycoreutils/gui/mappingsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/mappingsPage.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/mappingsPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,54 @@
+## mappingsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -663,10 +663,10 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ for k in keys:
+ print "%-25s %-25s %-25s" % (k, dict[k][0], translate(dict[k][1]))
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.33.1/gui/modulesPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/modulesPage.py policycoreutils-1.33.2/gui/modulesPage.py
--- nsapolicycoreutils/gui/modulesPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/modulesPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,157 @@
+++ policycoreutils-1.33.2/gui/modulesPage.py 2006-11-20 18:29:29.000000000 -0500
@@ -0,0 +1,161 @@
+## modulesPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@ -791,6 +791,10 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ except ValueError, e:
+ self.error(e.args[0])
+
+ def propertiesDialog(self):
+ # Do nothing
+ return
+
+ def addDialog(self):
+ dialog = gtk.FileChooserDialog(_("Load Policy Module"),
+ None,
@ -824,10 +828,10 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.33.1/gui/portsPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/portsPage.py policycoreutils-1.33.2/gui/portsPage.py
--- nsapolicycoreutils/gui/portsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/portsPage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,209 @@
+++ policycoreutils-1.33.2/gui/portsPage.py 2006-11-20 18:40:49.000000000 -0500
@@ -0,0 +1,214 @@
+## portsPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@ -859,16 +863,16 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+##
+## I18N
+##
+PROGNAME="policycoreutils"
+PROGNAME = "policycoreutils"
+import gettext
+gettext.bindtextdomain(PROGNAME, "/usr/share/locale")
+gettext.textdomain(PROGNAME)
+TYPE_COL=0
+PROTOCOL_COL=1
+MLS_COL=2
+PORT_COL=3
+TYPE_COL = 0
+PROTOCOL_COL = 1
+MLS_COL = 2
+PORT_COL = 3
+try:
+ gettext.install(PROGNAME, localedir="/usr/share/locale", unicode=1)
+ gettext.install(PROGNAME, localedir = "/usr/share/locale", unicode = 1)
+except IOError:
+ import __builtin__
+ __builtin__.__dict__['_'] = unicode
@ -889,6 +893,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ iter = liststore.get_iter_first()
+ self.ports_protocol_combo.set_active_iter(iter)
+ self.init_store()
+ self.edit = True
+ self.load()
+
+ def init_store(self):
@ -919,11 +924,11 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_sort_func(1,self.sort_int, "")
+
+ def group_toggle(self, button):
+ on=not button.get_active()
+ self.ports_add_button.set_sensitive(on)
+ self.ports_properties_button.set_sensitive(on)
+ self.ports_delete_button.set_sensitive(on)
+ self.mls_col.set_visible(on)
+ self.edit = not button.get_active()
+ self.ports_add_button.set_sensitive(self.edit)
+ self.ports_properties_button.set_sensitive(self.edit)
+ self.ports_delete_button.set_sensitive(self.edit)
+ self.mls_col.set_visible(self.edit)
+ if on:
+ self.load()
+ else:
@ -972,16 +977,20 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_value(iter, PORT_COL, ", ".join(dict[k]))
+ self.store.set_value(iter, MLS_COL, "")
+ self.view.get_selection().select_path ((0,))
+
+
+ def propertiesDialog(self):
+ if self.edit:
+ semanagePage.propertiesDialog(self)
+
+ def dialogInit(self):
+ store, iter = self.view.get_selection().get_selected()
+ self.ports_number_entry.set_text(store.get_value(iter, PORTS_COL))
+ self.ports_number_entry.set_text(store.get_value(iter, PORT_COL))
+ self.ports_number_entry.set_sensitive(False)
+ self.ports_protocol_combo.set_sensitive(False)
+ self.ports_name_entry.set_text(store.get_value(iter, TYPE_COL))
+ self.ports_mls_entry.set_text(store.get_value(iter, MLS_COL))
+ protocol=store.get_value(iter, PROTOCOL_COL)
+ liststore=self.ports_protocol_combo.get_model()
+ protocol = store.get_value(iter, PROTOCOL_COL)
+ liststore = self.ports_protocol_combo.get_model()
+ iter = liststore.get_iter_first()
+ while iter != None and liststore.get_value(iter,0) != protocol:
+ iter = liststore.iter_next(iter)
@ -1037,10 +1046,10 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.store.set_value(iter, MLS_COL, mls)
+
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.33.1/gui/semanagePage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/semanagePage.py policycoreutils-1.33.2/gui/semanagePage.py
--- nsapolicycoreutils/gui/semanagePage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/semanagePage.py 2006-11-17 11:52:44.000000000 -0500
@@ -0,0 +1,107 @@
+++ policycoreutils-1.33.2/gui/semanagePage.py 2006-11-20 18:32:20.000000000 -0500
@@ -0,0 +1,109 @@
+## semanagePage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
+
@ -1127,6 +1136,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ def addDialog(self):
+ self.dialogClear()
+ self.dialog.set_title(_("Add %s" % self.description))
+ self.dialog.set_position(gtk.WIN_POS_MOUSE)
+
+ while self.dialog.run() == gtk.RESPONSE_OK:
+ try:
@ -1139,6 +1149,7 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ def propertiesDialog(self):
+ self.dialogInit()
+ self.dialog.set_title(_("Modify %s" % self.description))
+ self.dialog.set_position(gtk.WIN_POS_MOUSE)
+ while self.dialog.run() == gtk.RESPONSE_OK:
+ try:
+ self.modify()
@ -1148,9 +1159,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ self.dialog.hide()
+
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.33.1/gui/statusPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/statusPage.py policycoreutils-1.33.2/gui/statusPage.py
--- nsapolicycoreutils/gui/statusPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/statusPage.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/statusPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,213 @@
+## statusPage.py - show selinux status
+## Copyright (C) 2006 Red Hat, Inc.
@ -1365,9 +1376,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ return self.types[self.selinuxTypeOptionMenu.get_active()]
+
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.33.1/gui/system-config-selinux.glade
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.glade policycoreutils-1.33.2/gui/system-config-selinux.glade
--- nsapolicycoreutils/gui/system-config-selinux.glade 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/system-config-selinux.glade 2006-11-17 11:52:26.000000000 -0500
+++ policycoreutils-1.33.2/gui/system-config-selinux.glade 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,2792 @@
+<?xml version="1.0" standalone="no"?> <!--*- mode: xml -*-->
+<!DOCTYPE glade-interface SYSTEM "http://glade.gnome.org/glade-2.0.dtd">
@ -4161,9 +4172,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+</widget>
+
+</glade-interface>
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.33.1/gui/system-config-selinux.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/system-config-selinux.py policycoreutils-1.33.2/gui/system-config-selinux.py
--- nsapolicycoreutils/gui/system-config-selinux.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/system-config-selinux.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/system-config-selinux.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,156 @@
+#!/usr/bin/python
+#
@ -4321,9 +4332,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+
+ app = childWindow()
+ app.stand_alone()
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.33.1/gui/translationsPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/translationsPage.py policycoreutils-1.33.2/gui/translationsPage.py
--- nsapolicycoreutils/gui/translationsPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/translationsPage.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/translationsPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,109 @@
+## translationsPage.py - show selinux translations
+## Copyright (C) 2006 Red Hat, Inc.
@ -4434,9 +4445,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ store, iter = self.view.get_selection().get_selected()
+ self.store.set_value(iter, 0, level)
+ self.store.set_value(iter, 1, translation)
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.33.1/gui/usersPage.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/gui/usersPage.py policycoreutils-1.33.2/gui/usersPage.py
--- nsapolicycoreutils/gui/usersPage.py 1969-12-31 19:00:00.000000000 -0500
+++ policycoreutils-1.33.1/gui/usersPage.py 2006-11-17 11:52:44.000000000 -0500
+++ policycoreutils-1.33.2/gui/usersPage.py 2006-11-20 18:27:22.000000000 -0500
@@ -0,0 +1,155 @@
+## usersPage.py - show selinux mappings
+## Copyright (C) 2006 Red Hat, Inc.
@ -4593,18 +4604,18 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
+ except ValueError, e:
+ self.error(e.args[0])
+
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.1/Makefile
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/Makefile policycoreutils-1.33.2/Makefile
--- nsapolicycoreutils/Makefile 2006-11-16 17:15:00.000000000 -0500
+++ policycoreutils-1.33.1/Makefile 2006-11-14 09:54:05.000000000 -0500
+++ policycoreutils-1.33.2/Makefile 2006-11-20 18:27:22.000000000 -0500
@@ -1,4 +1,4 @@
-SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po
+SUBDIRS=setfiles semanage load_policy newrole run_init restorecon restorecond secon audit2allow audit2why scripts sestatus semodule_package semodule semodule_link semodule_expand semodule_deps setsebool po gui
all install relabel clean indent:
@for subdir in $(SUBDIRS); do \
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/newrole/newrole.c policycoreutils-1.33.1/newrole/newrole.c
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/newrole/newrole.c policycoreutils-1.33.2/newrole/newrole.c
--- nsapolicycoreutils/newrole/newrole.c 2006-11-20 12:19:55.000000000 -0500
+++ policycoreutils-1.33.1/newrole/newrole.c 2006-11-17 11:55:39.000000000 -0500
+++ policycoreutils-1.33.2/newrole/newrole.c 2006-11-20 18:27:22.000000000 -0500
@@ -1068,11 +1068,16 @@
*/
int rc;
@ -4623,9 +4634,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
if (restore_tty_label(fd, ttyn, tty_context, new_tty_context)) {
fprintf(stderr, _("Unable to restore tty label...\n"));
exit_code = -1;
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/run_init/run_init.c policycoreutils-1.33.1/run_init/run_init.c
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/run_init/run_init.c policycoreutils-1.33.2/run_init/run_init.c
--- nsapolicycoreutils/run_init/run_init.c 2006-11-16 17:14:27.000000000 -0500
+++ policycoreutils-1.33.1/run_init/run_init.c 2006-11-16 09:37:03.000000000 -0500
+++ policycoreutils-1.33.2/run_init/run_init.c 2006-11-20 18:27:22.000000000 -0500
@@ -132,6 +132,14 @@
result = 1; /* user authenticated OK! */
}
@ -4641,9 +4652,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
/* We're done with PAM. Free `pam_handle'. */
pam_end(pam_handle, PAM_SUCCESS);
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-1.33.1/semanage/semanage.8
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/semanage.8 policycoreutils-1.33.2/semanage/semanage.8
--- nsapolicycoreutils/semanage/semanage.8 2006-11-20 12:19:55.000000000 -0500
+++ policycoreutils-1.33.1/semanage/semanage.8 2006-11-17 09:57:31.000000000 -0500
+++ policycoreutils-1.33.2/semanage/semanage.8 2006-11-20 18:27:22.000000000 -0500
@@ -82,9 +82,6 @@
.TP
.I \-T, \-\-trans
@ -4654,9 +4665,9 @@ diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolic
.SH EXAMPLE
.nf
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.33.1/semanage/seobject.py
diff --exclude-from=exclude --exclude='*.po' --exclude='*.pot' -N -u -r nsapolicycoreutils/semanage/seobject.py policycoreutils-1.33.2/semanage/seobject.py
--- nsapolicycoreutils/semanage/seobject.py 2006-11-16 17:14:26.000000000 -0500
+++ policycoreutils-1.33.1/semanage/seobject.py 2006-11-15 18:20:53.000000000 -0500
+++ policycoreutils-1.33.2/semanage/seobject.py 2006-11-20 18:27:22.000000000 -0500
@@ -94,23 +94,25 @@
return re.search("^" + reg +"$",raw)

View File

@ -45,7 +45,7 @@ context.
%patch1 -p1 -b .rhatpo
%build
make LOG_AUDIT_PRIV=y LIBDIR="%{_libdir}" CFLAGS="%{optflags} -fPIE" LDFLAGS="-pie" all
make LOG_AUDIT_PRIV=y LIBDIR="%{_libdir}" CFLAGS="%{optflags} -fPIE" LDFLAGS="-pie -Wl,-z,relro" all
%install
rm -rf %{buildroot}