New upstream version
This commit is contained in:
parent
aba099dad1
commit
2bfac66739
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ poedit-1.4.6.1.tar.gz
|
||||
/poedit-1.5.4.tar.gz
|
||||
/poedit-1.7.1.tar.gz
|
||||
/poedit-1.7.3.tar.gz
|
||||
/poedit-1.7.4.tar.gz
|
||||
|
@ -5,8 +5,8 @@
|
||||
msgid ""
|
||||
msgstr ""
|
||||
"Project-Id-Version: manpages-de\n"
|
||||
"POT-Creation-Date: 2015-01-14 20:25+0100\n"
|
||||
"PO-Revision-Date: 2015-01-14 20:27+0100\n"
|
||||
"POT-Creation-Date: 2015-03-05 11:18+0100\n"
|
||||
"PO-Revision-Date: 2015-03-05 11:19+0100\n"
|
||||
"Last-Translator: Mario Blättermann <mario.blaettermann@gmail.com>\n"
|
||||
"Language-Team: German <debian-l10n-german@lists.debian.org>\n"
|
||||
"Language: de\n"
|
||||
@ -24,8 +24,8 @@ msgstr "POEDIT"
|
||||
#. type: TH
|
||||
#: poedit.1:10
|
||||
#, no-wrap
|
||||
msgid "01/10/2015"
|
||||
msgstr "10. Januar 2015"
|
||||
msgid "01/26/2015"
|
||||
msgstr "26. Januar 2015"
|
||||
|
||||
#. type: TH
|
||||
#: poedit.1:10
|
||||
|
12
poedit.spec
12
poedit.spec
@ -1,6 +1,6 @@
|
||||
Name: poedit
|
||||
Version: 1.7.3
|
||||
Release: 5%{?dist}
|
||||
Version: 1.7.4
|
||||
Release: 1%{?dist}
|
||||
Summary: GUI editor for GNU gettext .po files
|
||||
Summary(de): Grafischer Editor für GNU Gettext-Dateien
|
||||
|
||||
@ -10,9 +10,6 @@ URL: http://www.poedit.net/
|
||||
Source0: https://github.com/vslavik/%{name}/releases/download/v%{version}-oss/%{name}-%{version}.tar.gz
|
||||
Source1: https://mariobl.fedorapeople.org/Translations/%{name}.1.de.po
|
||||
Source2: %{name}.appdata.xml
|
||||
# backported from Git
|
||||
Patch0: %{name}_broken_file_actions.diff
|
||||
Patch1: %{name}_disable_undo_redo.diff
|
||||
|
||||
BuildRequires: wxGTK3-devel >= 3.0.0
|
||||
BuildRequires: gtkspell3-devel
|
||||
@ -37,8 +34,6 @@ Quellcode-Parser. Es hilft beim Übersetzen von Anwendungen in andere Sprachen.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0
|
||||
%patch1
|
||||
# Make sure docs are utf-8
|
||||
for FILE in `find docs/en -name '*.hhp'`; do
|
||||
iconv -f iso-8859-15 -t utf-8 $FILE > $FILE.tmp && \
|
||||
@ -125,6 +120,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Mar 05 2015 Mario Blättermann <mario.blaettermann@gmail.com> - 1.7.4-1
|
||||
- New upstream version
|
||||
|
||||
* Wed Jan 28 2015 Petr Machata <pmachata@redhat.com> - 1.7.3-5
|
||||
- Rebuild for boost 1.57.0
|
||||
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- src/edframe.cpp
|
||||
+++ src/edframe.cpp
|
||||
@@ -3361,7 +3361,7 @@ void PoeditFrame::OnUpdateFromSourcesUpdate(wxUpdateUIEvent& event)
|
||||
void PoeditFrame::OnTextEditingCommand(wxCommandEvent& event)
|
||||
{
|
||||
#ifdef __WXGTK__
|
||||
- wxEventBlocker block(this);
|
||||
+ wxEventBlocker block(this, wxEVT_MENU);
|
||||
#endif
|
||||
wxWindow *w = wxWindow::FindFocus();
|
||||
if (!w || w == this || !w->ProcessWindowEventLocally(event))
|
||||
@@ -3371,7 +3371,7 @@ void PoeditFrame::OnTextEditingCommand(wxCommandEvent& event)
|
||||
void PoeditFrame::OnTextEditingCommandUpdate(wxUpdateUIEvent& event)
|
||||
{
|
||||
#ifdef __WXGTK__
|
||||
- wxEventBlocker block(this);
|
||||
+ wxEventBlocker block(this, wxEVT_UPDATE_UI);
|
||||
#endif
|
||||
wxWindow *w = wxWindow::FindFocus();
|
||||
if (!w || w == this || !w->ProcessWindowEventLocally(event))
|
@ -1,15 +0,0 @@
|
||||
--- src/resources/menus.xrc
|
||||
+++ src/resources/menus.xrc
|
||||
@@ -64,9 +64,9 @@
|
||||
</object>
|
||||
<object class="wxMenu" name="menu_edit">
|
||||
<label>_Edit</label>
|
||||
- <object class="wxMenuItem" name="wxID_UNDO" platform="unix|win"/>
|
||||
- <object class="wxMenuItem" name="wxID_REDO" platform="unix|win"/>
|
||||
- <object class="separator" platform="unix|win"/>
|
||||
+ <object class="wxMenuItem" name="wxID_UNDO" platform="win"/>
|
||||
+ <object class="wxMenuItem" name="wxID_REDO" platform="win"/>
|
||||
+ <object class="separator" platform="win"/>
|
||||
<object class="wxMenuItem" name="wxID_CUT"/>
|
||||
<object class="wxMenuItem" name="wxID_COPY"/>
|
||||
<object class="wxMenuItem" name="wxID_PASTE"/>
|
Loading…
Reference in New Issue
Block a user