pkgtreediff/pkgtreediff.spec

216 lines
6.0 KiB
RPMSpec

# generated by cabal-rpm-2.1.0
# https://docs.fedoraproject.org/en-US/packaging-guidelines/Haskell/
%global pkg_name pkgtreediff
%global pkgver %{pkg_name}-%{version}
# one test needs network
%bcond_with tests
Name: %{pkg_name}
Version: 0.6.0
Release: 2%{?dist}
Summary: RPM package tree diff tool
License: GPL-3.0-or-later
Url: https://hackage.haskell.org/package/%{name}
# Begin cabal-rpm sources:
Source0: https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
# End cabal-rpm sources
# Begin cabal-rpm deps:
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-Glob-devel
BuildRequires: ghc-async-devel
BuildRequires: ghc-base-devel
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-directory-devel
BuildRequires: ghc-extra-devel
BuildRequires: ghc-filepath-devel
BuildRequires: ghc-http-client-devel
BuildRequires: ghc-http-client-tls-devel
BuildRequires: ghc-http-directory-devel
BuildRequires: ghc-http-types-devel
BuildRequires: ghc-koji-devel
BuildRequires: ghc-rpm-nvr-devel
BuildRequires: ghc-simple-cmd-devel
BuildRequires: ghc-simple-cmd-args-devel
BuildRequires: ghc-text-devel
%if %{with ghc_prof}
BuildRequires: ghc-Glob-prof
BuildRequires: ghc-async-prof
BuildRequires: ghc-base-prof
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-directory-prof
BuildRequires: ghc-extra-prof
BuildRequires: ghc-filepath-prof
BuildRequires: ghc-http-client-prof
BuildRequires: ghc-http-client-tls-prof
BuildRequires: ghc-http-directory-prof
BuildRequires: ghc-http-types-prof
BuildRequires: ghc-koji-prof
BuildRequires: ghc-rpm-nvr-prof
BuildRequires: ghc-simple-cmd-prof
BuildRequires: ghc-simple-cmd-args-prof
BuildRequires: ghc-text-prof
%endif
# End cabal-rpm deps
%description
Tool for comparing RPM packages and version-releases in OS dist trees or
instances.
%package -n ghc-%{name}
Summary: Haskell %{name} library
%description -n ghc-%{name}
This package provides the Haskell %{name} shared library.
%package -n ghc-%{name}-devel
Summary: Haskell %{name} library development files
Provides: ghc-%{name}-static = %{version}-%{release}
Provides: ghc-%{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc-compiler = %{ghc_version}
%endif
Requires: ghc-%{name}%{?_isa} = %{version}-%{release}
%description -n ghc-%{name}-devel
This package provides the Haskell %{name} library development files.
%if %{with haddock}
%package -n ghc-%{name}-doc
Summary: Haskell %{name} library documentation
BuildArch: noarch
Requires: ghc-filesystem
%description -n ghc-%{name}-doc
This package provides the Haskell %{name} library documentation.
%endif
%if %{with ghc_prof}
%package -n ghc-%{name}-prof
Summary: Haskell %{name} profiling library
Requires: ghc-%{name}-devel%{?_isa} = %{version}-%{release}
Supplements: (ghc-%{name}-devel and ghc-prof)
%description -n ghc-%{name}-prof
This package provides the Haskell %{name} profiling library.
%endif
%prep
# Begin cabal-rpm setup:
%setup -q
# End cabal-rpm setup
%build
# Begin cabal-rpm build:
%ghc_lib_build
# End cabal-rpm build
%install
# Begin cabal-rpm install
%ghc_lib_install
mkdir -p %{buildroot}%{_datadir}/bash-completion/completions/
%{buildroot}%{_bindir}/%{name} --bash-completion-script %{name} | sed s/filenames/default/ > %{buildroot}%{_datadir}/bash-completion/completions/%{name}
# End cabal-rpm install
%check
%if %{with tests}
%cabal_test
%endif
%files
# Begin cabal-rpm files:
%license LICENSE
%doc CHANGELOG.md README.md TODO
%{_bindir}/%{name}
%{_datadir}/bash-completion/completions/%{name}
# End cabal-rpm files
%files -n ghc-%{name} -f ghc-%{name}.files
# Begin cabal-rpm files:
%license LICENSE
# End cabal-rpm files
%files -n ghc-%{name}-devel -f ghc-%{name}-devel.files
%doc CHANGELOG.md README.md TODO
%if %{with haddock}
%files -n ghc-%{name}-doc -f ghc-%{name}-doc.files
%license LICENSE
%endif
%if %{with ghc_prof}
%files -n ghc-%{name}-prof -f ghc-%{name}-prof.files
%endif
%changelog
* Thu Feb 16 2023 Jens Petersen <petersen@redhat.com> - 0.6.0-2
- refresh to cabal-rpm-2.1.0 with SPDX migration
* Thu Oct 27 2022 Jens Petersen <petersen@redhat.com> - 0.6.0-1
- significant processing performance improvement
- allow multiple mode options; separate summary & rst options
- add support for package list files via http
- fix local filesystem recursion
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jun 17 2022 Jens Petersen <petersen@redhat.com> - 0.5.0-5
- rebuild
* Thu May 12 2022 Jens Petersen <petersen@redhat.com> - 0.5.0-4
- rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Sat Jan 08 2022 Miro Hrončok <mhroncok@redhat.com> - 0.5.0-2
- Rebuilt for https://fedoraproject.org/wiki/Changes/LIBFFI34
* Wed Nov 03 2021 Jens Petersen <petersen@redhat.com> - 0.5.0-1
- update to 0.5.0
- https://hackage.haskell.org/package/pkgtreediff-0.5.0/changelog
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 0.4.1-2
- Rebuilt with OpenSSL 3.0.0
* Thu Aug 5 2021 Jens Petersen <petersen@redhat.com> - 0.4.1-1
- update to 0.4.1
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-5
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jul 17 2020 Jens Petersen <petersen@redhat.com> - 0.4-2
- refresh to cabal-rpm-2.0.6
* Fri Mar 13 2020 Jens Petersen <petersen@redhat.com> - 0.4-1
- update to 0.4
* Thu Jan 23 2020 Fedora Haskell SIG <haskell@lists.fedoraproject.org> - 0.3-1
- spec file generated by cabal-rpm-2.0.0