php/php-5.2.4-tests-dashn.patch

56 lines
2.1 KiB
Diff

--- php-5.2.4/ext/standard/tests/file/bug26615.phpt.tests-dashn
+++ php-5.2.4/ext/standard/tests/file/bug26615.phpt
@@ -7,9 +7,9 @@ variables_order=E
$out = array();
$status = -1;
if (substr(PHP_OS, 0, 3) != 'WIN') {
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
} else {
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
}
print_r($out);
?>
--- php-5.2.4/ext/standard/tests/file/proc_open01.phpt.tests-dashn
+++ php-5.2.4/ext/standard/tests/file/proc_open01.phpt
@@ -9,7 +9,7 @@ if ($php === false) {
die("no php executable defined");
}
$proc = proc_open(
- $php,
+ $php . " -n",
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
$pipes
);
--- php-5.2.4/ext/standard/tests/file/bug26938.phpt.tests-dashn
+++ php-5.2.4/ext/standard/tests/file/bug26938.phpt
@@ -6,14 +6,14 @@ $out = array();
$status = -1;
$php = getenv('TEST_PHP_EXECUTABLE');
if (substr(PHP_OS, 0, 3) != 'WIN') {
- exec($php . ' -r \''
+ exec($php . ' -n -r \''
. '$lengths = array(10,20000,10000,5,10000,3);'
. 'foreach($lengths as $length) {'
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
. ' print "\n";'
. '}\'', $out, $status);
} else {
- exec($php . ' -r "'
+ exec($php . ' -n -r "'
. '$lengths = array(10,20000,10000,5,10000,3);'
. 'foreach($lengths as $length) {'
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
--- php-5.2.4/Makefile.global.tests-dashn
+++ php-5.2.4/Makefile.global
@@ -63,7 +63,7 @@ install-headers:
done; \
fi
-PHP_TEST_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
+PHP_TEST_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1'
PHP_TEST_SHARED_EXTENSIONS = ` \
if test "x$(PHP_MODULES)" != "x"; then \
for i in $(PHP_MODULES)""; do \