php/php-5.0.4-tests-dashn.patch

64 lines
2.5 KiB
Diff

Pass -n to php when running tests, to ensure that the system inidir
and hence the installed (old) shared extensions are not loaded.
- when running run-tests.php itself
- passed to run-tests.php to ensure it's passed when running each test case
- in cases where the PHP executable is run by a test case
--- php-5.2.2/ext/standard/tests/file/bug26615.phpt.tests-dashn
+++ php-5.2.2/ext/standard/tests/file/bug26615.phpt
@@ -7,9 +7,9 @@
$out = array();
$status = -1;
if (substr(PHP_OS, 0, 3) != 'WIN') {
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r \'for($i=1;$i<=5000;$i++) print "$i\n";\' | tr \'\n\' \' \'', $out, $status);
} else {
- exec($_ENV['TEST_PHP_EXECUTABLE'].' -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
+ exec($_ENV['TEST_PHP_EXECUTABLE'].' -n -r "for($i=1;$i<=5000;$i++) echo $i,\' \';"', $out, $status);
}
print_r($out);
?>
--- php-5.2.2/ext/standard/tests/file/proc_open01.phpt.tests-dashn
+++ php-5.2.2/ext/standard/tests/file/proc_open01.phpt
@@ -9,7 +9,7 @@
die("no php executable defined");
}
$proc = proc_open(
- $php,
+ $php . " -n",
array(0 => array('pipe', 'r'), 1 => array('pipe', 'w')),
$pipes
);
--- php-5.2.2/ext/standard/tests/file/bug26938.phpt.tests-dashn
+++ php-5.2.2/ext/standard/tests/file/bug26938.phpt
@@ -6,14 +6,14 @@
$status = -1;
$php = getenv('TEST_PHP_EXECUTABLE');
if (substr(PHP_OS, 0, 3) != 'WIN') {
- exec($php . ' -r \''
+ exec($php . ' -n -r \''
. '$lengths = array(10,20000,10000,5,10000,3);'
. 'foreach($lengths as $length) {'
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
. ' print "\n";'
. '}\'', $out, $status);
} else {
- exec($php . ' -r "'
+ exec($php . ' -n -r "'
. '$lengths = array(10,20000,10000,5,10000,3);'
. 'foreach($lengths as $length) {'
. ' for($i=0;$i<$length;$i++) print chr(65+$i % 27);'
--- php-5.2.2/Makefile.global.tests-dashn
+++ php-5.2.2/Makefile.global
@@ -79,7 +79,7 @@
TEST_PHP_EXECUTABLE=$(top_builddir)/$(SAPI_CLI_PATH) \
TEST_PHP_SRCDIR=$(top_srcdir) \
CC="$(CC)" \
- $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php $(TESTS); \
+ $(top_builddir)/$(SAPI_CLI_PATH) -d 'open_basedir=' -d 'safe_mode=0' -d 'output_buffering=0' -d 'memory_limit=-1' $(top_srcdir)/run-tests.php -n $(TESTS); \
else \
echo "ERROR: Cannot run tests without CLI sapi."; \
fi