php/php-5.4.0-httpd24.patch
Joe Orton e77af5a170 rebuild against httpd 2.4
- use _httpd_mmn, _httpd_apxs macros
2012-03-26 16:49:30 +01:00

86 lines
2.9 KiB
Diff

http://svn.php.net/viewvc?view=revision&revision=323750
--- php-5.4.0/configure.in.httpd24
+++ php-5.4.0/configure.in
@@ -1587,6 +1587,21 @@ cat <<X
X
fi
+ if test "$PHP_SAPI" = "apache2handler" || test "$PHP_SAPI" = "apache2filter"; then
+ if test "$APACHE_VERSION" -ge 2004001; then
+ if test -z "$APACHE_THREADED_MPM"; then
+cat <<X
++--------------------------------------------------------------------+
+| *** WARNING *** |
+| |
+| You have built PHP for Apache's current non-threaded MPM. |
+| If you change Apache to use a threaded MPM you must reconfigure |
+| PHP with --enable-maintainer-zts |
+X
+ fi
+ fi
+ fi
+
# Warn about linking Apache with libpthread if oci8 extension is enabled on linux.
if test "$PHP_OCI8" != "no"; then
if test "$PHP_SAPI" = "apache"; then
--- php-5.4.0/sapi/apache2filter/config.m4.httpd24
+++ php-5.4.0/sapi/apache2filter/config.m4
@@ -39,7 +39,6 @@ if test "$PHP_APXS2FILTER" != "no"; then
APXS_BINDIR=`$APXS -q BINDIR`
APXS_HTTPD=`$APXS -q SBINDIR`/`$APXS -q TARGET`
APXS_CFLAGS=`$APXS -q CFLAGS`
- APXS_MPM=`$APXS -q MPM_NAME`
APU_BINDIR=`$APXS -q APU_BINDIR`
APR_BINDIR=`$APXS -q APR_BINDIR`
@@ -118,8 +117,16 @@ if test "$PHP_APXS2FILTER" != "no"; then
;;
esac
- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser"; then
- PHP_BUILD_THREAD_SAFE
+ if test "$APACHE_VERSION" -lt 2004001; then
+ APXS_MPM=`$APXS -q MPM_NAME`
+ if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
+ else
+ APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
+ if test -n "$APACHE_THREADED_MPM"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
fi
AC_MSG_RESULT(yes)
PHP_SUBST(APXS)
--- php-5.4.0/sapi/apache2handler/config.m4.httpd24
+++ php-5.4.0/sapi/apache2handler/config.m4
@@ -38,7 +38,6 @@ if test "$PHP_APXS2" != "no"; then
APXS_BINDIR=`$APXS -q BINDIR`
APXS_HTTPD=`$APXS -q SBINDIR`/`$APXS -q TARGET`
APXS_CFLAGS=`$APXS -q CFLAGS`
- APXS_MPM=`$APXS -q MPM_NAME`
APU_BINDIR=`$APXS -q APU_BINDIR`
APR_BINDIR=`$APXS -q APR_BINDIR`
@@ -117,8 +116,16 @@ if test "$PHP_APXS2" != "no"; then
;;
esac
- if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
- PHP_BUILD_THREAD_SAFE
+ if test "$APACHE_VERSION" -lt 2004001; then
+ APXS_MPM=`$APXS -q MPM_NAME`
+ if test "$APXS_MPM" != "prefork" && test "$APXS_MPM" != "peruser" && test "$APXS_MPM" != "itk"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
+ else
+ APACHE_THREADED_MPM=`$APXS_HTTPD -V | grep 'threaded:.*yes'`
+ if test -n "$APACHE_THREADED_MPM"; then
+ PHP_BUILD_THREAD_SAFE
+ fi
fi
AC_MSG_RESULT(yes)
PHP_SUBST(APXS)