PHP 5.6.0RC2
This commit is contained in:
parent
b9eda6e77b
commit
f375c6a3b0
1
.gitignore
vendored
1
.gitignore
vendored
@ -26,3 +26,4 @@ php-5.4.*.bz2
|
||||
/php-5.5.12-strip.tar.xz
|
||||
/php-5.5.13-strip.tar.xz
|
||||
/php-5.6.0RC1-strip.tar.xz
|
||||
/php-5.6.0RC2-strip.tar.xz
|
||||
|
26
php-man.patch
Normal file
26
php-man.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 07d227229771015600789ae36e3b12ce29b1f339 Mon Sep 17 00:00:00 2001
|
||||
From: Andy Thompson <me@andytson.com>
|
||||
Date: Sat, 5 Jul 2014 13:05:05 +0100
|
||||
Subject: [PATCH] Fix phpdbg.1 man page installation when build != src
|
||||
directory
|
||||
|
||||
---
|
||||
Makefile.frag | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.frag b/Makefile.frag
|
||||
index b276aaa..36c7512 100644
|
||||
--- a/sapi/phpdbg/Makefile.frag
|
||||
+++ b/sapi/phpdbg/Makefile.frag
|
||||
@@ -28,7 +28,7 @@ install-phpdbg: $(BUILD_BINARY)
|
||||
@$(INSTALL) -m 0755 $(BUILD_BINARY) $(INSTALL_ROOT)$(bindir)/$(program_prefix)phpdbg$(program_suffix)$(EXEEXT)
|
||||
@echo "Installing phpdbg man page: $(INSTALL_ROOT)$(mandir)/man1/"
|
||||
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man1
|
||||
- @$(INSTALL_DATA) sapi/phpdbg/phpdbg.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)phpdbg$(program_suffix).1
|
||||
+ @$(INSTALL_DATA) $(srcdir)/phpdbg.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)phpdbg$(program_suffix).1
|
||||
|
||||
clean-phpdbg:
|
||||
@echo "Cleaning phpdbg object files ..."
|
||||
--
|
||||
1.9.2
|
||||
|
120
php-phpdbg.patch
120
php-phpdbg.patch
@ -1,120 +0,0 @@
|
||||
diff -up sapi/phpdbg/config.m4.old sapi/phpdbg/config.m4
|
||||
--- sapi/phpdbg/config.m4.old 2014-06-23 09:42:29.381980030 +0200
|
||||
+++ sapi/phpdbg/config.m4 2014-06-23 09:20:13.948592684 +0200
|
||||
@@ -21,7 +21,7 @@ if test "$PHP_PHPDBG" != "no"; then
|
||||
PHP_PHPDBG_CFLAGS="-D_GNU_SOURCE"
|
||||
PHP_PHPDBG_FILES="phpdbg.c phpdbg_parser.c phpdbg_lexer.c phpdbg_prompt.c phpdbg_help.c phpdbg_break.c phpdbg_print.c phpdbg_bp.c phpdbg_opcode.c phpdbg_list.c phpdbg_utils.c phpdbg_info.c phpdbg_cmd.c phpdbg_set.c phpdbg_frame.c phpdbg_watch.c phpdbg_btree.c"
|
||||
|
||||
- if test "$PHP_READLINE" != "no"; then
|
||||
+ if test "$PHP_READLINE" != "no" -o "$PHP_LIBEDIT" != "no"; then
|
||||
PHPDBG_EXTRA_LIBS="$PHP_READLINE_LIBS"
|
||||
fi
|
||||
|
||||
diff -up sapi/phpdbg/phpdbg_cmd.c.old sapi/phpdbg/phpdbg_cmd.c
|
||||
--- sapi/phpdbg/phpdbg_cmd.c.old 2014-06-23 09:43:13.910158686 +0200
|
||||
+++ sapi/phpdbg/phpdbg_cmd.c 2014-06-23 09:35:30.571299456 +0200
|
||||
@@ -792,7 +792,7 @@ PHPDBG_API int phpdbg_stack_execute(phpd
|
||||
PHPDBG_API char* phpdbg_read_input(char *buffered TSRMLS_DC) /* {{{ */
|
||||
{
|
||||
char *cmd = NULL;
|
||||
-#ifndef HAVE_LIBREADLINE
|
||||
+#if !defined(HAVE_LIBREADLINE) && !defined(HAVE_LIBEDIT)
|
||||
char buf[PHPDBG_MAX_CMD];
|
||||
#endif
|
||||
char *buffer = NULL;
|
||||
@@ -811,7 +811,7 @@ disconnect:
|
||||
return NULL;
|
||||
}
|
||||
|
||||
-#ifndef HAVE_LIBREADLINE
|
||||
+#if !defined(HAVE_LIBREADLINE) && !defined(HAVE_LIBEDIT)
|
||||
if (!(PHPDBG_G(flags) & PHPDBG_IS_REMOTE)) {
|
||||
if (!phpdbg_write("%s", phpdbg_get_prompt(TSRMLS_C))) {
|
||||
goto disconnect;
|
||||
@@ -850,7 +850,7 @@ readline:
|
||||
|
||||
buffer = estrdup(cmd);
|
||||
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#if defined(HAVE_LIBREADLINE) || defined(HAVE_LIBEDIT)
|
||||
if (!buffered && cmd &&
|
||||
!(PHPDBG_G(flags) & PHPDBG_IS_REMOTE)) {
|
||||
free(cmd);
|
||||
diff -up sapi/phpdbg/phpdbg.h.old sapi/phpdbg/phpdbg.h
|
||||
--- sapi/phpdbg/phpdbg.h.old 2014-06-23 09:42:47.364052178 +0200
|
||||
+++ sapi/phpdbg/phpdbg.h 2014-06-23 09:22:20.941107800 +0200
|
||||
@@ -64,7 +64,7 @@
|
||||
# include "TSRM.h"
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#if defined(HAVE_LIBREADLINE) || defined(HAVE_LIBEDIT)
|
||||
# include <readline/readline.h>
|
||||
# include <readline/history.h>
|
||||
#endif
|
||||
diff -up sapi/phpdbg/phpdbg_prompt.c.old sapi/phpdbg/phpdbg_prompt.c
|
||||
--- sapi/phpdbg/phpdbg_prompt.c.old 2014-06-23 09:43:04.216119792 +0200
|
||||
+++ sapi/phpdbg/phpdbg_prompt.c 2014-06-23 09:32:02.850463053 +0200
|
||||
@@ -732,6 +732,11 @@ PHPDBG_COMMAND(print) /* {{{ */
|
||||
#else
|
||||
phpdbg_writeln("Readline\tno");
|
||||
#endif
|
||||
+#ifdef HAVE_LIBEDIT
|
||||
+ phpdbg_writeln("Libedit\t\tyes");
|
||||
+#else
|
||||
+ phpdbg_writeln("Libedit\t\tno");
|
||||
+#endif
|
||||
|
||||
phpdbg_writeln("Exec\t\t%s", PHPDBG_G(exec) ? PHPDBG_G(exec) : "none");
|
||||
phpdbg_writeln("Compiled\t%s", PHPDBG_G(ops) ? "yes" : "no");
|
||||
diff -up sapi/phpdbg/phpdbg_utils.c.old sapi/phpdbg/phpdbg_utils.c
|
||||
--- sapi/phpdbg/phpdbg_utils.c.old 2014-06-23 09:43:20.690185888 +0200
|
||||
+++ sapi/phpdbg/phpdbg_utils.c 2014-06-23 09:58:37.075896488 +0200
|
||||
@@ -400,12 +400,16 @@ PHPDBG_API const char *phpdbg_get_prompt
|
||||
}
|
||||
|
||||
/* create cached prompt */
|
||||
+#ifdef HAVE_LIBREADLINE
|
||||
+ /* TODO: libedit doesn't seems to support coloured prompt */
|
||||
if ((PHPDBG_G(flags) & PHPDBG_IS_COLOURED)) {
|
||||
asprintf(
|
||||
&PHPDBG_G(prompt)[1], "\033[%sm%s\033[0m ",
|
||||
PHPDBG_G(colors)[PHPDBG_COLOR_PROMPT]->code,
|
||||
PHPDBG_G(prompt)[0]);
|
||||
- } else {
|
||||
+ } else
|
||||
+#endif
|
||||
+ {
|
||||
asprintf(
|
||||
&PHPDBG_G(prompt)[1], "%s ",
|
||||
PHPDBG_G(prompt)[0]);
|
||||
diff -up sapi/phpdbg/phpdbg.h.orig sapi/phpdbg/phpdbg.h
|
||||
--- sapi/phpdbg/phpdbg.h.orig 2014-06-23 10:10:19.674754095 +0200
|
||||
+++ sapi/phpdbg/phpdbg.h 2014-06-23 10:13:14.041460315 +0200
|
||||
@@ -64,10 +64,13 @@
|
||||
# include "TSRM.h"
|
||||
#endif
|
||||
|
||||
-#if defined(HAVE_LIBREADLINE) || defined(HAVE_LIBEDIT)
|
||||
+#ifdef LIBREADLINE
|
||||
# include <readline/readline.h>
|
||||
# include <readline/history.h>
|
||||
#endif
|
||||
+#ifdef HAVE_LIBEDIT
|
||||
+# include <editline/readline.h>
|
||||
+#endif
|
||||
|
||||
#include "phpdbg_lexer.h"
|
||||
#include "phpdbg_cmd.h"
|
||||
diff -up sapi/phpdbg/phpdbg_utils.c.orig sapi/phpdbg/phpdbg_utils.c
|
||||
--- sapi/phpdbg/phpdbg_utils.c.orig 2014-06-23 10:10:13.224727967 +0200
|
||||
+++ sapi/phpdbg/phpdbg_utils.c 2014-06-23 10:12:41.309327759 +0200
|
||||
@@ -400,7 +400,7 @@ PHPDBG_API const char *phpdbg_get_prompt
|
||||
}
|
||||
|
||||
/* create cached prompt */
|
||||
-#ifdef HAVE_LIBREADLINE
|
||||
+#ifndef HAVE_LIBEDIT
|
||||
/* TODO: libedit doesn't seems to support coloured prompt */
|
||||
if ((PHPDBG_G(flags) & PHPDBG_IS_COLOURED)) {
|
||||
asprintf(
|
30
php-syslog.patch
Normal file
30
php-syslog.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From a0ecb3794f00e65cd2a073b2073e32d6c2fb7180 Mon Sep 17 00:00:00 2001
|
||||
From: Remi Collet <remi@php.net>
|
||||
Date: Fri, 27 Jun 2014 09:45:53 +0200
|
||||
Subject: [PATCH] Fix Bug #67530 error_log=syslog ignored
|
||||
|
||||
As for Bug #64915
|
||||
Systemd use --nodaemonize but need to error_log to file or syslog to be honoured
|
||||
---
|
||||
sapi/fpm/fpm/fpm_stdio.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/sapi/fpm/fpm/fpm_stdio.c b/sapi/fpm/fpm/fpm_stdio.c
|
||||
index d81e101..769d3a6 100644
|
||||
--- a/sapi/fpm/fpm/fpm_stdio.c
|
||||
+++ b/sapi/fpm/fpm/fpm_stdio.c
|
||||
@@ -268,7 +268,11 @@ int fpm_stdio_open_error_log(int reopen) /* {{{ */
|
||||
if (!strcasecmp(fpm_global_config.error_log, "syslog")) {
|
||||
openlog(fpm_global_config.syslog_ident, LOG_PID | LOG_CONS, fpm_global_config.syslog_facility);
|
||||
fpm_globals.error_log_fd = ZLOG_SYSLOG;
|
||||
+#if HAVE_UNISTD_H
|
||||
+ if (fpm_global_config.daemonize || (!isatty(STDERR_FILENO) && !fpm_globals.force_stderr)) {
|
||||
+#else
|
||||
if (fpm_global_config.daemonize) {
|
||||
+#endif
|
||||
zlog_set_fd(fpm_globals.error_log_fd);
|
||||
}
|
||||
return 0;
|
||||
--
|
||||
1.9.2
|
||||
|
14
php.spec
14
php.spec
@ -66,12 +66,12 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
%global rcver RC1
|
||||
%global rcver RC2
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.0
|
||||
Release: 0.2.%{rcver}%{?dist}
|
||||
Release: 0.3.%{rcver}%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -123,7 +123,8 @@ Patch47: php-5.4.9-phpinfo.patch
|
||||
Patch48: php-5.6.0-mock.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
Patch100: php-phpdbg.patch
|
||||
Patch100: php-man.patch
|
||||
Patch101: php-syslog.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -746,7 +747,8 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%patch48 -p1 -b .mock
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p0 -b .libedit
|
||||
%patch100 -p1 -b .manpath
|
||||
%patch101 -p1 -b .syslog
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1499,6 +1501,7 @@ exit 0
|
||||
%files dbg
|
||||
%{_bindir}/phpdbg
|
||||
%doc sapi/phpdbg/{README.md,CREDITS}
|
||||
%{_mandir}/man1/phpdbg.1*
|
||||
|
||||
%files fpm
|
||||
%doc php-fpm.conf.default
|
||||
@ -1579,6 +1582,9 @@ exit 0
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 7 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.3.RC2
|
||||
- php 5.6.0RC2
|
||||
|
||||
* Mon Jun 23 2014 Remi Collet <rcollet@redhat.com> 5.6.0-0.2.RC1
|
||||
- fix phpdbg with libedit https://bugs.php.net/67499
|
||||
- add workaround for unserialize/mock issue from 5.4/5.5
|
||||
|
Loading…
Reference in New Issue
Block a user