drop merged patch

This commit is contained in:
Remi Collet 2014-07-31 07:20:56 +02:00
parent 19934c7bc4
commit bd310bf389
4 changed files with 1 additions and 61 deletions

2
.gitignore vendored
View File

@ -1,7 +1,7 @@
clog
php.spec~
php-5.3.*.bz2
php-5.4.*.bz2
php-5.5.*.xz
/php-5.5.0beta1.tar.xz
/php-5.5.0beta2.tar.xz
/php-5.5.0beta3.tar.xz

View File

@ -1,26 +0,0 @@
From 07d227229771015600789ae36e3b12ce29b1f339 Mon Sep 17 00:00:00 2001
From: Andy Thompson <me@andytson.com>
Date: Sat, 5 Jul 2014 13:05:05 +0100
Subject: [PATCH] Fix phpdbg.1 man page installation when build != src
directory
---
Makefile.frag | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.frag b/Makefile.frag
index b276aaa..36c7512 100644
--- a/sapi/phpdbg/Makefile.frag
+++ b/sapi/phpdbg/Makefile.frag
@@ -28,7 +28,7 @@ install-phpdbg: $(BUILD_BINARY)
@$(INSTALL) -m 0755 $(BUILD_BINARY) $(INSTALL_ROOT)$(bindir)/$(program_prefix)phpdbg$(program_suffix)$(EXEEXT)
@echo "Installing phpdbg man page: $(INSTALL_ROOT)$(mandir)/man1/"
@$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man1
- @$(INSTALL_DATA) sapi/phpdbg/phpdbg.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)phpdbg$(program_suffix).1
+ @$(INSTALL_DATA) $(srcdir)/phpdbg.1 $(INSTALL_ROOT)$(mandir)/man1/$(program_prefix)phpdbg$(program_suffix).1
clean-phpdbg:
@echo "Cleaning phpdbg object files ..."
--
1.9.2

View File

@ -1,30 +0,0 @@
From a0ecb3794f00e65cd2a073b2073e32d6c2fb7180 Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@php.net>
Date: Fri, 27 Jun 2014 09:45:53 +0200
Subject: [PATCH] Fix Bug #67530 error_log=syslog ignored
As for Bug #64915
Systemd use --nodaemonize but need to error_log to file or syslog to be honoured
---
sapi/fpm/fpm/fpm_stdio.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/sapi/fpm/fpm/fpm_stdio.c b/sapi/fpm/fpm/fpm_stdio.c
index d81e101..769d3a6 100644
--- a/sapi/fpm/fpm/fpm_stdio.c
+++ b/sapi/fpm/fpm/fpm_stdio.c
@@ -268,7 +268,11 @@ int fpm_stdio_open_error_log(int reopen) /* {{{ */
if (!strcasecmp(fpm_global_config.error_log, "syslog")) {
openlog(fpm_global_config.syslog_ident, LOG_PID | LOG_CONS, fpm_global_config.syslog_facility);
fpm_globals.error_log_fd = ZLOG_SYSLOG;
+#if HAVE_UNISTD_H
+ if (fpm_global_config.daemonize || (!isatty(STDERR_FILENO) && !fpm_globals.force_stderr)) {
+#else
if (fpm_global_config.daemonize) {
+#endif
zlog_set_fd(fpm_globals.error_log_fd);
}
return 0;
--
1.9.2

View File

@ -123,8 +123,6 @@ Patch47: php-5.4.9-phpinfo.patch
Patch48: php-5.6.0-mock.patch
# Upstream fixes (100+)
Patch100: php-man.patch
Patch101: php-syslog.patch
# Security fixes (200+)
@ -747,8 +745,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%patch48 -p1 -b .mock
# upstream patches
%patch100 -p1 -b .manpath
%patch101 -p1 -b .syslog
# security patches