Update to 5.6.6 - http://www.php.net/releases/5_6_6.php
This commit is contained in:
parent
a789395163
commit
bb646a4440
1
.gitignore
vendored
1
.gitignore
vendored
@ -40,3 +40,4 @@ php-5.5.*.xz
|
||||
/php-5.6.5RC1-strip.tar.xz
|
||||
/php-5.6.5-strip.tar.xz
|
||||
/php-5.6.6RC1-strip.tar.xz
|
||||
/php-5.6.6-strip.tar.xz
|
||||
|
@ -1,52 +0,0 @@
|
||||
From f457487e163502480f74a70bf9272fd003fc1919 Mon Sep 17 00:00:00 2001
|
||||
From: Julien Pauli <jpauli@php.net>
|
||||
Date: Thu, 5 Feb 2015 10:01:26 +0100
|
||||
Subject: [PATCH] Revert "Fixed bug #55407 (Impossible to prototype
|
||||
DateTime::createFromFormat)"
|
||||
|
||||
This reverts commit 8e19705a93d785cd1ff8ba3a69699b00169fea47.
|
||||
---
|
||||
ext/date/php_date.c | 2 +-
|
||||
ext/date/tests/bug55407.phpt | 17 -----------------
|
||||
2 files changed, 1 insertion(+), 18 deletions(-)
|
||||
delete mode 100644 ext/date/tests/bug55407.phpt
|
||||
|
||||
diff --git a/ext/date/php_date.c b/ext/date/php_date.c
|
||||
index 8a7aeae..f8571b9 100644
|
||||
--- a/ext/date/php_date.c
|
||||
+++ b/ext/date/php_date.c
|
||||
@@ -163,7 +163,7 @@ ZEND_END_ARG_INFO()
|
||||
ZEND_BEGIN_ARG_INFO_EX(arginfo_date_create_from_format, 0, 0, 2)
|
||||
ZEND_ARG_INFO(0, format)
|
||||
ZEND_ARG_INFO(0, time)
|
||||
- ZEND_ARG_OBJ_INFO(0, object, DateTimeZone, 1)
|
||||
+ ZEND_ARG_INFO(0, object)
|
||||
ZEND_END_ARG_INFO()
|
||||
|
||||
ZEND_BEGIN_ARG_INFO_EX(arginfo_date_parse, 0, 0, 1)
|
||||
diff --git a/ext/date/tests/bug55407.phpt b/ext/date/tests/bug55407.phpt
|
||||
deleted file mode 100644
|
||||
index 00c3356..0000000
|
||||
--- a/ext/date/tests/bug55407.phpt
|
||||
+++ /dev/null
|
||||
@@ -1,17 +0,0 @@
|
||||
---TEST--
|
||||
-Bug #55407 (Impossible to prototype DateTime::createFromFormat)
|
||||
---INI--
|
||||
-error_reporting=-1
|
||||
---FILE--
|
||||
-<?php namespace melt\core;
|
||||
-
|
||||
-class DateTime extends \DateTime {
|
||||
- public static function createFromFormat($format, $time, DateTimeZone $timezone = null) {
|
||||
- return new DateTime(parent::createFromFormat($format, $time, $timezone));
|
||||
- }
|
||||
-}
|
||||
-
|
||||
-echo "DONE\n";
|
||||
-?>
|
||||
---EXPECTF--
|
||||
-DONE
|
||||
--
|
||||
2.1.4
|
||||
|
11
php.spec
11
php.spec
@ -57,12 +57,12 @@
|
||||
%global db_devel libdb-devel
|
||||
%endif
|
||||
|
||||
%global rcver RC1
|
||||
#global rcver RC1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
Version: 5.6.6
|
||||
Release: 0.1.RC1%{?dist}
|
||||
Release: 1%{?dist}
|
||||
# All files licensed under PHP version 3.01, except
|
||||
# Zend is licensed under Zend
|
||||
# TSRM is licensed under BSD
|
||||
@ -113,8 +113,6 @@ Patch46: php-5.6.3-fixheader.patch
|
||||
Patch47: php-5.6.3-phpinfo.patch
|
||||
|
||||
# Upstream fixes (100+)
|
||||
# BC break reverted for release, but after RC
|
||||
Patch100: php-datetime.patch
|
||||
|
||||
# Security fixes (200+)
|
||||
|
||||
@ -718,7 +716,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
|
||||
%patch47 -p1 -b .phpinfo
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .datetime
|
||||
|
||||
# security patches
|
||||
|
||||
@ -1476,6 +1473,10 @@ rm -f README.{Zeus,QNX,CVS-RULES}
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 19 2015 Remi Collet <remi@fedoraproject.org> 5.6.6-1
|
||||
- Update to 5.6.6
|
||||
http://www.php.net/releases/5_6_6.php
|
||||
|
||||
* Thu Feb 5 2015 Remi Collet <rcollet@redhat.com> 5.6.6-0.1.RC1
|
||||
- php 5.6.6RC1 for Koschei
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user