Update to 7.2.17 - http://www.php.net/releases/7_2_17.php
(cherry picked from commit da6b538f5c
)
This commit is contained in:
parent
7aafa8e9d0
commit
a382cd9db8
1
.gitignore
vendored
1
.gitignore
vendored
@ -29,3 +29,4 @@ php-7.1.*.xz
|
|||||||
/php-7.2.14.tar.xz
|
/php-7.2.14.tar.xz
|
||||||
/php-7.2.15.tar.xz
|
/php-7.2.15.tar.xz
|
||||||
/php-7.2.16.tar.xz
|
/php-7.2.16.tar.xz
|
||||||
|
/php-7.2.17.tar.xz
|
||||||
|
@ -1,29 +0,0 @@
|
|||||||
From 19a44ffb7be91344550fa700830b8e62a73031ba Mon Sep 17 00:00:00 2001
|
|
||||||
From: Anatol Belski <ab@php.net>
|
|
||||||
Date: Thu, 28 Feb 2019 12:48:47 +0100
|
|
||||||
Subject: [PATCH] Sync with behavior change in OpenSSL 1.1.1b
|
|
||||||
|
|
||||||
A behavior change in revealed by some openssl_decrypt() based test,
|
|
||||||
where an encrypt API is used with a decrypt context. The EVP_Cipher*
|
|
||||||
functions will automatically choose the right operation depending on the
|
|
||||||
context passed.
|
|
||||||
---
|
|
||||||
ext/openssl/openssl.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
|
|
||||||
index 871a30c..7df5072 100644
|
|
||||||
--- a/ext/openssl/openssl.c
|
|
||||||
+++ b/ext/openssl/openssl.c
|
|
||||||
@@ -6494,7 +6494,7 @@ static int php_openssl_cipher_update(const EVP_CIPHER *cipher_type,
|
|
||||||
{
|
|
||||||
int i = 0;
|
|
||||||
|
|
||||||
- if (mode->is_single_run_aead && !EVP_EncryptUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
|
|
||||||
+ if (mode->is_single_run_aead && !EVP_CipherUpdate(cipher_ctx, NULL, &i, NULL, (int)data_len)) {
|
|
||||||
php_openssl_store_errors();
|
|
||||||
php_error_docref(NULL, E_WARNING, "Setting of data length failed");
|
|
||||||
return FAILURE;
|
|
||||||
--
|
|
||||||
2.1.4
|
|
||||||
|
|
7
php.spec
7
php.spec
@ -58,7 +58,7 @@
|
|||||||
%global with_lmdb 0
|
%global with_lmdb 0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%global upver 7.2.16
|
%global upver 7.2.17
|
||||||
|
|
||||||
Summary: PHP scripting language for creating dynamic web sites
|
Summary: PHP scripting language for creating dynamic web sites
|
||||||
Name: php
|
Name: php
|
||||||
@ -112,7 +112,6 @@ Patch47: php-5.6.3-phpinfo.patch
|
|||||||
Patch48: php-7.2.8-getallheaders.patch
|
Patch48: php-7.2.8-getallheaders.patch
|
||||||
|
|
||||||
# Upstream fixes (100+)
|
# Upstream fixes (100+)
|
||||||
Patch100: php-openssl111.patch
|
|
||||||
|
|
||||||
# Security fixes (200+)
|
# Security fixes (200+)
|
||||||
|
|
||||||
@ -715,7 +714,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
|||||||
%patch48 -p1 -b .getallheaders
|
%patch48 -p1 -b .getallheaders
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p1 -b .up
|
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
|
|
||||||
@ -1557,6 +1555,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Apr 3 2019 Remi Collet <remi@remirepo.net> - 7.2.17-1
|
||||||
|
- Update to 7.2.17 - http://www.php.net/releases/7_2_17.php
|
||||||
|
|
||||||
* Wed Mar 6 2019 Remi Collet <remi@remirepo.net> - 7.2.16-1
|
* Wed Mar 6 2019 Remi Collet <remi@remirepo.net> - 7.2.16-1
|
||||||
- Update to 7.2.16 - http://www.php.net/releases/7_2_16.php
|
- Update to 7.2.16 - http://www.php.net/releases/7_2_16.php
|
||||||
- add upstream patch for OpenSSL 1.1.1b
|
- add upstream patch for OpenSSL 1.1.1b
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (php-7.2.16.tar.xz) = cd2ea3c68d7ed20317800f4b838b0dd9ae2fde508c79662b296dacdacf6c7e35b6ef30a6564516d7b22e82749a6e9e2ffcfd95b05cd79a9f227fbfaf9e25bc31
|
SHA512 (php-7.2.17.tar.xz) = 52451a13bdb480e599a8d0baf3b76303cfec0bc2057166607ae1b0cf423a16361c059bd4df85f7c435715c86d7252399cb1744e435f0adb50bada0e40804c302
|
||||||
|
Loading…
Reference in New Issue
Block a user