prevent php_config.h changes across (otherwise identical) rebuilds

This commit is contained in:
Joe Orton 2012-12-11 09:00:37 +00:00
parent e4993fab95
commit 5c4b428582
2 changed files with 30 additions and 1 deletions

23
php-5.4.9-fixheader.patch Normal file
View File

@ -0,0 +1,23 @@
Make generated php_config.h constant across rebuilds.
--- php-5.4.9/configure.in.fixheader
+++ php-5.4.9/configure.in
@@ -1258,7 +1258,7 @@ fi
EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
-PHP_BUILD_DATE=`date '+%Y-%m-%d'`
+PHP_BUILD_DATE=`date '+%Y-%m-%d' -r LICENSE`
AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
case $host_alias in
@@ -1269,7 +1269,7 @@ case $host_alias in
AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[hardcode for each of the cross compiler host])
;;
*)
- PHP_UNAME=`uname -a | xargs`
+ PHP_UNAME=`uname | xargs`
AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
PHP_OS=`uname | xargs`
AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])

View File

@ -58,7 +58,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 5.4.9
Release: 1%{?dist}
Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@ -105,6 +105,8 @@ Patch43: php-5.4.0-phpize.patch
Patch44: php-5.4.5-system-libzip.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.4.8-ldap_r.patch
# Make php_config.h constant across builds
Patch46: php-5.4.9-fixheader.patch
# Fixes for tests
@ -677,6 +679,7 @@ support for using the enchant library to PHP.
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
%patch45 -p1 -b .ldap_r
%endif
%patch46 -p1 -b .fixheader
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@ -1409,6 +1412,9 @@ fi
%changelog
* Tue Dec 11 2012 Joe Orton <jorton@redhat.com> - 5.4.9-2
- prevent php_config.h changes across (otherwise identical) rebuilds
* Thu Nov 22 2012 Remi Collet <rcollet@redhat.com> 5.4.9-1
- update to 5.4.9