define SOURCE_DATE_EPOCH for reproducible build
This commit is contained in:
Remi Collet 2018-01-31 08:25:52 +01:00
parent 6c89e9e3dd
commit 55017a4c44
4 changed files with 11 additions and 35 deletions

1
.gitignore vendored
View File

@ -32,3 +32,4 @@ php-7.0.*.xz
/php-7.1.11.tar.xz
/php-7.1.12.tar.xz
/php-7.1.13.tar.xz
/php-7.1.14.tar.xz

View File

@ -1,23 +0,0 @@
Make generated php_config.h constant across rebuilds.
--- php-7.0.0/configure.in.fixheader
+++ php-7.0.0/configure.in
@@ -1278,7 +1278,7 @@ fi
EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
-PHP_BUILD_DATE=`date '+%Y-%m-%d'`
+PHP_BUILD_DATE=`date '+%Y-%m-%d' -r $srcdir/NEWS`
AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
case $host_alias in
@@ -1289,7 +1289,7 @@ case $host_alias in
AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[hardcode for each of the cross compiler host])
;;
*)
- PHP_UNAME=`uname -a | xargs`
+ PHP_UNAME=`uname | xargs`
AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
PHP_OS=`uname | xargs`
AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])

View File

@ -51,8 +51,6 @@
%global with_zip 0
%global with_libzip 0
# Not yet compatible with firebird 3
# https://bugs.php.net/bug.php?id=73512
%global with_firebird 1
%if 0%{?fedora} < 18 && 0%{?rhel} < 7
@ -66,7 +64,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
Version: 7.1.13
Version: 7.1.14
Release: %{?rcver:0.}%{rpmrel}%{?rcver:.%{rcver}}%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@ -106,8 +104,6 @@ Patch42: php-7.1.0-systzdata-v14.patch
Patch43: php-5.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.6.3-ldap_r.patch
# Make php_config.h constant across builds
Patch46: php-7.0.0-fixheader.patch
# drop "Configure command" from phpinfo output
Patch47: php-5.6.3-phpinfo.patch
# Automatically load OpenSSL configuration file
@ -196,12 +192,8 @@ Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
Requires: php-common%{?_isa} = %{version}-%{release}
Requires(pre): /usr/sbin/useradd
BuildRequires: systemd-units
BuildRequires: systemd-devel
Requires: systemd-units
Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units
%{?systemd_requires}
# To ensure correct /var/lib/php/session ownership:
Requires(pre): httpd-filesystem
# For php.conf in /etc/httpd/conf.d
@ -714,7 +706,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
%patch45 -p1 -b .ldap_r
%endif
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
%patch48 -p1 -b .loadconf
@ -824,6 +815,9 @@ sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
%build
# Set build date from https://reproducible-builds.org/specs/source-date-epoch/
export SOURCE_DATE_EPOCH=$(date +%s -r NEWS)
# aclocal workaround - to be improved
cat `aclocal --print-ac-dir`/{libtool,ltoptions,ltsugar,ltversion,lt~obsolete}.m4 >>aclocal.m4
@ -1504,6 +1498,10 @@ rm -f README.{Zeus,QNX,CVS-RULES}
%changelog
* Wed Jan 31 2018 Remi Collet <remi@remirepo.net> - 7.1.14-1
- Update to 7.1.14 - http://www.php.net/releases/7_1_14.php
- define SOURCE_DATE_EPOCH for reproducible build
* Wed Jan 3 2018 Remi Collet <remi@remirepo.net> - 7.1.13-1
- Update to 7.1.13 - http://www.php.net/releases/7_1_13.php

View File

@ -1 +1 @@
SHA512 (php-7.1.13.tar.xz) = f5357ffcbcaab1ba03d70edc0f1329b530f9f9c7779ac57d6fd2bd0bb730162f8d107025e5ff66592077d1bf504ee6816ec0379f50ceb1fac36cea90b0fc4fa2
SHA512 (php-7.1.14.tar.xz) = 7604e490aef95ae9c87bc4230491328c4cbcce42653234906885f9aa323f867ea941a7dbe80424aa4c4872392559ff5fa2acf1605c402055b6e428e6fe79ece6