* Wed Feb 4 2009 Joe Orton <jorton@redhat.com> 5.2.8-8

- fix patch fuzz, renumber patches
This commit is contained in:
jorton 2009-02-04 11:39:55 +00:00
parent 228c015e94
commit 2b2e42f5b4
5 changed files with 55 additions and 66 deletions

View File

@ -1,11 +0,0 @@
--- php-5.2.4/ext/odbc/config.m4.odbc
+++ php-5.2.4/ext/odbc/config.m4
@@ -423,6 +423,8 @@ PHP_ARG_WITH(unixODBC,,
PHP_ODBC_CHECK_HEADER(sqlext.h)
AC_DEFINE(HAVE_UNIXODBC,1,[ ])
AC_MSG_RESULT([$ext_output])
+ ODBC_SHARED_LIBADD="-lodbc -lodbcpsql"
+ PHP_SUBST(ODBC_SHARED_LIBADD)
fi
fi

View File

@ -1,5 +1,5 @@
--- php-5.2.6/configure.in.gnusrc --- php-5.2.8/configure.in.gnusrc
+++ php-5.2.6/configure.in +++ php-5.2.8/configure.in
@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl @@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
@ -9,8 +9,8 @@
dnl Setting up the PHP version based on the information above. dnl Setting up the PHP version based on the information above.
dnl ------------------------------------------------------------------------- dnl -------------------------------------------------------------------------
--- php-5.2.6/ext/interbase/interbase.c.gnusrc --- php-5.2.8/ext/interbase/interbase.c.gnusrc
+++ php-5.2.6/ext/interbase/interbase.c +++ php-5.2.8/ext/interbase/interbase.c
@@ -24,7 +24,6 @@ @@ -24,7 +24,6 @@
#include "config.h" #include "config.h"
#endif #endif
@ -19,8 +19,8 @@
#include "php.h" #include "php.h"
--- php-5.2.6/ext/pdo_firebird/firebird_driver.c.gnusrc --- php-5.2.8/ext/pdo_firebird/firebird_driver.c.gnusrc
+++ php-5.2.6/ext/pdo_firebird/firebird_driver.c +++ php-5.2.8/ext/pdo_firebird/firebird_driver.c
@@ -22,7 +22,6 @@ @@ -22,7 +22,6 @@
#include "config.h" #include "config.h"
#endif #endif
@ -29,8 +29,8 @@
#include "php.h" #include "php.h"
#include "php_ini.h" #include "php_ini.h"
--- php-5.2.6/ext/standard/file.c.gnusrc --- php-5.2.8/ext/standard/file.c.gnusrc
+++ php-5.2.6/ext/standard/file.c +++ php-5.2.8/ext/standard/file.c
@@ -118,7 +118,6 @@ php_file_globals file_globals; @@ -118,7 +118,6 @@ php_file_globals file_globals;
#ifdef HAVE_FNMATCH #ifdef HAVE_FNMATCH
@ -39,8 +39,8 @@
#endif #endif
#include <fnmatch.h> #include <fnmatch.h>
#endif #endif
--- php-5.2.6/ext/zlib/zlib_fopen_wrapper.c.gnusrc --- php-5.2.8/ext/zlib/zlib_fopen_wrapper.c.gnusrc
+++ php-5.2.6/ext/zlib/zlib_fopen_wrapper.c +++ php-5.2.8/ext/zlib/zlib_fopen_wrapper.c
@@ -19,7 +19,6 @@ @@ -19,7 +19,6 @@
/* $Id$ */ /* $Id$ */
@ -49,8 +49,8 @@
#include "php.h" #include "php.h"
#include "php_zlib.h" #include "php_zlib.h"
--- php-5.2.6/main/php.h.gnusrc --- php-5.2.8/main/php.h.gnusrc
+++ php-5.2.6/main/php.h +++ php-5.2.8/main/php.h
@@ -30,6 +30,7 @@ @@ -30,6 +30,7 @@
#define PHP_HAVE_STREAMS #define PHP_HAVE_STREAMS
#define YYDEBUG 0 #define YYDEBUG 0
@ -59,8 +59,8 @@
#include "php_version.h" #include "php_version.h"
#include "zend.h" #include "zend.h"
#include "zend_qsort.h" #include "zend_qsort.h"
--- php-5.2.6/main/streams/cast.c.gnusrc --- php-5.2.8/main/streams/cast.c.gnusrc
+++ php-5.2.6/main/streams/cast.c +++ php-5.2.8/main/streams/cast.c
@@ -18,7 +18,6 @@ @@ -18,7 +18,6 @@
/* $Id$ */ /* $Id$ */
@ -69,8 +69,8 @@
#include "php.h" #include "php.h"
#include "php_globals.h" #include "php_globals.h"
#include "php_network.h" #include "php_network.h"
--- php-5.2.6/main/streams/memory.c.gnusrc --- php-5.2.8/main/streams/memory.c.gnusrc
+++ php-5.2.6/main/streams/memory.c +++ php-5.2.8/main/streams/memory.c
@@ -18,7 +18,6 @@ @@ -18,7 +18,6 @@
/* $Id$ */ /* $Id$ */
@ -79,8 +79,8 @@
#include "php.h" #include "php.h"
PHPAPI int php_url_decode(char *str, int len); PHPAPI int php_url_decode(char *str, int len);
--- php-5.2.6/main/streams/streams.c.gnusrc --- php-5.2.8/main/streams/streams.c.gnusrc
+++ php-5.2.6/main/streams/streams.c +++ php-5.2.8/main/streams/streams.c
@@ -21,7 +21,6 @@ @@ -21,7 +21,6 @@
/* $Id$ */ /* $Id$ */
@ -89,8 +89,8 @@
#include "php.h" #include "php.h"
#include "php_globals.h" #include "php_globals.h"
#include "php_network.h" #include "php_network.h"
--- php-5.2.6/Zend/zend_language_parser.c.gnusrc --- php-5.2.8/Zend/zend_language_parser.c.gnusrc
+++ php-5.2.6/Zend/zend_language_parser.c +++ php-5.2.8/Zend/zend_language_parser.c
@@ -356,6 +356,8 @@ @@ -356,6 +356,8 @@
#include "zend_API.h" #include "zend_API.h"
#include "zend_constants.h" #include "zend_constants.h"

View File

@ -1,6 +1,6 @@
--- php-4.3.3/sapi/apache2handler/config.m4.install --- php-5.2.8/sapi/apache2handler/config.m4.install
+++ php-4.3.3/sapi/apache2handler/config.m4 +++ php-5.2.8/sapi/apache2handler/config.m4
@@ -59,7 +59,7 @@ @@ -68,7 +68,7 @@ if test "$PHP_APXS2" != "no"; then
fi fi
APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR` APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
@ -8,4 +8,4 @@
+ if true; then + if true; then
INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
$APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
-i -n php4" -i -n php5"

View File

@ -1,8 +1,5 @@
--- php-5.2.8/scripts/Makefile.frag.phpize64
Install phpize into libdir. +++ php-5.2.8/scripts/Makefile.frag
--- php-5.0.5/scripts/Makefile.frag.phpize64
+++ php-5.0.5/scripts/Makefile.frag
@@ -4,7 +4,7 @@ @@ -4,7 +4,7 @@
# #
@ -12,8 +9,8 @@ Install phpize into libdir.
BUILD_FILES = \ BUILD_FILES = \
scripts/phpize.m4 \ scripts/phpize.m4 \
--- php-5.0.5/scripts/phpize.in.phpize64 --- php-5.2.8/scripts/phpize.in.phpize64
+++ php-5.0.5/scripts/phpize.in +++ php-5.2.8/scripts/phpize.in
@@ -3,7 +3,7 @@ @@ -3,7 +3,7 @@
# Variable declaration # Variable declaration
prefix='@prefix@' prefix='@prefix@'
@ -22,4 +19,4 @@ Install phpize into libdir.
+phpdir="@libdir@/php/build" +phpdir="@libdir@/php/build"
includedir="`eval echo @includedir@`/php" includedir="`eval echo @includedir@`/php"
builddir="`pwd`" builddir="`pwd`"
SED="@SED@"

View File

@ -6,7 +6,7 @@
Summary: PHP scripting language for creating dynamic web sites Summary: PHP scripting language for creating dynamic web sites
Name: php Name: php
Version: 5.2.8 Version: 5.2.8
Release: 7%{?dist} Release: 8%{?dist}
License: PHP License: PHP
Group: Development/Languages Group: Development/Languages
URL: http://www.php.net/ URL: http://www.php.net/
@ -16,25 +16,25 @@ Source1: php.conf
Source2: php.ini Source2: php.ini
Source3: macros.php Source3: macros.php
Patch1: php-5.2.6-gnusrc.patch Patch1: php-5.2.8-gnusrc.patch
Patch2: php-4.3.3-install.patch Patch2: php-5.2.8-install.patch
Patch3: php-5.2.4-norpath.patch Patch3: php-5.2.4-norpath.patch
Patch5: php-5.0.2-phpize64.patch Patch4: php-5.2.8-phpize64.patch
Patch8: php-5.2.0-includedir.patch Patch5: php-5.2.0-includedir.patch
Patch9: php-5.2.4-embed.patch Patch6: php-5.2.4-embed.patch
# Fixes for extension modules # Fixes for extension modules
Patch22: php-4.3.11-shutdown.patch Patch20: php-4.3.11-shutdown.patch
Patch24: php-5.2.3-macropen.patch Patch21: php-5.2.3-macropen.patch
# Functional changes # Functional changes
Patch30: php-5.0.4-dlopen.patch Patch40: php-5.0.4-dlopen.patch
Patch31: php-5.2.4-easter.patch Patch41: php-5.2.4-easter.patch
Patch32: php-5.2.6-systzdata.patch Patch42: php-5.2.6-systzdata.patch
# Fixes for tests # Fixes for tests
Patch50: php-5.2.7-tests-dashn.patch Patch60: php-5.2.7-tests-dashn.patch
Patch51: php-5.0.4-tests-wddx.patch Patch61: php-5.0.4-tests-wddx.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -367,19 +367,19 @@ support for using the pspell library to PHP.
%patch1 -p1 -b .gnusrc %patch1 -p1 -b .gnusrc
%patch2 -p1 -b .install %patch2 -p1 -b .install
%patch3 -p1 -b .norpath %patch3 -p1 -b .norpath
%patch5 -p1 -b .phpize64 %patch4 -p1 -b .phpize64
%patch8 -p1 -b .includedir %patch5 -p1 -b .includedir
%patch9 -p1 -b .embed %patch6 -p1 -b .embed
%patch22 -p1 -b .shutdown %patch20 -p1 -b .shutdown
%patch24 -p1 -b .macropen %patch21 -p1 -b .macropen
%patch30 -p1 -b .dlopen %patch40 -p1 -b .dlopen
%patch31 -p1 -b .easter %patch41 -p1 -b .easter
%patch32 -p1 -b .systzdata %patch42 -p1 -b .systzdata
%patch50 -p1 -b .tests-dashn %patch60 -p1 -b .tests-dashn
%patch51 -p1 -b .tests-wddx %patch61 -p1 -b .tests-wddx
# Prevent %%doc confusion over LICENSE files # Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE cp Zend/LICENSE Zend/ZEND_LICENSE
@ -738,6 +738,9 @@ rm files.* macros.php
%files process -f files.process %files process -f files.process
%changelog %changelog
* Wed Feb 4 2009 Joe Orton <jorton@redhat.com> 5.2.8-8
- fix patch fuzz, renumber patches
* Wed Feb 4 2009 Joe Orton <jorton@redhat.com> 5.2.8-7 * Wed Feb 4 2009 Joe Orton <jorton@redhat.com> 5.2.8-7
- drop obsolete configure args - drop obsolete configure args
- drop -odbc patch (#483690) - drop -odbc patch (#483690)