update to 7.2.14RC1
This commit is contained in:
parent
2a1aff30e5
commit
212188c256
1
.gitignore
vendored
1
.gitignore
vendored
@ -33,3 +33,4 @@ php-7.3.*.xz
|
||||
/php-7.2.12.tar.xz
|
||||
/php-7.2.13RC1.tar.xz
|
||||
/php-7.2.13.tar.xz
|
||||
/php-7.2.14RC1.tar.xz
|
||||
|
@ -1,71 +0,0 @@
|
||||
From d8765852e0400ee2ce8ae9e2177c42731d4539d8 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Malyshev <stas@php.net>
|
||||
Date: Wed, 28 Nov 2018 15:45:51 -0800
|
||||
Subject: [PATCH] Add DISPLAY_INI_ENTRIES for imap
|
||||
|
||||
---
|
||||
ext/imap/php_imap.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
|
||||
index f6feebe9f769..a23e84c08521 100644
|
||||
--- a/ext/imap/php_imap.c
|
||||
+++ b/ext/imap/php_imap.c
|
||||
@@ -1153,6 +1153,8 @@ PHP_MINFO_FUNCTION(imap)
|
||||
php_info_print_table_row(2, "Kerberos Support", "enabled");
|
||||
#endif
|
||||
php_info_print_table_end();
|
||||
+
|
||||
+ DISPLAY_INI_ENTRIES();
|
||||
}
|
||||
/* }}} */
|
||||
|
||||
From 7edc639b9ff1c3576773d79d016abbeed1f93846 Mon Sep 17 00:00:00 2001
|
||||
From: Stanislav Malyshev <stas@php.net>
|
||||
Date: Sun, 11 Nov 2018 10:04:01 -0800
|
||||
Subject: [PATCH] Fix #77020: null pointer dereference in imap_mail
|
||||
|
||||
If an empty $message is passed to imap_mail(), we must not set message
|
||||
to NULL, since _php_imap_mail() is not supposed to handle NULL pointers
|
||||
(opposed to pointers to NUL).
|
||||
---
|
||||
NEWS | 1 +
|
||||
ext/imap/php_imap.c | 1 -
|
||||
ext/imap/tests/bug77020.phpt | 15 +++++++++++++++
|
||||
3 files changed, 16 insertions(+), 1 deletion(-)
|
||||
create mode 100644 ext/imap/tests/bug77020.phpt
|
||||
|
||||
diff --git a/ext/imap/php_imap.c b/ext/imap/php_imap.c
|
||||
index a23e84c08521..b30440f000f3 100644
|
||||
--- a/ext/imap/php_imap.c
|
||||
+++ b/ext/imap/php_imap.c
|
||||
@@ -4125,7 +4125,6 @@ PHP_FUNCTION(imap_mail)
|
||||
if (!ZSTR_LEN(message)) {
|
||||
/* this is not really an error, so it is allowed. */
|
||||
php_error_docref(NULL, E_WARNING, "No message string in mail command");
|
||||
- message = NULL;
|
||||
}
|
||||
|
||||
if (_php_imap_mail(ZSTR_VAL(to), ZSTR_VAL(subject), ZSTR_VAL(message), headers?ZSTR_VAL(headers):NULL, cc?ZSTR_VAL(cc):NULL,
|
||||
diff --git a/ext/imap/tests/bug77020.phpt b/ext/imap/tests/bug77020.phpt
|
||||
new file mode 100644
|
||||
index 000000000000..8a65232eec6d
|
||||
--- /dev/null
|
||||
+++ b/ext/imap/tests/bug77020.phpt
|
||||
@@ -0,0 +1,15 @@
|
||||
+--TEST--
|
||||
+Bug #77020 (null pointer dereference in imap_mail)
|
||||
+--SKIPIF--
|
||||
+<?php
|
||||
+if (!extension_loaded('imap')) die('skip imap extension not available');
|
||||
+?>
|
||||
+--FILE--
|
||||
+<?php
|
||||
+imap_mail('1', 1, NULL);
|
||||
+?>
|
||||
+===DONE===
|
||||
+--EXPECTF--
|
||||
+Warning: imap_mail(): No message string in mail command in %s on line %d
|
||||
+%s
|
||||
+===DONE===
|
||||
|
11
php.spec
11
php.spec
@ -58,9 +58,9 @@
|
||||
%global with_lmdb 0
|
||||
%endif
|
||||
|
||||
%global upver 7.2.13
|
||||
#global rcver RC1
|
||||
%global rpmrel 2
|
||||
%global upver 7.2.14
|
||||
%global rcver RC1
|
||||
%global rpmrel 1
|
||||
|
||||
Summary: PHP scripting language for creating dynamic web sites
|
||||
Name: php
|
||||
@ -116,7 +116,6 @@ Patch48: php-7.2.8-getallheaders.patch
|
||||
# Upstream fixes (100+)
|
||||
|
||||
# Security fixes (200+)
|
||||
Patch200: php-imap.patch
|
||||
|
||||
# Fixes for tests (300+)
|
||||
# Factory is droped from system tzdata
|
||||
@ -719,7 +718,6 @@ low-level PHP extension for the libsodium cryptographic library.
|
||||
# upstream patches
|
||||
|
||||
# security patches
|
||||
%patch200 -p1 -b .imap
|
||||
|
||||
# Fixes for tests
|
||||
%patch300 -p1 -b .datetests
|
||||
@ -1559,6 +1557,9 @@ systemctl try-restart php-fpm.service >/dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 18 2018 Remi Collet <remi@remirepo.net> - 7.2.14~RC1-1
|
||||
- update to 7.2.14RC1
|
||||
|
||||
* Sat Dec 8 2018 Remi Collet <remi@remirepo.net> - 7.2.13-2
|
||||
- Fix null pointer dereference in imap_mail CVE-2018-19935
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (php-7.2.13.tar.xz) = 9df1d43e9cd701db10281811b328721b85cb90c6c8dae1842b0fd848cb5388328918b3040bbad7634b340550d82b93746ea479ed45f4d8a80e8a316e6324115d
|
||||
SHA512 (php-7.2.14RC1.tar.xz) = e24404aae74615bf7877feb09dce1473fd9c28f5114d9445e827b4e019aa0fb286015abac1da1d278ed32b9f997ec02981598ccbec1f425d69be7a1ffbbc2e99
|
||||
|
Loading…
Reference in New Issue
Block a user